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While the publisher and the authors have used good faith efforts to ensure that the information and instructions contained in this work are accurate, the publisher and the authors disclaim all responsibility for errors or omissions, including without limitation responsibility for damages resulting from the use of or reliance on this work. Use of the information and instructions contained in this work is at your own risk. If any code samples or other technology this work contains or describes is subject to open source licenses or the intellectual property rights of others, it is your responsibility to ensure that your use thereof complies with such licenses and/or rights.

Integrated Design
AutoTRAX DEX-PCB is the industry’s only unified electronic design software which gives you an unmatched ability to design and build current and future generation of electronic products.
This is in sharp contrast to the previous generation of software such as Diptrace, Eagle, MultiSim, Orcad, DesignSparks and Proteus which have separate data files for schematics and PCBs – even different applications with different user interfaces.
The design of DEX-PCB’s internal data ensures you maintain full electrical integrity with your schematic design.
Schematic Design
DEX-PCB ensures that your design remains correct throughout with no ‘dangling wires’ or PCB design rule violations.
You can also create your own parts either in-place on your design sheets or using the integrated Part Creator. Again, design integrity is maintained throughout using AutoTRAX’s design rule checker.
PCB Design
When you are satisfied with your design, you can then quickly proceed to produce your finished and populated PCB board without leaving the DEX-PCB program.
The AutoTRAX PCB Designer will take your hierarchical design and place the components, with or without your assistance. Next DEX-PCB can either autoroute your board or you can use a combination of automatic and manual routing to quickly and reliably complete all electrical wiring.
Manufacturing
Now that you have your design finished and routed you can easily produce all Computer Aided Manufacturing files you will need to produce the board, drill the holes, cut its profile, order parts using the Bill of Materials, and place your parts using the pick and place files.
These files can be placed together and forwarded to your board manufacturers, electronically via email.

Contents

1.	<%CHAPTER_HEADING1%>	4
1.1.	<%CHAPTER_HEADING2%>	4
1.1.1.	<%CHAPTER_HEADING3%>	4



1. [bookmark: Introduction]Introduction
Published Tuesday, November 30, 2021
AutoTRAX DEX-PCB : Powerful PCB design made easy
AutoTRAX is a powerful integrated Electronic Design Suite for Electronic Engineers. It has all the features you expect and need to rapidly and easily take your design from conception through to production. Its in-built hierarchical project manager lets you perform both top-down and bottom-up design and reuse design components and sub-systems. Schematic capture and PCB layout has never been easier.
DEX-PCB is the industry’s only unified electronic design software which gives you an unmatched ability to design and build current and future generation of electronic products.
This is in sharp contrast to the previous generation of software which have separate data files for schematics and PCBs – even different applications with different user interfaces for schematic design and PCB design.
No Limits
Unlike software from other EDA developers DEX-PCB is not stymied by the limited thinking of the software developers of the last century.
Why do they limits their boards? Who know?
There are absolutely no limits* to your design in DEX-PCB.
· Unlimited board size
· Unlimited number of layers (More than any PCB manufacturer can make)
· Unlimited number of parts
· Unlimited number of pads
· Unlimited number of nets
· No time limits. The software is yours to keep. You are not even limited to using it on only one machine or having to mess about with floating licenses.
As DEX-PCB has only 1 license type- unlimited- you get it all. No immoral Trojan horses to trap you into paying more. Read more...
Unified Platform
AutoTRAX is the industry’s only unified electronic design software which gives you an unmatched ability to design and build current and future generation of electronic products. Schematic's and PCBs are tightly integrated together; any change in the schematic is fully updated in the PCB and similarly any change in PCB is reflected back in the schematic.
Traditional concepts of an electronics design system haven’t changed much, at least for most EDA vendors. This can be apparent in the way they struggle to meet even the current challenges. The fragmented approach of trying to glue separate solutions together eventually breaks down as more challenges are thrown at them. It’s just unsustainable and difficult to innovate on top of inconsistent design applications that rely on constantly unmatched data exchanges. That’s not how AutoTRAX is designed.
DEX-PCB has been designed from the ground up as a powerful, single-application electronics development environment that contains all the advanced design tools you’ll need to capture and simulate hardware, design PCBs, collaborate with MCAD, manage your ECAD data and documentation, as well as manage your designs from concept to production. It’s all there in a single, unified design platform.
DEX-PCB also unifies your design data, from component models to sub-assemblies. Unlike conventional design systems based on a collection of linked tool applications, the AutoTRAX unified platform allows each design application to access and modify a single, centralized model of the design data. That’s one 


Schematics
AutoTRAX ensures that your design remains correct throughout, with no dangling wires or PCB design rule violations. You can also create your own parts either in-place on your design sheets or using the integrated Part Creator. Again, design integrity is maintained throughout using AutoTRAX's design rule checker. 


PCB Design
When you are satisfied with your design, you can then quickly proceed to produce your finished and populated PCB board without leaving AutoTRAX. The AutoTRAX's PCB Designer will take your hierarchical design and place the components, with or without your assistance. Next AutoTRAX can either auto-route your board or you can use a combination of automatic and manual routing to quickly and reliably complete all electrical wiring. The design of AutoTRAX's internal data ensures you maintain full electrical integrity with your schematic design.


Manufacturing
Now that you have your design finished and routed you can produce all Computer Aided Manufacturing files you will need to produce the board, drill the holes, cut its profile, order parts using the Bill Of Materials, and place your parts using the pick and place files. These files can be placed together and forwarded to your favorite board manufacturers, electronically via email.

Have Gerber, Will Travel!
Unlike other programs, AutoTRAX is not locked to a PCB manufacturer where if you use their program you must use their services to produce your boards, and pay the price their demand!
With AutoTRAX Gerber files you can shop around to get the best price and service for your PCBs. 
Be in control!
Have XML, Will Travel!
Again, unlike other programs, AutoTRAX does not lock you in to using AutoTRAX now and forever. The design file is totally self contained and is in the industry standard XML file format. This is human readable and you can easily write your own programs to use the data in your design.
This is in sharp contrast to other programs which have their own secret file format. This locks you into using their program now and forever. 
If the company goes under then so could your archive of designs.
1.1. [bookmark: Using_This_Manual9FF41BB8]Using This Manual
Table of Contents
Use the Content tab on the left to show the table of contents. Then click the + symbol next to the chapter names to open them.
Link
Click on the chapter/page names to view the page.
Finding Specific Information
Use the Search tab on the left. Enter a few key words and click the List Topics button. If the number of topics found in the query is too large, you can narrow the search by adding more keywords.
Saving/Removing and Viewing Your Favorite Pages
To add a favorite page to a list of favorite pages select Favorites tab on the left and click the Add button. 
 To view the favorite page click on a page name in the favorites tab.
You can remove favorites by selecting the name in the tab and clicking on the Remove Button.
The Very Basics
To use this book, and indeed to use a computer, you need to know a few basics. You should be familiar with these terms and concepts:
· Clicking. This book gives you three kinds of instructions that require you to use your computer’s mouse or track pad. To click means to point the arrow cursor at something on the screen and then—without moving the cursor at all—to press and release the clicker button on the mouse (or laptop track pad). A right-click is the same thing using the right mouse button. (On a Mac, press Control as you click if you don’t have a right mouse button.) 
· To double-click means to click twice in rapid succession, again without moving the cursor at all. And to drag means to move the cursor while pressing the button. When you’re told to c-click something on the Mac, or Ctrl-click something on a PC, you click while pressing the c or Ctrl key (both of which are near the space bar).
· Menus. The menus are the words at the top of your screen or window: File, Edit, and so on. Click one to make a list of commands appear; as though they’re written on a window shade you’ve just pulled down. This book assumes that you know how to open a program, surf the Web, and download files. You should know how to use the Start menu (Windows) or the Dock or a menu (Mac), as well as the Control Panel (Windows) or System Preferences (Mac OS X).
Keyboard shortcuts. Every time you take your hand off the keyboard to move the mouse, you lose time and potentially disrupt your creative flow. That’s why many experienced computer fans use keystroke combinations instead of menu commands wherever possible. When you see a shortcut like Ctrl+S (c-S) (which saves changes to the current document), it’s telling you to hold down the Ctrl or c key, and, while it’s down, type the letter S, and then release both keys.
About→These→Arrows
Throughout this book, and throughout the Missing Manual series, you’ll find sentences like this one: “Open the System→Library→Fonts folder.” That’s shorthand for a much longer instruction that directs you to open three nested folders in sequence, like this: “On your hard drive, you’ll find a folder called System. Open that. Inside the System folder window is a folder called Library; double-click it to open it. Inside that folder is yet another folder one called Fonts. Double-click to open it, too.”
Similarly, this kind of arrow shorthand helps to simplify the business of choosing commands in menus, as shown with View/Snap→Zoom→In
Ribbon Menu



1.2. [bookmark: Project_Parts_and_Artwork7913DCA5]Project, Parts and Artwork
With AutoTRAX you can produce 3 different types of work in different file types.
Project
A project is a self-contained file that contains all the schematics, text documents and the PCB to make a PCB. It relies on no other file. Project files have the file extension .project
A project consists of one or more schematics that define the abstract logical design. A project also contains a single PCB which defines the physical Printed Circuit Board that you are designing.Read more...
Parts
A part is a self-contained file that contains all the symbols and the footprint/land pattern for a part. Like a project file, it relies on no other file. Part files have the file extension .part
A part is an electronic device that you will add to a project to construct your design. Read more...
Artwork
An artwork is yet another self-contained file. This only contains graphics or artwork that you can include in projects and parts by dragging them from the library, Windows File Explorer or the desktop onto a design sheet. Artwork files have the file extension .artwork Read more...
File Associations
When AutoTRAX is installed the following file extensions are associated with AutoTRAX and Windows will open then with AutoTRAX unless you specify another file. To change the file association for a file right-click on the file name and select 'Open With...' Read more...

1.3. [bookmark: Requirements]Requirements
System Requirements
Windows 8  or later. 
You can use a 32 bit version or a 64 bit version. A 64 bit version is recommended.


DISC DRIVE
A decent size disc with ample space is recommended. At least 500Mb of free space is recommended.

A Solid State Drive (SSD) is recommended for faster start-up.
CPU
The faster the better. We suggest an I7.

RAM
The more the better. On a  32 bit version O/S you are limited to 3GB usable (the extra 1GB is reserved for your video card). I recommend at least 2GB on Windows XP and 3GB on Windows 7 and later. Windows Vista is not recommended.

VIDEO CARD
You must have at least a 24 bit color video card. All modern video cards support 24/32 bit color.

MONITOR
Here the bigger, the better. The Monitor is your view into your design. I recommend at least 1920 pixels horizontal.
AutoTRAX will work with multiple monitors and you can drag parts of AutoTRAX onto different monitors. AutoTRAX remembers the position of all its windows are restored them the next time you run AutoTRAX.

All modern video cards support at least two monitor outputs, and many support even more. 
MOUSE
You definitely a 3 button mouse with a central thumb wheel. The thumb wheel is use you zoom in and out and pressing down the thumbwheel/middle mouse button pans the view.


1.4. [bookmark: Limitations]Limitations
These are the limitation with AutoTRAX (Well really there are no practical limitations)

	Number of schematic sheets
	Unlimted *

	Number of PCB Layers
	Unlimted *

	Size of PCBs
	Unlimted *

	Number of Parts
	Unlimted *

	Number of Terminals
	Unlimted *

	Size of Schematics
	Unlimted *

	Units
	IEEE Floating Point


* Limited only by memory size
1.5. [bookmark: About_DEX68F5B9F3]About AutoTRAX
In keeping with the Open Design philosophy of AutoTRAX the following details on the development of AutoTRAX are provided.
       AutoTRAX is mainly written in C# .NET 4 and will run on Windows Vista, Windows 7 and Windows 8., Windows 10. 
It will also run on Apple Macs.
   It uses both Winforms, GDI+ and WPF and well as Direct X and OpenGL.
As well as C#, AutoTRAX is also written in C++/CLI, C++ and C. Each language is used for optimum performance and reliability.
There are over 600,000 lines of code and 3000 classes. These exclude 3rd party code such as .NET, DevExpress;
When AutoTRAX is installed it is compiled on the target machine for the target processor. AutoTRAX is therefore a 64 bit application on a 64 bit O/S and a 32 bit application on a 32 bit O/S. The code is also optimized for the target processor version. This is impossible to do in C++ applications. There is only one installer executable.
The previous version of AutoTRAX was AutoTRAX EDA. This was written in C++ and MFC. 
A version of AutoTRAX was developed using C++ and QT but this was abandoned in favor of .NET.
Both AutoTRAX and AutoTRAX EDA have been used, under license, to develop application for other software companies. 
 The AutoTRAX website was written in C# with ASP.NET MVC 4.5. It is an HTML 5 site and uses SQLServer 2012, WebGL,  SVG and JavaScript with j Query.
 AutoTRAX is developed with Visual Studio Ultimate and Team Foundation Server 2012. Design methodology is Scrum Agile.

AutoTRAX uses SQLite. SQLite is a C-language library that implements a small, fast, self-contained, high-reliability, full-featured, SQL database engine. SQLite is the most used database engine in the world. SQLite is built into all mobile phones and most computers and comes bundled inside countless other applications that people use every day.
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2. [bookmark: Getting_Started5FA7CEAC]Getting Started
AutoTRAX Design Express, AutoTRAX, is a fully integrated electronic schematic capture program combined with an easy to use PCB Designer.
It has all the features you expect and need to rapidly and easily take your design from conception through to production. Its in-built hierarchical project manager lets you perform both top-down and bottom-up design and reuse design components and sub-systems.
Starting with its easy to use Schematic Capture mode, you can drag previously created parts onto your design sheets and rapidly and reliably connected the terminals together using wires, buses and off-page connectors. AutoTRAX ensures that your design remains correct throughout with no ‘dangling wires’ or design rule violations.
You can also create your own parts either in-place on your design sheets or using the integrated Part Creator. Again, design integrity is maintained throughout using the AutoTRAX's design rule checker.
When you are satisfied with your design, you can then quickly proceed to produce your PCB board without leaving the AutoTRAX. The AutoTRAX PCB Designer will take your hierarchical design and place the components, with or without your assistance. Next AutoTRAX can either auto-route your board or you can use a combination of automatic and manual routing to quickly and reliably complete all electrical wiring. The design of AutoTRAX's internal data ensures full electrical integrity between your schematic and PCB designs; there are no surprises with lost or missing PCB tracks or wires, or those ‘extra’ wires.
Now that you have your design finished and routed you can then produce all Computer Aided Manufacturing files you will need to produce the board, drill the holes, cut its profile, order parts using the Bill Of Materials, and place your parts using the pick and place files. These files can be place together and forwarded to your favorite board manufacturers, electronically via email.
In only a short time you will see the fruits of your labor and will be pleased at the time and money you have saved.


2.1. [bookmark: Quick_Start1C906C86]Quick Start
For those of you that are keen to use AutoTRAX here is a quick start guide.
· AutoTRAX does not have separate schematic, part and PCB editors.  There is just one AutoTRAX editor that does it all.
· AutoTRAX integrates schematics with the PCB in a single project file.
· AutoTRAX integrates symbols with the footprint in a single part file. A multi-symbol part  with have several schematics with each schematic representing one of the sibling symbols.
· There is a very comprehensive undo/redo facility that will always get you out of trouble and thus allows you to experiment.
· Use a 3 button mouse with a mouse wheel. Use the middle button to pan and the mouse wheel to zoom in/out.
· Right-click on any object in a viewport to see a context sensitive menu.
· There are comprehensive tooltips that appear when you mouse over dialog controls and objects in schematics and on the PCB.
· Press F1 for help and search for topics using the search menu. Use keyboards like you would with Google.
· View the tutorial videos. They really will help you. Take a look at the video tutorials.
· Take a look at the Sample Projects.
Click on the picture below to see an independent tutorial on PCB design using AutoTRAX..

How to build a PCB design using AutoTRAX
by 
Mick Gulovsen


2.2. [bookmark: Sample_ProjectsCBD8567D]Sample Projects
There are several sample projects in the Help→Samples buttons group. These illustrates many of the powerful features and capabilities in AutoTRAX.  

Ribbon Menu Samples
The Serial Back-Pack
This project was donated by Mick Gulovsen from Melbourne, Australia.
The DEX UNO
DEX Uno is a microcontroller board based on the ATmega328P.
The Amplifier
The amplifier project shows a sample design of an amplifier using all TPH components.
The Diagram
This project is a simple diagram that shows you the graphical powers of AutoTRAX.
The CPU Diagram
This project shows you how you can use the powerful graphics capabilities in AutoTRAX to diagram a simple CPU using graphical blocks and in connecting wires.
The Flowchart Design
 This project shows you part of the electrical circuit in an automobile such as you might see in a typical user manual.
The Front Panel
With AutoTRAX you can even design front panel displays. The front panel project contains this example front panel design.
2.2.1. [bookmark: The_Serial_Back_Pack285917B6]The Serial Back-Pack
Click Help→Samples→  to open the Serial Backpack sample project.
This project was donated by Mick Gulovsen from Melbourne, Australia. He has created a tutorial on using AutoTRAX athttp://dexpcb.com/HowToMakeAPCB/

2.2.2. [bookmark: The_DEX_UNO55856C78]The DEX UNO
Click Help→Samples→  to open the DEX UNO sample project. 
DEX Uno is a microcontroller board based on the ATmega328P. It has 14 digital input/output pins (of which 6 can be used as PWM outputs), 6 analog inputs, a 16 MHz quartz crystal, a USB connection, a power jack, an ICSP header and a reset button. It contains everything needed to support the microcontroller; simply connect it to a computer with a USB cable or power it with a AC-to-DC adapter or battery to get started.
You are free to modify and use; however, you must comply with the Arduino license.

Orthographic 3D View

Perspective View

Schematic

PCB
2.2.3. [bookmark: The_Amplifier27B33C79]The Amplifier
Click Help→Samples→  to open the Amplifier sample project.
The amplifier project shows a sample design of an amplifier using all TPH components.

The Main Schematic for the Amplifier

The PCB view in 2-D with all layers on and the PCB set to draw as solid.


The Amplifier Viewed in 3-D
2.2.4. [bookmark: The_Diagram7401B88F]The Diagram
Click Help→Samples→  to open the Diagram sample project.
This project is a simple diagram that shows you the graphical powers of AutoTRAX.

2.2.5. [bookmark: The_CPU_DiagramF93F8AE6]The CPU Diagram
Click Help→Samples→  to open the CPU Diagram sample project.
This project shows you how you can use the powerful graphics capabilities in AutoTRAX to diagram a simple CPU using graphical blocks and in connecting wires.

CPU Diagram
2.2.6. [bookmark: The_Car_Harness112E2217]The Car Harness
Click Help→Samples→  to open the Car Harness sample project.
 This project shows you part of the electrical circuit in an automobile such as you might see in a typical user manual.

Car Electrical Harness
2.2.7. [bookmark: The_Flowchart_Design8B036957]The Flowchart Design
Click Help→Samples→  to open the Flow Chart sample project.
With AutoTRAX you can draw flowchart diagrams such as the one below. The flowchart design project shows you the example flowchart you see below.

Flowchart
2.2.8. [bookmark: The_Front_PanelC71101D4]The Front Panel
Click Help→Samples→  to open the Front Panel sample project.
With AutoTRAX you can even design front panel displays. An example front panel display is shown below And was designed using the powerful graphics available in AutoTRAX.
The front panel project contains this example front panel design.

2.3. [bookmark: Running_AutoTRAX_for_the_First_TBDD4D7BD]Running AutoTRAX for the First Time





2.4. [bookmark: Demonstration_Video]Demonstration Video
2.5. [bookmark: A_Simple_Resistor_Ladder944C031F]A Simple Resistor Ladder
2.6. [bookmark: Installing_AutoTRAX5782A1D2]Installing AutoTRAX
System Requirements:

Windows Vista and Windows 7/8/10 are fully supported (32 bit and 64 bit)

· Windows Vista,Windows 7, 8 and 10.
· 2GB on Vista, Windows 7 or Windows 8or Windows 10
· 24-bit graphics card.
· 100MB Hard Disk space.
· 3-button mouse with scroll wheel. AutoTRAX will work with a 2-button mouse but your productivity will be greater with a 3-button mouse with scroll wheel.


AutoTRAX will automatically prompt you to install the correct Microsoft .NET 4 if it not already installed.
2.6.1. [bookmark: Downloading_AutoTRAXB4098E17]Downloading AutoTRAX
You can download AutoTRAX from http://dexpcb.com/Download
When you have downloaded AutoTRAX run the installer program/
You will first see the select setup language dialog. 
Click here see where AutoTRAX installs files.

Select your language from the drop down list and click on the OK button to proceed. At any time you can click on the Cancel button to stop the installation and no files will be added to your machine.
You will see the welcome screen, click on the OK button to proceed.

Now you will see the license agreement. You must accept this to proceed. Click on I accept the agreement and then click on the Next button to proceed. Click here to see the full license agreement

Next you will see the Select Components dialog. I recommend you select all and then click the Next button to continue.

Now you get to select where to place AutoTRAX. You can use the default or add your own. Again click the Next button to continue.

Now you get to name the start menu folder. You can use the default or add your own. Again click the Next button to continue.

Now you can associate files with AutoTRAX. When you click on them in the Microsoft Windows Explorer, AutoTRAX will open them. Also AutoTRAX's icon appears alongside then. It is recommended you leave Associate files checked.  
AutoTRAX associates the following file extensions.
.project - used for project files.
.part - used for part files.
.art - used for art files.
Click the Next button to continue.


Finally you are ready to install. Check the installation options and click the Next button to continue.


During installation the following progress dialog is shown. Click on the Cancel button if you no longer wish to install AutoTRAX.

When the install is complete, you will see the following dialog box. Click the Finish button to continue.




2.6.1.1. [bookmark: File_AssociationsF86AB447]File Associations
AutoTRAX associated the following file extensions.
.project - used for project files.
.part - used for part files.
.art - used for art files.
A default program is the program that Windows uses when you open a particular type of file, such as a music file, an image, or a web-page. For example, if you have more than one web browser installed on your computer, you can choose one of them to be the default browser.
Changing File Associations for Windows Vista
Changing File Associations for Windows 7/8
Each file in your Windows operating system has an extension in its filename eg. .txt, .doc, etc. These extensions are used to identify the program, with which, windows can open this file. You can set or change these file associations in your Windows. In windows XP you had this setting to change file type associations in Folder Options. In Windows 8, Windows 7 and Windows Vista you don’t see it there, though.
To set File Associations in Windows 8 | 7, Open Control Panel→Control Panel Home→Default Programs→Set Associations. Select a file type in the list and click Change Program.
A list of extensions and their current default programs will be displayed. You can click on the Change program button to set or change the current defaults.

Alternatively, you can also right-click the file whose association you want to change, Properties→General tab→Type Of File→Change. Choose a program from the list or recommended or other programs or else click Browse to select one.





2.6.2. [bookmark: AutoTRAX_Files50956AA2]Where are the AutoTRAX  files?
AutoTRAX is installed in the following directories:
Roaming Data Files
C:\Users\XXXX\AppData\Roaming\AutoTRAX Software\AutoTRAX
Machine Specific Files
C:\Users\XXXX\AppData\Local\AutoTRAX Software\AutoTRAX
The Parts Library
The default location of the parts library is:
C:\Users\XXXX\AppData\Roaming\AutoTRAX Software\AutoTRAX\Library
Where XXXX is your account name.
The Windows Registry
The Windows Registry is a hierarchical database that stores configuration settings and options on Microsoft Windows operating systems. It contains settings for low-level operating system components and for applications running on the platform that have opted to use the registry. The kernel, device drivers, services, SAM, user interface and third party applications can all make use of the registry. The registry also provides a means to access counters for profiling system performance.
AutoTRAX does not use the registry or set entries in the Registry.
Configuration files are in C:\Users\XXXX\AppData\Roaming\AutoTRAX Software\AutoTRAX\Settings
2.7. [bookmark: Updating_Your_Version73D03DE9]Updating Your Version
Manual Checking
To manually check for updates click the Home→Account→ button. 
Auto-Updatings
When AutoTRAX starts it optionally checks to see if there is a new version of AutoTRAX available. 
If there is a new version it will display the dialog box below.

Click the  download button to have AutoTRAX download the latest version and install it. This is the easiest way to update and you will not be prompted for install passwords and setup details. When AutoTRAX is downloading the latest version it will display the download progress dialog shown below.

To disable auto-updating click the Cancel button and the following dialog will be displayed. Click on the No button to prevent checks for updates in future.

To re-enable auto-updatings click on the Get Latest Version button  in the Home→Account menu 

2.8. [bookmark: Your_Account_Settings4B554B19]Your Account Settings
To change your account details click the Software License button  in the Home→Account menu. 
If you have a valid license the account details dialog shown below will be displayed.
 (
The Sign On Dialog Box
)[image: ]
If you do not have a valid license you will see the sign-on dialog box below. If you have purchased a software license you will have received a sign in id and password by email. If you do not have it please check your spam box. If you still cannot find it then please contact us via email using this link. If you have not purchased a license the click on the  button to obtain a license
Change your details and click the OK button to save your changes. Click Cancel to close the dialog box without saving any changes.
Removing the AutoTRAX software license
 If you click on the  button, the software license will be removed from the machine. You can easily reauthorize your copy by signing in again.








2.9. [bookmark: Authorizing_Your_Copy3A21B6F0]Authorizing Your Copy
When you purchase AutoTRAX you will receive a signon id and password. This will allow you to automatically authorize your copy of AutoTRAX on the machine you are using.
Demo Expired
When you start AutoTRAX and it has not been authorized, if the demo period has expired you will see the following dialog.

Getting you Software Key Automatically
Click  to get your key online. You will then see the following dialog. Enter you Sign in ID and your password to authorize AutoTRAX on your machine. This will automatically retrieve the Software Key from the AutoTRAX web site. You do NOT need the software key; AutoTRAX sends it automatically to the website to get your key. All you need is you Sign In ID and your password. You will have been sent this automatically when you purchased AutoTRAX. Check your email. If you can't find it, try your spam folder.

Sometimes your Firewall may prevent AutoTRAX from contacting the AutoTRAX  web site, in this case you will have to enter the software key manually.
You can enter the software key manually. To get a software key you can go to http://dexpcb.com/Account/SoftwareKey
Demo Not Expired
If the demo period of your copy of AutoTRAX has not expired you can authorize your copy click the   button in the Home→Account menu.  
If you do not have a valid license you will see the sign on dialog box below. If you have purchased a software license you will have received a sign in id and password by email. If you do not have it please check your spam box. If you still cannot find it then please contact us via email using this link. If you have not purchased a license the click on the purchase button to obtain a license
If you cannot sign on and you know you have a valid license, your firewall may be block access for AutoTRAX to the internet.  Click to find out how to configure your firewall.

Click here for more details about your account.
2.10. [bookmark: Authorizing_Your_CopyMachine_IndCD89028C]Authorizing Your Copy Machine Independent
To check your software license or enter a software key click the Software License button  in the Home→Account menu. 

If you have a valid license the account details dialog shown below will be displayed.

If it does not have a valid license then you will see the dialog box below. Enter the Software key



When you start AutoTRAX and it has not been authorized, if the demo period has expired you will see the following dialog. Enter the Software key


2.11. [bookmark: Getting_Your_Key_OnlineFECDDACA]Getting Your Key Online
You get you key online go to http://dexpcb.com/Account/SoftwareKey
If this is the first time you will need to sign in. You will see the sign in dialog below.

Enter your sign in ID and password and click . You will have been sent this automatically when you  purchased AutoTRAX. Check your email. If you can't find it, try your spam folder.
If you have entered a valid sign in ID and password your will see your account details.

Click the  button and you will see the Software Key page below.

Enter your Serial Number and click . 
Where Is My Serial Number?
The Serial Number  is show by AutoTRAX in the startup dialog below. Copy and paste this into the web page above. You do not need it when getting the Software Key automatically as AutoTRAX sends it for you to the website.

If your Serial Number is valid you will see you Software Key below. Copy and paste this into the AutoTRAX startup dialog above. 

If the Software Key is good you will see the dialog below. (With your key entered)

Click  to start using AutoTRAX.
2.12. [bookmark: Unauthorizing_Your_Copy]Unauthorizing Your Copy
To remove the software license for AutoTRAX on a machine, sign out using the account dialog. See Your Account Settings  
Click the  button.


2.13. [bookmark: Firewalls]Firewalls

Sometime an internet Firewall will block AutoTRAX from accessing the internet.
AutoTRAX accesses the internet to:
· Optionally find out if there is a new version available. You can always turn this off.
· Optionally download new versions. You cancel a download if AutoTRAX detects there is a new version. You can also turn off update checks at this point. However I recommend you download new versions as they often contain essential bug fixes.
· Download the latest part libraries.
· Obtain a software license for your machine.
· Allow you to view and/or update your account details.
How to allow a program to communicate through Windows Firewall
A firewall can either be software-based or hardware-based and is used to help keep a network secure. Its primary objective is to control the incoming and outgoing network traffic by analyzing the data packets and determining whether it should be allowed through or not, based on a predetermined rule set. A network firewall provides a security perimeter between a local area network (LAN) and external networks like the internet.   Computers on the LAN side of the network are considered to be trusted and secure, while computers on the external side of the firewall are considered to be untrusted and may pose a risk to computers on the trusted side of the firewall.  The firewall is utilized to restrict communication between the trusted and untrusted networks.  
By default, most programs are blocked by Windows Firewall, to help make your computer more secure. To work properly, some programs might require you to allow them to communicate through the firewall. Here's how to do that:
1. Open Windows Firewall by clicking the Start button, clicking Control Panel, clicking Security, and then clicking Windows Firewall.
1. In the left pane, click Allow a program through Windows Firewall.   If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
1. Select the check box next to the program you want to allow, and then click OK.
Warning
Before allowing any program through the firewall, make sure you understand the risks involved.
Click to view a video and read more about firewalls...
Can't Get Your Software Key?
You can enter the software key manually. To get a software key you can go to http://dexpcb.com/Account/SoftwareKey


2.14. [bookmark: Closing_AutoTRAXA768B54C]Closing AutoTRAX
To close AutoTRAX click on the Exit button   in the Home menu.
If you have any unsaved changes, you will be prompted to save your work.

2.15. [bookmark: Removing_AutoTRAXF010DF70]Removing AutoTRAX
To uninstall AutoTRAX Select Uninstall AutoTRAX Design Express from the Application menu.

The following dialog box will appear. Click  to remove AutoTRAX, Click  to cancel the removal.

The following progress dialog box will appear. 

When complete the following dialog will appear. Click the  button to close it.


2.16. [bookmark: Manually_Removing_AutoTRAXD7469EA2]Manually Removing AutoTRAX
To manually remove AutoTRAX, you need to remove:
1. The installed files.
1. The desktop icons. Select them and press the delete button.
1. The AutoTRAX entry in the Application Start menu. See below. right-click on the AutoTRAX icon and select Delete.
(Note: AutoTRAX does not add any entries to the Registry).



2.17. [bookmark: Disaster_RecoveryD4BF71F5]Disaster Recovery

Sadly it is sometimes the nature of Windows that AutoTRAX and other programs do not work.
	     
 If AutoTRAX does not start, a quick fix can be to delete the settings.
First click  in the Ribbon menu Panels->Panels command group. This will restore all the panel settings. 
If this does not work:
Try deleting...
C:\Users\XXX\AppData\Roaming\AutoTRAX Software\AutoTRAX\Settings
where XXX is you.


1. Next, make sure you have the latest graphics card driver. See Update the Graphics Card Driver
1. If it still is not working Manually Removing AutoTRAX and then install it from http://dexpcb.com/Download
1. If it still is not working Reinstall .NET
1. If it is still not working use Restore Points
1. If things are still not working I suggest trying a different graphics card.
1. Finally if things are still not working, backup all your data and repair Windows using the Windows DVD that came with your machine.
Restoring Previous Designs
I hope this helps.

2.17.1. [bookmark: Restoring_Previous_DesignsC71C34A9]Restoring Previous Designs
By default AutoTRAX saves a copy of EVERY change you make to your project. These are saves in a directory called XXX.backup where XXX is the full path name of your project.
To restore to any of the click the Home→Open→  button. The Restore Design dialog show below will appear.

The Restore Design dialog
Click on any of the rows in the left grid to view the project. The schematic (first page) and the PCB will be displayed in the viewports on the right.
 The date the design was saved
. The time the design was saved.
The action that occurred after the design was saved.
Click  to cancel/close the dialog.
Click  to restore the selected design state.
Click  to display this help topic.


2.17.2. [bookmark: Update_the_Graphics_Card_Drive963F0D9B]Update the Graphics Card Driver
To discover what your graphics card, right click on a blank area of the desktop.

Click the Screen Resolution menu item.

Click the Advanced Settings. You should see the device type as shown below.

Now Google for the device adding the word driver. Download and install the driver.
Hopefully this will fix the problem.

2.17.3. [bookmark: Reinstall__NET65D97AB6]Reinstall .NET
First uninstall .NET
Click on the Control Panel in the Start Menu.

Click on Uninstall a program

Click on the .NET version to remove.

Install the latest .NET from http://msdn.microsoft.com/en-us/library/5a4x27ek.aspx
Hopefully this will fix the problem.

2.17.4. [bookmark: Restore_Points91A9D59A]Restore Points
Sometimes installing a program or driver can make Windows run slowly or unpredictably. System Restore can return your PC's system files and programs to a time when everything was working fine, potentially preventing hours of troubleshooting headaches. It won't affect your documents, pictures, or other data. Read more http://windows.microsoft.com/en-gb/windows7/products/features/system-restore
Type in 'system restore' in the start menu and click on System Restore.




2.17.5. [bookmark: Preventing_Disasters64F86A63]Preventing Disasters


AutoTRAX saves every change you make to you design from the moment you first save it. See Restoring Previous Designs
In addition you should backup your Parts Library.
I strongly advise you to use third part software to automatically backup your .backup directory and all your .project files. See Free Backup Software

2.18. [bookmark: Design_ModesCB5E24FD]Design Modes
AutoTRAX handles 3 different types of files.
· Projects
· Parts
· Artwork
Projects contain schematics, text documents and a PCB and represent the design for your PCB.
Part files contain schematic symbols, text documents and a footprint (land pattern) that contains all the information needed to define the abstract schematic representation for a part together with the footprint required for the PCB and the 3D solid model for the part. 
Parts are defined parametrically; this allow a single part to be quickly and easily modified into a different part type. The parametric models define how to create a complete part from only a few simple parameters.
Artwork files contain schematic that do not have any electrical content, such as parts and wires. They are used for creating library artwork to be used in project and part files. They can also be used for any other drawing purposes, as AutoTRAX's powerful graphics allows you to graphically design engineering drawings.
2.19. [bookmark: Web_Tutorial066463D7]Web Tutorial
 Mick's Tutorial
Mick Gulovsen from Melbourne, Australia has created a tutorial on using AutoTRAX at http://dexpcb.com/HowToMakeAPCB.
'I intend to show the `basics’ of how to go about entering all of the required data to lay out a PCB, from start to finish, including creating the GERBER files to send to a PCB fabrication house for production. This document will no doubt be full of grammatical and spelling errors and may show methods that are not necessarily the easiest, or best, way to do things. It is the way that I go about using AutoTRAX, you may do things differently and that is fine. We are all individuals and we all do things in our own ways. I also make no guarantee about the accuracy of this board and in fact it may have serious errors that will make it useless. What is important is the methodology that I use and if you chose to make any PCBs using this design you do so at your own risk. Of course you can always edit the project to fix said errors, if they rear their ugly heads. One last thing is this will NOT be an exact TRACK for TRACK reproduction. You can route manually and exactly replicate the original but that would take a lot more effort and is a moot point as generally you will be designing from scratch'
 Mick Gulovsen 



2.20. [bookmark: The_Users_ForumC20F2A24]The Users Forum
The User Forum is a Windows client based application.
:
The Users Forum
You can start it by clicking on in the Help ribbon page.




3. [bookmark: Application_LayoutsFC6A8880]Application Layouts

Typical Layout

Parts of aTypical Layout


3.1. [bookmark: The_User_InterfaceDF2E64C3]The User Interface
The AutoTRAX workspace has had years to develop into a fine tuned working environment, and with bigger monitors and faster processors, working with AutoTRAX has only become more fun. With all the room that larger display options give you, you can easily organize the panels, viewports and tools in the workspace to provide an efficient designing environment.
AutoTRAX provides a consistent, single, highly configurable program interface to enable you to create parts, PCBs and even engineering artwork.
With all its features, AutoTRAX can be a bit daunting at first. The purpose of this chapter is to familiarize you with the AutoTRAX workspace and how to navigate around AutoTRAX, find tools, customize settings, and set the working environment so it best suits you.
So, without further ado let's look at the AutoTRAX workspace as shown below. 


3.2. [bookmark: The_Application_Layout8AFECEDF]The Application Layout
The Ribbon Menu is displayed at the top of the AutoTRAX main window as shown below.
The aim of the AutoTRAX Ribbon is to enhance usability by consolidating AutoTRAX's functions and commands in an easily recognizable place. You need not look through multiple levels of hierarchical menus, toolbars, or task panes before finding the right command.
The Ribbon consists of a pane that contains controls (such as buttons and icons) organized into a set of tabs, each one containing a grouping of relevant commands.
Some tabs, called contextual tabs, appear only after you select an object or a sheet. Contextual tabs expose functionality specific only to the object/sheet with focus.

File Button
Clicking this shows the file menu.
Ribbon Menu
This is the top menu which is similar to the ribbon menu you will see in Microsoft Office 2010 and later. It is a series of ribbon tabs which contain button groups. This is a modern substitute to the class drop down menu.
Ribbon Tab
A collection of ribbon button groups.
Ribbon Button Group
A collection of control buttons.
Quick Access Toolbar
At the top of AutoTRAX is the Quick Access toolbar which contains a grouping of ribbon control buttons that you can configure.
Viewport Tabs
This area contains viewports in tabbed control. Each tab shows you a different sheet. 
Viewport
Viewports are views of sheets. Sheets can be schematic sheet, symbol sheets, footprint sheet, PCB sheets or text document sheets.
Panels
Around the side of the viewports you can arrange Panels which are collections of controls to do a specific task.
Docking Panels
These are panels that are docked to the side of AutoTRAX. Normally you will dock them to the left or the right of the AutoTRAX main application window.
Floating Panels
These are panels that are free to move about the screen. You can even place then on different screens.
Auto-Hidden Panels
These are panels that automatically collapse and expand so you can see more of the viewports when you are working on them.
Status Bar
The status bar is always at the bottom of the AutoTRAX window. It shows the status prompts and lets you zoom in and out.
The Color Bar
This is a bar at the bottom of the AutoTRAX window that lets you set the fill and line color of selected objects.


3.2.1. [bookmark: The_File_MenuB614C15C]The File Menu
The File menu contains a list of commands for creating, opening, plotting, printing and sending projects, parts and artwork.  To show the file menu click on the  image at the top left of the AutoTRAX main application window.

Recent Designs
At the right of the menu is the Recent Designs list. This displays recent designs on which you have been working. Click on any design to open it.

New Project
Click to create a new project.
Open Project
Click to open an existing project.

New Part
Click to create a new part.
Open Part
Click to create open an existing part.
Part Wizard
Click to start the Part Wizard

New Artwork
Click to create a new artwork.
Open Artwork
Click to open an existing project.

Save
Click to save the current design. If it has never been saved you will be prompted for a new name, this is the same as the Save As command below.
Save As
This will prompt you for a new file name.
Close
This will close the current design. If you have unsaved work, you will be prompted to save it.

Export
This will reveal a pop-out menu list of different formats to which you can save.


Print
This will display the print preview dialog.
Plot
This will display the plot preview dialog.

Exit
This will close AutoTRAX. If you have unmodified work, you will be prompted to save it before AutoTRAX closes.
Send
Click this to send the design as an email attachment to a work colleague. It will open a send email dialog for your email program.

Options/Settings
This will display the options and settings control.
About
This will display the About dialog box that gives you details about the AutoTRAX program and its version number.

3.2.2. [bookmark: Ribbon_Menu036259FE]Ribbon Menu
A ribbon menu is a portion of a graphical user interface where a set of toolbars are placed on tabs in a tab bar. Microsoft software released since 2007 have popularized a form of modular ribbon as their main interface, where large toolbars filled with graphical button and other controls are grouped by functionality. Ribbons use tabs to expose different sets of controls, eliminating the need for many parallel tool bars. Contextual tabs are tabs that appear only when a user needs them. For instance, in a word processor, an image-related tab may appear when the user selects an image in a document, allowing the user to interact with that image.
The ribbon menu consists of a collection of Ribbon Tabs with each tab containing several ribbon button groups which contain related command buttons and controls.

AutoTRAX Ribbon Menu with Home Tab Selected
Ribbon Tab
A ribbon tab is a collection of ribbon button groups. Clicking on a tab will show a collection of related button groups.

Ribbon Button Groups
A ribbon button group is a collection of buttons with a common border.
Below is a collection of buttons arranged together in a button group that is named 'Select'.

Ribbon Button Group
Ribbon Button Group Pop-up Menu
At the base of some button groups you will see a small button. If you click on this a pop up dialog will appear that lets you set settings related to the commands in the button group.

Options Pop-up Button

Pop-up dialog for the select button group

3.2.3. [bookmark: Quick_Access_ToolbarC6B41E56]Quick Access Toolbar
The Quick Access Toolbar is a customizable toolbar that contains a set of commands that are independent of the tab that is currently displayed. You can move the Quick Access Toolbar from one of the two possible locations, and you can add buttons that represent commands to the Quick Access Toolbar.
The Quick Access Toolbar can be located in one of two places:
Upper-left corner next to the AutoTRAX Button

Below the Ribbon

If you don't want the Quick Access Toolbar to be displayed in its current location, you can move it to another location. If you find that the default location next to the AutoTRAX Button  is too far from your work area to be convenient, you may want to move it closer to your work area. Since location below the Ribbon encroaches on the work area, to maximize the work area, you may want to keep the Quick Access Toolbar in its default location.
Click Customize Quick Access Toolbar 
In the menu item list, click Show Below the Ribbon or Show Above the Ribbon.

Alternatively, you can right-click on any icon in the Quick Access Toolbar and select Show Below the Ribbon or Show Above the Ribbon from the shortcut menu.
Add a command to the Quick Access Toolbar
You can add a command to the Quick Access Toolbar directly from commands that are displayed on the Ribbon menu.
1. On the Ribbon, click the appropriate tab or group to display the command that you want to add to the Quick Access Toolbar.
1. Right-click the command, and then click Add to Quick Access Toolbar on the shortcut menu.
1. 
NOTES 
· You cannot increase the size of the buttons representing the commands by an option in AutoTRAX. The only way to increase the size of the buttons is to lower the screen resolution you use.
· You cannot display the Quick Access Toolbar on multiple lines.
· Only commands can be added to the Quick Access Toolbar. The contents of most lists, such as indent and spacing values and individual styles, which also appear on the Ribbon, cannot be added to the Quick Access Toolbar.
3.2.4. [bookmark: Auto_Repeat_commandAE374CBF]Auto-Repeat command
In AutoTRAX, there are times when it is convenient to repeat the last command immediately.  For example, you may want to place the same part on a graphical sheet more than once.  The Auto-Repeat commands feature in AutoTRAX is quite handy for this.  When enabled, the last command completed will automatically be repeated.  When this feature is enable to quit repeating the last command hit the ESC key.
To enable/disable the Auto-Repeat commands feature, in any viewport, right-click and select Auto-Repeat commands from the context menu displayed.  See below...


3.2.5. [bookmark: Cutomizing_The_Skins31475802]Themes
AutoTRAX comes with many attractive themes (Skins) that you can choose to match your mode and add that bit of variety to your life.
The Skins are selected via the Panels→Skins menu. Select the theme from the Skin gallery.

Themes ribbon button group

Standard Skins

Bonus Skins

Theme Skins

Default Theme

Halloween Theme

3.2.6. [bookmark: The_Workspace_Setttings6A0B33BF]The Workspace Setttings
AutoTRAX has 3 workspaces for each file type. When you click on any of the 3 work space buttons in the Panels ribbon tab, the layout of panels will be saved to the current work space and the panel layout for the clicked work space will be restored.

Workspace Buttons group
Click on the small button at the bottom left of the workspace button group to display the workspace settings pop up dialog. You can set the text name for each workspace button.

3.2.7. [bookmark: Workspaces]Workspaces
The AutoTRAX workspace consists of:
· A top menu. This can be a Microsoft Office style ribbon menu or the class drop-down menu with tool bars.
· A viewport area. This can be either a tabbed collection of viewports or a Multiple Document Interface (MDI) displaying a collection of one or more viewports displaying schematics, PCBs, 3D views and text documents.
· An optional status bar at the base of the viewport area.
· An optional color chooser, again at the base of the viewport area.
· One of several optional dockable/floatable control panels that contain controls to help you modify/control your design.

Workspace Buttons group
3.2.8. [bookmark: The_File_Settings8129EF28]The File Settings
The File button group has a pop up dialog that allows you to set the settings related to file open and save commands.
	
	Automatic Archive
This creates a directory where a separate project file is saved every time you make a change to a projects (Zooms, pans etc. do not create a saved project file).
This gives you a complete audit trail of all changes you make to a project.
Parts and Artworks are not archived.
Reload Last File on Startup
If checked, the last project, part or artwork saved will be reloaded on start-up.
Save File Compressed
If not checked, AutoTRAX files are uncompressed XML and can be views with any text editor. Compressed files can be less than 5% of the size of an uncompressed file. You are recommended to compress your files.
Decompress File
Click this to decompress a AutoTRAX file. A pop up dialog will appear where you can select a file to decompress.
Reset Default 
Reset the default template file for projects, parts and artworks to the factory default. You can always set the default again.





3.2.9. [bookmark: The_Color_BarB1ED26B1]The Color Bar
The Color Bar is shown below. You can hide/show the color bar from the Panels ribbon menu group in the main menu.
You can select the fill or pen/line color for selected object by clicking on one of the color buttons in the Color Bar.
The button on the left of the color bar is the fill color. The button to the right of the fill color is the line or border color. If you click on either of these buttons a color chooser will appear as shown below. Pick a color and click on the  button. Click the  button to ignore your changes. Press the  key to get help on this color picker.

Color Picker

Left-click on a button to set the fill color.
Right-click to set the pen/line color.
If the selected object can only have a fill color, or a pen/line color, then clicking the left or right mouse button will set the fill or pen/line color.
If no object is selected then the selected color will be used as the default color when adding more objects.

3.2.10. [bookmark: The_Status_Bar7341B044]The Status Bar
The status bar gives you timely status messages and details as you work on your design. By default the status bar is placed underneath the top menu. You can place the status bar at the bottom of the application just below the viewport. To change the position of the status bar right click on the status bar and select the position of the status bar from the context menu.
The status bar cannot be floated by the panels but you can I hide it by selecting hide from the status bars context menu. To reassure the status bar click on the view status bar in the panels menu.


 This is the text status area. The content changes for each command in AutoTRAX.
 Check/uncheck this button to enable/disable tooltips.
 Check/uncheck this button to enable/disable smart panning.
 Drag the slider to zoom in and out of the selected viewport. 
 These buttons let you set the number of snaps per grid.
 This button lets you turn stuck to objects on or off.
 You can turn snap rotation on/off by clicking this button.
 You can quickly change the units from millimeters to inches or vice versa by clicking on one of these two buttons.
 You can change the pickup mode from top-level pick to sub pick or vice versa by clicking on one of these two buttons. Sub picking allows you to select objects that are inside other objects.

3.3. [bookmark: The_Ribbon_MenuA367F816]The Ribbon Menu
The Ribbon menu is home to hundreds of commands. It consists of several ribbon pages filled with commands and appears at the top of AutoTRAX's main window. 
You make changes to your design using:
· The Ribbon Menu
· Interacting with the viewports using the mouse and keyboard.
· Making changes using one of the many panels.
	     The ribbon pages and their content are context sensitive and will only appear where applicable, for instance, the PCB Ribbon Page will only appear when editing a PCB in a project.

You can easily customize the command keyboard shortcuts using the Shortcuts Editor.


The Ribbon menu consists of the following ribbon pages:
The Home Ribbon Page

The Help Ribbon Page

The Panels Ribbon Page

The Symbol Ribbon Page

The Schematic Ribbon Page

The Footprint Ribbon Page

The PCB Ribbon Page

The Route Ribbon Page

The View/Snap Ribbon Page

The Edit Ribbon Page

The Add Ribbon Page

The Parts Ribbon Page

The Layout Ribbon Page

The Simulate Schematic Page


The Tools Ribbon Page

The 3D Ribbon Page


3.3.1. [bookmark: The_Home_Ribbon_Page1584D9D8]The Home Ribbon Page

The Home Ribbon Page
The Getting Started Command Group
	 How to Make a PCB
Click to see a quick and enlightening tutorial on how to make a PCB.

 Video Tutorials
Click to view a useful collection of video tutorials that will guide you through the process of PCB design.

AutoTRAX Video Tutorials Web Page



Getting Started Commands
	The Datasheets Command Group
	  Suppliers
This display valuable links to suppliers of electronic parts. Read more...

Suppliers



Suppliers Commands
	The Print Command Group
	  Print the Design
This will print your design. Read more...





Print Commands
	The New Command Group
	  Run the Part Wizard
This will run the Part Wizard what will guide you through the process of creating a custom part. Read more...

The Part Wizard
  Create a New Part
Click to create a new blank part. Read more about creating parts...

  Create a New Project
This will create a new project. Read more about projects...

 



New Commands
	The Open Command Group
	  Open an Existing Project
Click to open an existing project.

Open an Existing Project
  Open an Existing Part
Click to open an existing part.

Open an Existing Part

 Open an Existing AutoTRAX EDA Design
Click to open an existing legacy AutoTRAX EDA project. This will open a legacy schematic and PCB design. AutoTRAX EDA was discontinued 
You can download AutoTRAX EDA from here...

AutoTRAX EDA
  Recover a Past/Future Version
This displays the Restore Design dialog that list all changed that you have made to a project or part. You can easily revert to a past design change. Read more...

The Restore Design Dialog



Open Commands
	The Sheet Command Group
	  Create a New Schematic
This adds a new schematic sheet to your project..
 Create a New Symbol
In parts, schematics act as symbol schematics. So, if you have a part that needs two symbols, then you would have two  schematic symbol sheets.
If you currently have a part open, then the additional schematic symbol sheet will be a sub-part. For instance, if you are creating a part which has 2 op-amps, you would have 2 schematics symbol sheets in total; one for each op-amp. You might also add an additional schematic symbol sheet for the power connections.
 Create a New Text
This will add a new text/document sheet to your design.

  Add a PDF to the Design
Clicking this will allow you to embed an Adobe PDF file in your project/part.

Add a PDF to the Design

  Delete the Current Sheet
This will delete the currently select sheet.




Sheet Commands
	The File Command Group
	  Close
This will close the current project/part. A new unsaved project/part will then be created.  

New Design After Closing Current Design

   Save
This will save the design. If it has never been save you will be prompted for a save location and a file name.

   Save As

Save As Dialog
This will save the design to a new location and file name.




File Commands
	The Account Command Group
	  Get Latest Version
Click to get the latest version of AutoTRAX. Read more...
  What's New
Display the What's New web-page detailing changes.

What's New

 Software License
This will display you software license details. Read more...
 About
This will display the About AutoTRAX dialog box. It displays version details and the version of OpenGL installed on your machine.

The About Dialog Box





Account Commands
	The Exit Command Group
	  Close AutoTRAX
This will close AutoTRAX. If you have an unsaved edit then you will be prompted to save it.

	 What if you exit AutoTRAX but did not save it? Well, fear not:
 When you restart AutoTRAX if you click on the Redo buttons you can recover each change, one by one. 
Alternatively you can click the  button and select a state to recover to.
Find out more...



The Exit Commands
3.3.2. [bookmark: The_Help_Ribbon_Page72580DDE]The Help Ribbon Page

The Help Ribbon Page
	The Manual Command Group
	   Help
This will display the online manual.

The On-line Manual
 How to Make a Video Tutorial
Click to display the on-line tutorial on how to create a PCB using AutoTRAX DEX.

  
Tip of the Day
Show the Tip of the Day modal dialog.

  
 Download a Printable Manual
Click to download the AutoTRAX manual as:
· An Adobe PDF file or

Adobe PDF Manual
· An Apple ePub file

Apple ePub Manual



Manual Commands
	The Videos Command Group
	  View the YouTube Videos
This will display the AutoTRAX YouTube web site.

The AutoTRAX YouTube Website
 View the Video Tutorials
This will display the AutoTRAX video tutorials web page.

AutoTRAX Video Tutorials Web Page



Video Commands
	The Support Command Group
	 AutoTRAX Website
Click to go to the AutoTRAX Website.

 AutoTRAX Twitter Website
Click to go to the AutoTRAX Twitter page.

The AutoTRAX Twitter Page
 The AutoTRAX Users Forum
Find out more...

The Users Forum Application
 Subscribe to the Newsletter
Click to subscribe to the AutoTRAX Newsletter.

Subscribing to the Newsletter
 Send Feedback
Send us feedback.

Sending Feedback
 Send Us Your Wishlist

Sending Your Wishlist
 Report a Problem

Reporting a Problem
 Show the About Dialog
This will display the About AutoTRAX dialog box. It displays version details and the version of OpenGL installed on your machine.

The About Dialog Box




Support Commands
	The Samples Command Group
	 The Serial Backpack
Open the Serial Backpack project donated by Mick Gulovsen from Melbourne, Australia.

The Serial Backpack
 DEX UNO
Click to open the DEX UNO sample project. 

DEX UNO
 Amplifier
An amplifier.

The Main Schematic for the Amplifier
 Front Panel
A front panel demonstrating AutoTRAX's graphics capability.

Front Panel
 CPU Logic Diagram
A CPU logic diagram demonstrating AutoTRAX's graphics capability.

CPU Diagram
 Automotive Car Harness
 This project shows you part of the electrical circuit in an automobile such as you might see in a typical user manual.

Car Electrical Harness
 Flowchart
A flowchart demonstrating AutoTRAX's graphics capability.

Flowchart




Sample Commands
3.3.3. [bookmark: The_Panels_Ribbon_PageB78BBB94]The Panels Ribbon Page

The Panels Ribbon Page
	The Windows Command Group
	  Tabbled

  Cascade

  Horizontal

  Vertical

  Add Window

  First Schematic

  PCB

  3D

  Schematic and PCB
TODO
  PCB and 3D

  Schematic, PCB and 3D




Window Commands
	The Panels Command Group
	  Checklist
Read More...
  Part Builder
Read More...
  Project
Read More...
  Properties
Read More...
  Popup Properties
Read More...
  Spice Model Properties
Read More...
  Library
Read More...
  Layers
Read More...
  Route
Read More...
  DRC
Read More...
  Navigator
Read More...
  Settings
Read More...
  Parts Bin
Read More...
  Net List
Read More...
  Parts List
Read More...
 System Information
Read More...
  Status Bar
Read More...
  Color Bar
Read More...
  Source
Read More...
  Scripting
Read More...
  Reset
Click to reset all the panel layouts.




Panels Commands
	TheWork Space Command Group
	  Workspace 1

  Workspace 2

  Workspace 3





Workspace Commands
	The Menu Command Group
	  Edit ShortCuts

  Minimize

  Compact

 Large Fonts

  Radial Popups




Menu Commands
	The Themes Command Group
	
 Set the Theme



Theme Commands
3.3.4. [bookmark: The_Symbol_Ribbon_Page3E5D3AE9]The Symbol Ribbon Page

The Symbol Ribbon Page
	Undo/Redo Command Group
	  Recover

   Undo

   Redo
 
 Click on the small button at the bottom right of the command group to display the Undo Popup. 



Undo/Redo Commands
	Add Border and Terminals Command Group
	  New Symbol

  Duplicate Symbol

  Border

  Line

  Medium

  Short

  Dot

  Point

  Circle

  Dot-Clock

  Clock

  Input

  Output




Add Terminals and Symbols Commands
	Graphical Shapes Command Group
	  Line

  Polyline

  Arc

  Curve

  Text

  Image

  Hollow Rectangle

  Filled  Rectangle

  Solid  Rectangle

   Hollow Rounded Rectangle

  Filled  Rounded Rectangle

  Solid Rounded  Rectangle

  Hollow Ellipse / Circle

  Filled  Ellipse / Circle

  Solid Ellipse / Circle

  Hollow Polygon

  Filled Polygon

  Solid Polygon

  Hollow Closed Curve

  Filled Closed Curve

  Solid Closed Curve

  Note

  Note With Rounded Corners

  Line Style

  Fill Style

  Line Width

 Click on the small button at the bottom right of the command group to display the Shapes Default Popup.



Graphical Shapes Commands
	Rebuild Command Group
	  Single Sided

  2 Sided

  1 Sided
 



Rebuild Commands
	Footprint Command Group
	  No Footprint
 



Footprint Commands
	Panels Command Group
	  Library
Read More...
  Part Builder
Read More...
  Project
Read More...
  Properties
Read More...



Panels Commands
3.3.5. [bookmark: The_Tools_Schematic_Page9B89D3C9]The Schematic Ribbon Page

The Schematic Ribbon Page
	Undo/Redo Command Group
	   Undo

   Redo
 
  Click on the small button at the bottom right of the command group to display the Undo Popup



Undo/Redo Commands
	PCB Command Group
	  Build PCB

  PCB




PCB Commands
	Panels Command Group
	  Project
Read More...
  Library
Read More...



Panels Commands
	Ground Command Group
	 Digital
 
 Ground
 
  Analog
 



Ground Commands
	Power Command Group
	 Single Cell
 
 Multiple Cell
 
  +5V
 
  -5V
 
  +12V

  -12V

  Vcc

  Vdd
 
 Fuse
 



Power Commands
	Resistors Command Group
	 Variable
 
 Preset
 
  Thermistor
 
 Resistor
 
 Click on the small button at the bottom right of the command group to display the Add Parts Settings Popup.




Resistors Commands
	Capacitors Command Group
	 Capacitor
 
 Capacitor
 
 Electrolytic
 
 Click on the small button at the bottom right of the command group to display the Add Parts Settings Popup..



Capacitors Commands
	Wires Command Group
	  Wire

  No Connect

  Inter-Wire

  Click on the small button at the bottom right of the command group to display the Wire and Bus Settings Popup.



Wires Commands
	Buses Command Group
	  Bus

  Bevel

  Click on the small button at the bottom right of the command group to display the Wire and Bus Settings Popup.



Buses Commands
	Graphical Shapes Command Group
	  Line

  Polyline

  Arc

  Curve

  Text

  Image

  Hollow Rectangle

  Filled  Rectangle

  Solid  Rectangle

   Hollow Rounded Rectangle

  Filled  Rounded Rectangle

  Solid Rounded  Rectangle

  Hollow Ellipse / Circle

  Filled  Ellipse / Circle

  Solid Ellipse / Circle

  Hollow Polygon

  Filled Polygon

  Solid Polygon

  Hollow Closed Curve

  Filled Closed Curve

  Solid Closed Curve

  Note

  Note With Rounded Corners

  Line Style

  Fill Style

  Line Width

 Click on the small button at the bottom right of the command group to display the Shapes Default Popup.



Graphical Shapes Commands
	Refactor Command Group
	  Move to Schematic




Refactor Commands
	Autoroute/Snap Command Group
	  Selected

  All

  Snap

 Click on the small button at the bottom right of the command group to display the Wire and Bus Settings Popup.
 



Autoroute/Snap Commands
	Connections Command Group
	  Connect

  Remove

 



Connections Commands
3.3.6. [bookmark: The_Footprint_Schematic_PageE1A9226D]The Footprint Ribbon Page

The Footprint Ribbon Page
	Undo/Redo Command Group
	  Recover

   Undo

   Redo

 Click on the small button at the bottom right of the command group to display the Undo Popup. 



Undo/Redo Commands
	The Panels Command Group
	  Library
Read More...
  Part Builder
Read More...
  Properties
Read More...
  Layers
Read More...



Panels Commands
	Pads Command Group
	 Round/Elliptical TPH Pad

 Square/Rectangular TPH Pad

 Polygonal TPH Pad

 Round/Elliptical SMT Pad

 Square/Rectangular SMT Pad

 Polygonal SMT Pad

  Lock Pad Width to Height

 Add Preset or Interactive

  Pad Size Pad Size

 Renumber




Pads Commands
	No Mask Command Group
	 Square/Rectangular

 Circle/Ellipse

 Polygonal




No Mask Commands	
	Graphical Shapes Command Group
	  Line

  Polyline

  Arc

  Curve

  Text

  Image

  Hollow Rectangle

  Filled  Rectangle

  Solid  Rectangle

   Hollow Rounded Rectangle

  Filled  Rounded Rectangle

  Solid Rounded  Rectangle

  Hollow Ellipse / Circle

  Filled  Ellipse / Circle

  Solid Ellipse / Circle

  Hollow Polygon

  Filled Polygon

  Solid Polygon

  Hollow Closed Curve

  Filled Closed Curve

  Solid Closed Curve

  Note

  Note With Rounded Corners

  Line Style

  Fill Style

  Line Width

 Click on the small button at the bottom right of the command group to display the Shapes Default Popup.



Graphical Shapes Commands
	Pads Command Group
	 Show Holes

 Show Pad Names




Pads Commands
	Footprints Command Group
	 Courtyards

 Placement




Footprints Commands
	View From Command Group
	  Top

 Bottom




View From Commands
3.3.7. [bookmark: The_PCB_Ribbon_Page80B938A8]The PCB Ribbon Page

The PCB Ribbon Page
	 Undo/Redo Command Group
	   Undo

   Redo

 Click on the small button at the bottom right of the command group to display the Undo Popup. 




Undo/Redo Commands
	Panels Command Group
	 DRC

 Layers

 Preview Gerber

 3D




Panels Commands
	PCB Command Group
	 Build PCB

 Rectangular PCB

 Circular/Elliptical PCB

 Polygonal PCB

 Rotate 90°

 Fiducial

 V-Cut

 Click on the small button at the bottom right of the command group to display the Fiducial Popup.




PCB Commands
	Cutouts Command Group
	 Retabgular

Circular/Elliptical

Polygon

 Polyline

 Curve

 Drill Hole

 Clip

  Click on the small button at the bottom right of the command group to display the Cutouts Popup.




Cutouts Commands
	Layout Command Group
	   Place Around Border
 
  Auto-Layout

  Interactive
 
  Distribute
 
  Renumber Parts
 
   Click on the small button at the bottom right of the command group to display the Layout Settings Popup.



Layout Commands
	Footprints Command Group
	 Lock

 Unlock All

 Swap




Footprints Commands	
	 Route Command Group
	 Hide Unrouted
	When manually routing a PCB, it often difficult to find a path because the un-routed track segments from other nets obscure you vision; You cannot 'see the wood for the trees'. This video on the right shows you how AutoTRAX solves this problem by using auto-dimming and auto-hiding.
If the button is checked and a net/track has been chosen, then all unrouted track segments on all nets are hidden except for the chosen net/track.
You can chose a net/track by:
· Clicking on the net in the viewport or
· Click on the net’s row in the Route Panel.
If unchecked the all unrouted track segments will be visible if no net/track is selected.
	


 All
Auto-route all nets.
 Selected
Auto-route the selected net.
 Import
Import an Electra route file.
  Click on the small button at the bottom right of the command group to display the Router Settings Popup.
	



Route Commands
	Pads Command Group
	 Round/Elliptical TPH Pad

 Square/Rectangular TPH Pad

 Polygonal TPH Pad

 Round/Elliptical SMT Pad

 Square/Rectangular SMT Pad

 Polygonal SMT Pad

  Lock Pad Width to Height

 Add Preset or Interactive

  Pad Size Pad Size

 Renumber




Pads Commands
	Unroute Command Group
	 All

 Net

 Track

 Segment




Unroute Commands	
	Vias Group
	 Add

 Size

 X

  Click on the small button at the bottom right of the command group to display the Track Via Settings Popup.



Vias Commands	
	Split Command Group
	 Rectangular Split Power Plane

 Circular/Elliptical Split Power Plane

 Polygonal Split Power Plane





Split Commands	
	Copper Pour Command Group
	 Rectangular Copper Pour

 Circular/Elliptical Copper Pour

 Polygonal Copper Pour

 Fill All 

 Clear All 
 Click on the small button at the bottom right of the command group to display the Copper Pour Settings Popup.




Copper Pour Commands	
	No Mask Command Group
	 Square/Rectangular

 Circle/Ellipse

 Polygonal




No Mask Commands	
	View From Command Group
	  Top

 Bottom




View From Commands
3.3.8. [bookmark: The_Route_Ribbon_Page77DBB2D2]The Route Ribbon Page

The Route Ribbon Page
	General Command Group
	   Undo

   Redo

  Show/Hide the Grid

  DRC
Read More...
  Layers
Read More...
  Route
Read More...




General Commands	
	Footprints Command Group
	 Lock

 Unlock All

 Swap




Footprints Commands	
	 Route Command Group
	 All

 Selected

 Import





Route Commands	
	Tracks Command Group
	 Add Track

 Stub

 Rounded Tracks

 Analog

 90°

 45°

 Any

 Move
 
 Free
 
 Ortho

 Angled

 Hide Unrouted
	When manually routing a PCB, it often difficult to find a path because the un-routed track segments from other nets obscure you vision; You cannot 'see the wood for the trees'. This video on the right shows you how AutoTRAX solves this problem by using auto-dimming and auto-hiding.
If the button is checked and a net/track has been chosen, then all unrouted track segments on all nets are hidden except for the chosen net/track.
You can chose a net/track by:
· Clicking on the net in the viewport or
· Click on the net’s row in the Route Panel.
If unchecked the all unrouted track segments will be visible if no net/track is selected.
	


  Auto-Dim

  Auto-Hide

  Optimize Unrouted





Tracks Commands	
	Snaps per Grid Command Group
	 Each button displays the number of snaps per grid.
 Snap Settings
Click on the small button at the bottom right of the command group to display the Snap Settings popup. 



Snaps per Grid Commands
	Unroute Command Group
	 All

 Net

 Track

 Segment




Unroute Commands	
	SMD Pads to Powe Planes Command Group
	 Reconnect All

 Auto Connect




SMD Pads to Power Planes Commands	
	Design Rules Command Group
	  Check
 
  Clear

  DRC Errors
 
  Click on the small button at the bottom right of the command group to display the Design Rules Popup.



Design Rules Commands
	Pads Command Group
	 Show Holes

 Show Pad Names




Pads Commands
	Footprints Command Group
	 Courtyards

 Placement




Footprints Commands
3.3.9. [bookmark: The_View_Snap_Ribbon_Page67587F9F]The View/Snap Ribbon Page

The View/Snap Ribbon Page
	View Command Group
	  View Full Page

   View Page Width

   View Page Height

   View Content

   View All

  View  Selected

  Page Settings
Click on the small button at the bottom right of the command group to display the Page Settings popup. 



View Commands
	Zoom Command Group
	  Zoom Window

 Zoom In

 Zoom Out




Zoom Commands
	Pan Command Group
	  Pan Left

  Pan Right

  Pan Up

  Pan Down

  Pan




Pan Commands
	Snap Command Group
	  Snap to Guides

  Snap Rotation

  Snap to Objects

  Snap to Object Profiles
This is only enabled if Snap to Objects is enabled.
  Snap Settings
Click on the small button at the bottom right of the command group to display the Snap Settings popup.



Snap Commands
	Snaps per Grid Command Group
	 Each button displays the number of snaps per grid.
 Snap Settings
Click on the small button at the bottom right of the command group to display the Snap Settings popup. 



Snaps per Grid Commands
	Show Command Group
	  Show/Hide Rulers

  Show/Hide the Scroll Bars

  Show/Hide the Grid

  Show/Hide the Origin

  Show/Hide the Guides

  Show/Hide Node Names

  Show/Hide DRC Errors




Show Commands
	Page Command Group
	  Show Page

  Show the Grid Reference

  Show the Title Block

  Page Settings
Click on the small button at the bottom right of the command group to display the Page Settings popup. 



Page Commands

3.3.10. [bookmark: The_Edit_Ribbon_Page2C41367F]The Edit Ribbon Page

The Edit Ribbon Page
	Edit Command Group
	  Recover

   Undo

   Redo

   Cut

  Delete

  Copy

  Paste

  Copy Image

  Clear

  Duplicate Symbol

 Click on the small button at the bottom right of the command group to display the Undo Popup. 



Edit Commands
	Select/Lock Command Group

	  Sub Pick

   Pick

   Select All

   Invert Selection

   Deselect All

  Lock

  Unlock

 Click on the small button at the bottom right of the command group to display the Selection Settings Popup. 



Select/Lock Commands
	Rotate Command Group
	  Rotate Clockwise 90° 
To rotate an object by 90°
1. Select the object.
1. Click the button above.
   Rotate180° 

   Rotate Anticlockwise 90° 

   Turn Rotate Snap On/Off

   Rotate Snap Angle

  Rotate About the Z Axis




Rotate Commands
	Mirror Command Group
	  Mirror About the Selected Entities Horizontal Axis

   Mirror About the Selected Entities Vertical Axis




Mirror Commands
	Scale Command Group
	 Scale Up

  Scale Down

  Scale Factor




Scale Commands
	Array Command Group
	  Create a Rectangular Array From the Selected Entities

 Create a Circular Array From the Selected Entities




Array Commands
	Group Command Group
	  Group the Selected Entities

  Ungroup the Selected Entities




Group Commands
	Combine Command Group
	   Combine the Selected Entities




Combine Commands
3.3.11. [bookmark: The_Add_Ribbon_PageED4F1BDE]The Add Ribbon Page

The Add Ribbon Page
	Undo/Redo Command Group
	   Undo

   Redo
 
  Cancel
  Click on the small button at the bottom right of the command group to display the Undo Popup



Undo/Redo Commands
	Parts Command Group
	  Add Part

  Resistor

  Capacitor

  Vcc

  Analog
  Click on the small button at the bottom right of the command group to display the Add Parts Popup.



Parts Commands
	Guides Command Group
	  Vertical Guide

  Horizontal Guide

  Angled Guide

  Point Guide




Guides Commands
	Graphical Shapes Command Group
	  Line

  Polyline

  Arc

  Curve

  Text

  Image

  Hollow Rectangle

  Filled  Rectangle

  Solid  Rectangle

   Hollow Rounded Rectangle

  Filled  Rounded Rectangle

  Solid Rounded  Rectangle

  Hollow Ellipse / Circle

  Filled  Ellipse / Circle

  Solid Ellipse / Circle

  Hollow Polygon

  Filled Polygon

  Solid Polygon

  Hollow Closed Curve

  Filled Closed Curve

  Solid Closed Curve

  Note

  Note With Rounded Corners

  Line Style

  Fill Style

  Line Width

 Click on the small button at the bottom right of the command group to display the Shapes Default Popup.



Graphical Shapes Commands
	Markers Command Group
	  Ellipse




Markers Commands
	Dimensions Command Group
	  Linear

  Aligned

  Coord.

 Click on the small button at the bottom right of the command group to display the Dimension Settings Popup.



Dimensions Commands
	Wires Command Group
	  Wire

  No Connect

  Inter-Wire

  Click on the small button at the bottom right of the command group to display the Wire and Bus Settings Popup.



Wires Commands
	Buses Command Group
	  Bus

  Bevel

  Click on the small button at the bottom right of the command group to display the Wire and Bus Settings Popup.



Buses Commands
	Symbol Command Group
	  Border

  Line

  Medium

  Short

  Dot

  Point

  Circle

  Dot-Clock

  Clock

  Input

  Output




Symbol Commands
	Sub Command Group
	  New

  Add Existing

  Port




Sub Commands
	Sheet Command Group
	  Create a New Schematic
This adds a new schematic sheet to your project..
 Create a New Symbol
In parts, schematics act as symbol schematics. So, if you have a part that needs two symbols, then you would have two  schematic symbol sheets.
If you currently have a part open, then the additional schematic symbol sheet will be a sub-part. For instance, if you are creating a part which has 2 op-amps, you would have 2 schematics symbol sheets in total; one for each op-amp. You might also add an additional schematic symbol sheet for the power connections.
 Create a New Text
This will add a new text/document sheet to your design.

  Add a PDF to the Design
Clicking this will allow you to embed an Adobe PDF file in your project/part.

Add a PDF to the Design
  Clear
Clears the current sheet.



Sheet Commands

3.3.12. [bookmark: The_Parts_Schematic_PageE111AC28]The Parts Ribbon Page

The Parts Ribbon Page
	Library Command Group
	  Library

  Add Part

  Suppliers
 



Library Commands
	Ground Command Group
	 Digital
 
 Ground
 
  Analog
 



Ground Commands
	Power Command Group
	 Single Cell
 
 Multiple Cell
 
  +5V
 
  -5V
 
  +12V

  -12V

  Vcc

  Vdd
 
 Fuse
 



Power Commands
	Resistors Command Group
	 Variable
 
 Preset
 
  Thermistor
 
 Resistor
 
 Click on the small button at the bottom right of the command group to display the Add Parts Settings Popup.




Resistors Commands
	Capacitors Command Group
	 Capacitor
 
 Capacitor
 
 Electrolytic
 
 Click on the small button at the bottom right of the command group to display the Add Parts Settings Popup..



Capacitors Commands
	Inductors Command Group
	 Inductor
 
 Inductor
 
 Inductor
 



Inductors Commands
	Transformers Command Group
	 Transformer
 
 Transformer
 
 Transformer
 



Transformers Commands
	Diodes Command Group
	  Diode
 
  Diode
 
  Diode
 
 LED
 
  LED
 
 LED
 
 LED
 
 LED
 



Diodes Commands
	BJT Command Group
	 PNP
 
 NPN
 



BJT Commands
	JFET Command Group
	 P-Channel
 
 N-Channel
 



JFET Commands
	NMOS Command Group
	 P-Channel
 
 N-Channel
 
  P-Channel
 
  N-Channel



NMOS Commands
	Switches Command Group
	 Closed
 
 Push
 
 Push
 
 Open
 
 Push
 
 Push
 



Switches Commands
	 Miscellaneous Command Group
	 Motor
 
 Loudspeaker
 
 Xtal
 



Miscellaneous Commands
	Connectors Command Group
	 Test Point
 
 SIP 2
 
 SIP 4
 
 DIP 4
 
 DIP 6
 
 DIP 8
 



Connectors Commands


3.3.13. [bookmark: The_Layout_Ribbon_Page6DD151E7]The Layout Ribbon Page

The Layout Ribbon Page
	Align Command Group
	  Top
 
  Bottom

  Left
 
  Right

  Center
 
  Middle




Align Commands
	Distribute Command Group
	  Across
 
  Down




Distribute Commands
	Size Command Group
	  Width
 
  Height




Size Commands
	Group Command Group
	  Group the Selected Entities

  Ungroup the Selected Entities




Group Commands
	Order Command Group
	  To Front
 
  To Back

  Bring Forward

  Send Backward
 



Order Commands
	Center Command Group
	  Center Drawing
 
  Center PCB




Center Commands
	Layout Command Group
	   Build PCB

  Place Around Border
 
  Auto-Layout

  Interactive
 
  Distribute
 
  Renumber Parts
 
   Click on the small button at the bottom right of the command group to display the Layout Settings Popup.



Layout Commands

3.3.14. [bookmark: The_Simulate_Schematic_Page1F3990B0]The Simulate Schematic Page

The Simulate Ribbon Page
	Spice Model Command Group
	  Open Sample

  Spice Model Popup
 



 Spice Model Commands
	Passive Command Group
	  Resistor

  Capacitor

  Inductor
 
  Transformer
 



Passive Commands

	Diodes Command Group
	 Diode

  Transmission Line





 Diodes Commands
	BJT Command Group
	 PNP
 
 NPN
 



BJT Commands
	JFET Command Group
	 P-Channel
 
 N-Channel
 



JFET Commands
	NMOS Command Group
	 P-Channel
 
 N-Channel
 
  P-Channel
 
  N-Channel



NMOS Commands
	Power Command Group
	 +12V
 
 -12V
 
  +5V
 
  -5V

  Analog
 



Power Commands
	Source Command Group
	 Voltage
 
 Current
 
 110V AC
 
  230V AC



Sources Commands
	Dependent Sources Command Group
	 VCVS
 
 VCCS
 
  CCVS
 
  CCCS



Dependent Sources Commands
	Instruments Command Group
	 Power Supply
 
 Function Generator
 
  Oscilloscope
 
  Chart




Instruments Commands
	Analysis Command Group
	 Node Names
 
 Probe Traces
 
  Add Probe
 



 Analysis Commands
3.3.15. [bookmark: The_Tools_Ribbon_Page9C735DB4]The Tools Ribbon Page

The Tools Ribbon Page
	Units Command Group
	  Microns
 
  Millimetres

   Centimetres
 
   Metres
 
   Thou
 
   Inches
 
   Click on the small button at the bottom right of the command group to display the Snap Settings Popup.



Units Commands

	Renumber Command Group
	  Renumber Parts
 
  Renumber Fiducials
. 



Renumber Commands

	Miscellaneous Command Group
	  Measure
 
  Library




Miscellaneous Commands
	Design Rules Command Group
	  Check
 
  Clear

  DRC Errors
 
  Click on the small button at the bottom right of the command group to display the Design Rules Popup.



Design Rules Commands
	Manufacturing Command Group
	  Plot
 
  Manufacture Files

  Preview Gerber
 
  Generate Gerber
 
  Dill File
 
  Pick and Place
 
  BOM
 
  Click on the small button at the bottom right of the command group to display the Manufacturing Settings Popup.



Manufacturing Commands
	Import Command Group
	  Import 3D

  Eagle Library

  Eagle Project
 
  DXF
 
  SVG
 
  Click on the small button at the bottom right of the command group to display the File Settings Popup. 



Import Commands
	Export Command Group
	  CNC

  DXF
 
  SVG
 
  IDF
 
  Image
 
  Netlist
 
  PDF
 
  Spice
 
  Collada
 
  STL

  OBJ

  POV RAY

  Click on the small button at the bottom right of the command group to display the File Settings Popup. 



Export Commands
	Utilities Programs Command Group
	  Part Creator

  Active3D
 
  Sketcher
 
  Diagrams
 
  Spreadsheet
 
  Text Editor
 
  Scheduler




Utilities Commands
3.3.16. [bookmark: The_3D_Ribbon_Page2336112A]The 3D Ribbon Page
The 3D Ribbon page, which contains 43 separate commands, will only be visible if a 3D viewport is visible and selected: see the View/Edit ribbon page and the viewport context menu

The 3D Ribbon Page
	The Import/Export Command Group
	  Import 3D

  Export to STL

  Export to OBJ

  Export to Colada

  Export to POV RAY




Import/Export Commands
	The Model Command Group
	 3D Copper
View copper as true 3D else view copper as a 2D image on the PCB. Viewing copper as 3D may make your 3D viewing slower - it depends on your graphics card.
 Refresh All 3D Models
Click to rebuild all the 3D content in the 3D viewport. You might do this if the 3D looks out of sync with your design. Generally, you should not need to do this as AutoTRAX automatically rebuilds your 3D models if needed.
	



Model Commands
	The Move/View Command Group
	  Move

  View


	



Move/View Commands
	The Zoom Command Group
	 Zoom Window

  Zoom In

  Zoom Out

  View All

	



Zoom Commands
	The Pan Command Group
	 Pan Left

 Pan Right

 Pan Left

 Pan Down

 Pan

	



Pan Commands
	The View From Command Group
	
 View from Standard Home Position

  View from Preset Camera Position

  View from the Top

  View from the Bottom

   View from the Left

   View from the Right

   View from the Front

  View from the Back

	



View From Commands
	The View Command Group
	 Copy Inage to Clipboard

 View/Hide the PCB Base Board

 Toggle Perspective/Orthographic View

	



View Commands
	The Render Command Group
	 Show Shadows

	



Render Commands
	The Rotate Command Group
	 Rotate About the X Axis

  Rotate About the Y Axis

  Rotate About the Z Axis


	



Rotate Commands
	The 3D Add Command Group
	 Adding a Box

  Adding a Sphere (Ball)

 Adding a Cylinder

 Adding a  Cone

 Adding a Torus (Donut)

	



Add Commands
	The 3D Viewports Command Group
		· You have 5 preset view configurations. 
· If there is more than 1 view visible then the active view has a red border.
· View can have separators that you can drag to re-size.
	


 Viewing a Single 2D Viewport


Single Viewport
   Viewing two (1+1) 3D Viewports


 Two (1+1)  Viewports
   Viewing three (2+1) 3D Viewports


 three (2+1)  Viewports
   Viewing three (1+2) 3D Viewports


 Three (1+2) Viewports
   Viewing Four 3D Viewports


Four 3D Viewports



3D Viewport Commands
3.3.17. [bookmark: The_4_Menu_Layout_ModesD9C08C32]The 4 Ribbon Layout Modes
You now have a choice of a traditional drop-down menu or a Microsoft Office style ribbon menu.
Switching Between Drop-down and Ribbon Menus
To switch from the ribbon menu to the drop-down menu click on  in the Panels->Menu ribbon button group.
To switch from the drop-down menu to the ribbon menu click on .

 Drop-Down Menu
You have a classic drop-down menu. This also comes with optional toolbars.


Ribbon Menu
You can save some of the screen space normally occupied by the the Ribbon Menu.
The Ribbon menu has 3 display layout modes:
1. Classic Fully Expanded
1. Simplified
1. Minimized
Classic Fully Expanded Ribbon Menu
In this mode, all the ribbon page buttons groups are visible.

Classic Fully Expanded Ribbon Menu
Simplified Ribbon Layout
In this mode, the ribbon page button groups are compacted.

Simplified Ribbon Layout
To switch between the Classic and the Simplified layout: click on the arrows button  at the bottom left of the Ribbon Menu. 
Minimized Ribbon Layout
In this layout mode, the ribbon button groups are hidden until made visible by clicking on a ribbon page heading.

Minimized Ribbon Layout
AutoTRAX can optionally collapse panels and the ribbon menu to give you the maximum view of the design. The choice is yours and you can rapidly change your workstation style at the click of a mouse button.
To collapse the Ribbon Menu click the Maximixe in the Panels→ Menu→  button. When collapsed, the ribbon menu appears as shown above. When you click on a ribbon tab, the ribbon will expand down, as shown below, allowing you to select a command and will contract after the command starts. To restore the ribbon to classic node: in the Panels menu button group click the Panels→ Menu→   button.


Ribbon Buttons Group Expanded in Minimized Ribbon Layout

Classic Dropdown Menu

3.3.18. [bookmark: Popup_Settings17628948]Popup Settings
The Page Settings Popup
3.3.18.1. [bookmark: The_Add_Parts_Popup770914BF]The Add Parts Popup

3.3.18.2. [bookmark: The_CAM_Settings_Popup41F62DB0]The CAM Settings Popup

3.3.18.3. [bookmark: The_Copper_Pour_Settings_PopupDD5C04A7]The Copper Pour Settings Popup

3.3.18.4. [bookmark: The_Cutouts_Popup2E726892]The Cutouts Popup

3.3.18.5. [bookmark: The_Design_Rules_Popup9F183707]The Design Rules Popup

3.3.18.6. [bookmark: The_Dimension_Settings_Popup078F62F9]The Dimension Settings Popup
Enter topic text here.
3.3.18.7. [bookmark: The_Fiducial_Popup3D1479E8]The Fiducial Popup

3.3.18.8. [bookmark: The_File_Settings_PopupE80B339B]The File Settings Popup

3.3.18.9. [bookmark: The_Layout_Settings_Popup5870B56D]The Layout Settings Popup

3.3.18.10. [bookmark: The_Page_Settings_PopupD5D56038]The Page Settings Popup

3.3.18.11. [bookmark: The_Router_Settings_PopupCA8C223A]The Router Settings Popup

3.3.18.12. [bookmark: The_Selection_Settings_Popup41B0558F]The Selection Settings Popup

3.3.18.13. [bookmark: The_Shapes_Default_PopupB241EB51]The Shapes Default Popup

3.3.18.14. [bookmark: The_Snap_Settings_Popup0501FF6D]The Snap Settings Popup

3.3.18.15. [bookmark: The_Tracks_Popup1CE1F273]The Tracks Popup

3.3.18.16. [bookmark: The_Track_Via_Settings_PopupB8C62087]The Track Via Settings Popup

3.3.18.17. [bookmark: The_Undo_Popup47675423]The Undo Popup

3.3.18.18. [bookmark: The_Wire_and_Bus_Settings_Popu371EFBB7]The Wire and Bus Settings Popup

3.3.18.19. [bookmark: The_Workspace_Popup775C3484]The Workspace Popup

3.3.19. [bookmark: Menu_Shortcuts0DD771BB]Menu Shortcuts
You can set you own shortcuts for the ribbon menu commands.
Click the Panels→Menu→ button group. The Edit Short Cuts dialog box shown below will appear.

Click on any of the column headers to sort by that column.
Right-click on a column header to show the context menu.

To set a command pick a key in the Key column/Check the control checkbox to require the CTRL key to be pressed, similarly check the Alt checkbox to require the Alt key to be pressed. (Note – It is possible to require both the CTRL and Alt keys to be required)
Below the Add Closed Curve has a shortcut assigned to it which is the 'D' key and the CTRL Key.




3.4. [bookmark: Using_The_Panels07DBDFFC]The Panels
AutoTRAX has the following panels which can be docked to the sides of the application or left floating.
· The Checklist Panel
· The Part Builder Panel
· The Project Panel
· The Properties Panel
· The Library Panel
· The Layers Panel
· The Design Rules Checker Panel
· The Navigator Panel
· The Settings Panel
· The Source View Panel
· The Parts Bin Panel
· The Netlist Panel
· The Parts List Panel
· The System Information Panel
Moving Panels
Dock panels are the main building blocks of the AutoTRAX application. They represent dockable windows on which visual controls are placed. A panel can be docked to another panel or it can float. The panel's caption allows you to drag a panel to a new position and thus perform docking operations on it.
To move a panel hold down the left mouse button and drag the panel. As you move the panel you will see small rectangles appear showing you where you can dock the panel you are moving. Below the Library Panel is being dragged.

Collapsing Panels
To collapse a panel click the small pin in the top right of the panels caption bar.

Non-collapsed Docked Panel

Collapsed Docked Panel
Floating Panels
Double-click on the panels caption bar to float it.

Floated Panel


3.4.1. [bookmark: The_Checklist_PanelD9E3A099]The Checklist Panel
When you are at certain key stages in your design such as when you have completed the schematic design it is good practice to check you design. AutoTRAX provides you with the Checklist panel for just such a purpose.
The Checklist panel is a collection of controls that let you 'check off' you design.
To view/hide the Checklist Information panel click the Panels→Panels→  button.

Parts

Use this to check off and mark parts as verified in the design.
Check the  checkbox to display verified markers on your schematics. The markers are similar to marks left by a marker pen but much neater!


Terminal without verified marker

Terminal showing verified marker (grayed rectangle)
When you select an item it will be selected in the schematic

Selected Item
Click the button to print the list.
Click the  button to remove all verified status for the design.
Click the  button to display this help topic.
You can sort the list by clicking on the column header.
Right click on the column header to find more options.


Connections

Use this to check off and mark electrical connections (wires/nodes) as verified in the design.

Connection showing without verified marker

Connection showing verified marker (grayed rectangles)

Selected Item
Check the  to flash the selected item.
Check the  to have the item zoomed into view when selected. This combined with  makes them easier to find.
	




3.4.2. [bookmark: The_Part_Builder_Panel02CC7630]The Part Builder Panel
The Parts Builder Panel groups several common controls and displays them based your current context. For instance, if you are editing a part's schematic symbol, the symbol wizard will be shown. If you are editing a part's footprint, the footprint wizard will appear.
To view/hide the Parts Builder panel click the Panels→Panels→  button.


The Part Builder Panel
3.4.3. [bookmark: The_Project_PanelE29BFA38]The Project Panel
The Project Panel displays a tree list of the contents of your projects. It is shown below. To display the Project Panel click on the Projects button  in the Panels ribbon tab or right-click on a viewport and select Project Panel from the context menu.
The Project Panel
Using the Project Panel you can add sheets and text documents as well as view and edit them.
Double-click on a project item schematic, PCB or text document to view it in a viewport. If a viewport already exists that contains the item to view, then it will be brought to the front.
 Adds a new schematic sheet.
 Adds a new text document.
 Prints the project hierarchy. This will display the print preview dialogs similar to the one below. You can print it or save it to PDF and several other formats.

 If checked then you can edit the name of the sheet or document as well as the description. Otherwise they are protected and read only. 
 Show/Hide the description column.
Both the Allow Edit and Descriptions settings are saved from session to session.
Expanded directories are also saved from session to session.
Right-click in the Project panel to display the context menu. This will allow you to add sheets and delete selected sheet.
 Displays this help page.
You can drag sheets to reposition them in the project hierarchy.
Right-click on the Name or Description column header to display the header context menu shown below. This will allow you to sort columns etc.

Right-click over a sheet to see the context menu as shown below.

 
3.4.4. [bookmark: The_Properties_PanelD9191602]The Properties Panel
The Properties Panel lets you edit the properties of selected objects on schematic and PCB sheets.
To view/hide the Properties panel click the Panels→Panels→  button.
When you select an object on a schematic or PCB the properties panel will display an editor that is specifically tailored for the selected object. Below you can see the editor for a selected footprint. If nothing is selected then you will see an editor for the sheet in the currently selected viewport.
To find out more details of the editor for the selected object click the button in the property panel.
To discover more about the sheet editor view the sheet editor details.

Editor for selected footprint

Editor for sheet (nothing selected)



3.4.5. [bookmark: The_Properties_Popup_Panel69C2EE85]The Properties Popup Panel

The Properties Popup Panel
3.4.6. [bookmark: The_Spice_Model_Properties_Pop0A5ED206]The Spice Model Properties Popup Panel

The Spice Model Properties Popup Panel
3.4.7. [bookmark: The_Library_Panel0C729252]The Library Panel
The Local Library Panel is shown below.
To view/hide the Library panel click the Panels→Panels→  button.

3.4.8. [bookmark: The_Layers_Panel2B722AC1]The Layers Panel
The Layers Panel is shown below.
To view/hide the Layers panel click the Panels→Panels→  button.

The Layers Popup
3.4.9. [bookmark: The_Design_Rules_Checker_Panel22AB577B]The Design Rules Checker Panel
The Design Rules Checker Panel is shown below.
To view/hide the Design Rules Checker panel click the Panels→Panels→  button.
You can  and  the design rules.
Checking Your PCB Design


The Design Rule Checker Panel


Typical PCB Error Display
3.4.10. [bookmark: The_Navigator_Panel0F0E9AC2]The Navigator Panel
The Navigator Panel is shown below.
To view/hide the Navigator panel click the Panels→Panels→  button.

3.4.11. [bookmark: The_Settings_PanelD0E9C582]The Settings Panel
The Settings Panel lets you view and edit the individual settings and preferences for sheets and the project.
To view/hide the Settings panel click the Panels→Panels→  button.
[bookmark: The_Settings_Panel_AE873B0FF]
The AutoTRAX Settings Panel is a central control that lets you view and change all the parameters that are used by AutoTRAX.
3.4.12. [bookmark: The_Source_View_Panel5003BF1E]The Source View Panel
The Source Panel displays the XML file data that describes your project.
To view/hide the Source panel click the Panels→Panels→  button.


The file format for all project and part files in AutoTRAX are industry standard XML files. The files are text files, readable by you. AutoTRAX files are open and the specification is freely available from the AutoTRAX web site.  Even AutoTRAX's config files are human readable XML files. 

3.4.13. [bookmark: The_Parts_Bin_Panel352781C9]The Parts Bin Panel
The Parts Bin Panel contains parts that you do not wish to appear on schematic sheets. It acts as a holding bin for parts not yet needed in a design.
To view/hide the Parts Bin panel click the Panels→Panels→  button.

3.4.14. [bookmark: The_Net_List_Panel9EF8FFF5]The Netlist Panel
The Netlist Panel shows you the netlist, in a spreadsheet format that details the electrical connectivity of your design.
To view/hide the Netlist panel click the Panels→Panels→  button.

3.4.15. [bookmark: The_Parts_List_Panel31BDAC26]The Parts List Panel
The Parts List Panel displays the parts in your project.
To view/hide the System Information panel click the Panels→Panels→  button.

3.4.16. [bookmark: The_Route_PanelD152C410]The Route Panel

The Route Panel
3.4.17. [bookmark: The_System_Info_Panel35CA0F0B]The System Info. Panel
The System Information Panel is shown below. It provides extensive information about your machine and the operating system. It is a valuable tool to help you explore the capabilities of your machine and O/S. It can also help you  track down problems with your machine. As the information it provides is vast and detailed the best way to find out what it has to offer is to click on each tab and view its contents. For more information about what each parameter represents I suggest you do a Google search.
To view/hide the System Information panel click the Panels→Panels→  button.

3.5. [bookmark: Viewports]Viewports
Viewports provide a graphical  view into your design and can display
· Schematic Sheets
· Symbols
· Footprints
· PCBs
· Text documents

3.5.1. [bookmark: Cross_CursorsE6E9FC58]Cross Cursors
AutoTRAX can optionally display a cross cursor which is a horizontal line in the vertical line that meet at the position of the cursor and extend to the edges of the viewport. The cross cursor is only visible when adding and editing objects. An additional pair of diagonal lines can be added to the cross cursor.

Cross cursor disabled

The cross cursor


3.5.2. [bookmark: The_Diagonal_CursorA76ADA5E]The Diagonal Cursor
You can optionally display tool with dial lines in additional to the cross cursor when manually routing. When enabled you will see two lines at 45° emanating from the cursor position. This is useful when you are wanting to manually route tracks and keep them aligned horizontally, vertically or at 45°. You can turn the diagonal cursor on/off using the application settings in the settings panel.

Diagonal cursor disabled

Diagonal cursor enabled
3.5.3. [bookmark: Arranging_ViewportsA37AC029]Arranging Viewports
Viewports can be arranged in a tabbed layout or a tiled or cascaded layout.
Floating Viewport
Viewports can also be floated onto other screens or the current screen.
AutoTRAX remembers the position of the viewports when the program ends and restores them when the program starts.
Floating viewports are only enabled when you have a tabbed layout.
To float a viewport double-click on the tab at the top of the viewport or hold down the left mouse button and drag the tab.


3.5.4. [bookmark: Rulers]Rulers
You can optionally display rulers around graphical viewports.By default, schematic to not display a rulers while PCBs do. The rulers act as a measuring device changes when you change units. The rulers also have context menus which contain many useful commands.
As you move your mouse on the viewport you will see both rulers display a line indicating the position of the mouse in the viewport.
At the junction of the two rulers, top left, you will see the origin box. The origin box has a similar context menu to the rulers. 
Click the View/Snap→View→  button to view/hide the rulers.

Both the top horizontal ruler and the vertical ruler on the left have context menus. To view the context menu right click on the ruler. The context menus for the horizontal ruler in the vertical ruler shown below. Click on one of the menu items to perform the indicator function.

The horizontal rulers context menu

The vertical rulers context menu
Adding Guides
You can add guides to the viewport by dragging from the origin box of the top/left rulers.
Dragging from the left ruler adds a vertical guide to the viewport.
Dragging from the top of ruler adds a vertical guide to the viewport.
Dragging from the origin box adds a point to guide to the viewport.
Setting the Origin
You can set the horizontal or vertical origin or both by selecting the appropriate command in the context menu. Then drag the mouse to where you want the origin to appear and left click to set the new origin. The rulers will update to show the new origin and if you are the grid displayed it will be updated.
Setting The Units
Click on any of the unit menu items to change the units for the current sheet. The rulers will update to show your changes.


3.5.5. [bookmark: The_Origin_Box9DAC5A40]The Origin Box
The origin box is located at the top left of the viewport where the two rulers meet as shown below.

The origin box
If you right click the mouse over the origin box, the context menu shown below will appear. The context menu is very similar to the context menu you see with the rulers and contains many useful commands. Click on any of the commands to run them.

The origin boxes context menu
See the rulers topic to find out how to add a point guide, set the origin or change the units.


3.5.6. [bookmark: Tabbed_Viewports0A591438]Tabbed Viewports
You can arrange the viewports in a tabbed control.
Click the Panels→Window→ button to arrange the viewports in a tabbed control.

Tabbed Viewports
3.5.7. [bookmark: Tiled_And_Cascaded_ViewportsC7292891]Tiled and Cascaded Viewports
Click the Panel→Windows→ button to arrange the viewports cascaded.

Cascaded Viewports
Click the Panel→Windows→ button to arrange the viewports cascaded.

Cascaded Viewports
Click the Panel→Window→ button to tile the viewports horizontally.

Horizontally Tiled Viewports
Click the Panel→Windows→ button to tile the viewports vertically.

Vertically Tiled Viewports
3.5.8. [bookmark: Zooming_and_Panning91AAC0D1]Zooming In and Out
Buttons to zoom and pan the viewport can be found in the View/Snap tab.  
Click the View/Snap→Zoom→ button to zoom in or press the PgUp key.
Click the View/Snap→Zoom→ button to zoom out or press the PgDn key.
Click the View/Snap→Zoom→ button to zoom to a window. After clicking, move the mouse to a corner of the area to wish to zoom in on. Next, hold down the left mouse button and drag the cursor to define the area, releasing the left mouse button adjusts the view.
Zooming with the mouse
You can also use the mouse scroll wheel. Scroll it and the viewpoint will zoom in/out depending on the direction that you rotate the wheel. You can often use the mouse wheel and middle mouse button for panning and zooming while doing other things such as adding and editing objects.
Panning with the mouse
If you drag the mouse while holding down the mouse scroll wheel the view will pan.
Panning with the keyboard
You can pan the viewport using the 4 arrow keys on the numeric keyboard to pan.
Home
Press the Home key to view the entire sheet or all the contents of your sheet if the sheet border is not visible.


3.5.9. [bookmark: Smart_PanningAC9F71A9]Smart Panning
If smart panning is enabled, as you move selected items in a viewport, the viewport will automatically pan to always show the items. It remembers the original position and contents of the viewport before panning and will try and restore that view if at all possible.
You can always pan by using one of the direction arrows. You can also pan by holding down the middle mouse button and dragging the mouse. This will work when you're doing most things. Additionally, if you rotate the middle mouse wheel the view will zoom in/out. By rotating the middle mouse button and holding the middle mouse button down while dragging the mouse you can quickly change the view.
You can turn smart panning on/off by click the   button in the status bar.
3.5.10. [bookmark: The_Viewport_Context_MenuECA3E93C]The Viewport Context Menu
All viewports have a context menu. To view the context menu press the right mouse button. A context menu similar to the one shown below will appear. The items in the context menu depend on whether an object is selected. If an object is selected then the context menu will contain items suitable for editing the selected object.

The schematic context menu with nothing selected

The context menu for a rectangle



3.5.11. [bookmark: Switch_Between_Schematic_and_PBA68881C]Switch Between Schematic and PCB Views
Press the TAB key to switch between schematic and PCB views. This only works in picking mode.
3.6. [bookmark: Working_with_GridsBFBAB366]Grids Views
Grid views provides rich capabilities for displaying, shaping and editing data from any data source.

Data shaping capabilities include, but are not limited to, sorting, grouping, summary calculation, cell merging, data editing, master-detail and split presentations, as well as a rich set of filtering and data searching options such as built-in column filters and Find Panel.
3.6.1. [bookmark: Grouping]Grouping
Data grouping is enabled in the Data Grid by default. To group data by a column, drag a column header into the group panel. Another option is to right-click a column header and select "Group By This Column". 

By default, when you group data by columns, these columns automatically hide from the View, and all groups collapse.

3.6.2. [bookmark: Auto_Filter_RowBBF2EDD7]Auto Filter Row
The automatic filtering row allows data to be filtered on the fly by typing text into that row. When you type text into this filtering row, a filter condition is automatically created based on the entered value and then applied to the focused column. The automatic filtering row is displayed at the top of the Grid View.



When the top data row is focused, you can move focus to the auto filter row by pressing the CTRL + UP ARROW keys.

3.6.3. [bookmark: Columns]Columns
Columns represent data source fields. A column consists of the following elements:
· a Column Header that displays the column caption and enables you to drag and resize the column, sort and filter column values, etc
·  row cells displaying field values and editing facilities
· a footer cell that displays a total summary result

3.6.4. [bookmark: Column_HeaderBB04AD4C]Column Header
Column headers identify columns in Grid Views. A column header contains:
· a caption string identifying column content;
· a column header image providing graphical information about column content;
· a sort glyph identifying the data sort order (if any) applied to column values;
· a filter button enabling you to filter column values.
The column header image contains the headers of all visible columns. Headers of grouped columns are displayed in the group panel . The Customization Form displays hidden columns' headers. Right-clicking a column header in the header panel or group panel activates the  column header context menu.

3.6.5. [bookmark: Column_Header_Context_Menu94092492]Column Header Context Menu
The column header context menu enables you to manipulate a column (apply sorting, grouping, calculate the best column width, etc.). The menu is activated by right-clicking a Column Header displayed in a Column Header Panel or in a Group Panel.

 
3.6.6. [bookmark: Column_Header_Panel402E832F]Column Header Panel
The column header panel displays headers of visible columns.

3.6.7. [bookmark: Customization_FormBE3AFD3E]Customization Form
The Customization Form allows you to customize the layout of columns (and bands in Banded Grid Views). To invoke this form, select the Column Chooser (or the Column/Band Chooser) command from the Column Header Context Menu.
Default Customization Form

· The form displays the headers of hidden columns and bands.
· Users can show and hide columns/bands using drag-and-drop operations between the View and the Customization Form.
· An optional search box allows users to locate columns/bands by their captions.
3.6.8. [bookmark: Data_Row053D32F7]Data Row
A data row represents an individual data source record. Rows contain row cells used for displaying and editing values of particular data fields. In Grids Views , row cells are arranged in a single line. 
A row edge is a single line displayed below row cells. You can drag the row edge in order to change row height.


3.6.9. [bookmark: Filter_ButtonD2D2A057]Filter Button
Filter buttons are displayed within  column headers and can be clicked to activate filter dropdown lists. Such lists enable you to specify data filtering conditions.

3.6.10. [bookmark: Fixed_Panel_Divider9CF99123]Fixed Panel Divider
The fixed panel divider separates fixed columns or bands from a View's scrollable area.  See Columns.

3.6.11. [bookmark: Footer_Cell27FF39AC]Footer Cell
Footer cells are elements of the View Footer and Group Footer panels, and they display summary values. View footer cells present total summaries ,while group footer cells present  group summaries. Right-clicking a footer cell activates the Footer Context Menu that enables you to set or change the summary type.

3.6.12. [bookmark: Footer_Context_Menu50A13047]Footer Context Menu
Footer context menus enable you to specify or change the type of summary calculated for a column. The menu can be invoked by clicking a Footer Cell in the View Footer or Group Footer panels. Only items suitable for the column are enabled in the menu.

 
3.6.13. [bookmark: Group_Expand_Button09C99EC7]Group Expand Button
Group expand buttons enable you to expand or collapse group rows.

3.6.14. [bookmark: Group_Footer2DE5B8A1]Group Footer
Group footers display group summaries, i.e. summaries calculated for data rows belonging to the group. Group footers contain footer cells, each corresponding to a column. Footer cells display formatted summary values. These cells can be clicked to invoke the Footer Context Menu.

3.6.15. [bookmark: Group_Panel9DD45026]Group Panel
Group panels display headers of columns involved in data grouping. They also serve as drag-and-drop targets allowing you to drag column headers onto it. Right-clicking the group panel invokes the group panel context menu, which provides grouping related options.

3.6.16. [bookmark: Group_Panel_Context_MenuA4F55310]Group Panel Context Menu
The group panel context menu can be invoked by right-clicking the group panel. It provides grouping related options.

 
3.6.17. [bookmark: Group_Row3CBA6670]Group Row
Group rows are used to organize data rows into a tree when data grouping is applied. A group row contains a Group Expand Button that enables you to expand and collapse a group row, and thus show or hide its child rows. Group rows can also display group summary values.


3.6.18. [bookmark: Group_Row_Check_Box_Selector1A397C13]Group Row Check Box Selector
The Group Row Check Box Selector allows you to select/deselect all grid rows of a group simultaneously. This visual element is supported if the Multiple Row Selection feature is enabled.


3.6.19. [bookmark: Group_Row_Context_MenuD7F8125E]Group Row Context Menu
Users can right-click a Group Row to invoke a context menu that expands / collapses the group.


3.6.20. [bookmark: Multiple_Row_SelectionE409D134]Multiple Row Selection
The Grids Views support multiple row selection via a built-in Check column. When this feature is enabled you can use checkboxes to toggle the selection state of certain rows, all rows or data group rows.

3.6.21. [bookmark: Header_Panel_Button564F5E2B]Header Panel Button
The header panel button belongs to both the column header and  Row Indicator Panel elements. By default, the header panel button has no special functionality. When a View is used to represent detail data, the header panel button serves as a zoom button.

3.6.22. [bookmark: Zoom_Button0CBF0CE8]Zoom Button
The zoom button enables you to maximize the detail View, so that it occupies an entire grid control's region. For Grid Views and their descendants, a Zoom button represents an intersection of a detail View's Column Header and Row Indicator Panel. 

Clicking the zoom button maximizes the detail View while hiding all the other Views including the master. The button's image now displays an 'X' sign to indicate the View is maximized.

3.6.23. [bookmark: Preview_Section0DF5FC88]Preview Section
Preview sections are non-editable regions in data rows that allow large memo fields to be displayed across all View columns, thus the preview section's width is equal to the total column width.


3.6.24. [bookmark: Row_CellBDA26F2D]Row Cell
Row cells display field values within data rows. Each cell provides an in-place editor that can be invoked by you to edit a cell's value.

3.6.25. [bookmark: Row_Indicator_Panel305BBAEB]Row Indicator Panel
The row indicator panel represents a region displayed at the left edge of the View. The panel contains row indicator cells corresponding to different View sections (the band header panel, the column header panel, data rows, the View footer, etc). The cell relating to the focused row indicates the row state (whether it is in edit mode or has been modified, etc.). When multiple selection is enabled, you can click cells and then drag the mouse cursor to another cell to select a range of rows.

3.6.26. [bookmark: Row_Separator5FC5802A]Row Separator
Represents a region that separates adjacent data rows.

 
3.6.27. [bookmark: Sort_GlyphD63514CD]Sort Glyph
Sort glyphs are displayed within column headers when sorting is applied by column values. These glyphs indicate the applied sort order.

 
3.6.28. [bookmark: View_Footer3ACAB193]View Footer
The view footer is designed to display total sumaries, i.e. summaries calculated for all data rows in a View. The footer contains Footer Cells displaying summary values for particular columns. Clicking a footer cell invokes the Footer Context Menu.

3.6.29. [bookmark: Summaries]Summaries
Summaries are grid items that utilize aggregate functions to display summary information about displayed data: total record count, minimum values, etc.

Summary Types
Total summaries Grid summary items are calculated over all Data Grid records and displayed within a view footer. 
Group summaries Grid summary items are calculated over individual groups and displayed either in a group footer area or within group rows.

Total Summaries
When the view footer is visible, you can right-click it and use a context menu to add and remove summary items. It is also possible to right-click existing summaries to change their aggregate functions.

Group Summaries
You can manually add and modify group summaries in two cases:
· You can right-click a grouped column header to invoke a Group Summary Editor dialog.

· when the group footer is visible you can right-click this footer below the required column and select a summary item type.

Sort Groups by Summary Values
When the Data Grid displays group summaries, you can right-click a column header in a group panel and select "Sort by Summary". By doing so, you can sort groups by any group summary item, associated with any Data Grid column. When sorting by summaries is active, a dash is painted above the regular ascending/descending sort indicator in column headers.

3.6.30. [bookmark: Data_NavigatorAC691AC0]Data Navigator
The data navigator is an embedded control displayed at the bottom of a grid that enables the you to navigate and edit data. Note: it only handles visible rows. To access rows hidden within collapsed groups, you need to expand group rows first.

3.6.31. [bookmark: Find_Panel6B63C23C]Find Panel
The grid can display a find panel that enables you to search for keywords in visible columns.

3.6.32. [bookmark: New_Item_Row_CardC3BA12BC]New Item Row/Card
The new item row/card is used to enter new records. In Grid Views, the new item row can be displayed above or below all data and group rows. In Card Views and Layout Views the new item card is displayed as an empty card below all the cards.

3.6.33. [bookmark: Filter_PanelD2142F7F]Filter Panel
The filter panel displays a string representation of the filter criteria applied to a View. It can contain the following buttons:
· Close Filter Button - closes the filter panel clearing the filter;
· Enable Filter Button - can be used to temporarily disable and enable the current filter;
· MRU Filter Button - provides access to the most recently used filters;
· Edit Filter Button - opens the Filter Editor, allowing you to build complex filter criteria.

3.6.34. [bookmark: Filter_Panel_Close_Button275B6CB1]Filter Panel Close Button
The close filter button ("x") closes the Filter Panel and clears the current filter. The button is displayed on the left edge of the Filter Panel.

3.6.35. [bookmark: Views_MRU__Most_Recently_Used_ACAA488D]View's MRU (Most Recently Used) Filter List
The MRU filter dropdown list displays the most recently used filters in a View. This dropdown can be invoked by clicking the MRU filter button or the filter text within the Filter Panel .

3.6.36. [bookmark: Edit_Filter_ButtonE8E357F0]Edit Filter Button
The Edit Filter Button enables you to invoke the Filter Editor. This button is displayed at the right edge of the Filter Panel.

3.6.37. [bookmark: Filter_EditorE997F57A]Filter Editor
The Filter Editor allows you to build filter criteria in the Tree-like and/or IntelliSense text-based form.

Tree-like Filter Editor

IntelliSense text-based Filter Editor
3.6.38. [bookmark: Columns_Filter_DropDownD6FACEB6]Column's Filter DropDown
Filter dropdowns provide a UI for applying filter criteria against columns in the .Grids View
You can choose between four filter dropdown presentation styles.

3.6.39. [bookmark: View_CaptionFB3AAD6E]View Caption
View captions represent titles for Views displayed at the top edge.

3.6.40. [bookmark: Filter_and_Search74AD0857]Filter and Search
Filtering Dropdown Menus
When a filter is applied, the View displays only those records that meet the current filter criteria. You can filter data against one or multiple columns.

To invoke a filtering dropdown menu for a column, click the filter icon within the column header. In the "Values" tab, you can select specific cell values from those that are currently displayed by the Data Grid.

The "Filters" tab gives you a wider pool of filtering options. For example, when filtering by dates, you can only show those records that correspond to the previous week.

The content of a filtering dropdown menu depends on the type of data displayed by the related grid column. For instance, the figure below illustrates what this menu looks like when filtering by a numeric column.


3.6.41. [bookmark: Advanced_Filter_and_Search_Con730C24B5]Advanced Filter and Search Concepts
Filter Expressions
A filter expression is a formula (or a set of formulas) that specifies how data should be filtered. Each expression contains three parts:
· a data field whose values should be filtered;
· a filtering value that should be compared to records stored in the data field;
· an operator that compares data field values with a filtering value.
For example, the following expression selects all the "Count" data field values that are greater than 5 but less than 20:
[Count] Between ('5', '20')
Filter Expression Syntax
The table below enumerates most frequently used operators. 
	Operator
	Description
	Example

	=
	Equals. Selects data field values that equal the entered filtering value.
	[OrderDate] = #2016-01-01#

	<>
	Does not equal. Selects data field values that are not equal to the entered filtering value.
	[OrderDate] <> #2016-01-01#

	>
	Is greater than. Selects data field values that are greater than the entered filtering value.
	[OrderDate] > #2016-01-01#

	>=
	Is greater than or equal to. Selects data field values that are greater than the entered filtering value or equal to it.
	[OrderDate] >= #2016-01-01#

	<=
	Is less than or equal to. Selects data field values that are less than the entered filtering value or equal to it.
	[OrderDate] >= #2016-01-01#

	<
	Is less than. Selects data field values that are less than the entered filtering value.
	[OrderDate] >= #2016-01-01#

	Between
	Is between. Selects data field values that belong to the specific value interval.
	[CustomerID] Between ('1', '100')

	Not Between
	Is not between. Selects data field values that lie outside the specific value interval.
	Not [CustomerID] Between ('1', '100')

	Contains
	Contains. Selects data field values that contain the filtering value.
	Contains([ShipCountry], 'land')

	Not Contains
	Does not contain. Selects data field values that do not contain the filtering value.
	Not Contains([ShipCountry], 'land')

	Starts with
	Begins with. Selects data field values that start with the filtering value.
	StartsWith([ShipCountry], 'G')

	Ends with
	Ends with. Selects data field values that ends with the filtering value.
	Ends with([ShipCountry], 'ia')

	In
	Is any of. Selects data field values that equal any of the entered filtering values.
	[ShipCountry] In ('Germany', 'Italy', 'USA')

	Not In
	Is none of. Selects data field values that do not equal any of the entered filtering values.
	Not [ShipCountry] In ('Germany', 'Italy', 'USA')

	Like
	Is like. Selects data field values that contain the filtering value.
Accepts wildcards: '_' to replace a single character, '%' to replace any number of characters.
	[OrderDate] Like '%2011'
same as
Contains ([OrderDate], '2011')

	Not Like
	Is not like. Selects data field values that do not contain the filtering value.
Accepts wildcards: '_' to replace a single character, '%' to replace any number of characters.
	Not [OrderID] Like '103__'
same as
Not [OrderID] Between ('10300', '10399')

	Is Null
	Is null. Selects null values.
	[ShipRegion] Is Null

	Is Not Null
	Is not null. Excludes null values.
	[ShipRegion] Is Not Null



· String values must be enclosed within single quote characters. If a single quote character needs to be included as a literal to a filter, it must be doubled (e.g., [ProductID] LIKE 'Uncle Bob''s%');
· Date-time values must be wrapped with the '#' characters and represented using a culture-independent (invariant) format. The invariant culture is based on the English culture, but some of the idiosyncratic English formats have been replaced by more globally-accepted formats. Below are some of the culture-independent formats for representing date-time values.
MM/dd/yyyy — 07/30/2008
dd MMM yyyy — 30 JUL 2008
yyyy-MM-dd — 2008-07-30
yyyy-MM-ddTHH:mm:ss — 2008-07-30T22:59:59
yyyy-MM-dd HH:mm:ssZ — 2008-07-30 15:59:59Z
4. [bookmark: Projects]Projects
A project in AutoTRAX is a self-contained file that contains all the details for your design. It does not rely on any external files (except font files). All schematics, text sheets and the PCB for your design is contained in this single file.

Your design project consists of one or more schematic diagrams and a single PCB.
The  schematics are the logical design for your project. The PCB is the physical manifestation of your design. 

A Schematic

The PCB (2D Layout)

The 3D PCB without parts

The 3D PCB with parts
4.1. [bookmark: Schematics2]Schematics
You place parts on a schematic by dragging them from the library panel or clicking  on a part in the Parts menu.


Parts placed on schematic


Parts wired together
	
	


 PCB without schematic wiring

	
	


PCB after schematic wiring and PCB routing


4.2. [bookmark: The_PCB265CC59AB]The PCB
The PCB is the physical manifestation of your design and represents your ultimate goal: To make a PCB.
It consists of a PCB border, parts and electrical connections.
A PCB border
The border can have any number of cutouts and round hole. Cutouts are usually created with a CNC cutter and are expensive. Round holes are simply drill out.
Parts
You place the footprints for your physical parts inside the border and usually not covering holes and cutouts. However, sometimes you may place a part over a cutout/hole so design reasons.
Parts can be placed on the top or the bottom of the PCB.
The parts are connected together either by electrical copper tracks or via internal layers of solid copper called signal/power planes.
Copper Tracks (electrical connections)
Tracks are parts of electrical PCB nets.
A Net is a collection of pads that need to be electrically connected together. AutoTRAX calculate a optimal unrouted non-cyclic* graph of unrouted track.
Nets map 1:1 with schematic nodes.
You manually route the unrouted tracks. That's the fun part. You can also use an auto-router.
*non-cyclic - does not form loops
4.3. [bookmark: Creating_ProjectsCDB79F12]Creating Projects
AutoTRAX integrates all the data for a design into a single project file.
A project file is a self contained XML file (with optional compression), that contains all the details of your design. It does not rely on any external files.
The project file contains:
1. Zero or more schematics. 
2. Zero of more text documents.
3. The PCB for the project. -- A project can only contain one PCB.
The schematics and text documents can be arranged in a hierarchical fashion or left in a flat arrangement.
The schematics are firmly attached to the PCB and AutoTRAX's internal data structure ensures that the schematics and the PCB are always in sync. Any changes to a schematic are instantly reflected in the PCB.  Likewise, any changes in the PCB are immediately reflected in the schematics.
To create a new project select the New Project button   in the Home tab of the ribbon menu.
4.4. [bookmark: Setting_The_Default_Project7CED9C38]Setting The Default Project
You can set the default project template by first creating a project, setting it up exactly as you want all new projects to be and then click the  in the File Menu. Then, every time you create a new project, it will start off as a mirror image of the default project you saved.

The file  is named Default.project and is in the library '___SystemDoNotRemove' directory .
You can always reset the default project to the factory default using the File Settings.
4.5. [bookmark: Schematic_PCB_Cross_SelectionFD704A71]Schematic-PCB Cross Selection
[bookmark: Schematic_PCB_Cross_Selection_A8009D336]You can optionally select PCB footprints when you select schematic symbols and vice versa. You can also do this for schematic wires and nets/tracks in the PCB. This video lets you quickly see how the parts relate to each other in the schematics and the PCB.

4.6. [bookmark: Saving_Projects23DF8DF9]Saving Projects
To save you work click the Save button  in the Home tab of the ribbon menu. If you have never saved your work, you will be prompted for the file name to save to as show below.

To save your work to a different file click the Save As button  in the Home tab of the ribbon menu. You will be prompted for the file name to which to save.


4.7. [bookmark: Opening_Projects2ED5E31F]Opening Projects
To open an existing project click on the Open button  in the Home tab of the ribbon menu.



4.8. [bookmark: Automatic_Backups06E7EBEB]Automatic Backups
AutoTRAX automatically archives your work in a directory with the same name as your project but with the '.Backup' extension added. For example if you project is called 'My Project',  backups are saved to  'My Project. Backup'  as shown below.
The backups have the save name with the date appended and a short description of the action that caused a backup to be made.
It is a good idea to use some 3rd party automatic backup software to backup this directory, giving you full confidence that none of your work will be lost.
AutoTRAX will never delete any of these files even if you undo changes you make.

List of Automatically archived copies of the current project.
4.9. [bookmark: Restoring_Backups7DA7BB77]Restoring Backups
To restore a backup file open it and then save it. !!To maintain the original backup, save the project to a different name using the Save-As button from the Home Tab of the Ribbon menu!!
Opening a backup...

Saving the backup as your original...






4.10. [bookmark: Sheets]Sheets
AutoTRAX can contain the following types of sheets in addition to the PCB.
· Schematic Sheets
· Text Sheets

4.10.1. [bookmark: Setting_Sheet_SizesE9109387]Setting Sheet Sizes
To set the sheet size use the Sheet properties dialog in the Properties panel.
The Sheet properties dialog is visible when nothing is selected.



4.10.2. [bookmark: Schematic_Sheets704AC3E8]Schematic Sheets
A schematic sheet contains a symbolic representation of the design of your project or of a part. See the chapter on schematics for more details.
A typical schematic for a project



A typical schematic sheet for a part. (It's symbol)


4.10.3. [bookmark: Text_Sheets56A5D998]Text Sheets
You can add text sheets to your design or parts. These text sheets can be used to add documentation or anything else you like. Full text formatting features are available. See the text sheets chapter for more details.
A Typical Text Sheet (Document).

4.10.4. [bookmark: Hierarchical_Layout3941238E]Hierarchical Layout
Schematic sheets and text sheets are arranged in an hierarchy.
Each schematic sheet or text document can have zero or more child schematic sheets  and text documents respectively.
As many schematics sheets and text documents  can be added as desired or necessary. These can be added using either the Project Panel or the Add Ribbon menu.
4.10.5. [bookmark: Sub_Systems238EEC87]Sub-Systems
A sub-system in AutoTRAX is a schematic sheet in a project that can be referenced from another schematic sheet using a sub-system reference symbol. Below is a sub-system placed on a schematic. It is labeled S1 and refers to schematic 'My sub-system'.
A sub-system can, optionally, have ports (terminals) on their boundaries which connect to ports in the sub-system schematic.
The example on the right, S1 has 2 terminals, In and Out. In the 'My sub-system' schematic, the 2 ports are connected to the input and output of the op-amp. So S1 symbolizes an amplifier while the 'My sub-system' schematic implements it. This allows you to break down a design into more logical parts.

Sub-system reference symbol without terminals

Sub-system reference symbol with terminals that connect to ports on the 'My sub-system' schematic


Contents of the 'My sub-system' schematic.
4.10.5.1. [bookmark: Adding_Sub_Systems70C9E5AB]Adding New Sub-Systems
To add a sub-system to a schematic click the Add→Sheets→ button.
You will then see the following dialog box. 

Enter the name of the new sub-system. In this case Amplifier and click the OK button.
Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a rectangle or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the starting point.

Now drag the mouse and you will see the border change in size. Left-click when the point cross is where you want to end the Sub-System or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the end point.

 The Sub-System reference is shown below.

Double-clicking inside the blue rectangle for the sub-system reference will open the sub-system's schematic sheet.

4.10.5.2. [bookmark: Opening_Sub_SystemsFB822176]Opening Sub-systems
To open a Sub-System, double-click on its sub-system reference symbol in the schematic or double-click on it in the project panel.
4.10.5.3. [bookmark: Adding_Terminals_To_A_SubsystemC399F26F]Adding Terminals to a Sub-system Reference
There are 2 different ways to add terminals to a sub-system reference.
· Add terminals directly to the sub-system reference.
· Open the sub-system reference's schematic by doubling-clicking on or in the sub-system reference's border and adding ports.
Adding terminals directly to the sub-system reference
To add terminals directly to the sub-system reference:
1. Select the sub-system reference by clicking on or in it's border. (If there is only 1 sub-system reference or part in the schematic then you do not need to do this as AutoTRAX knows what to add the terminal to.)
2. Click on one of the symbol terminals in the Symbols group in the Add ribbon menu.

The symbol terminal dialog box will appear.

3. Enter the Name and click the Add button.
4. Now move the mouse around the sub-system reference. You will see the terminal move around and try to follow the mouse. Left-click to finally place the terminal.
Repeat 1-4 to add more terminals.
When you add terminals to a sub-system reference, ports are automatically added to the sub-system reference's schematic.
For more about symbol terminals click here.
4.10.5.4. [bookmark: Editing_Sub_Systems67D1F04E]Editing Sub-Systems
You  can edit a sub-subsystem's reference by:
1. Dragging the sub-subsystem reference's value or ID.
1. Double-click on the sub-subsystem reference's value or ID to edit its value.
1. Drag any of the terminals. As the mouse moves, the terminal will follow the mouse but will always remain attached to the sub-subsystems reference's border.
1. Re size the sub-subsystem reference's border by selecting it using sub-pick from the menu or pressing down the CTRL key while selecting the sub-subsystem reference's border by clicking on it. You can then re-size the border by dragging the border's manipulator points.

Drag any of the blue rectangles to re-size the border. The terminals will move to remain on the border.
If you delete a terminal from a sub-subsystem reference then all equivalent terminals is all sub-subsystems references that reference the same schematic will be deleted. The port in the schematic will also be deleted.
If you add a terminal to a sub-subsystems reference then all sub-subsystems references that reference the same schematic will have a terminal added. A corresponding port will be added to the  sub-subsystem reference's schematic.
If you delete a port in a schematic then the corresponding terminal will be removed from all  sub-subsystem references that reference that sheet.
4.10.5.5. [bookmark: Sub_Systems_References0F85559E]Sub-Systems Names
The sub-system name is linked to the name of the sub-system schematic and displays it's name. If you change the name of the sub-system schematic then the text displayed by the sub-system's name changes.
The name can be multi-lined.

A multi-lined sub-system name

4.10.5.6. [bookmark: Using_Sub_Systems9B8D76CE]Using Sub-Systems
Sub-systems are a great way to break down a complex design into management check. You can use a top down method, a bottom up method or a mixture of both.
Top Down
To partition a design, on a schematic add 1 or more Sub-Systems. 
Bottom Up
Add a new schematic and create your bottom level design.
In another schematic from which you want to reference your new bottom level design, add a sub-system from the Add | Add Existing  menu. 
The Add Sub-System dialog box shown below will appear.
Select the sub-system and click on the   button.

4.10.5.6.1. [bookmark: Adding_Sub_Systems_ReferencesAA9C45CA]Adding Sub-Systems References
To add a sub-system reference the Add→Sub→ ribbon button group.

Select the sub-system and click the  button to add it.
Click the  button to create a new sub-system and add a reference to it. Enter its name.
 
4.10.6. [bookmark: Graphical_SheetsFEA4934A]Graphical Sheets
Schematic sheets, symbol sheets and PCB sheets are all graphical sheets. 
Graphical sheets can optionally consist of:
· A Page Border
· A Grid Reference
·  A Title Block



4.10.6.1. [bookmark: Page_Borders814F37DD]Page Borders
You can have a page border appear on a schematic or a PCB sheet. Page borders can be optionally decorated with a Grid Reference and/or a Title Block. 
To view/hide a page border either:
· Right-click and select Show Page from the context menu or
· Click on the   button in the View→Page menu or
· Click on the Show Page checkbox in the Page Properties Panel.
· Use the Sheet Settings Pop-up.
· Use the Properties Panel (with nothing selected).
You can edit the size and other attributes of the page using the Sheet Settings Pop-up or the Properties Panel.
A schematic with a page border, grid reference and a title block.
A PCB sheet with a page border, grid reference and a title block.

4.10.6.2. [bookmark: The_Grid_ReferenceA37B7A68]The Grid Reference
The grid reference is a set of reference boxes placed around the edges of the page as shown below.
You can toggle the visibility of the grid reference using the View tab.


Click to displays this help topic.
Horizontal
This group sets the parameters for the horizontal grid cells.
Vertical
This group sets the parameters for the vertical grid cells.
Count
This sets the number of cells.
Border
The size of the grid cell from the edge towards the center of the sheet.
Text
If checked then the cell value is displayed as a character from 'A' onwards.
Numeric
If checked then the cell value is displayed as a number from '1' upwards.
Left to Right
If checked then the cell values increases from the left to the right of the sheet.
Right to Left
If checked then the cell values increases from the right to the left of the sheet.
Top To Bottom
If checked then the cell values increases from the top to the bottom of the sheet.
Bottom to Top
If checked then the cell values increases from the bottom to the top of the sheet.
Show Grid Reference
This will hide/show the grid reference.

 
4.10.6.3. [bookmark: The_Title_Block0A61A98C]The Title Block
The title block is a rectangular region displayed at the bottom right of the sheet as shown below.

The date is the date of the last save in your local time. If the same sheet is displayed in a different time zone then the date displayed is adjusted.
You can edit the parameters for the title block by displaying the Properties Panel. If nothing is selected on the sheet you will see the Title Block dialog.

 Clicking this displays this help topic.
Title
This is the title for the sheet.
Description
This is a more detailed description of the contents of the sheet.
Sheet Name
The name of the sheet. It is also the name displayed in the Projects Panel and in the viewport tab title.
Checked By
The name of the person who checked the design.
Approved By
The name of the person who approved the design.
Design By
The name of the person who designed the sheet.
Revision
The revision prefix. This is displayed along with the save count. The same revision text is displayed on all sheets.
Doc. Number
The document number. The same number is displayed on all sheets.
Show Title Block
Check to display the title block on the sheet, otherwise it is hidden.

4.10.6.4. [bookmark: Sheet_Settings19CE8A4D]Sheet Settings
To set the sheet/page settings click the small  button at the bottom right of View-Snap→Page ribbon button group.





4.10.6.5. [bookmark: Page_Scale]Page Scale
You can set the page scale so your drawing fills the sheet. The circuit below only occupies a small area of the sheet.
NOTE: This does not affect the units and so the page rulers etc. will adjust automatically.

Page scale = 1
Below the page scale has been set to 0.3 so the small circuit fills the sheet. Setting the scale to more than 1 will shrink the design down so more will find onto a sheet.


Page scale = 0.3
4.10.6.6. [bookmark: Customizing_Sheet_ColorDE8FADA4]Customizing Sheet Colors
You can change the style of the schematic sheets from the standard multi-color style to a blueprint where all electrical items are in one color in the sheet is in a different color. See below.
1. To change the colors first make sure the properties panel is open and you have nothing selected.
1. Check the use electrical color checkbox
1. now select the color you wish to have for the electrical wiring by double-clicking on the color button next to the use electrical color checkbox.
1. Finally you need to set the color of the page. You can do this by clicking on the page color button.

The page properties panel


The standard multicolor display


A blueprint type display

High contrast white on black

4.10.6.7. [bookmark: Customizing_Symbols3ABC69E6]Customizing Symbols
You can fully customize your symbols.
You can set the fill color, fill pattern and border color, border thickness and border line style as well as the border corner style.
Below you can see several examples of a terminal magnet that has been filled and colored. The terminal magnet line style has also been changed.

Examples of symbols that have been modified
4.10.6.8. [bookmark: Customizing_Schematic_WiresDE39F321]Customizing Schematic Wires
You can set the line styles for all nodes to be different, just select the node and adjust the properties in the node properties panel.
Below you see several different nodes each one with a different color and a different line style.
Note: even the wire that is shown as a red dashed line is actually an electrical wire and it does make An electrical connection. 


Electrical node (wire) styles
You can set the corner style for electrical wires to be orthogonal, beveled or rounded as shown below.

Orthogonal

Beveled

Rounded
4.10.6.9. [bookmark: The_Wire_and_Bus_Settings_Popu]The Wire and Bus Settings Popup
The settings for the schematic wires and buses are shown below.
To display the settings pop-up click on the small button at the bottom right of the schematics wires group.

Wire and bus settings


4.10.6.10. [bookmark: Customizing_Schematic_Joins_and_31E6E38A]Customizing Schematic Joins and Cross-overs
You can optionally have a small jump as wire crosses another one for you can add a wire to simply cross. see The Wire and Bus Settings Popup

No jump

With jumper
You can optionally set the junction with one wire and another to be a point or a junction to have no point at all as shown below.

With junction point

No junction point

4.10.6.11. [bookmark: Customizing_All_Schematic_Wire]Customizing All Schematic Wires
You can set the line style, colors etc for all wires on the schematics. See The Wire and Bus Settings Popup



4.11. [bookmark: The_PCBD2BD4F7B]The PCB
The PCB is the physical printed circuit board.

A typical PCB


The PCB showing the PCB filled and physical parts on the top of the PCB


The PCB viewed in 3-D

4.11.1. [bookmark: Viewing_The_PCB_In_3D7E5A59FB]Viewing the PCB in 3D
To view the PCB in 3D click the Panels→Window→ button. Alternatively right-click in a PCB viewport and select .
This will display a 3D view of the PCB.

Typical 3D view of a PCB
4.12. [bookmark: Units]Units
You can set the units for all Graphical Sheets.
The possible units are:
·  Mil/Thou.
·  Inches
·  Microns 
·  MM
·  CM
·  Meters
To set the units for a sheet click on the appropriate button in the  Tools ribbon button group.
 Set Design Settings to Imperial (Inches). This will set snap and grid spacing to 0.1" for all schematics and the PCB. Units will be set to inches for all schematics and the PCB. This will apply to all new projects. Existing schematic symbols and wires will be snapped to the new grid.
Set Design Settings to Metric. This will set snap and grid spacing to 2 mm for all schematics and to 1 mm for the PCB. Units will be set to cm for all schematics and to mm for the PCB. This will apply to all new projects.


4.12.1. [bookmark: The_Origin3B4812BA]The Origin
To change the origin right-click on the origin or the vertical or horizontal ruler and select the appropriate menu command.

5. [bookmark: Parts]Parts
A part consists of a footprint, and optional 3-D model, 1 or more symbols and ideally a datasheet coupled with hyperlinks to both the supplier and the manufacturer.
Normally a part consists of just a single symbol, but the part may have 2 or more symbols such as the old TTL devices which have multiple gates and you want a separate symbol for each gate.
When you start designing a part, the first thing you need to do is find the datasheet for the part. The datasheet should define the physical package, the preferred footprint or land pattern and the pin assignment details and what each pin does. Without the parts datasheet you are flying blind and just guessing as to what you are designing.
So how to find the datasheet?
In AutoTRAX there are two different types of symbols:
Symbols with terminal magnets. 
Fully custom symbols without terminal magnets such as a traditional NPN transistor or an operational amplifier.
Part files contain schematic symbols, text documents and a footprint (land pattern) that contains all the information needed to define the abstract schematic representation for a part together with the footprint required for the PCB and the 3D solid model for the part. 
Parts are defined parametrically and this allows a single part to be quickly and easily modified into a different part type. The parametric models define how to create a complete part from only a few simple parameters.
	Part=
	
	+
	
	+
	

	
	Schematic Symbol(s)
	
	Footprint
	
	3D Package


This video gives you a quick overview of what parts are in AutoTRAX
 (
Parts in AutoTRAX
)[image: ]
5.1. [bookmark: What_is_a_part0858235D]What is a part

What is a part? That is a good question. For AutoTRAX a part can be one of several different things. These are physical parts, which can either be electrical or purely mechanical and non-physical parts which can also be electrical but can also be meta data such as sheet title blocks or  just graphics.
Physical Parts
The first, and most obvious type is a physical part.
In AutoTRAX, a physical part as many different representations. These are symbolic shapes, physical land patterns and 3-D physical models
The first representation is a logical or symbolic form. This is where the part is represented by a graphical symbol.
The second representation is as a 2-D footprint or land pattern. This 2-D representation is a collection of objects which include pads, silkscreen artwork, reference IDs, placement points, PCB holes, PCB cutouts and even the PCB shape or outline.
The third and final representation is a 3-D model that shows you are way part actually exist in reality. This is the closest of the three representations that matches what a physical part really looks like.

Most parts consist of:
· 1 or more symbols
· 1 footprint
· 1 3D model
· An optional Spice simulation model.
Symbols
A part can consist of one or more symbols. Each symbol represents the electrical characteristics of the part and also is the main visualisation of the part.
There are 2 types of symbols. Terminal Magnet based symbols and custom symbols.
Terminal Magnet based symbols

A symbol using a terminal magnet

Custom Symbols

A symbol not using terminal magnet
Single Symbol
Most parts consist of a single symbol.
Multiple Symbols
A part can have more than one symbol. Here you have a symbol that has been represented by 4 different logical get symbols and one power connection symbol using a terminal magnet.



Or you can split a symbol as many different symbols as you wish. For instance below the single symbol on the left has been split into five separate symbols whether functionality has been grouped into each symbol. This makes the understanding of the design a lot easier. You can split a symbol into multiple symbols at you have placed a symbol onto a schematic sheet.
 
The single symbol

The above symbol split into five separate symbols to clearly reflect the functionality of the device


Footprints or Land-Patterns
A footprint is literally the footprint of a part on the PCB. The most obvious part of the footprint is the collection of electrical contact pads the electrically connect the electrical terminals of a part to copper tracks which also connect to contact pads belonging to the footprints of other parts.
In addition the contact pads act as 'glue' point to stick the parts to the PCB. The 'glue' is not an organic based adhesive but instead is an alloy (solder) that melts at just above 200°C and bonds to the copper pads and the leads of the part.

In addition to the contact pads (pads) the footprint also have:
· A Footprint Reference ID
· A Placement Point
· A Silkscreen Pattern
· A Courtyard rectangle
The 3D Model
Each part usually has an associated 3D model to represent the part in the 3D view of the PCB. Parametric parts generate the 3D model automatically saving you a great deal of time - 3D models are difficult and time consuming to make.  On the right is a 3D model for a capacitor that has been automatically created from the parameters defining the parts.
3D models can be very large in memory size and can greatly increase the size of your part and project files by several megabytes for each part. The beauty of parametric parts is that the model is generated 'on the fly' when needed from the parameters of the parts. This greatly reduces the storage required from  several megabytes to just 10's of bytes.
It is also possible to import a 3D model either created by yourself or somebody in your team or imported from the Internet.


5.2. [bookmark: Tutorials]Tutorials
Overview of Parts
Overview of Parts in DEX-PCB

Parametric Parts
DEX-PCB comes with many parametric parts. A parametric part is a part than can automatically generate a 2D footprint/land pattern and a matching 3D model. All from a few simple parameters.

Creating a Capacitor
This video show you how to quickly create a custom block capacitor.

Creating a part for an ATMEGA16U2
This video show you how to quickly create a part for a Microchip ATMEGA16U2 high-performance, low-power Microchip 8-bit AVR RISC-based microcontroller.

Importing 3D Models To Use in a PCB Part
This video shows you how to import a 3-D model from an external source into DEX-PCB. The part is also modified and the materials changed to give a more realistic appearance.

Automatic Generation of 3D model PCB Header
This video show the header produced by DEX-PCB/Active3D.

Renumbering Pads for PCB parts
This video show you how to easily renumber pads in either the part editor or on actual PCBs by simply clicking on each pad in turn.

Create a PCB Footprint by Tracing From a PDF
This video show you how to create a PCB footprint from an image captured from a PDF displayed in a browser. The image is copied and pasted into the footprint designer and pads are traced over the image to produce the final footprint. This uses DEX-PCB.

Creating a Part for a Button Battery
This video shows you how to create the part for a button battery in DEX-PCB. It shows you how to create the footprint/land pattern, the symbol and how to import a 3D model.

Creating a Custom SOT223 Transistor
This video show you how to create a custom SOT223 for a BSP16T1 High Voltage Transistor in DEX-PCB.

Add a Thermal Pad to a Footprint
This video shows you how to add a thermal pad to a footprint to help conduct heat away from the device.

Creating a Power Mosfet Part in DEX-PCB
This video show you how to create a power mosfet device which uses both a custom pad configuration and a custom mosfet symbol.

Creating round, rectangular and polygonal pads and offsetting pad holes
This video shows you how to add round/elliptical, rectangular and polygonal pads to a custom part footprint/land pattern. It also shows you how to offset pad holes.

Creating a custom potentiometer part
This video show you how to create a part for a Bourns 3362 potentiometer. It show you how to create the custom footprint/land pattern and the custom schematic symbol. It also show you how to import a 3D model and position in. Finally it shows the device being used on a PCB.

Creating a part with 4 schematic symbols (Split part)
This video show you how to create a 4000 CMOS logic device (two triple input NOR gates and an inverter) using DEX-PCB. This demonstrates how to create probably one of the most complex parts for DEX-PCB. Once you master how to create one of these, all other parts will seem easy.

Customizing a parametric footprint
This video show you how to take a 4x5 quad DEX-PCB device and add pads and modify pads. It also show you how to add 3D objects.

Capturing Pin Details from a PDF
This demonstration will show you how to quickly capture pin details for a schematic symbol from a PDF document. This will also work with text documents.

How to modify a placed part using the library
This video shows you how to modify a part by saving it to the library, editing the part in the library and then dragging the modified part over your original part.


5.2.1. [bookmark: Overview_of_Parts4C7C24F2]Overview of Parts
Overview of Parts in DEX-PCB


5.2.2. [bookmark: Parametric_Parts221FAA5B]Parametric Parts
DEX-PCB comes with many parametric parts. A parametric part is a part than can automatically generate a 2D footprint/land pattern and a matching 3D model. All from a few simple parameters.


5.2.3. [bookmark: Creating_a_CapacitorEA6D2B2A]Creating a Capacitor
This video show you how to quickly create a custom block capacitor.

5.2.4. [bookmark: Creating_a_part_for_an_ATMEGA126058E56]Creating a part for an ATMEGA16U2
This video show you how to quickly create a part for a Microchip ATMEGA16U2 high-performance, low-power Microchip 8-bit AVR RISC-based microcontroller.


5.2.5. [bookmark: Importing_3D_Models_To_Use_in_421777A3]Importing 3D Models To Use in a PCB Part
This video shows you how to import a 3-D model from an external source into DEX-PCB. The part is also modified and the materials changed to give a more realistic appearance.


5.2.6. [bookmark: Automatic_Generation_of_3D_mod27F10CDD]Automatic Generation of 3D model PCB Header
This video show the header produced by DEX-PCB/Active3D.

5.2.7. [bookmark: Renumbering_Pads_for_PCB_parts0CFA63F8]Renumbering Pads for PCB parts
This video show you how to easily renumber pads in either the part editor or on actual PCBs by simply clicking on each pad in turn.

5.2.8. [bookmark: Create_a_PCB_Footprint_by_Trac3A363125]Create a PCB Footprint by Tracing From a PDF
This video show you how to create a PCB footprint from an image captured from a PDF displayed in a browser. The image is copied and pasted into the footprint designer and pads are traced over the image to produce the final footprint. This uses DEX-PCB.
5.2.9. [bookmark: Creating_a_Part_for_a_Button_B61FD7241]Creating a Part for a Button Battery
This video shows you how to create the part for a button battery in DEX-PCB. It shows you how to create the footprint/land pattern, the symbol and how to import a 3D model.

5.2.10. [bookmark: Creating_a_Custom_SOT223_TransC0E61672]Creating a Custom SOT223 Transistor
This video show you how to create a custom SOT223 for a BSP16T1 High Voltage Transistor in DEX-PCB.

5.2.11. [bookmark: Add_a_Thermal_Pad_to_a_Footpri8A3E14D7]Add a Thermal Pad to a Footprint
This video shows you how to add a thermal pad to a footprint to help conduct heat away from the device.

5.2.12. [bookmark: Creating_a_Power_Mosfet_Part_i1C97CA3C]Creating a Power Mosfet Part in DEX-PCB
This video show you how to create a power mosfet device which uses both a custom pad configuration and a custom mosfet symbol.

5.2.13. [bookmark: Creating_round__rectangular_an107933EA]Creating round, rectangular and polygonal pads and offsetting pad holes
This video shows you how to add round/elliptical, rectangular and polygonal pads to a custom part footprint/land pattern. It also shows you how to offset pad holes.

5.2.14. [bookmark: Creating_a_custom_potentiometeDF3C33E1]Creating a custom potentiometer part
This video show you how to create a part for a Bourns 3362 potentiometer. It show you how to create the custom footprint/land pattern and the custom schematic symbol. It also show you how to import a 3D model and position in. Finally it shows the device being used on a PCB.

5.2.15. [bookmark: Creating_a_part_with_4_schemat14CC5549]Creating a part with 4 schematic symbols (Split part)
This video show you how to create a 4000 CMOS logic device (two triple input NOR gates and an inverter) using DEX-PCB. This demonstrates how to create probably one of the most complex parts for DEX-PCB. Once you master how to create one of these, all other parts will seem easy.

5.2.16. [bookmark: Customizing_a_parametric_footpF877E1DA]Customizing a parametric footprint
This video show you how to take a 4x5 quad DEX-PCB device and add pads and modify pads. It also show you how to add 3D objects.

5.2.17. [bookmark: Capturing_Pin_Details_from_a_PC7E0A5BA]Capturing Pin Details from a PDF
This demonstration will show you how to quickly capture pin details for a schematic symbol from a PDF document. This will also work with text documents.

5.2.18. [bookmark: How_to_modify_a_placed_part_us9FD821BE]How to modify a placed part using the library
This video shows you how to modify a part by saving it to the library, editing the part in the library and then dragging the modified part over your original part.

5.3. [bookmark: Dont_Trust_Part_Libraries1D742EAC]Don't Trust Part Libraries
You should never trust a parts library; even your own. You must always check each and every part that you use in your design.
Parts contained quite a few very specific details and when you have a library of tens of thousands of parts it is very easy for one of the parts to have an error. This error could easily cause your PCB not to work and will cost you both time and money to fix. So, check, check and check again.

5.4. [bookmark: The_Add_Parts_Dialog9414FB79]The Parts Catalog
The Parts Catalog is a collection of over 47,000 parts that you can use use in your designs by simply dragging the part from the Add Parts Dialog onto any of your schematics.
All parts come complete with symbols, footprint/land pattern and 3D model.

	Adding Parts from the Parts Catalog
	To display the Add Parts Dialog:
· Click the  button in the Parts->Library ribbon menu or
· Click the  button in the Library Panel

The Add Parts Dialog box is shown below.
The Library Panel
.
The Add Parts Dialog

The Add Parts Dialog Details



	Updating the Parts Catalog
	AutoTRAX automatically checks for a update to the Parts Catalog and will automatically download it. The update is done in the background. You need to be connected to the Internet for the check and download to work.


	Manually Downloading the Parts Catalog
	You can manually download the Parts Catalog setup program here. http://dexpcb.com/Download/Parts


	Previewing a Part
	You can preview a part by clicking on a line in the Grid View for the part. 3 views will display:
	The Symbol for the Part
 If the part has more than one symbol, only the first one will be displayed.
	The Footprint / Land Pattern
	The Part in 3D

	
	
	

	The Part's Symbol
	The Parts Footprint
	3D View of the Part


You can pan/zoom all 3 viewports using the mouse


	Keyword Search
	The Add Parts Dialog is a modeless dialog that lets you search for parts using one or more keywords and up to 4 filters.
You enter the search keywords in the Search For text input box. 
  
Enter the keywords and separate each one with 1 or more spaces. 
 Each keyword does not have to be a full match for the word you are looking for. The keyword can be a partial match. For instance alleg will match Allego and all other words containing alleg, 
The case of the keyword does not matter.
The search is made in the following parameters for all parts.
· Name
· Description
· Package Type
· Device Group
· Manufacturer
· Technology
If you enter 2 or more keywords then each keyword must find a match. For instance searching for alleg dip match all parts with alleg and dip in their details as shown below.



	Filters
	You can filter your search for parts by:
· Device Types

· Technology

· Package Type

· Manufacturer

To add any of the above 4 filter types, click on the small down arrow at the right hand side of the box below the title of the filter type. 
A pop-up list of filters will be displayed: click on one of them and the list of parts found will be updated automatically.
You probably will not use the filters as you can use keywords instead.


	The Grid View
	All parts found are displayed in the Grid View.

Typical Grid View
Click on a row to select a part
Drag a column header to the top to group by the column. You can drag more than 1 column

Grouping by Manufacturer

Grouping by Manufacturer Then by Device Group
Right click on the column header for Context menu for column options

Right Click Context Menu

Reordered Columns and Some Columns Hidden
Drag a column to reorder columns and/or re-size columns

Columns Reordered and Resized


	Adding Parts to Your Design
	You must add the parts to a schematic, not to a PCB or 3D PCB view. In AutoTRAX, schematics are central to designs. PCB are derived from information in schematics together with further input directly to the PCB, such as part placement, layer details, PCB outline and routing.
Double Click - recommended
To add a part to a design using double click :
1. Double click the left mouse button any part of a line describing the part in the Grid View
1. The Add Parts Dialog will be hidden if it obscures the target schematic and you will see the symbol for the part being dragged inside the schematic
1. Click the left mouse button to place the part's symbol. The footprint is automatically added to the PCB
1. If you have Reshow After Adding Part checked, the Add Parts Dialog will appear and you can then add more parts or close the dialog
Drag and Drop
To add a part to a design using drag and drop:
1.  Hold down the left mouse button over any part of a line describing the part in the Grid View and drag the mouse
1. Once drag as started, the Add Parts Dialog will be hidden if it obscures the target schematic and you will see the symbol for the part being dragged inside the schematic
1. Release to left mouse button to place the part's symbol. The footprint is automatically added to the PCB
1. If you have Reshow After Adding Part checked, the Add Parts Dialog will appear and you can then add more parts or close the dialog
Click the Add Button
To add a part to a design using the add button :
1. Click the  button any part of a line describing the part in the Grid View
1. The Add Parts Dialog will be hidden if it obscures the target schematic and you will see the symbol for the part being dragged inside the schematic
1. Click the left mouse button to place the part's symbol. The footprint is automatically added to the PCB
1. If you have Reshow After Adding Part checked, the Add Parts Dialog will appear and you can then add more parts or close the dialog
	 After you have added a part: 
· Get the Datasheet
Then check and check again:
· Symbol Terminals Names
· Pad Names
· Footprint dimensions
· Symbol terminals are connected to the correct Pads
There is nothing worse than getting a collection of board back from the manufacturer and having to rework them to fix errors.


Reshowing the Add Parts Dialog After Adding Parted
Check the  checkbox to automatically reshow the Add Parts Dialog after a part is added. 


	Adding Parts to Your Local Library
	To add a part to your local library:
1. Select the part by clicking on the Grid View line describing the part
1. Click the  button
1. You will be then prompted for the file directory to save it to
1. Select the directory
1. Set the part name
1. Click 


	Editing a Part
	You can edit and part ans save it to any location on your computer or network.
1. Select the part by clicking on the Grid View line describing the part
1. Click the  button to edit the part
1. Save the part
You cannot save the part back to the Parts Catalog, The Parts Catalog is read only.


	Getting Help
	Clicking the  button will display this help


	The SQLite Database
	AutoTRAX uses SQLite:
· SQLite is a C-language library that implements a small, fast, self-contained, high-reliability, full-featured, SQL database engine. 
· SQLite is the most used database engine in the world.
· SQLite is built into all mobile phones and most computers and comes bundled inside countless other applications that people use every day.
The Parts Catalog is contained in a single database file  AutoTRAXPartsCatalog.db. The database file is located in: 
C:\Users\XXX\AppData\Roaming\AutoTRAX Software\DEX  
where XXX is your Windows user name.
 
:Find out more...






5.5. [bookmark: Downloading_Parts_from_SnapEDAD9A27A99]Downloading Parts from SnapEDA
Downloading Parts from SnapEDA.com

You can now easily search for parts on SnapEDA.com and quickly download the part into AutoTRAX.
SnapEDA Website
You can go direct to the website by clicking on the SnapEDA button in the Library Panel.


Download File Type
Download both the Symbol and Footprint.

Click on Eagle for the download file type.

Opening the Part
Once downloaded you can open the part by double clicking on it.
If AutoTRAX does not startup the you can set the default app for the file type by right clicking on the file.

Part Requests
You can request any symbol or footprint and have it delivered in under 24 hours.


We're building the library. You're building the future.
SnapEDA is the Internet's first electronics design library. Our mission is to help engineers build products faster by removing design barriers.
Each year, over 750,000 professional engineers rely on SnapEDA to design faster. They're at small shops, to household names like Google, Facebook, & Samsung. They're building over 192,000 unique products, including medical devices, satellites, drones and so much more.
Since SnapEDA shaves days off development time, engineers can focus more on innovation. They also gain instant transparency into manufacturability with our patented verification technology. You can learn more about our schematic symbol & PCB footprint standards here.

5.6. [bookmark: Setting_The_Default_Part60D89B74]Setting The Default Part
You can set the default part template by first creating a part, setting it up exactly as you want all new parts to be and then click the  in the File Menu. Then, every time you create a new part, it will start off as a mirror image of the default project you saved.

The file  is named Default.part and is in the library '___SystemDoNotRemove' directory .
You can always reset the default part to the factory default using the File Settings.
5.7. [bookmark: Virtual_PartsF5EF11A6]Virtual Parts
Virtual parts are parts with no physical package and therefore do not have a footprint. They do not appear on a PCB.
Example of virtual parts are power and ground symbols., See below.
Virtual parts have the following properties...
· You can attach a wire to a terminal in the part. This terminal is usually invisible but it's position is usually at the end of the vertical line at the top or bottom of the part's graphics.
· The terminal has a named node. so that all wires attached to similar symbols will all be electrically connected together e.g. All digital grounds will be connected together using PCB tracks.
· They do not have any electrical pads on the PCB; in fact, nothing is present on the PCB that belongs to a virtual part.
· You connect at least on the them to a terminal on a part that is a physical part. This connection will be to a pad on the parts footprint. Below is a Vcc and an analog ground connected to either end of of resistor.

	
Schematic
	
R1 and R2 automatically connected together


Example Virtual Parts
	Digital Ground
	

	Analog Ground
	

	Generic Ground
	

	+5V DC
	

	-5V DC
	

	+12V DC
	

	-12V DC
	

	Vcc
	

	Vdd
	


5.8. [bookmark: Creating_a_Virtual_Part2C429649]Creating a Virtual Part
Compared to creating a physical parts, creating a virtual part.
All you need to do is: (in any order)
· Add 1 or more schematic symbol with named nodes. Usually these are hidden and are placed at then end of straight lines.
· Add graphics to make the purpose of the symbol easy to deduce.
5.9. [bookmark: Parametric_PartA189AAA8]Parametric Parts
A parametric part is the encapsulation of all the details needed by AutoTRAX to generate the schematics symbols, footprint and 3D solid model for a real part.
Parametric parts are extremely powerful. From only a small collection of numerical values parametric parts can generate complex graphics including 2-D graphics and 3-D graphics.
To illustrate the concept let's consider a PIC10F200 micro-controller from Microchip.
We will consider the version that comes in an 8-pin PDIP package.
There are 3 parts to consider.
1. The Manufacturer's model and specification of the device.
1. What you actually get.
1. The model used by AutoTRAX to help you incorporate it into the system you are designing.


5.9.1. [bookmark: The_Suppliers_Model2BFD78FF]The  Manufacturers Model
The manufacturer will detail the part they will sell you using a datasheet.  The datasheet will describe what the device does and the physical package in which it comes. There may be more than one package for a part.
Each package has a set of electrical pins that you must connect to your circuit. The naming, allocation and description of these pins are in the datasheet.
To use a part in AutoTRAX you will need to know its package, its pinout and its recommended footprint.
The PIC10F200 micro-controller datasheet is available at http://ww1.microchip.com/downloads/en/DeviceDoc/41239D.pdf
For the Microchip parts there is also an additional packaging specification available at http://ww1.microchip.com/downloads/en/PackagingSpec/00049AU.pdf
The datasheet has a pinout of the part as shown below.

The physical package is shown below

The physical package parameters are defined below.

5.9.2. [bookmark: The_DeliverableD1FA45B7]The Deliverable
What is delivered to you to construct an electronic system is a physical part. In the case of the 8-pin DIP PC its looks like this:

You need to extract the essential data from the supplier's model and make a computer representation that can be used to design the system both logically and physically.
5.9.3. [bookmark: The_AutoTRAX_Model02B47AE4]The AutoTRAX Model
AutoTRAX models the device defined by the above specification as a DIP.
The parametric model of the PIC10F200 is divided into 3 parts.
The Schematic Symbol

The Footprint

The 3D Package




5.9.4. [bookmark: Datasheet]Datasheet
When you create a part, the first thing you must do is find the data sheet for the part and obtain a physical part so you can check the dimensions against the datasheet.
Do not trust part libraries. 
Always get the datasheet for all the parts that you use and check each part's symbol(s), footprint and 3D model. 
5.9.5. [bookmark: Schematic_Symbol73CB37B8]Schematic Symbol
All parametric parts has 1 or more schematic symbols. By default it is a symbol with a rectangular terminal magnet with symbol terminals attached to the left and right edges of the terminal magnet. There will be 1 symbol terminal associated with each pad in the footprint.
Symbols
A part can consist of one or more symbols. Each symbol represents the electrical characteristics of the part and also is the main visualisation of the part.

Single Symbol
Below is a single symbol representation of a part using a terminal magnet.


A symbol using a terminal magnet

In contrast to the above we have a single symbol representation of a part not using a terminal magnet. Here the symbol terminals can be placed freely. The graphics are designed to make the functionality of the device clearly visible. In this case an operational amplifier. This is in short contrast to a rectangular representation using a terminal magnet where sometimes the functional to is not clearly visible


A symbol not using terminal magnet
Multiple Symbols
A part can have more than one symbol. Here you have a symbol that has been represented by 4 different logical get symbols and one power connection symbol using a terminal magnet.



Or you can split a symbol as many different symbols as you wish. For instance below the single symbol on the left has been split into five separate symbols whether functionality has been grouped into each symbol. This makes the understanding of the design a lot easier. You can split a symbol into multiple symbols at you have placed a symbol onto a schematic sheet.
 
The single symbol

5.9.6. [bookmark: Attributes]Attributes
Distributor
Distributor's Website
Short Description
Full Description
Merge Lines into Paragraphs
5.9.7. [bookmark: Package_Placement_Point41DA1FF9]Package Placement Point
The package placement point defines the placement point for Pick and Place machines.
To hide/show placement points click the View/Edit→Footprints→  button.

 Placement Point


5.9.8. [bookmark: Package_Silkscreen74EC5800]Package Silkscreen


5.9.9. [bookmark: Package_CourtyardEF9A98EE]Package Courtyard
Courtyards

5.9.10. [bookmark: Package_Reference1A51CC1C]Package Reference
You can rotate and scale the package value text.
You can also set the font for text.
In the schematic symbol you can set the color for the text.

Symbol References
The Footprint Reference

5.9.11. [bookmark: Package_Value]Package Value
You can rotate and scale the package value text.
You can also set the font and color for text.
5.9.12. [bookmark: Package_Color0414DA4C]Package Color
You can set the color of the package using the Package Color expandable control.

The Package Color Expandable Control


Changing The Package Color
See the Editing Colors topic on how to change colors. 
5.9.13. [bookmark: Pads2]Pads
Pads are areas of copper on the surface of a PCB with an optional hole that is used to both secure a part to the PCB and also to provide an electrical connection between electrical contact points/areas and pins of a part with other parts using copper tracks.

2 pads connected via a copper track
A footprint can have pads automatically generated as for the part type and also have pads that you manually add to the footprint.

Parametric SMT footprint with 2 manually added THT pads
Footprints can have zero or more pads. 
The parametric footprints pads dialog is shown below.

Pad Shape
Pad can have rectangular/square pads with optional rounded corners or circular/elliptical pads.
Check the radio button to set make all the pads in the parametric footprint rectangular. This does not affect any additional pads you have added to customize the footprint.
      
Check the radio button to set make all the pads in the parametric footprint round.. This does not affect any additional pads you have added to customize the footprint.
      
Width - Enter the horizontal width of the pad.
Height - Enter the vertical height of the pad.
Rounding the corners of rectangular pads
Slide the  slider to round the 4 corners of rectangular pads.
     
See also:
Pads

5.9.14. [bookmark: Type_SelectionDEFD0BB9]Type Selection


Type Selector
	
Dual-Inline Package
	
Small Outline IC
	
Quad Flat Pack
	
Ball Grid Array

	
Female Header
	
Male Header
	
TO-220
	
SOT-223

	
TO-3
	
TO-66
	
TO-18
	
CHIP

	
Block
	
Block/Crystal
	
Radial
	
Panasonic Style

	
Disc
	
LED
	
Axial -Vertical-Banded
	
Axial -Horizontal-Banded

	
Axial -Vertical
	
Axial -Horizontal
	
SOT-223
	
SOT-89

	
SOT-353
	
SOT-143
	
SOT-143
	
SOT-143

	
SOT-23-3
	
SOT-23-4
	
SOT-23-5
	
SOT-23-6

	
SOD-323
	
	
Inductor
	
Arial





5.9.14.1. [bookmark: The_Part_BuilderB9876025]The Part Builder
The semiconductor industry manufactures a very huge variety of integrated circuits that have different packaging requirements. 
The Part Builder lets you create parts both in-place in a schematic or in a separate part file. Click the Panels→Panels→ button to show/hide the Part Builder.

 The part builder can create the following devices:
	
DIP
	 
SOIC
	 
QUAD
	 
BGA



	 
Generic
	 
Header
	 
SOT-223
	 
SOT-353



	 
SOT-143
	 
SOT-23
	 
SOT-89
	 
TO-92



	 
TO-220
	 
Metal Can
	 
TO-3 and TO-6
	 
SOD-323



	 
Chip
	 
Block
	 
Crystal
	 
Axial



	 
MELF
	 
Radial
	
 Disc
	 
LED



	 
Inductor
	 
Antenna
	 
Edge Connector
	 
Castellated PCB



	 
Wizard
	 
Custom

















5.9.14.1.1. [bookmark: Using_The_Part_Wizard7E268554]Using the Part Wizard
A quick way to add a part is to use the Parts Wizard. 
To start the parts Wizard click on the Home->New->  in the ribbon menu. This will display the part Wizard dialogue box shown below.
The part Wizard consists of several pages that help you define your new part. It starts with the welcome page shown below

After completing the details required in the welcome page you will be presented with the second page shown below:







5.9.14.1.2. [bookmark: Cutomizing_The_Part]Customizing The Part
Customizing The Symbol 
Customizing The Footprint
5.9.14.1.2.1. [bookmark: Customizing_The_Symbol791DD501]Customizing The Symbol
To set the name for a symbol terminal, double click on it.

Terminal to Rename
You will see the Rename Terminal dialog shown below.

Enter the new name for the terminal and click the  button. You can enter more than one line of text.

Renamed Terminal
Over-strike Text
To over-strike text in a symbol terminal:
1. Select the text to over-strike in the Rename Terminal dialog.
1. Click the  button. To remove over-strike text click the  button.

Symbol Terminal with Over-strike

Symbol Terminal with Partial Over-strike

Multi-line Text
In the text, the special character ˆ starts over-strike and the special character ˇ ends over-strike.
5.9.14.1.2.2. [bookmark: Customizing_The_Footprint87BCBA22]CustomizingThe Footprint
Adding Graphics to Footprint
Adding Pads to Parametric Footprints
Adding Graphics to Parametric Footprints
Adding 3D to Parametric Footprints
Adding 3D objects 
Adding Copper Areas to Parametric Footprints
Editing the Part Value
Editing the Part Reference

[bookmark: Adding_Pads_to_Parametric_Footpr6031DA44]Adding Pads to Parametric Footprints
You can add additional non-parametric pads to a parametric part using the Add→Pads  button group.
See Adding Pads.

[bookmark: Adding_Vias_to_Parametric_Footpr542210B7]Adding Vias to Parametric Footprints
You can add vias to footprints by clicking on the add Via button in the add menu. 
[bookmark: Adding_Graphics_to_Parametric_Fo81DE2231]Adding Graphics to Parametric Footprints
You are free to add graphics to parametric footprints as well as non-parametric footprints.
[bookmark: Adding_Copper_Areas_to_ParametriAAACB8C2]Adding Copper Areas to Parametric Footprints
To add a copper area to a footprint select the layer that you want the copper to be on and add a graphic shape such as a rectangle or circle.
[bookmark: Editing_the_Part_Value62D03328]Editing the Part Value
To edit a part value either double-click on the text or select the part value and edit the text and/or other parameters using the properties panel.
.
[bookmark: Editing_the_Part_Reference2AD4CE8A]Editing the Part Reference
To edit a part reference either double-click on the text or select the part value and edit the text and/or other parameters using the properties panel.

[bookmark: Adding_3D_to_Parametric_Footprin2E4F3613]Adding 3D to Parametric Footprints
To add additional 3-D to a parametric footprint add any of the 3-D objects in the add menu.
5.9.14.1.3. [bookmark: DIP_PartsA32ADC12]DIP Parts
To create a DIP part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

8 pin DIP

8 pin DIP showing package

3D View of 8 pin DIP

Schematic Symbol

Device Overview
Dip Parameters
Pads 
Package Color 
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.4. [bookmark: SOIC_Parts3BD18529]SOIC Parts

To create a SOIC part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

8 pin SOIC

8 pin SOIC  showing package

3D View of 8 pin SOIC

Schematic Symbol
Device Overview
SOIC Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.5. [bookmark: QUAD_PartsB556922A]QUAD Parts
To create a QUAD part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.




Device Overview
QUAD Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.6. [bookmark: BGA_Parts3E12DDE3]BGA Parts
To create a BGA part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.







Device Overview
BGA Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.7. [bookmark: Header_PartsF77F5CA8]Header Parts
To create a Header part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Header Parameters
 Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.8. [bookmark: Axial_Parts7E00151C]Axial Parts
To create an Axial part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Axial Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.9. [bookmark: Radial_Parts6BFB2D06]Radial Parts
To create a Radial part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Radial Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.10. [bookmark: Chip_Parts63317927]Chip Parts
To create a Chip part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Chip Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.11. [bookmark: SOD323_Parts5F31B9F3]SOD 323 Parts
To create a SOD 323 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
SOD 323 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.12. [bookmark: TO_92_TransistorsC8A26864]TO-92 Transistors

To create a TO-92 click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.





Device Overview
TO-92 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.13. [bookmark: SOT_23_Transistors01037F23]SOT-23 Transistors
To create a SOT-23 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
SOT-23 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.14. [bookmark: SOT_353_TransistorsBBB8AED9]SOT-353 Transistors
To create a SOT-353 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
SOT-353 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.15. [bookmark: SOT_89_Transistors2E2168AB]SOT-89 Transistors
To create a SOT-89 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
SOT-89 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.16. [bookmark: SOT_143_TransistorsDF4DE76C]SOT-143 Transistors
To create a SOT-143 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
SOT-143 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.17. [bookmark: SOT_223_TransistorsCE890D7F]SOT-223 Transistors
To create a SOT-223 part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview 
SOT-223 Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.18. [bookmark: Metal_Can_Parts3FC233A5]Metal Can Parts
To create a metal can part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Metal Can Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.1.19. [bookmark: Antenna_Parts0A3106AA]Antenna Parts
You can create a coil pattern on a copper layer to act as a antenna coil.
To create an antenna part click the  button in the The Part Builder
The part builder will automatically create the copper pattern and pads for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

Schematic Symbol without outer ring


Copper pattern and pads

3D View of the antenna

Device Overview
Inductor Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.20. [bookmark: Inductor_PartsF93276D1]Inductor Parts
You can create a coil pattern on a copper layer to act as an inductor.
To create a Inductor part click the  button in the The Part Builder
The part builder will automatically create the copper pattern and pads for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

Schematic Symbol

Copper pattern and pads

3D View of the inductor


Device Overview
Inductor Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.1.21. [bookmark: Package_Symbols5EE63F30]Package Symbols
5.9.14.2. [bookmark: Arial]Arial
5.9.14.2.1. [bookmark: Device_Overview16]Device Overview
You can create an arial from copper traces on a PCB.
5.9.14.2.2. [bookmark: Antenna_Parameters]Antenna Parameters

Antenna Parameters

Inner Radius. The inner radius. See the diagram above.
Track Width. The width of the copper track forming the antenna.
Trace Space. The space between copper rings. See the diagram above.
Rings. The number of complete rings.
Check the  checkbox to use plated through holes for the pads. Uncheck to use SMT pads,
Check the  checkbox is run the rings clockwise. Uncheck to run the rings in the opposite direction.

Clockwise

Anticlockwise
Check the  checkbox to add an outer ring.

Antenna with outer ring
5.9.14.3. [bookmark: Axial]Axial
To create an Axial part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Axial Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.3.1. [bookmark: Device_Overview5]Device Overview
5.9.14.3.2. [bookmark: Axial_Parameters]Axial Parameters

5.9.14.4. [bookmark: BGA]BGA
To create a BGA part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.







Device Overview
BGA Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.4.1. [bookmark: Device_Overview3]Device Overview
A ball grid array (BGA) is a type of surface-mount packaging used for integrated circuits. BGA packages are used to permanently mount devices such as microprocessors. A BGA can provide more interconnection pins than can be put on a dual in-line or flat package. The whole bottom surface of the device can be used, instead of just the perimeter. The leads are also on average shorter than with a perimeter-only type, leading to better performance at high speeds.
Soldering of BGA devices requires precise control and is usually done by automated processes. A BGA device is never mounted in a socket in use.
Advantages
The BGA is descended from the pin grid array (PGA), which is a package with one face covered (or partly covered) with pins in a grid pattern. These pins conduct electrical signals from the integrated circuit to the printed circuit board (PCB) on which it is placed. In a BGA, the pins are replaced by balls of solder stuck to the bottom of the package. These solder spheres can be placed manually or with automated equipment. The solder spheres are held in place with a tacky flux until soldering occurs. The device is placed on a PCB with copper pads in a pattern that matches the solder balls. The assembly is then heated, either in a reflow oven or by an infrared heater, causing the solder balls to melt. Surface tension causes the molten solder to hold the package in alignment with the circuit board, at the correct separation distance, while the solder cools and solidifies.
The BGA is a solution to the problem of producing a miniature package for an integrated circuit with many hundreds of pins. Pin grid arrays and dual-in-line surface mount (SOIC) packages were being produced with more and more pins, and with decreasing spacing between the pins, but this was causing difficulties for the soldering process. As package pins got closer together, the danger of accidentally bridging adjacent pins with solder grew. BGAs do not have this problem when the solder is factory-applied to the package.
A further advantage of BGA packages over packages with discrete leads (i.e. packages with legs) is the lower thermal resistance between the package and the PCB. This allows heat generated by the integrated circuit inside the package to flow more easily to the PCB, preventing the chip from overheating.
The shorter an electrical conductor, the lower its inductance, a property which causes unwanted distortion of signals in high-speed electronic circuits. BGAs, with their very short distance between the package and the PCB, have low inductances and therefore have far superior electrical performance to leaded devices.
Disadvantages
A disadvantage of BGAs is that the solder balls cannot flex in the way that longer leads can, so they are not compliant. As with all surface mount devices, bending due to a difference in coefficient of thermal expansion between PCB substrate and BGA (thermal stress) or flexing and vibration (mechanical stress) can cause the solder joints to fracture.
Thermal expansion issues can be overcome by matching the mechanical and thermal characteristics of the PCB to those of the package. Typically, plastic BGA devices more closely match PCB thermal characteristics than ceramic devices.
The predominant use of RoHS compatible lead-free solder alloy assemblies have presented some further challenges to BGAs including "head in pillow" soldering phenomenon, "pad cratering" problems as well as their decreased reliability versus lead-based solder BGAs in extreme operating conditions such as high temperature, high thermal shock and high gravitational force environments, in part due to lower ductility of RoHS-compliant solders.
Mechanical stress issues can be overcome by bonding the devices to the board through a process called "under filling", which injects an epoxy mixture under the device after it is soldered to the PCB, effectively gluing the BGA device to the PCB. There are several types of under fill materials in use with differing properties relative to workability and thermal transfer. An additional advantage of under fill is that it limits tin whisker growth.
Another solution to non-compliant leads is to put a "compliant layer" in the package that allows the balls to physically move in relation to the package. This technique has become standard for packaging DRAMs in BGA packages.
Once the package is soldered down, it may be difficult to look for soldering faults. X-ray machines, Industrial CT Scanning machines, special microscopes as well as endoscopes to look underneath the soldered package have been developed to overcome this problem. If a BGA is found to be badly soldered, it can be removed in a rework station, which is a jig fitted with infrared lamp (or hot air), a thermocouple and a vacuum device for lifting the package. The BGA can be replaced with a new one, or the BGA can be refurbished (or reballed) and re-installed on the circuit board. Pre-configured solder balls matching the array pattern (preforms) can be used to reballing the BGA's when only one or a few need to be reworked.
Due to cost of X-ray BGA inspection, electrical testing is very often used. Very common is boundary scan testing using IEEE 1149.1 JTAG port.
During development it is not practical to solder BGAs into place, and sockets are used instead, but tend to be unreliable. There are two common types of socket: the more reliable type has spring pins that push up under the balls, although it does not allow using BGAs with the balls removed as the spring pins may be too short.
The less reliable type is a ZIF socket, with spring pinchers that grab the balls. This does not work well, especially if the balls are small.
Expensive equipment is required to reliably solder BGA packages; hand-soldering BGA packages is very difficult and unreliable, usable only for the smallest packages in the smallest quantities.
Other BGA package types
CABGA 		Chip Array Ball Grid Array
CBGA and PBGA 	denote the Ceramic or Plastic substrate material to which the array is attached.
CTBGA 		Thin Chip Array Ball Grid Array
CVBGA 		Very Thin Chip Array Ball Grid Array
DSBGA 		Die-Size Ball Grid Array
FBGA 			or Fine Ball Grid Array based on ball grid array technology. It has thinner contacts and is mainly used in system-on-a-chip designs. Known as FineLine BGA by Altera.
FCmBGA 		Flip Chip Molded Ball Grid Array
LBGA 			Low-profile Ball Grid Array
LFBGA 		Low-profile Fine-pitch Ball Grid Array
MBGA 		Micro Ball Grid Array
MCM-PBGA 		Multi-Chip Module Plastic Ball Grid Array
PBGA 			Plastic Ball Grid Array
SuperBGA (SBGA) 	Super Ball Grid Array
TABGA 		Tape Array BGA
TBGA 			Thin BGA
TEPBGA 		Thermally Enhanced Plastic Ball Grid Array
TFBGA 		or Thin and Fine Ball Grid Array
UFBGA and UBGA 	and Ultra Fine Ball Grid Array based on pitch ball grid array
5.9.14.4.2. [bookmark: BGA_Parameters]BGA Parameters


5.9.14.5. [bookmark: BLOCK]Block
5.9.14.6. [bookmark: Block___Crystal574C16B2]Block - Crystal
5.9.14.7. [bookmark: Castellated_PCB41601EBE]Castellated PCB
5.9.14.8. [bookmark: CHIP]Chip
To create a Chip part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Chip Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.8.1. [bookmark: Device_Overview7]Device Overview
5.9.14.8.2. [bookmark: Chip_Parameters]Chip Parameters


See Color Names

	
	



5.9.14.9. [bookmark: DIP]DIP
To create a DIP part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

8 pin DIP

8 pin DIP showing package

3D View of 8 pin DIP

Schematic Symbol

Device Overview
Dip Parameters
Pads 
Package Color 
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.9.1. [bookmark: Device_OverviewCB85D648]Device Overview
 A dual in-line package (DIP or DIL) is an electronic device package with a rectangular housing and two parallel rows of electrical connecting pins. The package may be through-hole mounted to a printed circuit board or inserted in a socket. Dual-in-line packages were developed in the 1960s when the restricted number of leads available on transistor-style packages became a limitation in the use of integrated circuits. Increasingly complex circuits required more signal and power supply leads ( as observed in Rent's rule); eventually microprocessors and similar complex devices required more leads than could be put on a DIP package, leading to development of higher-density packages.

A DIP is usually referred to as a DIPn, where n is the total number of pins. For example, a microcircuit package with two rows of seven vertical leads would be a DIP14. The above photograph shows three DIP14 ICs. Common packages have as few as four and as many as 64 leads. Many analog and digital integrated circuit types are available in DIP packages, as are arrays of transistors, switches, light emitting diodes, and resistors. DIP plugs for ribbon cables can be used with standard IC sockets.
DIP packages are usually made from an opaque molded epoxy plastic pressed around a tin, silver, or gold-plated lead frame that supports the device die and provides connection pins. Some types of IC are made in ceramic DIP packages, where high temperature or high reliability is required, or where the device has an optical window to the interior of the package. Most DIP packages are secured to a printed circuit board by inserting the pins through holes in the board and soldering them in place. Where frequent replacement of the parts is desired, such as in test fixtures or where programmable devices must be removed for changes, a DIP socket is used. Some sockets include a zero insertion force mechanism.
Variations of the DIP package include those with only a single row of pins, possibly including a heat sink tab in place of the second row of pins, and types with four rows of pins, two rows, staggered, on each side of the package. DIP packages have been mostly displaced by surface-mount package types, which avoid the expense of drilling holes in a printed circuit board and which allow higher density of interconnections.
Mounting
DIPs can be mounted either by through-hole soldering or in sockets. Sockets allow easy replacement of a device and eliminate the risk of damage from overheating during soldering. Generally sockets were used for high-value or large ICs, which cost much more than the socket. Where devices would be frequently inserted and removed, such as in test equipment or EPROM programmers, a zero insertion force socket would be used.
DIPs are also used with breadboards, a temporary mounting arrangement for education, design development or device testing. Some hobbyists, for one-off construction or permanent prototyping, use point-to-point wiring with DIPs, and their appearance when physically inverted as part of this method inspires the informal term "dead bug style" for the method.
5.9.14.9.2. [bookmark: Dip_Parameters]Dip Parameters

DIP Parameter Editor
Pitch
X the horizontal pitch between pad columns centers.
Y the vertical pitch between pad row centers.
Outer The horizontal distance between pad outer edges.
Inner The horizontal distance between pad inner edges.
Total Pads The total number of pads.

DIP Parameters




5.9.14.10. [bookmark: Disc]Disc
5.9.14.11. [bookmark: Generic]Generic
Enter topic text here.
5.9.14.12. [bookmark: HEADER]Header
To create a Header part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Header Parameters
 Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.12.1. [bookmark: Device_Overview4]Device Overview
A pin header (or simply header) is a form of electrical connector, often associated with ribbon cable connectors. It consists of one or more rows of pins typically spaced 0.1 inches (2.54 mm) apart, but sometimes 2 millimetres (0.079 in) or 0.05 inches (1.27 mm) is used as well.
In addition to being used to connect to a ribbon cable connector, pin headers often also function as recipients for jumpers. The most common jumper spacing is 0.1 inches (2.54 mm) spacing, though 2 millimetres (0.079 in) is sometimes used in smaller products.
Pin header connectors are thus "male" connectors (female counterparts do exist, but these are normally just called "header connectors", without "pin") and are mostly used inside equipment, rather than being used as a connector on the outside of the device.
Normally pin headers are pin through hole (PTH) devices, but surface-mount technology (SMT) versions of one and two row pin headers also exist. In the latter case the solder sides of the pins are simply bent on a 90 degree angle so as to be soldered to a solder plane. On single row pin headers the pins are bent alternating to one side or the other, on dual row pin headers the pins are simply bent outwards. If pin headers are optional, the PTH variant is often chosen for ease of manual assembly. Pin headers can be either straight or angled. The latter form is often used to connect two boards together.
Pin headers are cost-effective due to their simplicity. Headers are often sold as long strips (typically 40 pins for the dual row versions) which can easily be broken off to the right number of pins.
Pin headers with a plastic guide box around them are known as "box headers" or "shrouded headers" and are normally only used in combination with a ribbon cable connector. A notch (key) in the guide box normally prevents placing the connector (polarised by a "bump" on one side) the wrong way around.
In absence of a pin 1 designation on the header, one or more pins in the header may be removed or clipped to indicate a key for correct orientation. If a designation is missing from the header, the PCB may have a marking indicating orientation (often the solder pad around the hole of pin 1 of a PTH header is square rather than round).
5.9.14.12.2. [bookmark: Header_Parameters]Header Parameters

5.9.14.13. [bookmark: Inductor2]Inductor
You can create a coil pattern on a copper layer to act as an inductor.
To create a Inductor part click the  button in the The Part Builder
The part builder will automatically create the copper pattern and pads for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

Schematic Symbol

Copper pattern and pads

3D View of the inductor


Device Overview
Inductor Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.13.1. [bookmark: Inductor_Parameters]Inductor Parameters
The inductor parameters editor is shown below.


Inner Radius. The inner radius. See the diagram above.
Track Width. The width of the copper track forming the antenna.
Trace Space. The space between copper rings. See the diagram above.
Rings. The number of complete rings.
Check the  checkbox is run the rings clockwise. Uncheck to run the rings in the opposite direction.

Clockwise

Anticlockwise

5.9.14.13.2. [bookmark: Device_Overview17]Device Overview
You can create an inductor from copper traces on a PCB.

5.9.14.14. [bookmark: LED]LED
5.9.14.15. [bookmark: Metal_Can6541E562]Metal Can
5.9.14.15.1. [bookmark: Device_Overview15]Device Overview

Metal Can

5.9.14.15.2. [bookmark: Metal_Can_Parameters]Metal Can Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.

5.9.14.16. [bookmark: MELF]MELF
 Metal electrode leadless face (MELF) is a type of leadless cylindrical electronic surface mount device that is metallized at its ends. MELF devices are usually diodes and resistors.
Because of their cylindrical shape and small size, in some cases these components can easily roll off the workbench or circuit board before they have been soldered into place. As such, there is a joke which suggests an alternate meaning for the acronym: Most End Up Lying on the Floor. Additionally, MELF components are sometimes called a "roll away" package.
During automated SMT pick-and-place, this happens mostly if the mechanical pressure of the SMD placer nozzle is too low. If the MELF components are placed into the solder paste with enough pressure, then this problem can be minimized. Care must be taken with glass diodes which are less mechanically robust than resistors and other MELF components.
Also, when building up PCBs via manual assembly using tweezers (e.g., for prototyping) then the pressure at the end of tweezers can often cause a MELF component to slip and shoot out the ends, thereby making their placement more difficult, compared to other flat component packages.
Another reason for the nickname of MELF components is that most production engineers do not like to use MELF nozzles on a SMT pick-and-place machine. For them it is waste of time to change from flat nozzles to MELF nozzles. For MICRO-MELF and MINI-MELF most SMD placers are able to use flat chip nozzles if the vacuum is high enough; i.e., higher than for flat chip components. For MELFs with the case size of 0207 or less, it is recommended to use the original MELF nozzle supplied with the SMT machine. Each supplier of such SMD pick-and-place machines offers these types of nozzles.
In order to overcome some of the difficulties encountered when mounting these devices, there are also variants with square electrodes (e.g. SQ MELF, QuadroMELF and B-MELF). These variants are mainly used in semiconductor diodes for applications where the high-reliability of hermetically sealed voidless-glass packages is required.
These handling difficulties prompted development of alternative SMT packages for common MELF components (like diodes) where the power handling capability needed to be similar to MELF components (superior to low-power 0805/0603, etc. SMT components) but with improved automated pick-and-place handling characteristics. This resulted in various squared-off packages with fold-over contacts, similar to rectangular inductor/tantalum capacitor packages



Standard MELF on PCB with Solder


MELF Parameter Editor
Type

Selects one of 3 different package types.

Standard

Mini

Micro
Schematic Symbol
A schematic symbol will be automatically created for you by clicking on one of the following buttons.

Symbol Selector
 IEEE Resistor

 IEC Resistor

 Diode

 Terminal Magnet with 2 Terminals

 Custom with 2 Terminals




5.9.14.17. [bookmark: QUAD]QUAD
To create a QUAD part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.




Device Overview
QUAD Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.17.1. [bookmark: Device_Overview2]Device Overview
A QFP or Quad Flat Package is a surface mount integrated circuit package with "gull wing" leads extending from each of the four sides. Socketing such packages is rare and through-hole mounting is not possible. Versions ranging from 32 to 304 pins with a pitch ranging from 0.4 to 1.0 mm are common. Other special variants include low profile QFP and thin QFP.
The QFP component package type became common in Europe and United States during the early nineties, even though it has been used in Japanese consumer electronics since the seventies. It is often mixed with hole mounted, and sometimes socketed, components on the same printed circuit board.
A package related to QFP is PLCC which is similar but has pins with larger pitch, 1.27 mm (or 1/20 inch), curved up underneath a thicker body to simplify socketing (soldering is also possible). It is commonly used for NOR Flash memories and other programmable components.
The quad flat-pack has connections only around the periphery of the package. To increase the number of pins, the spacing was decreased from 50 mil (thousandths of an inch) (as found on small outline packages) to 20 and later 12 mil. However, this close lead spacing made solder bridges more likely and put higher demands on the soldering process and alignment of parts during assembly. The later pin grid array and ball grid array packages, by allowing connections to be made over the area of the package and not just around the edges, allowed for higher pin counts with similar package sizes, and reduced the problems with close lead spacing.
The basic form is a flat rectangular (often square) body with leads at four sides but with numerous variations in the design. These differ usually only in lead number, pitch, dimensions, and materials used (usually to improve thermal characteristics). A clear variation is Bumpered Quad Flat Package with extensions at the four corners to protect the leads against mechanical damage before the unit is soldered.
Heat sink Quad Flat Package, Heatsink Very-thin Quad Flat-pack No-leads (HVQFN) is a package with no component leads extending from the IC. Pads are spaced along the sides of the IC with an exposed DIE that can be used as ground. Spacing between pins can vary.
A thin quad flat pack (TQFP) provides the same benefits of the metric QFP, but is thinner. Regular QFP are 2.0 to 3.8 mm thick depending on size. TQFP packages range from 32 pins with a 0.8 mm lead pitch, in a package 5 mm by 5 mm by 1 mm thick, to 256 pins, 28 mm square, 1.4 mm thick and a lead pitch of 0.4 mm.
TQFPs help solve issues such as increasing board density, die shrink programs, thin end-product profile and portability. Lead counts range from 32 to 176. Body sizes range from 5 mm x 5 mm to 20  x 20 mm. Copper lead-frames are used in TQFPs. Lead pitches available for TQFPs are 0.4 mm, 0.5 mm, 0.65 mm, 0.8 mm, and 1.0mm. PQFP, or plastic quad flat pack, is a type of QFP, as is the thinner TQFP package. PQFP packages can vary in thickness from 2.0 mm to 3.8 mm. A Low-profile Quad Flat Package is a surface mount integrated circuit package format with component leads extending from each of the four sides. Pins are numbered counter-clockwise from the index dot. Spacing between pins can vary; common spacings are 0.4, 0.5, 0.65 and 0.80 mm intervals.
Some QFP packages have an Exposed Pad. The exposed pad is an extra pad underneath or on top of the QFP that may act as a ground connection and/or as a heat sink for the package. The pad is typically 10 or more mm², and with the pad soldered down onto the ground plane heat is passed into the PCB. This exposed pad also gives a solid ground connection. These type of QFP packages often have a -EP suffix (e.g. a LQFP-EP 64), or they have an odd number of leads, (e.g. a TQFP-101).
Other quad flat package types
BQFP 		Bumpered Quad Flat Package
BQFPH 	Bumpered Quad Flat Package with heat spreader
CQFP 		Ceramic Quad Flat Package
EQFP	 	Plastic Enhanced Quad Flat Package
FQFP 		Fine Pitch Quad Flat Package
LQFP 		Low Profile Quad Flat Package
MQFP 	Metric Quad Flat Package
NQFP 		Near chip-scale Quad Flat Package.
SQFP 		Small Quad Flat Package
TQFP 		Thin Quad Flat Package
VQFP 		Very small Quad Flat Package
VTQFP 	Very Thin Quad Flat Package
5.9.14.17.2. [bookmark: QUAD_Parameters]QUAD Parameters

5.9.14.18. [bookmark: RADIAL]Radial
To create a Radial part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.
Device Overview
Radial Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols

5.9.14.18.1. [bookmark: Device_Overview6]Device Overview
5.9.14.18.2. [bookmark: Radial_Parameters]Radial Parameters

5.9.14.19. [bookmark: SOIC]SOIC
To create a SOIC part click the  button in the The Part Builder
The part builder will automatically create the footprint for the device and also a suitable schematic symbol with the pin names left blank for you to fill in.

8 pin SOIC

8 pin SOIC  showing package

3D View of 8 pin SOIC

Schematic Symbol
Device Overview
SOIC Parameters
Pads 
Package Color
Package Reference 
Package Value
Package Silkscreen 
Package Courtyard
Package Placement Point 
Package Symbols
5.9.14.19.1. [bookmark: Device_Overview]Device Overview
A small-outline integrated circuit (SOIC) is a surface-mounted integrated circuit (IC) package which occupies an area about 30–50% less than an equivalent DIP, with a typical thickness that is 70% less. They are generally available in the same pinouts as their counterpart DIP ICs. The convention for naming the package is SOIC or sometimes just SO followed by the number of pins. For example, a 14-pin 4011 would be housed in an SOIC-14 or SO-14 package.
Small-outline J-leaded package (SOJ) is a version of SOIC with J-type leads instead of gull-wing leads.
JEDEC and EIAJ standards
SOIC actually refers to at least two different package standards. The EIAJ SOIC body is approximately 5.3 mm (0.21 in) wide while the JEDEC SOIC body is approximately 3.8 mm (0.15 in) wide. The EIAJ packages are also thicker and slightly longer. Otherwise the packages are similar.
Note that because of this, SOIC is not specific enough of a term to describe parts which are interchangeable. Many electronic retailers will list parts in either package as SOIC whether they are referring to the JEDEC or EIAJ standards. The wider EIAJ packages are more common with higher pin count ICs, but there is no guarantee that an SOIC package with any number of pins will be either one or the other.
General package characteristics 
This package is shorter and narrower than DIPs, the side-to-side pitch being 6 mm for an SOIC-14 (from lead tip to lead tip) and the body width being 3.9 mm. These dimensions differ depending on the SOIC in question, and there are several variants. This package has "gull wing" leads protruding from the two long sides and a lead spacing of 0.050 in (1.27 mm).
Narrow (JEDEC) SOIC package
The picture below shows the general shape of an SOIC narrow package, with major dimensions. The values of these dimensions (in mm) for common SOICs are shown in the table.

C  	Clearance between IC body and PCB
 H  	Total carrier height
 T  	Lead thickness
 L  	Total carrier length 
 LW 	Lead width
 LL	 Lead length
 P 	 Pitch
 WB 	IC body width
 WL	Lead-to-lead width
 O  	End overhang
	Package
	WB
	WL
	H
	C
	L
	P
	LL
	T
	LW
	O

	SOIC-8-N
	3.8–4.0
	5.8–6.2
	1.35–1.75
	0.10–0.25
	4.8–5.0
	1.27
	0.41 (1.04)
	0.19–0.25
	0.35–0.51
	0.33

	SOIC-14-N
	3.8–4.0
	5.8–6.2
	1.35–1.75
	0.10–0.25
	8.55–8.75
	1.27
	1.05
	0.19–0.25
	0.39–0.46
	0.3–0.7

	SOIC-16-N
	3.8–4.0
	5.8–6.2
	1.35–1.75
	0.10–0.25
	9.8–10.0
	1.27
	1.05
	0.19–0.25
	0.39–0.46
	0.3–0.7

	SOIC-16-W
	7.4–7.6
	10.0–10.65
	2.35–2.65
	0.10–0.30
	10.1–10.5
	1.27
	0.40–1.27
	0.20–0.33
	0.31–0.51
	0.4–0.9


Wide (or extended) SOIC package 
Next to the narrow SOIC package (commonly represented as SOx_N or SOICx_N, where x is the number of pins), there's also the wide (or sometimes called extended) version. This package is commonly represented as SOICX_W or SOICx_W.
The difference is mainly related to the parameters WB and WL.
As an example, the values WB and WL are given for an 8-pins wide (extended) SOIC package
	Package
	WB
	WL

	SOIC-8
	5.41 (5.16)
	8.07 (7.67)


Mini- or micro-SOIC package
Another SOIC variant, available only for 8-pins and 10-pins ICs, is the mini-SOIC, also called micro-SOIC. This case is much smaller with a pitch of only 0.5mm. See the following table for the 10-pin model:
	Package
	WB
	WL
	H
	C
	L
	P
	LL
	T
	LW

	miniSOIC-10
	3.0	
	4.9
	1.09
	0.10–0.25
	3.0
	0.5
	0..095
	0.19
	0.23


SOP
After SOIC came a family of smaller form factors, small outline package (SOP), with a pin spacing of 0.635 mm:
· Plastic small-outline package (PSOP)
· Thin small-outline package (TSOP)
· Thin-shrink small-outline package (TSSOP)
Shrink small-outline package (SSOP) chips have "gull wing" leads protruding from the two long sides, and a lead spacing of 0.025 inches (0.635mm). 0.5mm lead spacing is less common, but not rare.
The body size of a SOP was compressed and the lead pitch tightened to obtain a smaller version SOP. This yields an IC package which is a significant reduction in the size (compared to standard package). All IC assembly processes remain the same as with standard SOPs.
Applications for a SSOP enable end-products (pagers, portable audio/video, disc drives, radio, RF devices/components, telecom) to be reduced in size and weight. Semiconductor families such as operational amplifiers, drivers, optoelectronics, controllers, logic, analog, memory, comparators and more using BiCMOS, CMOS or other silicon / GaAs technologies are well addressed by the SSOP product family.
TSSOP
TSSOPs are particularly suited for gate drivers, controllers, wireless / RF, op-amps, logic, analog, ASICs, memory (EPROM, E2PROM), comparators and optoelectronics. Memory modules, disk drives, recordable optical disks, telephone handsets, speed dialers, video / audio and consumer electronics / appliances are suggested uses for TSSOP packaging.
The ExposedPad variant of small-outline packages can increase heat dissipation by as much as 1.5 times over a standard TSSOP, thereby expanding the margin of operating parameters. Additionally, the ExposedPad can be connected to ground, thereby reducing loop inductance for high frequency applications. The ExposedPad should be soldered directly to the PCB to realize the thermal and electrical benefits.
The ICs on DRAM memory modules were usually TSOPs until they were replaced by ball grid array (BGA).


5.9.14.19.2. [bookmark: SOIC_Parameters]SOIC Parameters

SOIC Parameter Editor
Pitch
X the horizontal pitch between pad columns centers.
Y the vertical pitch between pad row centers.
Outer The horizontal distance between pad outer edges.
Inner The horizontal distance between pad inner edges.
Total Pads The total number of pads.


SOIC Parameters
5.9.14.20. [bookmark: _SOT_223BD64410D] SOT-223
Enter topic text here.
5.9.14.21. [bookmark: SOT_23392BBD5A]SOT 23
5.9.14.21.1. [bookmark: Device_Overview10]Device Overview
A SOT is a small outline transistor.

An SOT
5.9.14.21.2. [bookmark: SOT_23_Parameters475F9909]SOT-23 Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.

5.9.14.22. [bookmark: SOD_32397162A1F]SOD 323
5.9.14.22.1. [bookmark: Device_Overview8]Device Overview
A SOD a small outline diode.

An SOD device
5.9.14.22.2. [bookmark: SOD_323_Parameters]SOD 323 Parameters

5.9.14.23. [bookmark: SOT_89392BBE62]SOT 89
5.9.14.23.1. [bookmark: SOT_89_Parameters7E0109A1]SOT-89 Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.

5.9.14.23.2. [bookmark: Device_Overview12]Device Overview

5.9.14.24. [bookmark: SOT_1439A58C713]SOT 143
5.9.14.24.1. [bookmark: Device_Overview13]Device Overview
A SOT is a small outline transistor.

SOT


5.9.14.24.2. [bookmark: SOT_143_ParametersD5792464]SOT-143 Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.

5.9.14.25. [bookmark: SOT_2239A58CDF6]SOT 223
5.9.14.25.1. [bookmark: Device_Overview14]Device Overview
A SOT is a small outline transistor.

SOT

5.9.14.25.2. [bookmark: SOT_223_Parameters6FDFBA1D]SOT-223 Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.


5.9.14.26. [bookmark: SOT_3539A58D5B0]SOT 353
5.9.14.26.1. [bookmark: Device_Overview11]Device Overview
A SOT is a small outline transistor.

SOT
5.9.14.26.2. [bookmark: SOT_353_Parameters8740172B]SOT-353 Parameters
The parameters editor is shown below. As you can see there are currently no editable parameters.


5.9.14.27. [bookmark: TO_3___TO_660C7CAF3E]TO 3 / TO 66
5.9.14.28. [bookmark: TO_22041BFBCD4]TO 220
5.9.14.29. [bookmark: Edge_Connector_Parts2660DB38]Edge Connector Parts
5.9.14.30. [bookmark: Wizard_PartsF0877842]Wizard
5.9.14.31. [bookmark: Custom_Parts9A191560]Custom Parts
5.9.14.32. [bookmark: Castellated_PCB_PartsDBBF5A61]Castellated PCB Parts
5.9.14.33. [bookmark: TO_92077B888B]TO 92
5.9.14.33.1. [bookmark: TO_92_Parameters166F334C]TO-92 Parameters

5.9.14.33.2. [bookmark: Device_Overview9]Device Overview
The TO-92 is a widely used style of semiconductor package mainly used for transistors. The case is often made of epoxy or plastic, and offers compact size at a very low cost. The JEDEC TO-92 descriptor is derived from the original full name for the package: Transistor Outline Package, Case Style 92.
Today, the industry prefers the new TO-226 nomenclature for the TO-92 three-leaded enclosure.
There are three TO-206 variants: TO-206AA with three straight leads; TO-206AB with the lead 2 formed to create a triangular pattern between the leads and the TO-206AC with the lead 2 omitted. (the latter is in fact a diode package and is mainly used for Varactor tuning diodes and shunt voltage references).
Construction and orientation 
The case is molded around the transistor elements in two parts; the face is flat, bearing a machine-printed part number. The back is semi-circularly-shaped. A line of moulding flash from the injection-moulding process can be seen around the case.
The leads protrude from the bottom of the case. When looking at the face of the transistor, the leads are commonly configured from left-to-right as the emitter, base, and collector for 2N series (JEDEC) transistors, however, other configurations are possible, such as emitter, collector, and base commonly used for 2S series (Japanese) transistors.
If the face has a part name made up of only one letter and a few numbers, it is usually assumed to be a Japanese part number (with the base on the end rather than in the center). Thus, "C1234" would likely be a 2SC1234 device.
The leads coming out of the case are spaced 0.05" (1.27 mm) apart. It is often convenient to bend them outward to a 0.10" (2.54 mm) spacing to make more room for wiring. Units with their leads pre-bent may be ordered to fit specific board layouts, depending on the application. Otherwise, the leads may be bent manually; however, care must be taken as they can break easily.
The physical dimensions of the TO-92 housing may vary sightly depending of the manufacturer, however, the 1.27mm lead spacing must be respected.
Advantages 
· Transistors of this type can be made very inexpensively and take up very little board space. Most models are readily available in large quantities from wholesale distributors.
· They are easy to find in small electronics stores because of their wide usefulness, making them a popular choice for hobby work and prototyping.
Disadvantages
The main disadvantage of this style of case is the lack of heat sinking.
· Transistors and ICs of these types cannot handle as much power as higher-power equivalents, such as the TO-220 and can burn out quickly if they dissipate excessive power.
· There is no standard pinout for the TO-92. The American BJT's use the E-B-C pinout while their Japanese counterparts use the E-C-B pinout and some RF devices use the B-E-C pinout.
More often than not, however, the disadvantages concerning accidental destruction are greatly outweighed by the small size and low cost of producing these units.
Although TO-92 devices are mainly used in low-voltage / low-current (<30 V; <1 A) applications, high-voltage (600 Volt Vce) and high-current (5 A Ic) devices are available. Nominal maximum power dissipation is less than one watt (600 mW).
5.10. [bookmark: Creating_Parts50540A5C]Creating Parts
Parts are the cities of your design. They are where the business is done. They are connected together with copper tracks that carry the goods from one part to another.
You can  create them in one of 3 ways.
· Create a new part.
· Use the part wizard.
· Create the in place in schematics.
5.10.1. [bookmark: Parts3]Parts
Parts consist of 3 distinct representation:
1. The physical device, This is shown in the 3-D view.
1. The footprint or land pattern which defines how the part is Attached to the PCB using pads, silkscreen graphics, placement points (which serve as device coordinates for pick and place machines) and courtyard rectangles (which define the area used by the part). on the PCB. 
1. The schematic symbol(s). A part can have the logical device split up into more than one symbols. This is  common in logic devices that contain more than one logical gate.

The Physical Part (3D)

The PCB Footprint or Land Pattern for the part (2D for PCB layout)

The Schematic Symbol for the part (for schematic diagrams)
You place one or more parts on your schematic(s).
5.10.2. [bookmark: Symbols3]Symbols
The parts are electrically connected together using schematic wires.
Parts are shown on schematics using schematic part symbols.
A part symbol consists of one or more symbol terminals.

Symbol terminal
The symbol terminals serve as the electrical connection points for the part and schematic wires start and end on symbol terminals.
A symbol can optionally have a terminal magnet that is rectangular and serves as the anchor for all the symbol terminals in a part. If you move the symbol terminal is always stays attached to the terminal magnet.

R1 has no terminal magnet while U1 does.

Symbol terminals are always snapped to a 0.05 grid. Since schematics are logical the coordinates are not tied to a measuring system such as inches or cm. However, when it comes to printing the grid is mapped to inches.
A symbol terminal has a name. The name can be set to invisible when it is on a project schematic. It is always visible in the part designer.
Wire connect terminals to each other.

2 parts wired together
All symbols have a symbol reference. This serves to identify the part on the schematic and the PCB and is used in the Bill of Materials (BOM) which lists all the parts used in your design.

Symbol Reference
There is also Footprint reference on the PCB for the part.

5.10.2.1. [bookmark: Terminals]Terminals
Terminals consist of 3 parts.
1. Graphical shapes such as a straight line or circle. 
1. A  name. This usually show the signal name such as Vcc or CLK.
1. A pin name. Normally this is just a number but in AutoTRAX it can be text with spaces. This is the pin name of the device. 

Symbol Terminal


Symbol Terminal showing components


The 9 different terminal types (Graphics) 
All terminals have an electrical connection point for schematic wires.

Electrical connection point

Electrical connection points marked as green crosses

.

Multi-line terminal names


Pin names - numeric and non-numeric


You can set the font, size and color for each terminal


Names and pin names can be moved independently


The name and pin name can be independently hidden



5.10.2.1.1. [bookmark: Terminal_Graphics15B41B50]Terminal-Graphics
There are 9 different types of terminal graphics.

Terminal Graphics
5.10.2.1.2. [bookmark: Terminal_NamesB9376EBB]Terminal Names
Each terminal can have an name. The name has no electrical significance when it comes to PCB layout. It is only for you to make sense of the design in schematics. 
The names can be more than one line.

Multi-line terminal names

The name is normally set to a signal name such as Vcc or D0.
Terminal names can be hidden.

The name and pin name can be independently hidden
You can move a terminal name from its default position.

Names and pin names can be moved independently

You can set the font, text size and color.

You can set the font, size and color for each terminal

5.10.2.1.3. [bookmark: Terminal_Pin_Names564B0573]Terminal Pin Names
The terminal name is the name you give to the physical connection of the device the part represents. It is generally the device pin leads. Conventionally you will use the name in the devices data sheet. Often it is a number but  sometimes it is a character and a number. With AutoTRAX you can name your pins with any combination or number of characters and digits.
AutoTRAX does not use the pin name electrically. It uses an internal unique id for each electrical connection on the device.
A pad in the part's footprint is the embodiment of the connection.
AutoTRAX records the pin name in the pad. If you  rename it in the symbol, the name in the pad is changed.
Terminals with no associated pads do not display a pin name. Instead they display a no connection symbol.


Symbol terminals with no associate pad.

You can mark a terminal as not having an associated pad by checking the No Footprint Pad in the terminals properties panel

You can change the associated pad for a terminal by selecting the pin name in the  terminals properties panel

Pin names - numeric and non-numeric


You can set the font, size and color for each terminal


Names and pin names can be moved independently


The name and pin name can be independently hidden


5.10.2.1.4. [bookmark: Assigning_a_Pad_to_a_Symbol_Term7993552F]Assigning Pads to Symbol Terminals
5.10.2.2. [bookmark: Reference]Reference
All symbols have a symbol reference. This serves to identify the part on the schematic and the PCB and is used in the Bill of Materials (BOM) which lists all the parts used in your design.

5.10.2.3. [bookmark: Border]Border
Symbols optionally have a terminal magnet. Terminal magnets server as anchor edges forces all symbol terminals to stick to the edge. Terminals cannot be dragged of the edge. As you drag a terminal the terminal will try to follow but it will always remain attached to the border.
Terminals always stick to a grid of 0.1 units. This gives you a good separation of terminals. Schematic wires snap to a 0.05 unit grid.
You can delete the border by selecting it and pressing the DEL key.

A terminal magnet with no terminals

A terminal magnet with terminals

Organized by pin name

Organized by name with grouping

Pins on all 4 sides
	
Pins on left
	
Pins on right




5.10.2.4. [bookmark: Value]Value
Symbol have a symbol value. It usually represents the part's name. It can be hidden.

Symbol Value

	
0°
	
90°

	
180°
	
270°


Rotating symbols - Symbol reference and value remain right reading
5.10.3. [bookmark: Footprints_Land_Patterns077BA858]Footprints/Land Patterns
The Footprint or Land Pattern defines what is needed on the PCB for manufacture.
This includes the footprint reference, pads, silkscreen pattern, the courtyard and the placement point.
the Footprint reference. This is drawn on the top or bottom silkscreen layer has no electrical significance.
The placement point used for pick and place devices when you board is made.



5.10.3.1. [bookmark: Courtyard]Courtyard
The courtyard rectangle. This defines the area of the PCB used by the part. Courtyard rectangles must not overlap each other.

Courtyard rectangle (magenta)
A footprints courtyard

5.10.3.2. [bookmark: Placement_Point803BF2D8]Placement Point
The placement point used for pick and place devices when you board is made.
You can move it by dragging it or setting it's position in the placement points properties panel.

The footprint placement point
5.10.3.3. [bookmark: Silkscreen_Pattern96722AC0]Silkscreen Pattern
The screen pattern to show humans where the part is. In this case it is the white rectangle. Like the footprint reference has no electrical significance and could be left out for cost conscious board at manufacture time.

The silkscreen layer showing only the footprint reference and silkscreen pattern
5.10.3.4. [bookmark: Pads3]Pads

The electrical pads and holes for Through Plated Technology (TPT) devices.

Electrical pads (SMT) 
5.10.4. [bookmark: Creating_a_New_Part9F6C1864]Creating a NewPart

5.11. [bookmark: CreatingParts]Creating Parts
You can create parts as a separate part or you can even create a part directly on a schematic.
Creating Parts on Schematics
Using the Part Wizard
The Part Builder
5.11.1. [bookmark: Creating_Parts_In_SchematicsFC90F65D]Creating Parts on Schematics
To create a part on a schematic click the Add→Symbol→ button.
Add a terminal magnet and then add symbol terminals.
Finally use the Part Wizard to set the footprint.
5.11.2. [bookmark: Editing_Parts_In_Schematics38AB864C]Editing Parts on Schematics
You can change part symbols in schematics by dragging the symbol terminal, the symbol reference or the symbol value.
Use sub-pick to select the terminal magnet and you can then drag and re-size it.
You can also use Part Builder
5.11.3. [bookmark: Saving_Your_Part96C9F93E]Saving Your Part
If editing a part you should save it to the parts library so you can drag and drop it onto schematics.

5.12. [bookmark: Using_the_Extended_Part_BuildeD955630E]Using the Extended Part Builder
5.13. [bookmark: Symbols]Symbols
A symbol is a graphical representation of a part that is placed on a schematic sheet.
A part can have one or more symbols.
A symbol can have several sibling symbols that optionally represent a part. (Its footprint or land pattern).
However it is possible for symbols to not be related to a part.
A symbol consists of:
· An optional Terminal Magnet 
· Symbol Terminals
· An optional Symbol Reference
· An optional Symbol Value
· Optional Graphics

Symbol with border

Symbol without border
5.13.1. [bookmark: Symbol_Borders2A351706]Symbol Borders (Terminal Magnets)
A symbol border is like a rectangular bar magnet where symbol terminals stick to the sides. This is a great aid in laying out and moving symbol terminals around a rectangular shape. It also facilitates the reorganization of terminals based either on pin names or symbol names. This reorganization is done by right clicking on the symbol's magnet and selecting the appropriate reorganize command from the pop-up context menu.
Using the magnet metaphor you can regard the terminal magnet (symbol border) as a magnetic monopole, say a north pole, [yes, finally one has been discovered]. Now you can regard symbol terminals as regular magnets with the end that connects to the terminal magnet ( symbol border) being the South Pole and the end that faces away from the terminal magnet being the North Pole. The point on the terminal that is furthest away from the terminal magnet is the electrical connection point. You can regard point and dot terminals as zero length magnets.
It's a bit like when you pick up iron filings with magnetic bar, all the filings stick out as spikes.

A terminal magnet, shown below, serves as anchor points for symbol terminals

Terminal Magnet
5.13.1.1. [bookmark: Editing_Symbol_Borders]Editing Symbol Borders (Terminal Magnets)
To edit a terminal magnet first select it. If the terminal magnet is on a schematic (project) then you will need to use sub-pick to select it.

A selected terminal magnet
Drag either of the border's corner manipulators() to change the corners or ends.
Drag any scale manipulator to re-size the border.
Drag the border to move it.

Terminal Magnet Properties Dialog
You can also edit the parameters of the border using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Terminal Magnet Properties Dialog
X
The X coordinate of the center of the border.
Y
The Y coordinate of the center of the border
Width
The width of the border.
Height
The height of the border
Reset Color
Click the  button to reset the fill color.


5.13.2. [bookmark: Symbol_ReferencesA5EE3FA5]Symbol References
A symbol reference is a text marker to identify a part. A symbol reference is also known as a symbol/part designator.

Symbol Reference (pointed out by red arrow)
5.13.3. [bookmark: Symbol_ValuesA765786F]Symbol Values
A symbol value is a text marker to identify a part type.

Symbol Value (pointed out by red arrow)
5.13.4. [bookmark: Symbol_TerminalsF70CA9AA]Symbol Terminals
A symbol terminal is an electrical connection point for a symbol. You can set the font, height and color for each terminal.

A symbol terminal is made up of 
1. Lines/graphics (You can set the color for the text in a symbol terminal).
1. A pin number. 
1. A pin value (Text description)
1. An electrical connection point that you attach to which you connect electrical wires.
Terminal can be invisible. (as in a ground symbol which is a collection of lines and an invisible terminal, symbol value and symbol reference.
Moving the pin number or pin value
You can move the pin number or pin value (relative to the terminal connection point/terminal line) by holding down the mouse cursor over the pin number and dragging the mouse. The pin number will follow. If the pin number will not move then hold down the control key and drag (sub- picking). This displacement will be maintained when you drag the terminal around the terminal magnet (symbol border).
Pin numbers are actually be text and can contain any character including Unicode characters. Pin values/names again are text and can actually be multi-line text. So a pin value can extend over more than one line.

Ground Symbol

Connection Point

Symbol Terminal

Pin number (Drag to move relative to the connection point)

Pin Value (Drag to move relative to the connection point)

Line graphics

Electrical connection point


5.13.4.1. [bookmark: Adding_Terminals4994208B]Adding Terminals
To add a terminal click on one of buttons in the Add→Symbol button group.


5.13.4.2. [bookmark: Terminal_Graphics2A5409672]Terminal Graphics
5.13.4.3. [bookmark: Terminal_Names21C4F996B]Terminal Names
5.13.4.4. [bookmark: Terminal_Pin_Names_Numbers4C4CE018]Terminal Pin Names/Numbers
5.13.4.5. [bookmark: Terminal_Connection_Points717D901D]Terminal Connection Points
5.13.4.6. [bookmark: Editing_Terminals8AC90546]EditingTerminals
To edit a terminal you can drag it.
If a terminal magnet is present it will drag around the edges of the terminal magnet.
Double-click on it to rename it.

Terminal Rename Dialog
You can also set its parameters using the Symbol Terminal properties dialog.

Symbol Terminal properties dialog
5.13.4.7. [bookmark: Capturing_Pin_Details_from_a_PDFA58CFFDC]Capturing Pin Details from a PDF
Often you will find a data sheet for a part on the internet is a Adobe compatible PDF. AutoTRAX can help you capture the symbol details from the part by monitoring your key clicks on the part's PDF. This enables you to rapidly create your own custom parts. Watch this video to see how it's done.
5.13.4.8. [bookmark: No_Connection_RequiredD43827CE]No Connection Required
You can quickly mark symbol terminals as not requiring a connection and to help the design checker check for errors. This video demonstrates this.

5.13.5. [bookmark: Editing_Symbols_In_Schematics277C5237]Editing Symbols in Schematics
You can reordering terminals in place and add graphics to symbols

5.13.5.1. [bookmark: Re_ordering_TerminalsCA606994]Reordering Terminals
When you place a part's symbol in a schematic you are not left with a fixed immutable symbol. With AutoTRAX you can drag terminals, their textural names and the pin numbers to customize the symbol to how you to your liking. This is a powerful feature that helps you to keep tidy schematics. 
5.13.5.2. [bookmark: Adding_Graphics_To_SymbolsD56E5E67]Adding Graphics to Symbols
To add graphics to a symbol in a schematic:
Select the symbol and the graphics to add.
Click the Edit→Group→ button.
The graphics will then be added to the internal data for the Symbol.
5.13.5.3. [bookmark: Symbol_Editor130867D2]Symbol Editor
The properties editor for selected symbols is shown below.
It consists of 4 tabs: Properties, Terminals,Footprint,and Spice model.
The Properties Tab
The Properties Tab lets you set general properties for the symbol/part.

The Terminals Tab
The Terminals Tab lists all the symbol terminals and their properties.

The Footprint Tab
The Footprint Tab displays the properties of the footprint for the selected part.

The Spice Model Tab
The Spice Model Tab displays the editable Spice simulation model for the part.


5.13.6. [bookmark: Multiple_Symbols0F1B2BC6]Multiple Symbols
Parts have one more symbols with each symbol representing a different aspect of the parts behavior.
5.14. [bookmark: Spice_Models2F5B33E1]Spice Models
You can assign SPICE simulation models to any part by selecting its schematic symbol.
5.14.1. [bookmark: BJT]Bipolar Transistors (BJT)
The Bipolar Transistor model dialog is shown below.

The Bipolar Transistor Model Dialog

5.14.2. [bookmark: Capacitors]Capacitors
The capacitor model dialog is shown below.

The Capacitor Model Dialog

5.14.3. [bookmark: Diodes]Diodes
The diode model dialog is shown below.

The Diode Model Dialog


5.14.4. [bookmark: Voltage_And_Current_SourcesD0E2602F]Voltage and Current Sources
You can add the following types of voltage and current models.
· Voltage Sources
· Current Sources 
· Controlled Sources
5.14.4.1. [bookmark: Voltage_Sources6BADB255]Voltage Sources
You can add the following types of voltage source models.
· Independent DC Voltage Sources
· Independent Sinusoidal Voltage Sources
· Independent Pulse Voltage Sources
· Independent Single Frequency FM Voltage Sources
· Independent Piece-Wise Linear Voltage Sources
· Independent Exponential Voltage Sources

5.14.4.1.1. [bookmark: Independent_DC_Voltage_Source68996CF1]Independent  DC Voltage Sources
The Independent DC Voltage Source model dialog is shown below.

The Model Dialog

5.14.4.1.2. [bookmark: Independent_Sinusoidal_Voltage0149ED5F]Independent Sinusoidal Voltage Sources
The Independent Sinusoidal Voltage Source model dialog is shown below.

The Independent Sinusoidal Voltage Model Dialog

5.14.4.1.3. [bookmark: Independent_Pulse_Voltage_SourceC6F42039]Independent Pulse Voltage Sources
The Independent Pulse Voltage Source model dialog is shown below.

The Independent Pulse Voltage Sources Model Dialog

5.14.4.1.4. [bookmark: Independent_Single_Frequency_2D61B1E67]Independent Single Frequency FM Voltage Sources
The Independent Single Frequency FM Voltage Source model dialog is shown below.

The Independent Single Frequency FM Voltage Model Dialog

5.14.4.1.5. [bookmark: Independent_Piece_Wise_Linear_26420D849]Independent Piece-Wise Linear Voltage Sources
The Independent Piece-Wise Linear Voltage Source model dialog is shown below.

The Independent Piece-Wise Linear Voltage Model Dialog

5.14.4.1.6. [bookmark: Independent_Exponential_VoltageEB263E4F]Independent Exponential Voltage Sources
The Independent Exponential Voltage Source model dialog is shown below.

The Independent Exponential Voltage Model Dialog

5.14.4.2. [bookmark: Current_Soucres8A077A66]Current Sources
You can add the following types of current source models.
· Independent DC Current Sources
· Independent Pulse Current Sources
· Independent Sinusoidal Current Sources
· Independent Single Frequency FM Current Sources
· Independent Piece-Wise Linear Current Sources

5.14.4.2.1. [bookmark: Independent_DC_Current_SourcesB030DAF5]Independent DC Current Sources
The Independent DC Current Source model dialog is shown below.

The Independent DC Current Model Dialog

5.14.4.2.2. [bookmark: Independent_Pulse_Current_Source1B0288BE]Independent Pulse Current Sources
The Independent Pulse Current Source model dialog is shown below.

The Independent Pulse Current Model Dialog

5.14.4.2.3. [bookmark: Independent_Sinusoidal_Current40351516]Independent Sinusoidal Current Sources
The Independent Sinusoidal Current Source model dialog is shown below.

The Independent Sinusoidal Current Model Dialog

5.14.4.2.4. [bookmark: Independent_Single_Frequency_FMF68E1EC6]Independent Single Frequency FM Current Sources
The Independent Single Frequency FM Current Source model dialog is shown below.

The Independent Single Frequency FM Current Model Dialog

5.14.4.2.5. [bookmark: Independent_Piece_WiseLinear86818687]Independent  Piece-Wise Linear Current Sources
The Independent Piece-Wise Linear Current Source model dialog is shown below.

The Independent Piece-Wise Linear Current Model Dialog

5.14.4.3. [bookmark: Controlled_SourcesA56BC5B5]Controlled Sources
You can add the following types of controlled source models.
· Current Controlled Current Sources
· Current Controlled Voltage Sources
· Voltage Controlled Current Sources
· Voltage Controlled Voltage Sources

5.14.4.3.1. [bookmark: Linear_Current_Controlled_Curren1D488A76]Current Controlled Current Sources
The Current Controlled Current Source model dialog is shown below.

The Current Controlled Current Model Dialog

5.14.4.3.2. [bookmark: Linear_Current_Controlled_VoltagDE5D62BF]Current Controlled Voltage Sources
The Current Controlled Voltage Source model dialog is shown below.

The Current Controlled Voltage Model Dialog

5.14.4.3.3. [bookmark: Linear_Voltage_Controlled_CurrenE03452A1]Voltage Controlled Current Sources
The Voltage Controlled Current Source model dialog is shown below.

The Voltage Controlled Current Model Dialog

5.14.4.3.4. [bookmark: Linear_Voltage_Controlled_VoltagA1492AEA]Voltage Controlled Voltage Sources
The Voltage Controlled Voltage Source model dialog is shown below.

The Voltage Controlled Voltage Model Dialog

5.14.5. [bookmark: Inductors]Inductors
The Inductor model dialog is shown below.

The Inductor Model Dialog

5.14.6. [bookmark: Junction_Field_Effect_Transistor35943299]Junction Field Effect Transistors (JFET)
The JFET model dialog is shown below.

The JFET Model Dialog

5.14.7. [bookmark: MESFETs]MESFETs
The MESFET model dialog is shown below.

The MESFET Model Dialog

5.14.8. [bookmark: MOSFETs]MOSFETs
The MOSFET model dialog is shown below.

The MOSFET Model Dialog

5.14.9. [bookmark: Resistors]Resistors
The Resistor model dialog is shown below.

The Resistor Model Dialog

5.14.10. [bookmark: Switches]Switches
The Switch model dialog is shown below.

The Switch Model Dialog

5.14.11. [bookmark: Transformers]Transformers
The Transformer model dialog is shown below.

The Transformer Model Dialog

5.14.12. [bookmark: Transmission_Lines82B4D616]Transmission Lines
You can add the following types of transmission line models.
· Lossless Transmission Lines
· Lossy Transmission Lines (LTRA)
· Lossy Transmission Lines (URC)

5.14.12.1. [bookmark: Lossless_Transmission_Lines012A2BA7]Lossless Transmission Lines
The Lossless Transmission Line model dialog is shown below.

The Lossless Transmission Line Model Dialog

5.14.12.2. [bookmark: Lossy_Transmission_Lines_LTRAC4D6F5F3]Lossy Transmission Lines (LTRA)
The Lossy Transmission Line model dialog is shown below.

The Lossy Transmission Line Model Dialog

5.14.12.3. [bookmark: Lossy_Transmission_Lines_URC6FBDCF42]Lossy Transmission Lines (URC)
The Lossy Transmission Line model dialog is shown below.

The Lossy Transmission Lines Model Dialog

5.15. [bookmark: Custom]Custom
The Custom model dialog is shown below.

The Custom Model Dialog

5.16. [bookmark: Footprints]Footprints
Footprints are the copper and silkscreen patterns (also called Land Patterns) that define the part on a PCB.

Footprint
A footprint consists of:
· Pads
· The Footprint Reference
· A Courtyard
· A Silkscreen Rectangle
· The Footprint Placement Point

5.16.1. [bookmark: TPH_Technology9C2C6EB5]TPH Technology
Through-hole technology (also spelled "thru-hole"), refers to the mounting scheme used for electronic components that involves the use of leads on the components that are inserted into holes drilled in printed circuit boards (PCB) and soldered to pads on the opposite side either by manual assembly (hand placement) or by the use of automated insertion mount machines.
History
Through-hole technology almost completely replaced earlier electronics assembly techniques such as point-to-point construction. From the second generation of computers in the 1950s until surface-mount technology (SMT) became popular in the late 1980s, every component on a typical PCB was a through-hole component. PCBs initially had tracks printed on one side only, later both sides, then multi-layer boards were in use. Through holes became plated-through holes (PTH) in order for the components to make contact with the required conductive layers. Plated-through holes are no longer required with SMT boards for making the component connections, but are still used for making interconnections between the layers and in this role are more usually called vias.
Axial and radial leads
Components with wire leads are generally used on through-hole boards. Axial leads protrude from each end of a typically cylindrical or elongated box-shaped component, on the geometrical axis of symmetry. Axial-leaded components resemble wire jumpers in shape, and can be used to span short distances on a board, or even otherwise unsupported through an open space in point-to-point wiring. Axial components do not protrude much above the surface of a board, producing a low-profile or flat configuration when placed "lying down" or parallel to the board.
Radial leads project more or less in parallel from the same surface or aspect of a component package, rather than from opposite ends of the package. Originally, radial leads were defined as more-or-less following a radius of a cylindrical component (such as a ceramic disk capacitor). Over time, this definition was generalized in contrast to axial leads, and took on its current form. When placed on a board, radial components "stand up" perpendicular, occupying a smaller footprint on sometimes-scarce "board real estate", making them useful in many high-density designs. The parallel leads projecting from a single mounting surface gives radial components an overall "plugin nature", facilitating their use in high-speed automated component insertion ("board-stuffing") machines.
When needed, an axial component can be effectively converted into a radial component, by bending one of its leads into a "U" shape so that it ends up close to and parallel with the other lead. Extra insulation with heat-shrink tubing may be used to prevent shorting out on nearby components. Conversely, a radial component can be pressed into service as an axial component by separating its leads as far as possible, and extending them into an overall length-spanning shape. These improvisations are often seen in breadboard or prototype construction, but are deprecated for mass production designs. This is because of difficulties in use with automated component placement machinery, and poorer reliability because of reduced vibration and mechanical shock resistance in the completed assembly.
Multiple lead devices
For electronic components with two or more leads, for example diodes, transistors, ICs or resistor packs, a range of standard-sized semiconductor packages are used, either directly onto the PCB or via a socket.
Characteristics
While through-hole mounting provides strong mechanical bonds when compared to SMT techniques, the additional drilling required makes the boards more expensive to produce. They also limit the available routing area for signal traces on layers immediately below the top layer on multilayer boards since the holes must pass through all layers to the opposite side. To that end, through-hole mounting techniques are now usually reserved for bulkier or heavier components such as electrolytic capacitors or semiconductors in larger packages such as the TO-220 that require the additional mounting strength, or for components such as plug connectors or electromechanical relays that require great strength in support.
Design engineers often prefer the larger through-hole rather than surface mount parts when prototyping, because they can be easily used with breadboard sockets. However, high-speed or high-frequency designs may require SMT technology to minimize stray inductance and capacitance in wire leads, which would impair circuit function. Ultra-compact designs may also dictate SMT construction, even in the prototype phase of design.
5.16.2. [bookmark: SMT_Technology92EAAE0B]SMT Technology
Surface-mount technology (SMT) is a method for producing electronic circuits in which the components are mounted or placed directly onto the surface of printed circuit boards (PCBs). An electronic device so made is called a surface-mount device (SMD). In industry, it has largely replaced the through-hole technology construction method of fitting components with wire leads into holes in the circuit board. Both technologies can be used on the same board, with the through-hole technology used for components not suitable for surface mounting such as large transformers and heat-sinked power semiconductors.
By employing SMT, the production process speeds up, but the risk of defects also increases due to component miniaturization and to the denser packing of boards. In those conditions, detection of failures has become critical for any SMT manufacturing process.
An SMT component is usually smaller than its through-hole counterpart because it has either smaller leads or no leads at all. It may have short pins or leads of various styles, flat contacts, a matrix of solder balls (BGAs), or terminations on the body of the component.
Surface mounting was originally called "planar mounting".
Surface-mount technology was developed in the 1960s and became widely used in the mid 1980s. By the late 1990s, the great majority of high-tech electronic printed circuit assemblies were dominated by surface mount devices. Much of the pioneering work in this technology was done by IBM. The design approach first demonstrated by IBM in 1960 in a small-scale computer was later applied in the Launch Vehicle Digital Computer used in the Instrument Unit that guided all Saturn IB and Saturn V vehicles. Components were mechanically redesigned to have small metal tabs or end caps that could be directly soldered to the surface of the PCB. Components became much smaller and component placement on both sides of a board became far more common with surface mounting than through-hole mounting, allowing much higher circuit densities and smaller circuit boards and, in turn, machines or subassemblies containing the boards.
History
Often only the solder joints hold the parts to the board; in rare cases parts on the bottom or "second" side of the board may be secured with a dot of adhesive to keep components from dropping off inside reflow ovens if the part has a large size or weight. Adhesive is sometimes used to hold SMT components on the bottom side of a board if a wave soldering process is used to solder both SMT and through-hole components simultaneously. Alternatively, SMT and through-hole components can be soldered on the same side of a board without adhesive if the SMT parts are first reflow-soldered, then a selective solder mask is used to prevent the solder holding those parts in place from reflowing and the parts floating away during wave soldering. Surface mounting lends itself well to a high degree of automation, reducing labor cost and greatly increasing production rates.
Conversely, SMT does not lend itself well to manual or low-automation fabrication, which is more economical and faster for one-off prototyping and small-scale production, and this is one reason why many through-hole components are still manufactured. Some SMDs can be soldered with a temperature-controlled manual soldering iron, but unfortunately, those that are very small or have too fine a lead pitch are impossible to manually solder without expensive hot-air solder reflow equipment. SMDs can be one-quarter to one-tenth the size and weight, and one-half to one-quarter the cost of equivalent through-hole parts, but on the other hand, the costs of a certain SMT part and of an equivalent through-hole part may be quite similar, though rarely is the SMT part more expensive.
Assembly techniques
Where components are to be placed, the printed circuit board normally has flat, usually tin-lead, silver, or gold plated copper pads without holes, called solder pads. Solder paste, a sticky mixture of flux and tiny solder particles, is first applied to all the solder pads with a stainless steel or nickel stencil using a screen printing process. It can also be applied by a jet-printing mechanism, similar to an inkjet printer. After pasting, the boards then proceed to the pick-and-place machines, where they are placed on a conveyor belt. The components to be placed on the boards are usually delivered to the production line in either paper/plastic tapes wound on reels or plastic tubes. Some large integrated circuits are delivered in static-free trays. Numerical control pick-and-place machines remove the parts from the tapes, tubes or trays and place them on the PCB.
The boards are then conveyed into the reflow soldering oven. They first enter a pre-heat zone, where the temperature of the board and all the components is gradually, uniformly raised. The boards then enter a zone where the temperature is high enough to melt the solder particles in the solder paste, bonding the component leads to the pads on the circuit board. The surface tension of the molten solder helps keep the components in place, and if the solder pad geometries are correctly designed, surface tension automatically aligns the components on their pads.
There are a number of techniques for reflowing solder. One is to use infrared lamps; this is called infrared reflow. Another is to use a hot gas convection. Another technology which is becoming popular again is special fluorocarbon liquids with high boiling points which use a method called vapor phase reflow. Due to environmental concerns, this method was falling out of favor until lead-free legislation was introduced which requires tighter controls on soldering. At the end of 2008, convection soldering was the most popular reflow technology using either standard air or nitrogen gas. Each method has its advantages and disadvantages. With infrared reflow, the board designer must lay the board out so that short components don't fall into the shadows of tall components. Component location is less restricted if the designer knows that vapor phase reflow or convection soldering will be used in production. Following reflow soldering, certain irregular or heat-sensitive components may be installed and soldered by hand, or in large-scale automation, by focused infrared beam (FIB) or localized convection equipment.
If the circuit board is double-sided then this printing, placement, reflow process may be repeated using either solder paste or glue to hold the components in place. If a wave soldering process is used, then the parts must be glued to the board prior to processing to prevent them from floating off when the solder paste holding them in place is melted.
After soldering, the boards may be washed to remove flux residues and any stray solder balls that could short out closely spaced component leads. Rosin flux is removed with fluorocarbon solvents, high flash point hydrocarbon solvents, or low flash solvents e.g. limonene (derived from orange peels) which require extra rinsing or drying cycles. Water-soluble fluxes are removed with deionized water and detergent, followed by an air blast to quickly remove residual water. However, most electronic assemblies are made using a "No-Clean" process where the flux residues are designed to be left on the circuit board, since they are considered harmless. This saves the cost of cleaning, speeds up the manufacturing process, and reduces waste. However, it is generally suggested to wash the assembly, even when a "No-Clean" process is used, when the application uses very high frequency clock signals (in excess of 1 GHz). Another reason to remove no-clean residues is to improve adhesion of conformal coatings and underfill materials. Regardless of cleaning or not those PCBs, current industry trend suggests to carefully review a PCB assembly process where "No-Clean" is applied, since flux residues trapped under components and RF shields may affect surface insulation resistance (SIR), especially on high component density boards.
Certain manufacturing standards, such as those written by the IPC - Association Connecting Electronics Industries require cleaning regardless of the solder flux type used to ensure a thoroughly clean board. Proper cleaning removes all traces of solder flux, as well as dirt and other contaminants that may be invisible to the naked eye. No-Clean or other soldering processes may leave "white residues" that, according to IPC, are acceptable "provided that these residues have been qualified and documented as benign". However, while shops conforming to IPC standard are expected to adhere to the Association's rules on board condition, not all manufacturing facilities apply IPC standard, nor are they required to do so. Additionally, in some applications, such as low-end electronics, such stringent manufacturing methods are excessive both in expense and time required.
Finally, the boards are visually inspected for missing or misaligned components and solder bridging. If needed, they are sent to a rework station where a human operator repairs any errors. They are then usually sent to the testing stations (in-circuit testing and/or functional testing) to verify that they operate correctly. Automated Optical Inspection (AOI) systems are commonly used in PCB manufacturing. This technology has proven highly efficient for process improvements and quality achievements.
Common abbreviations
Different terms describe the components, technique, and machines used in manufacturing. These terms are listed in the following table:
SMD	Surface-mount devices (active, passive and electromechanical components)
SMT	Surface-mount technology (assembling and mounting technology)
SMA	Surface-mount assembly (module assembled with SMT)
SMC	Surface-mount components (components for SMT)
SMP	Surface-mount packages (SMD case forms)
SME	Surface-mount equipment (SMT assembling machines)
Advantages
The main advantages of SMT over the older through-hole technique are:
· Smaller components.
· Much higher component density (components per unit area) and many more connections per component.
· Components can be placed on both sides of the circuit board.
· Higher density of connections because holes do not block routing space on inner layers, nor on back-side layers if components are mounted on only one side of the PCB.
· Small errors in component placement are corrected automatically as the surface tension of molten solder pulls components into alignment with solder pads. (On the other hand, through-hole components cannot be slightly misaligned, because once the leads are through the holes, the components are fully aligned and cannot move laterally out of alignment.)
· Better mechanical performance under shock and vibration conditions (partly due to lower mass, and partly due to less cantilevering)
· Lower resistance and inductance at the connection; consequently, fewer unwanted RF signal effects and better and more predictable high-frequency performance.
· Better EMC performance (lower radiated emissions) due to the smaller radiation loop area (because of the smaller package) and the lesser lead inductance.
· Fewer holes need to be drilled. (Drilling PCBs is time-consuming and expensive.)
· Lower initial cost and time of setting up for mass production, using automated equipment.
· Simpler and faster automated assembly. Some placement machines are capable of placing more than 136,000 components per hour.
· Many SMT parts cost less than equivalent through-hole parts.
· A surface mount package is favored where a low profile package is required or the space available to mount the package is limited. As electronic devices become more complex and available space is reduced, the desirability of a surface mount package increases. Concurrently, as the device complexity increases, the heat generated by operation increases. If the heat is not removed, the temperature of the device rises shortening the operational life. It is therefore highly desirable to develop surface mount packages having high thermal conductivity.
Disadvantages
· SMT is unsuitable for large, high-power, or high-voltage parts, for example in power circuitry. It is common to combine SMT and through-hole construction, with transformers, heat-sinked power semiconductors, physically large capacitors, fuses, connectors, and so on mounted on one side of the PCB through holes.
· SMT is unsuitable as the sole attachment method for components that are subject to frequent mechanical stress, such as connectors that are used to interface with external devices that are frequently attached and detached.
· SMDs' solder connections may be damaged by potting compounds going through thermal cycling.
· Manual prototype assembly or component-level repair is more difficult and requires skilled operators and more expensive tools, due to the small sizes and lead spacings of many SMDs. Handling of small SMT components can be difficult, requiring tweezers, unlike nearly all through-hole components. Whereas through-hole components will stay in place (under gravitational force) once inserted and can be mechanically secured prior to soldering by bending out two leads on the solder side of the board, SMDs are easily moved out of place by a touch of a soldering iron. Without expert skill, when manually soldering or desoldering a component, it is easy to accidentally reflow the solder of an adjacent SMT component and unintentionally displace it, something that is almost impossible to do with through-hole components.
· Many types of SMT component packages cannot be installed in sockets, which provide for easy installation or exchange of components to modify a circuit and easy replacement of failed components. (Virtually all through-hole components can be socketed.)
· SMDs cannot be used directly with plug-in breadboards (a quick snap-and-play prototyping tool), requiring either a custom PCB for every prototype or the mounting of the SMD upon a pin-leaded carrier. For prototyping around a specific SMD component, a less-expensive breakout board may be used. Additionally, stripboard style protoboards can be used, some of which include pads for standard sized SMD components. For prototyping, "dead bug" breadboarding can be used.
· Solder joint dimensions in SMT quickly become much smaller as advances are made toward ultra-fine pitch technology. The reliability of solder joints becomes more of a concern, as less and less solder is allowed for each joint. Voiding is a fault commonly associated with solder joints, especially when reflowing a solder paste in the SMT application. The presence of voids can deteriorate the joint strength and eventually lead to joint failure.
· SMDs, usually being smaller than equivalent through-hole components, have less surface area for marking, requiring marked part ID codes or component values to be more cryptic and smaller, often requiring magnification to be read, whereas a larger through-hole component could be read and identified by the unaided eye. This is a disadvantage for prototyping, repair, or rework, and possibly for production set-up.
Packages
Surface-mount components are usually smaller than their counterparts with leads, and are designed to be handled by machines rather than by humans. The electronics industry has standardized package shapes and sizes (the leading standardisation body is JEDEC).
Small outline diode (SOD)
SOD-923	0.8 × 0.6 × 0.4 mm 
SOD-723	1.4 × 0.6 × 0.59 mm 
SOD-523 (SC-79)	1.25 × 0.85 × 0.65 mm 
SOD-323 (SC-90)	1.7 × 1.25 × 0.95 mm 
SOD-128	5 × 2.7 × 1.1 mm 
SOD-123	3.68 × 1.17 × 1.60 mm 
SOD-80C	3.50 × ⌀ 1.50 mm 

5.16.3. [bookmark: Pads]Pads
Electrical parts are 'glued' on the PCB using solder between the part's electrical terminals and copper pads on the PCB. The solder is usually the only way the part is mechanically affixed to the PCB.

	
TPH Pads Soldered (glued) to PCB
	
SMT Pads Soldered (glued) to PCB


Pad are copper areas on the top/bottom or both sides of the PCB.
	
TPH Pad (PCB invisible)
	
SMT Pad (PCB invisible)



If pads are on both sides then there is a hole drilled trough both the top and the bottom side of PCB and is usually plated with copper to provide an electrical connection between both sides.
5.16.3.1. [bookmark: Pad_ShapesA1053B08]Pad Shapes
Pads can be circular, elliptical, rectangular (with optional rounded corners) polygonal or a complex curve.
	

Circular

	
Elliptical

	

Square

	
Rectangular

	
Rectangular with rounded corners

	
Polygonal

	
Curved


In addition Pads in rectangular parametric footprints can have rounded corners set to sides.
	
	
	





5.16.3.2. [bookmark: Creating_Pads553786D0]Creating Pads
For parametric parts, pads are automatically created. However, once you have fully created a parametric part you can add additional pads.
You can add a pad by clicking a pad in the  group in the Add menu.
Click  to toggle between   and 
TPH Pads
Click  to add a rectangular TPH pad.
Click  to add a circular/elliptical TPH pad.
Click  to add a polygonal/curved TPH Pad.
SMT Pads
Click  to add a rectangular SMT pad.
Click  to add a circular/elliptical SMT pad.
Click  to add a polygonal/curved SMT Pad.

If   is visible  it sets the size of pads added. So when pads are added they have a fixed size. If it is not visible then you define the pad sized by dragging the mouse to define the pad size.
 is used for setting pad number.
5.16.3.3. [bookmark: Setting_Pad_Numbers6D2BD51F]Setting Pad Numbers
Click    in the Add menu to set pad numbers. You would normally do this after you have added all your pads.
5.16.3.4. [bookmark: Editing_Pads2780200E9]Editing Pads
5.16.3.5. [bookmark: Automatic_3D_Pins08FE4F9C]Automatic 3D Pins









5.16.4. [bookmark: Placement_Points8A11CA6B]Placement Points
5.16.5. [bookmark: Silkscreens]Silkscreens
Silkscreens or artworks that are printed on the top and/or bottom of the PCB. The unknown electrical significance and are only for human consumption, mainly for use during manual assembly and for field service engineers. For cost sensitive PCBs the silkscreen will usually be omitted to say money. 
Also a side-effect of silk screens when they are used to define part reference IDs is that the consume PCB area and can cause problems when you're trying to design a compact PCB.


5.16.6. [bookmark: Footprint_ValuesFCEFC594]Footprint Values
Footprint values contain no electrical information and are usually not added to the final PCB.
They are often used by the part builder when it is automatically creating a 3-D part for the device. It will be used to assure the device type on the 3-D is a model. 

5.16.7. [bookmark: Footprint_Reference_IDs0E24738C]Footprint Reference IDs

5.16.8. [bookmark: The_Footprint_Viewport6B523310]The Footprint Viewport
The footprint viewport show you a stylised view of the footprint or land pattern for your device. The footprint viewport is very similar to a PCB viewport but has characteristics that are relevant to PCB footprint design rally PCB viewport as characteristics relevant to laying out your parts and routing them together using electrical tracks.
The key electrical components of your footprint are clearly shown and differ quite significantly from an actual 3-D view.
Pads
Pads are shown as solid rectangles colored the same as a  Top or bottom layer, or optionally coloured yellow. (You would have them colored yellow so you can clearly see what is a part in what is a normal copper area).
Pads are used as areas to glue the parts to the PCB. The glue being the electrical solder. 
 The placement point
Also other items are shown stylized, for instance the placement point which is used for pick and place. This is shown as a simple white on black cross. You move this cross to define the placement point to be used in pick and place.
Silkscreens and the part reference ID
You also see the silkscreen pattern. This consists of text that is the parts reference ID and other graphical objects usually used to define the placement of the part on the PCB. 
 Silkscreen patterns are for human consumption only and are not used electrically by the PCB. In fact, for cost conscious device,s you will not actually use a silkscreen and this will save you a lot of money. However, the silkscreen allows service personnel to locate parts on the device if they intend to repair the PCB.
The silkscreen is a real object that is actually placed on your final PCB like a placementpoint which you will never see on the PCB.
The courtyard rectangle
Another thing that you will see is the courtyard rectangle. This is a rectangular area that defines the area used by the part on your PCB and helps prevent overlapping of adjacent parts.
This view was in sharp contrast to the feed if you which shows a more photorealistic view of your PCB but did not show the abstract data. So you will see the footprint pads but you will not see the placement point for the courtyard rectangle.
Holes and cutouts
If you add any holes or cutouts to the footprint these are shown as black circles or the case of cutouts either circles ellipses, polygons, rectangles or curved black cutouts. The shape will have a colored line around it
5.16.9. [bookmark: 3D_FootprintsDB1ADB30]3D Footprints
5.16.10. [bookmark: The_Footprint_Reference3F844CDD]The Footprint Reference
The footprint reference is a text marker on the silkscreen layer that identifies a specific part. They have no electrical significance and can be omitted to save costs.  Pick and Place machines do not need them.

The Footprint Reference
5.16.10.1. [bookmark: Editing_Footprint_References003EA987]Editing Footprint References
Select the footprint reference and change it's value in the properties panel or double click it to edit it's value.
5.16.11. [bookmark: Footprint_Values]Footprint Values
A footprint value is text that defined the part type. It is displayed in the 3D view.
5.16.11.1. [bookmark: Editing_Footprint_Values341AF4F1]Editing Footprint Values
Select the footprint value and change it's value in the properties panel or double click it to edit it's value.
5.16.12. [bookmark: Courtyards]Courtyards
Courtyards are rectangles that define the area used by a part. They have no electrical significance and can be omitted to save costs. They are used during the auto-layout.  Pick and Place machines do not need them.

Courtyard (magenta rectangle)


5.16.12.1. [bookmark: Editing_Courtyards49CC0A1F]Editing Courtyards
You edit courtyards like editing keep pout regions.
5.16.13. [bookmark: Silkscreen_Rectangles03A79CB8]Silkscreen Rectangles
Silkscreen rectangles are shapes drawn on the non-electrical silkscreen layer (usually white ink) that details for humans the shape of body of the part. They have no electrical significance and can be omitted to save costs.  Pick and Place machines do not need them.

Silkscreen Rectangle (White)

5.16.14. [bookmark: The_Footprint_Placement_PointEE9B4722]The Footprint Placement Point
The footprint placement point defines the parts placement position for Pick and Place  Pick and Place machines.

The Footprint Placement Point

5.16.14.1. [bookmark: Editing_Footprint_Placement_Poin7B708726]Editing Footprint Placement Points
Select the footprint placement and change it's value in the properties panel or  drag it in the viewport.
5.16.15. [bookmark: Adding_3D_objects_2091EC589]Adding 3D objects
You can add 3D objects to a part. 
Use the  button group in the Add menu.
1. Select either the top or bottom package layer as the current layer.
1. Add your graphics.
1. Set the height and base of the graphic using the properties panel.

5.16.16. [bookmark: Adding_GraphicsC032739B]Adding Graphics to Footprint
You can add graphics to any layer for a footprint. 
If the graphics are on the top, bottom or inner layers (copper layers), then they will be in copper and do have electrical significance.

5.16.17. [bookmark: Customizing_a_Parametric_Footp]Customizing a Parametric Footprint
In AutoTRAX, a parametric footprint is a part that is defined by a small number of numeric and textural parameters. From this small set of parameters, AutoTRAX can generate whole families of parts with the schematic symbols, footprints (often called land patterns) and even the 3D part.
5.17. [bookmark: 3D_Packages063CCEF5]3D Packages
The Part Builder will automatically generate the 3D model for parametric parts.

5.18. [bookmark: The_Parts_LibraryF90286F2]The Parts Library
To set the location of the Parts Library, right-click in the parts library panel and select Set Library Directory.

Then enter the location.


5.19. [bookmark: Searching_for_Part_Prices_and_1D0F1E4A]Searching for Part Prices and Datasheets
AutoTRAX now comes with a powerful datasheet search utility. This will search the Internet for electronic parts, their datasheets and  the latest prices from several electronic part distributors.
 (
Video - Searching for part prices and datasheets
)[image: ]
To to start, click on the find datasheet   in the tools ribbon menu.
You will then see the datasheet search dialog.
Enter the search pattern and click on the  to find the part information. You need to be connected to the Internet.

For instance, to search for an  ATMEGA16U2-MU device enter ATMEGA16U2-MU and click search.
Here is the result obtained. Yours may differ depending on supply.

Selecting the first entry for Dig-Key and expanding the Prices you will see a list of today's prices as shown below.


You can click on  to save the datasheet or click on  to print it.
Click on  to view the suppliers website. 






5.20. [bookmark: Gold_Plating9C6C3E2E]Gold Plating
You can optionally add gold plating to all pads in a part or to individual pads.
Gold plating is normally applied to edge connectors.
When you generate Gerber manufacturing files, top and bottom gold Gerber files will also be generated. No  Gerber files will be generated if there are no pads with gold plating.
 (
Sizing Schematic Sheet Content to Fill the Page
)[image: ]

5.21. [bookmark: Suppliers]Suppliers
The Suppliers dialog displays 3 expandable lists of suppliers: Semiconductors, Distributors, and Passive.
Click on the  button in the Home->Datasheets menu to display the dialog.
Semiconductors
This is a list of manufacturers of semiconductors and devices you would use to make a PCB.
Expand the items by clicking on the  button.
Double-click on a row to view their website in your web browser.

Distributors
This is a list of distributors of parts for your PCB.
Double-click on a row to view their website in your web browser.

Passive
This is a list of manufacturers of passive parts for your PCB.
Double-click on a row to view their website in your web browser.



6. [bookmark: Graphics]Graphics
You can add graphical elements to AutoTRAX.
In schematics graphical elements have no electrical significance, they are not wire connections and have no impact on the PCB.
On PCBs, if you add graphical items to electrical layers, e.g. the top or bottom copper layer, then copper will be placed there.
You can add the following graphics:
· Lines
· Arcs
· Polylines
· Polygons
· Rectangles
· Curves
· Ellipses and Circles
· Text
· Notes 
· Pictures

6.1. [bookmark: Lines]Lines
In AutoTRAX you can add graphical lines. In schematics they have no electrical significance. However in PCBs, they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Lines have a width that can be zero for an infinitely thin line. However, if you add lines to a PCB, you need to make sure their width is at least the size of the manufacturing minimum width.
Lines also have color and can be semi-transparent. It is even possible to define an invisible line. If you have snap to objects enabled, objects will snap to invisible lines.
Lines are defined by 2 points, the start point of the line and the end point of the line.

Lines can have different widths.

Lines can also have a line style as shown below.

Different line thicknesses and styles
In addition, you can also set the line cap style for lines to any of the cap styles shown below. Each end of the line can have a different style.

Line end caps
If you have snap to objects enabled, then as you add other objects they can  snap to either end of a line or the center of the line.
6.1.1. [bookmark: Adding_Lines3BD1C793]Adding Lines
In AutoTRAX you can add graphical lines to both schematics and PCBs.
To set the  Line Styles before adding lines, use the Default Graphics Settings
1. To add a line, click on the line button in the Add→Shapes menu.
1. Now move the mouse to where you want to start the line then:
1. Left-click when the start cross is where you want to start of the line to be or 
1. press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Start point cursor and input boxes
1. Now as you move the mouse you will see the line being drawn and the end point will follow the cursor. If snap is enabled, both the start and the end points will snap to the grid. At any time you can turn snap on and off by pressing the ‘s’ key. As you move the mouse, the length and angle of the line displayed.  Left click to define the line's end point or press the Enter key followed by the length, Enter, the angle, and Enter to exactly define the end point of line. Note that as you move the end of the line, if smart pan is enabled, the viewport will automatically pan so the end point is always visible. If possible, the original view will be restored.

End point cursor and input boxes
To turn smart-pan on or off, click on the smart-pan button on the status bar.
If you have Auto-repeat commands enabled, then you will be prompted to enter the start point for another line. To cancel adding more lines press either the ESC key or right-click  and select cancel from the context menu.
Alternately, you can create a line by left-clicking and holding at the location for the start of the line, moving to the end location for the line and releasing the left button. The line is then added to your design.

6.1.2. [bookmark: Line_Context_MenuAACE1F3A]Context Menu
If you right-click on a line that you have selected, a context sensitive menu will be displayed.

right-click context menu

6.1.3. [bookmark: Editing_Lines773B50BE]Editing Lines
To edit a line first select it.
When a line is selected you will see 2 manipulator points, one at the start of the end and another at the end of the line.

A selected line showing the manipulator points at both ends
Click and hold either point and drag it to set the start or end of the line. If snap is enabled then the end points of the line will snap to the grid as the ends are moved.
To move a line keeping its angle to the horizontal constant, left-click anywhere on the line other than on either of the end manipulators and drag the line to its new position. If snap is enabled then the line will move in steps as defined by the grid; in this case the end points may not snap to the grid. To snap the end points to the grid, drag the end points individually.
As you drag the end points they may snap to other objects if snap to objects is enabled.
If you have any point, horizontal or vertical guides on your schematic or PCB and snap to guides is enabled, then the end points will snap to them if they are close enough.
You can set the color of the line by either left or right-clicking on a color button in the color bar at the base of the application viewports.
You can also set the lines parameters using its properties panel.
Line Properties Dialog
You can also edit the parameters of the line using its properties panel as shown below. To view the properties panel first select it. Then right-click on it, then select Properties Panel from the context menu that opens.

Click the  button to show this help topic.
Start
This is the start point of the line.
End
This is the end point of the line.
Layer
Use this to set the layer on which the line lies. This only applies to PCBs.
Locked
Check this box to prevent its properties from being altered or the line being moved. 
Line Style
Here you can set the style of the line.
This includes the:
· dash/solid style
· The width
· The start and end caps
· The lines color.








6.2. [bookmark: Arcs]Arcs
In AutoTRAX you can add graphical arcs. In schematics they have no electrical significance. However, in PCBs they have significance  if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Arcs have a width that can be zero for an infinitely thin arc. However, if you add arcs to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.
Arcs also have color and can be semi-transparent. It is even possible to define an invisible arc. If you have snap to objects enabled, objects will snap to invisible arcs.
Arcs can also have a line style as shown below.
6.2.1. [bookmark: Adding_Arcs84511535]Adding Arcs
To add an arc to a graphical sheet, click on the  button in the Add→Shapes ribbon menu button group.
To set the  Line Styles before adding arcs, use the Default Graphics Settings
Move the mouse inside a graphical sheet's viewport. You will see the arc center cross follow the mouse.

Mouse Center Point
Left-click when the center cross is where you want to start the arc or press the Enter key followed by the X value, Enter/Space/Tab, and then the Y value and Enter/Space/Tab.
You will next be prompted for the start angle of the arc. Moving the mouse defines the arc's diameter and displays the start angle. Left-click to define the start angle of the arc or press the Enter/Space/Tab key followed by the start angle numerical value in degrees.

Arc diameter and start angle
Now move the mouse to define the arc's end point . Finally left-click to define the arc or press the Enter/Space/Tab key followed by the end angle numerical value in degrees.


6.2.2. [bookmark: Editing_ArcsDF003036]Editing Arcs
To edit an arc first select it.

Drag either of the arc's end manipulators(  ) to change the start/end angle of the arc.
Drag the arc's diameter manipulators(  ) to change the diameter of the arc
Drag any rotate manipulator to rotate the arc.
Drag any scale manipulator to re-size the arc.
Drag the arc to move it.
Arc Properties Dialog
You can also edit the parameters of the arc using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Click the  button to show this help topic.
Center
Enter the X and Y coordinates for the center of the arc.
Radius
Enter the X and Y radius for the arc.
Start and End Angle
Enter the start and end angle for the arc in degrees.
Click to swap the start and end angles.
Use the Layers drop down to change the layer of the arc.


6.3. [bookmark: Polylines]Polylines
In AutoTRAX you can add graphical polylines. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Polylines have a width that can be zero for an infinitely thin arc. However if you add polylines to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.
Polylines also have color and can be semi-transparent. It is even possible to define an invisible polyline. If you have snap to objects enabled, objects will snap to invisible polylines.
Polylines can also have a line style as shown below.
6.3.1. [bookmark: Adding_Polylines43092D9F]Adding Polylines
To add a polyline to a graphical sheet click on the  button in the Add→Shapes ribbon menu button group.
To set the  Fill Styles and Line Styles before adding polylines use the Default Graphics Settings

Polyline start point
Left-click when the start cross is where you want to start the polyline or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.
Now as you move the mouse, the first segment of the polyline is defined. Left click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polyline.

Defining the first segment
Now as you move the mouse, the second segment of the polyline is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the second segment of the polyline.

Defining the second segment
Moving the mouse again, the third segment of the polyline is defined. Left-click to define its end point or press theEnter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the third segment of the polyline.

Defining the third segment
Continue this process to add as many line segments as you wish. 
Press the ESC key to remove the last vertex added.
Double-click to complete adding the polyline.

To close the polyline move the mouse over or very near the start of the polyline and left-click.

6.3.2. [bookmark: Editing_Polylines843E125A]Editing Polylines
To edit a polyline first select it.

A selected polyline
Drag either of the polyline corner manipulators(  ) to change the corners or ends.
Drag any rotate manipulator to rotate the polyline.
Drag any scale manipulator to re-size polyline.
Drag the polyline to move it.
Polyline Properties Dialog
You can also edit the parameters of the polyline using it's properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Polyline/Polygon Properties Dialog
Click the  button to show this help topic.
Vertex
This is the selected vertex/segment. The selected vertex is drawn as a solid red square. The selected segment id drawn in red.
X
The X coordinate of the selected vertex.
Y
The Y coordinate of the selected vertex.
Click  to add a vertex.
Click  to delete the selected vertex.
Check/uncheck  close/open the polyline.
Click  to fillet the polyline

A filleted polyline
6.4. [bookmark: Polygons]Polygons
In AutoTRAX you can add graphical polygons. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Polygons have a width that can be zero for an infinitely thin polygon. However if you add polygons to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.
Polygons also have color and can be semi-transparent. It is even possible to define an invisible polygon. If you have snap to objects enabled, objects will snap to invisible polygons.
Polygons can also have a line style as shown below.
6.4.1. [bookmark: Adding_Polygons4EEE68F9]Adding Polygons
To add a polygon to a graphical sheet click on one of the   buttons in the Add→Shapes ribbon menu button group.
To set the  Fill Styles and Line Styles before adding rectangles use the Default Graphics Settings
 Draws a hollow polygon.
 Draws a filled polygon with fill different from the outline.
 Draws a filled polygon with no outline.

Polygon start point
Left-click when the start cross is where you want to start the polygon or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.
As you move the mouse, the first segment of the polygon is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polygon.

Defining the first segment
Now as you move the mouse the second segment of the polygon is defined. Left-click to define its end point or press the Enter key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the second segment of the polygon.

Defining the second segment
Moving the mouse again, the third segment of the polygon is defined. Left-click to define its end point or press the Enter/Space/Tab key followed by the length, Enter/Space/Tab, the angle, and Enter/Space/Tab to exactly define the first segment of the polygon.

Defining the third segment
Continue this process to add as many line segments as you wish. 
Double-click to end the polygon or hit the ESC key to end the polygon with the last placed line segment.

6.4.2. [bookmark: Editing_Polygons38A23EAA]Editing Polygons
To edit a polygon first select it.

A selected polygon
Drag either of the polygon corner manipulators(  ) to change the corners or ends.
Drag any rotate manipulator to rotate the polygon.
Drag any scale manipulator to re-size the polygon.
Drag the polygon to move it.
Polygon Properties Dialog
You can also edit the parameters of the polygon using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Polyline/Polygon Properties Dialog
Click the  button to show this help topic.
Vertex
This is the selected vertex/segment. The selected vertex is drawn as a solid red square. The selected segment id drawn in red.
X
The X coordinate of the selected vertex.
Y
The Y coordinate of the selected vertex.
Click  to add a vertex.
Click  to delete the selected vertex.
Check/uncheck  close/open the polygon.
Click  to fillet the polygon

A filleted polygon
6.5. [bookmark: Rectangles]Rectangles
In AutoTRAX you can add graphical rectangles. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Rectangles have a width and height.
Rectangles also have color and can be semi-transparent. It is even possible to define an invisible rectangle. If you have snap to objects enabled objects will snap to invisible lines.
Rectangles can also have a line style as shown below.
See Fill Styles and Line Styles for more styling information.

Sample rectangles 
6.5.1. [bookmark: Adding_Rectangles264F3478]Adding Rectangles
You can add rectangles and rectangles with corners.
To set the  Fill Styles and Line Styles before adding rectangles use the Default Graphics Settings.

Rectangles and rounded rectangles
To add a rectangle to a graphical sheet click on one of the   buttons in the Add→Shapes ribbon menu button group.
 Adds a hollow rectangle.
 Adds a filled rectangle with border.
 Adds a filled rectangle without a border.
 Adds a hollow rectangle with rounded corners.
 Adds a filled rectangle with border with rounded corners.
 Adds a filled rectangle without a border with rounded corners.
Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a rectangle or press the Enter/Space/Tab key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Now as you move the mouse the rectangle will change in size and aspect ratio.
If you hold down the Shift key as you move the mouse, the rectangle will be centered at the first point.
If you hold down the CTRL key as you move the mouse, the rectangle will be square with width and height being the same.
If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the rectangle will be centered at the first point and will be square with the width and the height being the same.
Alternately, you can add a rectangle with a simple left click and hold then drag.  When the point cross is where you want to start a rectangle, left-click and hold the left button. Left-click and hold and drag to re-size the rectangle and release the button; the rectangle will be placed. In this mode, if you hit Enter before releasing the left button, you will be able to enter X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method.

Dragging the mouse defines the rectangles size
6.5.2. [bookmark: Editing_Rectangles1A319FE1]Editing Rectangles
To edit a rectangle first select it.

A selected rectangle
Drag either of the rectangle's corner manipulators(  ) to change the corners or ends.
Drag any rotate manipulator to rotate the rectangle.
Drag any scale manipulator to re-size the rectangle.
Drag the rectangle to move it.
Rectangle Properties Dialog
You can also edit the parameters of the rectangle using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Rectangle Properties Dialog
X
The X coordinate of the center of the rectangle.
Y
The Y coordinate of the center of the rectangle
Width
The width of the rectangle.
Height
The height of the rectangle
Roundness
Drag the slider to change the roundness of the rectangles corners.
Layer
Use this drop-down to set the layer for the rectangle.

6.6. [bookmark: Curves]Curves
In AutoTRAX you can add graphical curves. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Curves have a width that can be zero for an infinitely thin curve. However if you add curves to a PCB, you need to make sure their width is at least the size of the manufacturing minimum width.
Curves also have color and can be semi-transparent. It is even possible to define an invisible curve. If you have snap to objects enabled, objects will snap to invisible curves.

Open

Closed

Closed with Border and Filled

Closed with No Border and Filled

6.6.1. [bookmark: Adding_CurvesBFD74F48]Adding Curves
You can add open and closed curves.
To set the  Fill Styles and Line Styles before adding curves use the Default Graphics Settings.

Open

Closed
To add an open curve to a graphical sheet, click on the   button in the Add→Shapes ribbon menu button group.
To add a closed curve to a graphical sheet, click on one of the   buttons in the Add→Shapes ribbon menu button group.
 Adds a hollow curve.
 Adds a filled curve with border.
 Adds a filled curve without a border.
Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start a curve or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Now as you mouse the mouse the first segment of the curve will be defined. 

Left-click to define the second point for the curve or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the second point. Now as you move the mouse the curves second segment is being defined.

Open Curve

Closed Curve

Continue this to complete the curve. If you are adding an open curve and you place the cursor over the first point of the curve and left-click, the curve will be automatically closed and filled.
Double-click to end the curve with the next segment to be placed or press the ESC key to end the curve with the last completed curve segment. 


6.6.2. [bookmark: Editing_CurvesBA915981]Editing Curves
To edit a curve first select it.

A selected curve
Drag any of the manipulators(  ) to change the corners or ends.
Drag the curve to move it.
Curve Properties Dialog
You can also edit the parameters of the curve using its Properties Panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Curve Properties Dialog

Editable Curve
Click the  button to show this help topic.
Vertex
This is the selected vertex/segment. The selected vertex is drawn as a solid red square. The selected segment id drawn in red.
X
The X coordinate of the selected vertex.
Y
The Y coordinate of the selected vertex.
Tension
Slide the  slider to change the 'curvature' of the curve.
Click  to add a vertex.
Click  to delete the selected vertex.
Check/uncheck  close/open the polygon.
All Segments
Check the Smooth button to smooth the entire curve.
Check the Straight button to straighten the entire curve.
Check the Editable button to make the entire curve editable.
Segment
Click the button to straighten the selected segment.
Click the button to smooth the selected segment.
Layer
Use this drop-down to set the layer for the rectangle.
Click  to fillet the polygon
Editable Curves
Drag any of the control points to change the shape.
Uncheck the  button to make the control points for the vertex independent of each other.

6.7. [bookmark: Ellipses_And_Circles723D9221]Ellipses and Circles
In AutoTRAX you can add graphical ellipses.
A circle is an ellipse where the horizontal and vertical dimensions are the same.
 (
Circle
)[image: ]
 (
Ellipses
)[image: ]

 In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Ellipses have a width that can be zero for an infinitely thin ellipse. However if you add ellipses to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.
Ellipses also have color and can be semi-transparent. It is even possible to define an invisible ellipse. If you have snap to objects enabled, objects will snap to invisible ellipses.
Ellipses can also have an ellipse style as shown below.
Ellipses are defined by their center and the size. The size is defined by a horizontal width and a  vertical height.

6.7.1. [bookmark: Adding_Ellipses_And_CirclesE6C377AD]Adding Ellipses and Circles
You can add ellipses or circles. A circle is an ellipse with the x and y radii being the same.
To set the  Fill Styles and Line Styles before adding ellipses use the Default Graphics Settings

Ellipses/Circles
To add an ellipse to a graphical sheet click on one of the   buttons in the Add→Shapes ribbon menu button group.
 Adds a hollow ellipse.
 Adds a filled ellipse with border.
 Adds a filled ellipse without a border.
Move the mouse inside the graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to start an ellipse or circle or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Now as you move the mouse the ellipse will change in size and aspect ratio.
If you hold down the Shift key as you move the mouse, the ellipse will be centered at the first point.
If you hold down the CTRL key as you move the mouse, the ellipse will be circle with width and height the same.
If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the circle will be centered at the first point as you move the mouse, with the width and the height being the same.
Left-click when the ellipse/circle is the shape you want or press the Enter key followed by the numeric values for the width and height of the ellipse.

Dragging the mouse defines the ellipses size
6.7.2. [bookmark: Editing_Ellipses_And_Circles4BC2936E]Editing Ellipses and Circles
To edit an ellipse or a circle first select it.

A selected ellipse
Drag any rotate manipulator to rotate the ellipse.
Drag any scale manipulator to re-size the  ellipse.
Drag the ellipse/circle to move it.
Ellipse Properties Dialog
You can also edit the parameters of the ellipse using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Ellipse Properties Dialog
X
The X coordinate of the center of the ellipse.
Y
The Y coordinate of the center of the ellipse
Width
The width of the ellipse.
Height
The height of the ellipse
Layer
Use this drop-down to set the layer for the ellipse.

6.8. [bookmark: Text]Text
In AutoTRAX you can add graphical text. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.


6.8.1. [bookmark: Adding_Text8467C7C1]Adding Text
You can add Text.
To set the  Fill Styles, Line Styles and Font Style  before adding text use the Default Graphics Settings.

Text
To add text to a graphical sheet. click on the   button in the Add→Shapes ribbon menu button group.
You will be prompted for the text.

Enter the text and click the  button.
Move the mouse inside a graphical sheet's viewport. You will see the text cross follow the mouse. Left-click to place the text.

6.8.2. [bookmark: Editing_TextDF16E2C2]Editing Text
Double-click
Double-click on the text to edit the text. The edit text dialog will appear.

Enter the new text and click the  button.
Interactive Edit
To edit text interactively first select it.

Selected Text
Drag any rotate manipulator to rotate the text.
Drag any scale manipulator to re-size the text.
Drag the rectangle to move the text.
Text Properties Dialog
You can also edit the parameters of the text using its properties panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Text Properties Dialog
Text
Text to be placed
Font
Font style of the placed text
Height
The height of the text
X
The X coordinate of the center of the text
Y
The Y coordinate of the center of the text
Center
Center location of the text
Alignment
Alignment of the text

6.9. [bookmark: Notes]Notes
In AutoTRAX you can add graphical notes. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.
Notes have a width that can be zero for an infinitely thin line. However if you add lines to a PCB you need to make sure their width is at least the size of the manufacturing minimum width.
Notes also have color and can be semi-transparent. It is even possible to define an invisible note. If you have snap to objects enabled, objects will snap to invisible notes.

6.9.1. [bookmark: Adding_Notes3C418FBD]Adding Notes
You can add text notes.
To set the  Fill Styles, Line Styles and Font Style before adding notes use the Default Graphics Settings

Notes and rounded notes
To add a note to a graphical sheet click on one of the   buttons in the Add→Shapes ribbon menu button group.
 Adds a rectangular note.
 Adds a Rounded rectangular note.
You will be prompted for the text.

Enter the text and click the  button
Move the mouse inside a graphical sheet's viewport. You will see the point cross follow the mouse. Left-click when the point cross is where you want to place the note or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and Enter/Space/Tab again to exactly set placement point.

Now as you move the mouse the note will change in size and aspect ratio.
If you hold down the Shift key as you move the mouse, the note will be centered at the first point.
If you hold down the CTRL key as you move the mouse, the note will be square with the width and the height the same.
If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the note will be centered at the first point and will be square with the width and the height being the same.
Alternately, you can add a note image with a simple click, hold, and drag.  When the point cross is where you want to start the note, left-click and hold the left button. While holding the left button drag to re-size the note and release the button; the note will be placed.  In this mode, if you hit Enter before releasing the left button, you will be able to enter exact X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method. 

Dragging the mouse defines the rectangles size
6.9.2. [bookmark: Editing_Notes77AB18E8]Editing Notes
To edit a note first select it.

A selected note
Drag any rotate manipulator to rotate the note.
Drag any scale manipulator to re-size the note.
Drag the note to move it.
Note Properties Dialog
You can also edit the parameters of the note using its properties panel as shown below. To view the properties panel first select it.Then right-click on it and then select Properties Panel from the context menu that opens.

Note Properties Dialog
X
The X coordinate of the center of the note.
Y
The Y coordinate of the center of the note
Width
The width of the note.
Height
The height of the note
Roundness
Drag the slider to change the roundness of the notes corners.
Layer
Use this drop-down to set the layer for the note.

6.10. [bookmark: Images]Images
In AutoTRAX you can add graphical images. In schematics they have no electrical significance. However, in PCBs they have significance if they are placed on electrical layers such as the top or bottom layer; here they will leave copper traces and will provide an electrical connection to everything that is connected to them.

Image
6.10.1. [bookmark: Adding_ImagesF2B3F408]Adding Images
You can pictures/images to your design.


An image with transparency
To add an image to a graphical sheet click on one of the   button in the Add→Shapes ribbon menu button group.
An Open Image file dialog will be display.  Use this to select the image file to be inserted and click the Open button.
Move the mouse inside a graphical sheet's viewport. You will see the point cross follow the mouse. Left-click mouse button when the point cross is where you want to start the image or press the Enter key followed by the X value, Enter/Space/Tab key, the Y value, and then Enter/Space/Tab to exactly place the starting point.

Now as you move the mouse the image will change in size and aspect ratio.
If you hold down the Shift key as you move the mouse, the image will be centered at the first point.
If you hold down the CTRL key as you move the mouse, the image will be square with width and height the same.
If you hold down both the Shift and CTRL keys simultaneously as you move the mouse, the image will be centered at the first point and will be square with the width and the height the same.
Alternately, you can add an image with a simple click, hold, and drag.  When the point cross is where you want to start the image, left-click and hold the left button. Left-click and hold to re-size the image and release the button; the image will be placed.  In this mode, if you hit Enter before releasing the left button, you will be able to enter exact X and Y numerical values for the width and heights respectively. Note, using the Shift and CTRL keys as described above also works with this alternate method.


Dragging the mouse defines the image size
6.10.2. [bookmark: Editing_Pictures141FDD5E]Editing Images
To edit an image first select it.

A selected image
Drag either of the images corner manipulators(  ) to change the corners or ends.
Drag any rotate manipulator to rotate the image.
Drag any scale manipulator to re-size the image.
Drag the image to move it.
Image Properties Dialog
You can also edit the parameters of the image using its Properties Panel as shown below. To view the properties panel first select it.Then right-click on it, then select Properties Panel from the context menu that opens.

Image Properties Dialog
X
The X coordinate of the center of the image.
Y
The Y coordinate of the center of the image
Width
The width of the image.
Height
The height of the image
Load Image
Click the  button to load a different image.
Layer
Use this drop-down to set the layer for the image.

6.11. [bookmark: Shapes]Shapes
You can combine two or more graphics objects into a single shape object.
The  shape object consists of a shape outline and zero or more holes.
Shapes are useful to creating a complex shaped objects about of simple objects.

Example shape
The above shape was made by:
1. Adding a arc to a schematic.
1. Copying the arc and moving it to the left
1. Adding a line connecting the bottom ends of the two arcs.
1. Copying the line and moving it to connect the tops of the two arcs.
1. Selecting all 4 objects and then clicking the Layout→Group→ button.
 6. Setting the fill and line style.

Below is a cartoon shape created by combining 1 curve, 1 polyline, 2 circles, 1 ellipse and a polygon. Just draw the outline and internal cutouts and combine.  

Sample Shape - Made with polylines, arcs, an ellipse, a rectangle and a curve

Sample Shape
Creating Shapes
Editing Shapes

6.11.1. [bookmark: Creating_Shapes99BFAC9E]Creating Shapes
You can combine 2 or more graphics objects into a single shape object.
The  shape object consists of a shape outline and zero or more holes.
Shapes are useful to creating a complex shaped objects about of simple objects.
The following objects are converted into the shape outline.
· Lines
· Arcs
· Polylines
· Open Curves
The following objects are converted into the shape holes.
· Rectangles
· Circles
· Ellipses
· Closed Curves
· Polygons
You cannot create a shape object containing:
· Text
· Images
· Dimensions
· Coordinates
· Electrical items such as Symbols, wires, buses, inter-wire connectors, footprints, pads and tracks.

To combine graphics objects so that they can be moved, rotated and scaled as a single object first select them and then click the Layout→Group→ button. This button will only be enables if you have selected graphical objects.
All the fill styles of the hole objects will be set to transparent. The fill style of the resultant shape will be the shapes default fill style. And the line style will be the default line style.
	
	


Graphics to convert to  a single shape
	
	


New Shape object


6.11.2. [bookmark: Editing_Shapes44091F1B]Editing Shapes
To edit a shape first select it.

Selected Shape

Drag either of the shape's corner manipulators(  ) to change the corners or ends.
Drag any rotate manipulator to rotate the shape.
Drag any scale manipulator to re-size the shape.
Drag the shape to move it.
Shape Properties Dialog
You can also edit the parameters of the shape using its properties panel as shown below. To view the properties panel first select it. Then right-click on it, then select Properties Panel from the context menu that opens.

Click the  button to show this help topic.

Layer - Select the layer for the shape. This only applies to shapes in PCBs or Footprints.


6.12. [bookmark: Blocks]Blocks
Blocks are objects imported from DXF files.
6.13. [bookmark: Editing_ColorsB950E189]Editing Colors
The color editor consists of 4 separate editors. Click on the editor's name at the top of the control to display the editor.

The Color Swatch Editor
The RGB Color Editor 
The HSL Color Editor
The Color Wheel Editor



6.13.1. [bookmark: The_Color_SwatchF16587CE]The Color Swatch
The color swatch editor is shown below.
Click on any of the colored square to select the color.
Transparency
Drag the transparency slider  to the left to increase the transparency of the color and drag the slider to the right to reduce the transparency. You can also enter the transparency in the box. The transparency value is between 0 and 1 where 0 is totally transparent.

6.13.2. [bookmark: RGB]RGB
The RGB editor is shown below. RGB is an abbreviation for red–green–blue.
R( Red ) Drag the slider to change the red color component. You can enter a value between 0 and 255.
G( Green ) Drag the slider to change the green color component. You can enter a value between 0 and 255.
B( Blue ) Drag the slider to change the blue color component. You can enter a value between 0 and 255.
T(Transparency) Drag the transparency slider  to the left to increase the transparency of the color and drag the slider to the right to reduce the transparency. You can also enter the transparency in the box. The transparency value is between 0 and 1 where 0 is totally transparent.

Background
An RGB color space is any additive color space based on the RGB color model. A particular RGB color space is defined by the three chromaticity’s of the red, green, and blue additive primaries, and can produce any chromaticity that is the triangle defined by those primary colors. The complete specification of an RGB color space also requires a white point chromaticity and a gamma correction curve.
An RGB color space can be easily understood by thinking of it as "all possible colors" that can be made from three colorants for red, green and blue. Imagine, for example, shining three lights together onto a white wall: one red light, one green light, and one blue light, each with dimmer switches. If only the red light is on, the wall will look red. If only the green light is on, the wall will look green. If the red and green lights are on together, the wall will look yellow. Dim the red light and the wall will become more of a yellow-green. Dim the green light instead, and the wall will become more orange. Bringing up the blue light a bit will cause the orange to become less saturated and more whitish. In all, each setting of the three dimmer switches will produce a different result, either in color or in brightness or both. The set of all possible results is the gamut defined by those particular color lamps. Swap the red lamp for one of a different brand that is slightly more orange, and there will be a slightly different gamut, since the set of all colors that can be produced with the three lights will be changed.
An LCD display can be thought of as a grid of thousands of little red, green, and blue lamps, each with their own dimmer switch. The gamut of the display will depend on the three colors used for the red, green and blue lights. A wide-gamut display will have very saturated, "pure" light colors, and thus be able to display very saturated, deep colors.

6.13.3. [bookmark: HSL]HSL
The HSL (Hue-Saturation-Luminosity) editor is shown below.
H( Hue ) Drag the slider to change the Hue. You can enter a value between 0 and 360.
S( Saturation ) Drag the slider to change the Saturation. You can enter a value between 0 and 1.
L( Luminosity ) Drag the slider to change the Luminosity. You can enter a value between 0 and 1.
T(Transparency) Drag the transparency slider  to the left to increase the transparency of the color and drag the slider to the right to reduce the transparency. You can also enter the transparency in the box. The transparency value is between 0 and 1 where 0 is totally transparent.

Background
HSL is a common cylindrical-coordinate representation of points in an RGB color model. The representation rearrange the geometry of RGB in an attempt to be more intuitive and perceptually relevant than the Cartesian (cube) representation. Developed in the 1970s for computer graphics applications, HSL is used today in color pickers, in image editing software, and less commonly in image analysis and computer vision.
HSL stands for hue, saturation, and lightness, and is often also called HLS. 
In the cylinder, the angle around the central vertical axis corresponds to "hue", the distance from the axis corresponds to "saturation", and the distance along the axis corresponds to "lightness", "value" or "brightness".  Because HSL is a simple transformation of device-dependent RGB models, the physical colors they define depend on the colors of the red, green, and blue primaries of the device or of the particular RGB space, and on the gamma correction used to represent the amounts of those primaries. Each unique RGB device therefore has a unique HSL space to accompany it, and numerical HSL or HSV values describe a different color for each basis RGB space.
This representations is used widely in computer graphics, and one or the other of them is often more convenient than RGB, but both are also criticized for not adequately separating color-making attributes, or for their lack of perceptual uniformity. Other more computationally intensive models, such as CIELAB or CIECAM02 better achieve these goals.
Basic principle 
HSL has cylindrical geometries (see below), with hue, their angular dimension, starting at the red primary at 0°, passing through the green primary at 120° and the blue primary at 240°, and then wrapping back to red at 360°. In each geometry, the central vertical axis comprises the neutral, achromatic, or gray colors, ranging from black at lightness 0 or value 0, the bottom, to white at lightness 1 or value 1, the top. In both geometries, the additive primary and secondary colors – red, yellow, green, cyan, blue, and magenta – and linear mixtures between adjacent pairs of them, sometimes called pure colors, are arranged around the outside edge of the cylinder with saturation 1; in HSL they have lightness ½.  In HSL, both tints and shades have full saturation, and only mixtures with both black and white – called tones – have saturation less than 1.	
	
If we plot hue and HSL lightness against chroma rather than saturation, the resulting solid is a bicone or cone, respectively, not a cylinder. Such diagrams often claim to represent HSL directly, with the chroma dimension deceptively labeled "saturation".
Because these definitions of saturation – in which very dark (in both models) or very light (in HSL) near-neutral colors, for instance  or , are considered fully saturated – conflict with the intuitive notion of color purity, often a conic or bi-conic solid is drawn instead, with what this article calls chroma as its radial dimension, instead of saturation. Confusingly, such diagrams usually label this radial dimension "saturation", blurring or erasing the distinction between saturation and chroma. As described below, computing chroma is a helpful step in the derivation of each model. Because such an intermediate model – with dimensions hue, chroma, and HSV value or HSL lightness – takes the shape of a cone or bicone, HSV is often called the "hexcone model" while HSL is often called the "bi-hexcone model" 

HSL cylinder

Hue and HSL lightness against chroma

6.13.4. [bookmark: The_Color_Wheel1E2C18B1]The Color Wheel
The color wheel editor is shown below
.

 Drag the small  dot in the outer ring to change the Hue.


Drag the small  dot in the central triangle to change the saturation/luminosity.

Transparency
Drag the transparency slider  to the left to increase the transparency of the color and drag the slider to the right to reduce the transparency. You can also enter the transparency in the box. The transparency value is between 0 and 1 where 0 is totally transparent.

Background
A Color Wheel or color circle is an abstract illustrative organization of color hues around a circle that shows relationships between primary colors, secondary colors, complementary colors, etc.
6.14. [bookmark: Line_Styles77BCD177]Line Styles
The video below demonstrates editing the line style for a line ... (you will need to be connected to the Internet to view it)
 Many different objects in AutoTRAX have line style, these include:
· Lines and polylines.
· Polygons, rectangles, curves, ellipses and circles.
Pictures

The Line style properties dialog is shown on the left.
Start and End Cap
These control the capping at the start and the end of lines. Only objects with open ends can have end caps, e.g.,lines, polylines and open curves.
Dash Styles
The dash style buttons below the cap styles sets the line style as solid or a variety of dash styles.
Width
This sets the width of the line.
Color
This sets the color of the line.

6.15. [bookmark: Fonts2]Fonts
The Font Editor dialog is shown below.

Font Editor dialog
6.16. [bookmark: Fill_StylesB7218894]Fill Styles
If you select an object or several objects that can be filled then the fill style properties of the object will be displayed in the properties panel.
At the top of the fill styles properties panel you will see a collection of buttons as shown below which allow you to select the fill style.
You can apply 4 different fill styles.

The top part of the full style editor
  No Fill

Transparent or no fill
 Solid Fill 

Solid Fill
 Hatch Fill

Hatch Fill
 Linear Fill

Linear Fill
 Radial Fill

Radial Fill


6.16.1. [bookmark: No_Fill369B91E3]No Fill
You can set the fill style to be transparent or no fill. When object as no fill you will be able to see through the area of the object that is normally filled. 
Note: if you set the fill style to be no fill or transparent make sure the object has a line or body style that is not transparent otherwise you will not be able to see the object. However, it will be selectable using the window select tool, you be will not be able to select it by clicking on it.

Click on the transparent button  to set the fill style to transparent.

Transparent or no fill

6.16.2. [bookmark: Solid_FillAFE50AA1]Solid Fill
Solid fill is where you can fill a shape with a solid area of color.
For example, the rectangle shown below is being filled with a solid fill of cyan.

A rectangle with a solid fill of cyan

To fill an object first select it.
Now you have two options to set the color:
the first option and the quickest is to click on the desired color in the color bar at the base of the viewport.
The second method is to set the color using the fill properties in the selected objects properties panel.
What you see is a standard AutoTRAX color chooser.

The solid fill control is shown below.

 Solid Fill Control
6.16.3. [bookmark: Hatch_Fill85FD99A8]Hatch Fill
Hatch fill is where a shape is filled with a pattern. The pattern uses two different colors.

Hatch Fill
The hatch fill control is shown below. It consists of two separate color choosers are shown below. Use either of the color choosers to select the desired color.

 Hatch Fill Control
6.16.4. [bookmark: Radial_Fill67AC8929]Radial Fill
Radial fill is where you fill an object with a color pattern that is circular with the central color merging into an outer color as shown below.

Radial fill
The radial fill control is shown below. 

 Radial Fill Control
It consists of two separate color users. The top color chooser sets the central color while the bottom color chooser sets the outer color. You can set the position of the central color by dragging on the central color position control.

The central color position selector
Click the  button to exchange the two colors.
6.16.5. [bookmark: Linear_FillD696EB8B]Linear Fill
Linear fill is where the color changes from one color to the second along a straight line as shown below.

Linear Fill
Click the  button to exchange the two colors.

The colors have been swapped
Check either the horizontal or vertical radio button  to set the direction of color change.

Color direction changed to vertical

The linear fill control is shown below. The top color chooser sets the first color while the bottom, chooser sets the second color.

Linear filled preview

 Linear Fill Control
6.17. [bookmark: Default_Graphics_SettingsDE577931]Default Graphics Settings
To set the default line/fill and text settings for graphics, click on the small  button at the bottom right of the Add→Shapes ribbon button group.
The default settings pop-up consist of three separate tabs.
· The first tab sets the line of border style.
· The second tab sets the fill style.
· The third tab sets the font properties.

Shapes Default Setting pop up dialog

Lines properties
See Line Styles for more info.

Fill properties
See Fill Styles for more details

Font properties
See Fonts for more details



7. [bookmark: Drawing_Aids830804D6]Drawing Aids
AutoTRAX has several drawing aids to help add, edit and align parts, pads, footprints and graphics.
Coordinates
Guides
Snaps and the Grid
Rulers
7.1. [bookmark: Coordinates]Coordinates
A coordinate is a graphics symbol that displays its X,Y position on a sheet.
It is very much like a Dimension but instead of displaying the distance between 2 points (a relative distance or vector) it displays the position.
Coordinates have no electrical significance.

A Dimension showing the horizontal distance between 2 points, A and B

A Coordinate showing the position of point A
7.1.1. [bookmark: Adding_Coordinates1DF00C9F]Adding Coordinates
To add a coordinate to a sheet click on the  button in the Add→Dimension button group.
As you move the mouse cursor in the viewport, you will see the position cursor displayed below. You can press the 's' key to turn snap on/off.

Adding a Coordinate

When the coordinate is at the position you want to place it, left-click on to finish creating it. 
You can enter the value of the X and Y coordinates by first pressing the Enter key followed by the X coordinate, the Enter key, the Y coordinate and finally the Enter key to complete creating the coordinate.

Entering the X and Y coordinate using the keyboard

Completed Coordinate

7.1.2. [bookmark: Editing_Coordinates14F81742]Editing Coordinates
There are 2 ways to edit a coordinate, dragging it or using the Properties panel.
Dragging 
You can hold down the left mouse button on a coordinate to select it and then drag the mouse to move it. You will see the X and Y values of the coordinate change as you move it. Press the 's' key to turn snap on or off.
Properties Panel
If you select a coordinate and the Properties panel is visible, the coordinate's properties dialog will be shown.

X
The X or horizontal position of the coordinate.
X
The Y or vertical position of the coordinate
Pressing the  button displays this help page.
7.2. [bookmark: Guides]Guides
You can add guides to graphical sheet's to act as visual guides, or to act as snap guides. 
	Snapping to Guides
	You can snap objects to the horizontal, vertical or point guides. To toggle snapping to guides click on the  button in the View/Snap ribbon tab's  button group.




If Snapping to Guides is enabled then when objects are created or moved, they will snap to guides when they are close to them.
There are 4 types of guides
Horizontal Guides
Horizontal Guides will snap the vertical Y coordinate of objects.
Vertical Guides
Point Guides
Angled Guides

Vertical Guides will snap the horizontal X coordinate of objects.
Point Guides will snap both the horizontal X and the vertical Y coordinates of objects
Angled Guides will snap both the horizontal X and the vertical Y coordinates of objects to the Angled Guide
Guides are a powerful tool in AutoTRAX that help you layout your design and also serve to snap objects to a custom grids. This video show you how to add horizontal and vertical guides as well as point guides.

7.2.1. [bookmark: Vertical_GuidesB4FAC9A2]Vertical Guides
Vertical guides are vertical lines that act as:
· Visual Clue
· X coordinate snap points when adding or moving objects.

A vertical guide (blue line)
	Adding Vertical Guides
	There are 2 ways to add a vertical guide to a sheet.
1. The first and easiest is to hold down left mouse button on the vertical ruler to the left of the sheet (If rulers are visible) and drag it into position.
1. The second method is to click on the  button in the Add→Guides button group. 

The vertical guide and its horizontal position during initial creation
In both cases, as you drag the guide to position, you can enter a number value by first pressing the Enter key and then the X coordinate or click the left mouse button to place the guide.
You can press the 's' key at any time to turn snap on or off.


	Editing Vertical Guides
	There are 2 ways to edit a vertical guide, dragging it or using the Properties panel.
Dragging 
You can hold down the left mouse button on a vertical guide and drag the mouse to move the guide; release the mouse button when the guide is where you want it. You will see the X values of the coordinate change as you move it. Press the 's' key to turn snap on or off.

Vertical guide's horizontal position displayed during dragging
Properties Panel
If you select a vertical guide and the Properties panel is visible, the vertical guide properties dialog will be shown.


Vertical guide properties
X
The X or vertical position of the vertical guide
Pressing the  button displays this help page.


7.2.2. [bookmark: Horizonta_lGuides9B4FBB9A]Horizontal Guides
Horizontal guides are horizontal lines that act as:
· Visual clues
· Y coordinate snap points when adding or moving objects.

A horizontal guide (blue line)
	Adding Horizontal Guides
	There are 2 ways to add a horizontal guide to a sheet.
1. The first and easiest is to hold down the left mouse button on the horizontal ruler at the top of the sheet (If rulers are visible) and drag it into position.
1. The second method is to click on the  button in the Add→Guides button group. 

The horizontal guide and its horizontal position during initial creation
In both cases, as you drag the guide to position it you can enter a number value by first pressing the Enter key and then the Y coordinate or click the left mouse button to place the guide.
You can press the 's' key at any time to turn snap on or off.


	Editing Horizontal Guides
	There are 2 ways to edit a horizontal guide, dragging it or using the Properties panel.
Dragging 
You can hold down the left mouse button on a horizontal guide and drag the mouse to move the guide. You will see the Y value of the coordinate change as you move it. Press the 's' key to turn snap on or off.

Horizontal guide's vertical position displayed during dragging
Properties Panel
If you select a horizontal guide and the Properties panel is visible, the horizontal guide properties dialog will be shown.

Horizontal guide properties
The Y or vertical position of the  horizontal guide
Pressing the  button displays this help page.


7.2.3. [bookmark: Point_Guides88341324]Point Guides
Point guides are points that act as a visual clue and also as an X,Y coordinate snap point when adding or moving objects.

A point guide (blue cross)
7.2.3.1. [bookmark: Adding_Point_Guides811BEC30]Adding Point Guides
There are 2 ways to add a point guide to a sheet.
1. The first and easiest is to hold down the left mouse button on the ruler origin in the upper left hand corner of the rulers (If rulers are visible) and drag it into position.
1. The second method is to click on the  button in the Add→Guides button group. 
1. 
The point guide and its X,Y position during initial creation
In both cases, as you drag the guide to position it you can enter a number value by first pressing the Enter key and then the X and Y coordinate or click the left mouse button to place the guide.
You can press the 's' key at any time to turn snap on or off.

7.2.3.2. [bookmark: Editing_Point_GuidesFF75B591]Editing Point Guides
There are 2 ways to edit a point guide, dragging it or using the Properties panel.
Dragging 
You can hold down the left mouse button on a guide and then drag the mouse to move the guide. You will see the X, Y values of the point change as you move it. Press the 's' key to turn snap on or off.

Point guide's vertical position displayed during dragging
Properties Panel
If you select a point guide and the Properties panel is visible, the point guide properties dialog will be shown.

Point guide properties
X
The X or horizontal position of the point guide.
X
The Y or vertical position of the point guide
Pressing the  button displays this help page.
7.2.4. [bookmark: AngledGuide]Angled Guides
Angled guides are angled lines that act as a visual clue and also as an X,Y coordinate snap point when adding or moving objects.

An angled guide (blue diagonal line)
7.2.4.1. [bookmark: Adding_Angled_Guides6EBB7363]Adding Angled Guides
Unlike the other guides there is only one way to add an angled guide to a sheet and that is by clicking on the  button in the Add→Guides button group. 

The angled guide and its crossing point during initial creation
As you drag the guide to position it you can enter a number value by first pressing the Enter key and then the crossing coordinate or click the left mouse button to define the crossing point..
You can press the 's' key at any time to turn snap on or off.
Now as you drag the mouse, the angle of the angled guide will vary. Left-click to finish creating the angled guide or you can enter a number value for the angle in degrees by first pressing the Enter key and then entering the angle.

The angle of the angled guide as you drag the mouse


7.2.4.2. [bookmark: Editing_Angled_GuidesA7D046AE]Editing Angled Guides
There are 2 ways to edit an angled guide, dragging it or using the Properties panel.
Dragging 
You will see the angled guide in red together with 2 point manipulators. Drag any of them to edit the angled guide.
You can hold down the left mouse button on an angled guide manipulator and drag the mouse to move the guide. Press the 's' key to turn snap on or off.

Dragging an angled guide

Or, you can drag on of the 2 guide manipulators. You will see the angle change as you move it. 

Angled guides manipulators

Guide during dragging a manipulator point
Properties Panel
If you select an angled guide and the Properties panel is visible, the angled guide properties dialog will be shown.

Angled guide properties
X
The X or horizontal position of the guides start or end.
X
The Y or vertical position of the guides start or end.
Angle
The angle of the guide in degrees.
Pressing the  button displays this help page.
7.3. [bookmark: Snaps_And_The_Grid112388B0]Snaps and the Grid
AutoTRAX can optionally display a grid to help you place items. The grid can display as a graph grid, a line grid or a dot grid see the Grids
You can optionally snap objects to the rectangular grid. The snap can be to whole grid spacing or 2-10 divisions of the grid spacing.
You can also optionally have a Rotation Snap when rotating objects.
Symbol and Wire Grid
7.3.1. [bookmark: The_Grids178FF7D5]The Grids
There are 3 different types of grids possible in AutoTRAX, the graph, the line and the dot grids.
Use the Snap Settings pop up to change grid types.
The Graph Grid
The graph grid is like a sheet of graph paper. As you zoom in and out the graph paper adjusts to show a grid-like structure with strong major divisions and lighter minor division. When you zoom in, the graph paper will subdivide to show more grid lines.


The Graph Grid
The Line Grid
The line grid displays as a set of horizontal and vertical lines as shown below.

The Line Grid

The Dot Grid
The dot grid is drawn as a series of points at the major snap points.

The Dot Grid

7.3.2. [bookmark: Setting_The_Snaps_Per_Grid12B016D7]Setting the Snaps per Grid

You can set the number of snaps per grid spacing from 1 to 10 using the Snaps per Grid button group in the View/Snap ribbon menu tab.
Click on the button once to set the snaps per grid and enable snap to grid  Click on the same button again to disable snap to grid. Click on another button to set the snaps per grid as shown in the button.

7.3.3. [bookmark: Rotation_Snap0E0B104D]Rotation Snap
You can snap to a rotation angle when rotating objects. Use the Snap Settings pop up.
You can rotate objects by selecting the objects and:
· Pressing the Space key or
· Dragging any of the rotate handles at the 4 corners

Selected item showing rotate handles

· Clicking on any of the rotate command buttons in the Rotate group of the Edit ribbon tab

7.3.4. [bookmark: Snapping_To_Guides17D21034]Snapping to Guides
You can snap objects to the horizontal, vertical or point guides. To toggle snapping to guides click on the  button in the View/Snap ribbon tab's  button group.

7.3.5. [bookmark: Snapping_To_Objects20449043]Snapping to Objects
You can snap object to others as you draw them.
Select the Snap To Objects button in the Snap button group in the View/Snap ribbon tab to turn snapping to objects on or off. 
Certain graphic objects have intrinsic snap point, for instance lines have intrinsic snap points at the start and end of the line.
If you have snap to objects on and you add say a line, as you drag the line to define it and you move closer to the start or end of another line, the end of the line you are adding will snap to the closed end point of the other line.
As you drag the end of a line that you are creating, when you get close to the end of another line, the new line will snap to an end point of the second line.



7.3.6. [bookmark: Snap_Settings2D70F6D2]Snap Settings
 To set the grid and snap settings click on the small button at the bottom right of the Snap button group in the View→Snap ribbon tab...

The Grid/Snap Setting dialog will appear as shown below.

Clicking to display this help topic.
Snap Spacing 
This is the major snap grid spacing. You change the actual snaps per grid using the buttons in the Snaps Per Grid button group.
Graph
Click to display the grid as a graph grid.
Line
Click to display the grid as a line grid.
Dot
Click to display the grid as a dot grid.
Draw To Units
If checked, grid lines/points will be spaced on the measurements units you are using e.g. inches or cm.
Draw to Snap Spacing
If checked, grid lines/points will be spaced on the Snap Spacing you define.
Snap Rotation Angle
This is the rotation snap angle in degrees for rotating selected objects when you press the space bar.
Menu Rotation Angle
This is the rotation snap angle in degrees for rotating selected objects when you use the menu buttons.





7.3.7. [bookmark: Symbol_and_Wire_GridA9A8E897]Symbol and Wire Grid
AutoTRAX has a fixed grid for schematic terminal magnets, schematic terminals and schematic wires and buses. This is  0.05". This is 1.27 mm.
This was chosen for visibility reasons and to ensure it is easy to lay out wires vertically/horizontally with no small snap compensating section. A unit mm setting such as 1mm is too small and 2mm too large. 
The AutoTRAX schematic wire auto-router is grid based and uses a grid of 0.05".
You cannot change this. Setting the Snaps per Grid or the Snap Settings has no effect on adding/editing wire, moving terminals or changing the border size/position.

7.4. [bookmark: Measuring_DistancesBD2CD020]Measuring Distances and Angles
To measure distances click the Measure distance button  in the Tools→Misc. ribbon menu. 
Often in your design you will want to measure the size of an object or the distance between objects. This video show you how to quickly use the measure tool.

1. Move the cursor to the start point from which you wish to begin measuring. You can turn snap on or off by pressing the 's' key.

Move the cursor to the start point
1. Left-click to begin measuring.  Now, as you drag the cursor, the distance will be displayed. Again you can turn snap on or off by pressing the 's' key.

Drag the mouse to measure the distance

1. Left-click again to end the measurement.

If the Auto-repeat commands feature enabled, additional measurements by repeating the process above without the necessity of clicking the Measure distance button  in the Tools→Misc. ribbon menu. If Auto-repeat commands is enabled hit ESC to quit measuring.

7.5. [bookmark: Setting_The_Origin8A5F628B]The Origin
The origin can be editing by display it and the dragging it or changing it's position in the properties panel.
Both the horizontal and the vertical roller in the origin box have context menus that are command items to set the origin.
8. [bookmark: Dimensions]Dimensions
In AutoTRAX a dimension is used to show the distance between 2 points. There are 2 different types of dimensions, linear and aligned dimensions.
	Linear Dimensions
	Linear dimensions are dimensions that display horizontal or vertical distances.



	Adding Linear Dimensions
	1. To add a linear dimension click the  in the Add→Dimension button group. 
1. Now as you move the mouse in the viewport, you will see the start coordinate. Left-click to define the start point of the dimension or press the Enter key and enter the numeric value of the start point.

1. Now as you move the mouse the dimension will be drawn and the end point shown.

1. Left-click to set the end point or press the Enter key and enter the numeric value of the end point.
1. Now as you move the mouse you will see the dimension offset from the start and end points as shown below. Depending on the position of the mouse, the dimension will show the horizontal or vertical distance. Left-click again to finally define the dimension or press the Enter key and enter the numeric value of the offset.

Dimension showing the vertical distance

Dimension showing the horizontal distance





	Aligned Dimensions
	Aligned dimensions are dimensions that are drawn at an angle and aligned to the dimension being displayed.




	Dimension Labeling
	Dimensions can display the value, a label or both.

Just Value

Label only

Value and Label




8.1. [bookmark: Adding_Aligned_Dimensions77189572]Adding Aligned Dimensions
1. To add an aligned dimension click the  in the Add→Dimension button group. 
1. Now as you move the mouse in the viewport, you will see the start coordinate. Left-click to define the start point of the dimension or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the starting point.

1. Now as you move the mouse, the dimension will be drawn and the end point shown.

1. Left-click to set the end point or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the end point.
1. Now as you move the mouse you will see the dimension offset from the start and end points as shown below. Left-click again to finally define the dimension or press the Enter key and enter the numeric value of the offset.

8.2. [bookmark: Adding_Linear_DimensionsA683BD81]Adding Linear Dimensions
1. To add a linear dimension click the  in the Add→Dimension button group. 
1. Now as you move the mouse in the viewport, you will see the start coordinate. Left-click to define the start point of the dimension or press the Enter key and enter the numeric value of the start point.

1. Now as you move the mouse the dimension will be drawn and the end point shown.

1. Left-click to set the end point or press the Enter key and enter the numeric value of the end point.
1. Now as you move the mouse you will see the dimension offset from the start and end points as shown below. Depending on the position of the mouse, the dimension will show the horizontal or vertical distance. Left-click again to finally define the dimension or press the Enter key and enter the numeric value of the offset.

Dimension showing the vertical distance

Dimension showing the horizontal distance

8.3. [bookmark: Editing_Dimensions6098EDCA]Editing Dimensions
You can edit dimensions by selecting the dimension and dragging the text or text line to change the offset or drag the start/end handles.

Drag text or test line to change the offset

Drag start or end handle to change dimension points
Using the Properties Panel
In addition you can use the dimensions property dialog in the properties panel.

X
The start or end X coordinate.
Y
The start or end Y coordinate.
Length
The length of the dimension
Offset
The distance the dimension is from the start/end points
Style
The style of the dimension.
 Vertical

  Horizontal

 Angled

Markers
You can select the graphics markers for the ends of the dimension line.
 Arrow

 Slash


 Square


 None

TEXT
 Enter an optional text label.
Display Value
 Check to display numeric text for the distance.
Flip 
 Check to flip text orientation

Not Flipped


8.4. [bookmark: Dimension_SettingsA1D8468E]Dimension Settings
You can set the default properties of dimensions that you will add by clicking on the small button at the bottom left of the Add→Dimension button group. You can set the line/text style and text font.

Dimension Settings Pop-up

Dimension line and text style and color
See  Line Styles

Dimension text font
See Fonts
9. [bookmark: Selecting_Arranging_and_EditiC6DF2A72]Arranging and Editing Objects
In AutoTRAX you can edit and arrange all the objects in a sheet.
9.1. [bookmark: Undoing_And_Redoing_Your_ChangesA43400AF]Undoing and Redoing Your Changes
Every change (except viewpoint changes) you to make to your design or part is reversible.
To undo a change click the Edit→Undo/Redo→ button.
To reverse an undo and restore a change, click the Edit→Undo/Redo→ button.
Each change you make to a design or part is named with a name that reflects the action taken. You can view all changes made in the current session by clicking on the  button the lower left of the Edit→Edit ribbon button group. The Undo/Redo pop-up will be displayed as shown below. Click on any of the named states to revert the current design to that state. Clicking the  button displays this help topic.


You can also restore previous states that occurred before the current session using the Restore Backup command.

9.2. [bookmark: Selecting_Items63C3AA59]Selecting Items
There are 2 picking modes in AutoTRAX
Pick
In this mode only top level objects are picked. Click the Edit→Select→ button.
Sub-pick
In this mode you can pick objects that are components of other objects. This is good for selecting objects inside a group or symbol/footprint. Click the Edit→Select→ button.
Single Selection
To select single objects, click on the object in the viewport.
 If you hold the Shift key then the object you select will be added to the selected items if it is not already selected else it will be removed from the selected item.
Window Pick
To select multiple objects left-click and hold in an area not occupied by any objects and drag the mouse. As you drag the mouse you will see all objects inside the rectangle defined by the initial mouse press and the current location of the mouse are selected. The objects must be completely inside the picking rectangle.
Select All
Click the Edit→Select→ button to select all objects on a sheet.
Invert selection
Click the Edit→Select→ button to invert the selection. All selected objects become unselected and all previously unselected objects become selected.
Unselect All
Click the Edit→Select→ button to unselect all objects in a sheet.


9.3. [bookmark: Selection_Settings9C4B21B4]Selection Settings
When selecting items on a schematic you can optionally automatically select the corresponding PCB item, i.e. if you select a part symbol in a schematic the corresponding footprint in the PCB will also be selected. Similarly if you select a  footprint in the PCB then the corresponding part symbol in a schematic will be selected. To enable/disable this check the Cross Select checkbox in the Selection Settings popup dialog.
To view the Selection Settings popup click the  button at the bottom right of the Edit→Select ribbon button group.
Automatically zooming to the selected object in its viewport is possible.  To enable/disable this feature check the Auto-zoom Selected checkbox in the Selection Settings popup dialog.

9.4. [bookmark: Locking_Objects1DD7467E]Locking Objects
You can lock objects to prevent them from being edited or deleted.
To lock an object:
1. Select it.
1. Then tick the lock checkbox in its properties dialog in the Properties Panel.
Similarly, to unlock an object:
1. First select it.
1. Then clear the lock checkbox in its properties dialog in the Properties Panel.
9.5. [bookmark: Deleting_Objects752E6D17]Deleting Objects
To delete objects first Select them and then click the Edit→Edit→ button.  You can also delete them and place a copy of the deleted objects on the clipboard by clicking the Edit→Edit→ button. Either way, you can always undo you changes.
Pressing the Delete key is the same as clicking on the   button.

9.6. [bookmark: Moving_Objects_To_The_ClipboardE1FFEDC4]Moving Objects to the Clipboard
To move objects from the design and place them onto the clipboard, click the Edit→Edit→ button. You can always undo the change.
Pressing CTRL+x is the same as pressing the  button.
9.7. [bookmark: Clearing_Sheets_And_The_PCB99B80428]Clearing Sheets and the PCB
To clear all the contents of a schematic or a PCB click the Edit→Edit→ button.

9.8. [bookmark: Copying_ObjectsDE554614]Copying Objects
To copy selected objects click the Edit→Edit→ button. This copies the objects to the clipboard. You can then paste them onto sheets and into other applications.
9.9. [bookmark: Pasting_ItemsFF37B5EF]Pasting Items from the Clipboard
To paste objects from the clipboard, click the Edit→Edit→ button. There are three different types of objects that can be pasted from the clipboard:
· Images/pictures. These are added to the current sheet as image objects.
· Text. Text is added as a text object to the current sheet.
· Objects copied to the clipboard from AutoTRAX. These are added to the current sheet as selected objects. Once added, the objects are selected and will follow the movement of the mouse in the viewport. Left click the mouse to place the selected objects in their final position.
9.10. [bookmark: Rotating_Objects9C51142F]Rotating Objects
To rotate objects first select them.
You can quickly rotate them by pressing the Space bar.
You can also rotate them using any of the commands in Edit→Rotate ribbon button group.

Click the   button to rotate the selected objects clockwise by 90°.
Click the   button to rotate the selected objects by 180°.
Click the  button to rotate the selected objects anticlockwise by 90°.
To rotate selected objects by a set angle, enter the angle in the  control and click the  button.
You can also scale objects by dragging the rotate  handles.

Selected box showing scale and rotate handles.

9.11. [bookmark: Mirroring_Objects0AC5305E]Mirroring Objects
To mirror objects about the horizontal or vertical axis first select them.
Click the  Edit→Mirror→ button to mirror the selected items about the vertical Y axis.
Click the Edit→Mirror→ button to mirror the selected items about the horizontal X axis.

Mirroring Part Symbols
If you mirror a part symbol, the text orientation is maintained but symbol terminals change sides.

Original

 





9.12. [bookmark: Scaling_ObjectsC3A06A4A]Scaling Objects
To scale objects first select them.
To scale Up/down by a percentage click the  button in the  button group. Click the  button to scale down. Set the percentage in the  control.
You can also scale object by dragging the scale  handles. 

Selected box showing scale and rotate handles.
9.13. [bookmark: Aligning_Objects36257FAC]Aligning Objects
To align 2 or more objects you must first select them.

Original
Align Top
Click the Layout→Align→ button.

Align Bottom
Click the Layout→Align→ button/

Align Left
Click the Layout→Align→ button.

Align Right
Click the Layout→Align→ button.

Align Center
Click the  Layout→Align→ button.

Align Middle
Click the  Layout→Align→ button.

9.14. [bookmark: Grouping_ObjectsD76C686A]Grouping Objects
To group objects so that they can be moved, rotated and scaled as a single object first select them and then click the Layout→Group→ button.
To ungroup a group first select it and then click the Layout→Group→ button.
9.15. [bookmark: Distributing_ObjectsEBA574F9]Distributing Objects

Original
Distributing Horizontally
To distribute objects evenly in a horizontal direction, click the button in the Layout→Distribute button group.

Distributing Vertically
To distribute objects evenly in a vertical direction, click the button in the Layout→Distribute button group.

9.16. [bookmark: Re_ordering_Objects27763405]Reordering Objects
All objects are stacked vertically as they are created. You can change the stacking order.

Original
Bringing Objects to the Front
To bring objects to the front, first select them. Then click the Layout→Order→ button.

Sending Objects to the Back
To send objects to the back, first select them. Then click the Layout→Order→ button.

Bringing Objects Up 1 Level
To bring objects up one level, first select them. Then Layout→Order→ button.

Sending Objects Down 1 Level
To send objects down one level, first select them. Then click the Layout→Order→ button.


9.17. [bookmark: Creating_ArraysFE247B2A]Creating Arrays of Objects
You can create a rectangular or circular array of selected objects.

9.17.1. [bookmark: Creating_Rectangular_Arrays7241203D]Creating Rectangular Arrays
To create a rectangular array from one or more objects first select them.
Next click the Edit→Array→ button. This dialog box shown below will appear.
	
	Rows and Columns
Rows
Enter the number of rows for the array.
Columns
Enter the number of columns for the array.
Spacing
Row 
Enter the row (vertical) spacing.
Column
Enter the column (horizontal) spacing.
Click the button to create the array.
Click the  button to interactively create the array. As you drag the mouse in the viewport the array of objects will dynamically re-size according to the position of the mouse. Click the left mouse button to finalize the placement of the objects being arrayed.


Remember, you can always click the  button to undo a change. This lets you easily experiment.
	
	
	



9.17.2. [bookmark: Creating_Circular_Arrays48688E40]Creating Circular Arrays
To create a circular array from one or more objects first select them.
Next click the Edit→Array→ button. This dialog box shown below will appear.
	
	X
Enter the center X coordinate of the rotation center.
Y
Enter the center Y coordinate of the rotation center.
Items 
Enter the  number of items.
Rotate Items
Check to rotate the items as they are copied.
Click the button to create the array.


Remember, you can always click the  button to undo a change. This lets you easily experiment.
Without Rotation
	
	
	


With Rotation
	
	
	



9.18. [bookmark: Arranging_Terminals_on_a_Symbo68E768B4]Arranging Terminals on a Symbol
 (
Creating a part for a ATMEGA16U2
)[image: ]
10. [bookmark: Artworks]Artworks
Artwork files contain schematic symbols that do not have any electrical content, such as parts and wires. They are used for creating library artwork to be used in project and part files. They can also be used for any other drawing needs, as AutoTRAX's powerful graphics allows you to graphical design engineering drawings.
Below is an example of artwork for a transformer with a center tap. It consists of a collection of arcs and lines. There are no symbol terminals. 


You would use this when creating a custom transformer part.  To do this:
1. Create a new part.
1. Drag the artwork from the library.
1. Add the symbol terminals.
1. Save the part.
Below is a part created using the artwork and with terminals added

You can also add artwork from the library onto another artwork file that you are editing. This allows you to build complex art using a bottom up design methodology.
You can also add artwork to the PCB. However if the artwork is drawn with a black pen, it will appear drawn black on black on the PCB, so you will need to change its color and layer to make it visible. Artwork will initially be placed on the top document layer. 
10.1. [bookmark: Adding_Arwork_To_Library8BF78CB8]Adding Artwork to the Library
To add artwork to the library:
1. Select the graphics for the artwork in the schematic. Any electrical items such as symbol terminals, although selected, will not be added to the artwork file.
1. In the Library Panel, right-click and select Add Selected Graphics. The dialog box shown below will be displayed.
1. Enter the name for the artwork and click the OK button. You can change the target directory by typing it in or clicking on the browse  button.
Once added, you can drag the artwork from the library panel onto any schematic.
You can edit the saved artwork file in the library panel by double-clicking on its name or right-clicking on its name and select Edit Selected Part.




10.2. [bookmark: Setting_The_Default_Artwork6A4553B3]Setting The Default Artwork
You can set the default artwork template by first creating an artwork, setting it up exactly as you want all new artworks to be and then click the  in the File Menu. Then, every time you create a new artwork, it will start off as a mirror image of the default artwork you saved.

The file  is named Default.artwork and is in the library '___SystemDoNotRemove' directory .
You can always reset the default artwork to the factory default using the File Settings.
11. [bookmark: Schematics]Schematics
Schematics are Graphical Sheets that define the logical abstraction of the PCB design.

Typical Schematic
11.1. [bookmark: Adding_Parts3C98DD28]Adding Parts
You can add parts to a schematic by:
Using the Menu
Using the Library Panel
Adding Resistors
11.1.1. [bookmark: Using_The_Menu7CBCA088]Using the Menu
You can add parts by clicking on any of the part buttons in the Parts menu tab.

Once clicked, move the mouse in the schematic viewport to drag the part. 
Rotating the Part
Press the Space Bar to rotate the part 90° as you drag the part. 
Menu Parts Library
The parts that are added from this menu are in the XXXX/___SystemDoNotRemove directory where XXXX is the location of the parts library.
11.1.2. [bookmark: Using_The_Library_Panel12D9B171]Using the Library Panel
You can use the library panel to drag parts onto your schematics.

11.1.3. [bookmark: Adding_ResistorsE35405C2]Adding Resistors
To add a resistor click on of the  buttons in the Parts→Resistors button group. The add resistor dialog shown below will appear. 

Add Resistor Dialog
11.2. [bookmark: Hierarchical_DesignF3F0FB52]Hierarchical Design
In AutoTRAX you can create an hierarchical top down design with your schematics if you wish. 
11.2.1. [bookmark: SubSystem]Sub-Systems
A sub-system is a circuit in a separate schematic that contains ports. 
The sub-circuit can then be reference as sub-system symbols in other schematics. 

Port

Sub-system with Ports

Sub-system reference
11.2.1.1. [bookmark: Ports]Ports
A port is a connection point in a sub-system that appears as a terminal on sub-system reference symbols.

Port
11.2.1.1.1. [bookmark: Adding_Ports3CA9D932]Adding Ports
To add a port to a sub-system click the Add→Sub→ button. 

Enter the name for the port and click the button.

Drag the port and left-click to finally place it.



11.2.1.1.2. [bookmark: Editing_Ports7813625D]Editing Ports
There are 2 ways to edit a port, dragging it or using the Properties panel.
Dragging 
You can click and hold on a port to select it and then drag the mouse to move the coordinate. You will see the X and Y values of the coordinate change as you move it. Press the 's' key to turn snap on or off.
Properties Panel
If you select a port and the Properties panel is visible, the port properties dialog will be shown.

Actual
The actual for the port.
Name
The name for the port.
X
The X or horizontal position of the port.
X
The Y or vertical position of the port
Pressing the  button displays this help page
11.2.1.2. [bookmark: Referencing_A_Sub_System0293E901]Referencing a Sub-System
To add a reference to a sub-system click the Add→Sub→ button. The add Sub-System dialog will appear.

The Add Sub-System Dialog


11.2.1.3. [bookmark: Adding_A_Sub_SystemE9EEAB50]Adding a Sub-System
To add a sub-system to your design click the Add→Sub→ button.
You will be prompted for the name of the sub-system.

Enter its name and click the  button.
Move the mouse in the schematic viewport. As you mouse the mouse the point cursor shown below will appear. Left-click when the point cross is where you want the start corner of the sub-system or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to precisely place the start corner of the sub-system.

As you move the mouse you will see the sub-system re-size.

Click the left mouse button when it is the correct size press the Enter key followed by the Width and Height coordinates of the sub-system shape.


11.2.1.4. [bookmark: Editing_A_Sub_System684874B1]Editing a Sub-System
A sub-system is just like a Part symbol. See editing part symbols.
11.2.2. [bookmark: Refactor]Refactor
To refactor a part of a schematic design and place it in a separate schematic, select the parts to move and click the Edit→Refactor→ button.
A separate sub-system schematic will be placed and ports added.
11.3. [bookmark: Wiring_Parts_Together0ABC12AA]Wiring Parts Together

AutoTRAX can wire part terminals together.
Each wire forms part of an electrical node. 
Each node can have its own color and line width.
AutoTRAX can optionally show node IDs where nodes join to part terminals.




11.3.1. [bookmark: Adding_Wires3E0FBA12]Adding Wires
To add a wire:
As you mouse the mouse the standard mouse cursor will be shown.

No Connect
Move the wire over a terminal. The cursor will change to green. Click the left mouse button to start the wire.

Start OK
Now drag the mouse. The wire will be drawn and a red arrow cursor will be shown.

End Not OK
Move the wire over a terminal. The cursor will change to green. Click the left mouse button to end the wire.

End OK




11.3.2. [bookmark: Automatic_wiring7862262C]Automatic Wiring
This video show you how AutoTRAX will automatically create, route and layout the wires on your schematics. Simply click on a start terminal, drag the mouse to the target terminal and click again to complete the connection. Also, as you move part symbols, AutoTRAX will automatically re-route all the connect wires. Adding wire to your schematics has never been easier.
11.3.3. [bookmark: Automatic_Jumpers7E79625E]Automatic Jumpers
11.3.4. [bookmark: Wire_and_Bus_JunctionsB1CB314C]Wire and Bus Junctions


Track junctions are automatically created at the point where 3 more schematic wires meet. 
Bus junction are automatically created when you join a schematic wire to a bus.
Both are automatically deleted if they are no longer deleted.
You can move either one by holding down the left mouse button over the junction and dragging it to its new position.


A Track and bus Junction
11.3.5. [bookmark: Editing_Wires7979433D]Editing Wires
To edit a wire double-click on it.
To delete a wire, select it and the delete it.
11.3.6. [bookmark: Using_Busses7E433A2E]Using Buses
A bus represents a collection of electrical wires on a schematic sheet. The collection of wires are related in functionality, e.g. an address bus contains a collection of bus wires, say A0 to A31 for a 32 bit wide address bus. You connect several wires to a bus and the bus 'carries' the wires around the schematic grouped into a virtual single cable conduit.
Below is bus named Address which carries connections from the device on the left.


11.3.6.1. [bookmark: Adding_BussesB7154475]Adding Buses
To add a bus click the Add→Bus→ button.

11.3.6.2. [bookmark: Editing_BussesB1CF4EAE]Editing Buses
To edit a bus first select it.



11.3.7. [bookmark: Beveling_Wire_To_Bus_0ConnectionE5D3A0A3]Beveling Wire to Buss Connections
To bevel/unbevel the wire to bus connectors click the Add→Bus→ button.


Unbeveled

Beveled

11.3.8. [bookmark: Inter_Wire_ConnectorsBDEDD8AD]Inter-Wire Connectors
Also called off-page connectors.
An off-page connector is a symbol terminal that a wire connected to it will connect to all wires connected to off-page connectors with the same node name. Like space world tunnels that science fiction enthusiasts love.

An inter-wire connector
11.3.8.1. [bookmark: Adding_Inter_Wire_Connectors506B6731]Adding Inter-Wire Connectors
To add a bus click the Add→Wire→ button.
11.3.8.2. [bookmark: Editing_Inter_Wire_Connectors4745109C]Editing Inter-Wire Connectors
To edit an inter-wire connector first select it.

11.3.9. [bookmark: Marking_A_Terminal_As_No_Connect07994300]Marking a Terminal as No Connection Required
To mark a terminal as 'no connection required' click the Add→Wire→ button.
As you move the mouse in the schematic you will see a red cursor.

Red 'no terminal' cursor
If you move the mouse over a terminal it will turn green.

Green 'terminal' cursor
Left-click to mark a terminal as 'no connection required'. A green diagonal cross will be added to the terminal to signify that no connection is required for that terminal.

terminal marked as 'no connection required'
Deleting 'no connection required' Markers
To remove the 'no connection required' marker, select it and the delete it.
11.3.10. [bookmark: Nodes_And_Nets03EDCE20]Nodes and Nets
A node connects 2 or more electrical pins together or one or more schematics. 
A node can consist of 1 or more wire segments. A wire connected a wire(using a wire junction) or a terminal to another wire via a wire( using a wire junction) or a terminal.
Below is a node consisting of 3 wire segments connecting R1, R2 and Q1.



A terminal can be a
· A Symbol Terminal or
· An Inter-wire Connector or
· A Port.
Symbols consist of zero or more symbol terminals and possibly some graphics to represent the symbol. Symbol terminals can be visible or invisible.
A net defines the physical representation of a node on a PCB and defines which part pins (pads on footprints) are connected together.
Each node has a node index and an optional node name. By default nodes do not have a node name. Below, the node is shown with the node index displayed. (Use ribbon menu View→Node Names).

You can set the node name by selecting it by clicking on any of its wires and setting the nodes name using the properties panel. (right-click and select Properties Panel). Below shows the node after the node's name has been set to 'My Node'.

Instead of connecting terminals together with wires you can connect terminals to an inter-wire connector and name the inter-wire connector node by selecting it and setting its name using the Properties Panel. Below the top terminal of R2 and been connected to an inter-wire connector whose name has been set to 'My Node'. This connects R1, R2 and Q1 together. You can place as many inter-wire connectors as you wish on the same schematic or different schematics and all wire connecting to them will be connected together into a single node. The PCB net will then connect all the package pins together.

You can take this to the extreme and connect all terminals to named inter-wire connectors as shown below. Again R1, R2 and Q1are connected together.

You use inter-wire connectors on the same sheet to reduce wire clutter. You would use them on different schematics to connect wires between sheets. Copy and paste inter-wire connectors works fine.
Ports can also be used to connect wires together on different sheets. Ports let you use a schematic as a sub-system on other sheets.





11.3.11. [bookmark: Nodes]Nodes
Nodes are collections of wires on a schematic that connect 2 or more terminals together.
11.3.12. [bookmark: Wires]Wires
Wires are single connections between exactly two of the following:
· symbol terminals
· wire junctions (where 3 or more wires  meet)
· off-page connectors
· bus terminals. (terminal points on a bus)
Wire Junctions
All wire junctions are created/deleted automatically.
Created when starting a wire from another or ending a wire on another.
Deleted when only 2 wires connected to a wire junction. Junction trashed and wires added together.


Wire Junctions
11.3.13. [bookmark: Style_Guide834F1F68]Style Guide
· Use Jumpers for wire crossings.
· Avoid wire crossings. You often can do this by moving and/or rotating parts. (TP1 can be moved)
· Align parts. e.g. V1, R1,R2 and C1, horizontally, R1 and R2 vertically.
· Use common point to make circuit function obvious and also pleasing to the eye.
· Center the schematic on the page.
· Show signal flow from left to right. Inputs on the left, outputs on the right.
However, as always with AutoTRAX, the choice is yours.

Good

Ugly and ambiguous (jumper)


11.3.14. [bookmark: Wire_Settings9AD33F87]Wire Settings
To set the schematic wire setting click the small  button at the bottom right of Add→Wires ribbon button group.

Click  to display this help topic.
 IDs per Node (Wire Group)
	
Check this to display only one node ID per node.
	
Check this to display a node ID at each terminal.


 Node Text  
Show Name (text). Check to display the nodes textural name.
Show Index. Check to show the numerical node index.
11.4. [bookmark: Renumbering_PartsC7FBCE51]Renumbering Parts
To renumber parts click the Tools→Utilities→ button. 
The renumber dockable panel shown below will appear.
This will renumber all part references (designators).

The Renumber Parts Panel
11.5. [bookmark: Reference_Designators77CB7E09]Reference Designators
In AutoTRAX you can change the orientation, font and scaling of part reference designators in PCBs and schematics. In schematics you can also change the color. Watch this video to see how it's done.

11.6. [bookmark: Standard_Reference_Designators5D6DE025]Standard Reference Designators
A reference designator unambiguously identifies a component in an electrical schematic or on a printed circuit board. The reference designator usually consists of one or two letters followed by a number, e.g. R13, C1002. The number is sometimes followed by a letter, indicating that components are grouped or matched with each other, e.g. R17A, R17B. IEEE 315 contains a list of Class Designation Letters to use for electrical and electronic assemblies. For example, the letter R is a reference prefix for the resistors of an assembly, C for capacitors, K for relays.
	Designator	
	Component Type

	A
	Separable assembly or sub-assembly (e.g. printed circuit assembly)

	AT
	Attenuator or isolator

	BR
	Attenuator or isolator

	C
	Capacitor

	CN
	Capacitor network

	D
	Diode (including Zeners, thyristors and LEDs)

	DL
	Delay line

	DS
	Display

	F
	Fuse

	FB or FEB
	Ferrite bead

	FD
	Fiducial

	FL
	Filter

	G
	Generator or oscillator

	GN
	General network

	H
	Hardware

	HY
	Circulator or directional coupler

	J
	Jack (least-movable connector of a connector pair) | Jack connector (connector may have "male" pin contacts and/or "female" socket contacts)

	JP
	Link (Jumper)

	K
	Relay or contactor

	L
	Inductor or coil or ferrite bead

	LS
	Loudspeaker or buzzer

	M
	Motor

	MK
	Microphone

	MP
	Mechanical part (including screws and fasteners)

	P
	Plug (most-movable connector of a connector pair) | Plug connector (connector may have "male" pin contacts and/or "female" socket contacts)

	PS
	Power supply

	Q
	Transistor (all types)

	R
	Resistor

	RN
	Resistor network

	RT
	Thermistor

	RV
	Varistor

	S
	Switch (all types, including push-buttons)

	T
	Transformer

	TC
	Thermocouple

	TUN
	Tuner

	TP
	Test point

	U
	Inseparable assembly (e.g., integrated circuit)

	V
	Vacuum tube

	VR
	Variable resistor (potentiometer or rheostat)

	X
	Socket connector for another item not P or J, paired with the letter symbol for that item (XV for vacuum tube socket, XF for fuse holder, XA for printed circuit assembly connector, XU for integrated circuit connector, XDS for light socket, etc.)

	Y
	Crystal or oscillator

	Z
	Zener diode


11.7. [bookmark: Saving_Designs_for_Re_use58E1ACBC]Saving Designs for Re-use
You can save all or part of a design to the design library panel and drag these sub-circuits onto schematics in other projects. This video shows you how.
12. [bookmark: Circuit_SimulationE154EE6F]Circuit Simulation
AutoTRAX uses the SPICE 3f5 circuit simulator.
SPICE is an analog-circuit simulator that is used to calculate and display the circuit behavior. It was originally developed at the Electronics Research Laboratory of the University of California, Berkeley (1975). The source code was made freely available and has been used as the basis of many commercial simulators, and academic projects.
SPICE is a useful tool, not a magic wand, and its results should always be examined critically; in some cases it may not give results at all, for others the results may be misleading.

Sample Projects
Simulation Samples

Adding Circuit Elements
Adding Circuit Elements
Adding Voltage and Current Sources
Always Add a Ground

Instruments
Adding Instruments

Analysis Result
The Analysis Probe

The Spice Reference Manual

12.1. [bookmark: Simulation_SamplesF1B0E173]Simulation Samples
DEX comes with many sample projects that demonstrate circuit simulation.

To open a sample clink on the  button in the Simulation ribbon page.

You will then see a selection of circuit samples you can open. Double click on any circuit to open it.


Here are several samples:
Bridge Rectifier
12.1.1. [bookmark: Bridge_Rectifier16AB465D]Bridge Rectifier
	
	


The bridge rectifier uses four diodes connected as shown below. When the input cycle is positive as in part (a), diodes D1 and D2 are forward-biased and conduct current in the direction shown. A voltage is developed across R1 that looks like the positive half ofthe input cycle. During this time, diodes D3 and D4 are reverse-biased.
When the input cycle is negative as in Figure 2–38(b), diodes D3 and D4 are forwardbiased and conduct current in the same direction through RL as during the positive half-cycle. During the negative half-cycle, D1 and D2 are reverse-biased. A full-wave rectified output voltage appears across RL as a result of this action.
Bridge Output Voltage 
A bridge rectifier with a transformer-coupled input is shown in Figure 2–39(a). During the positive half-cycle of the total secondary voltage, diodes D1 and D2 are forward-biased. Neglecting the diode drops, the secondary voltage appears across the load resistor. The same is true when D3 and D4 are forward-biased during the negative half-cycle.


The Spice Probe shows the electrical signals.


12.2. [bookmark: Adding_Circuit_Elements2B168E23]Adding Circuit Elements
There are many different circuit elements you can add to your schematic.
Passive Devices
Adding a Resistor
Adding a Capacitor
Adding an Inductor
Adding a Transformer
Active Devices
Adding a BJT Transistor
Adding a JFET Transistor
Adding a MOSFET Transistor
Adding a MESFET Transistor
12.2.1. [bookmark: Adding_a_ResistorBFC5E6D5]Adding a Resistor
Coming soon...
12.2.2. [bookmark: Adding_a_CapacitorCA7DC0D6]Adding a Capacitor
Coming soon...
12.2.3. [bookmark: Adding_an_InductorD2D810A2]Adding an Inductor
12.2.4. [bookmark: Adding_a_Transformer374FC391]Adding a Transformer
Coming soon...
12.2.5. [bookmark: Adding_a_DiodeE630F5B3]Adding a Diode
Coming soon...
12.2.6. [bookmark: The_Transmission_LineC199ED31]Adding Transmission Lines
The Lossless Transmission Line
The Lossy Transmission Line 1
The Lossy Transmission Line 2
12.2.6.1. [bookmark: The_Lossless_Transmission_LineF82CA8D4]The Lossless Transmission Line
Coming soon...
12.2.6.2. [bookmark: The_Lossy_Transmission_Line_1CE4664CE]The Lossy Transmission Line 1
Coming soon...
12.2.6.3. [bookmark: The_Lossy_Transmission_Line_2CE4664CF]The Lossy Transmission Line 2
Coming soon...
12.2.7. [bookmark: Adding_Transistors781F8E66]Adding Transistors
Adding a BJT Transistor
Adding a JFET Transistor
Adding a MOSFET Transistor
Adding a MESFET Transistor

12.2.7.1. [bookmark: Adding_a_BJT_TransistorF67B6842]Adding a BJT Transistor
Coming soon...
12.2.7.2. [bookmark: Adding_a_JFET_Transistor62B3142B]Adding a JFET Transistor
Coming soon...
12.2.7.3. [bookmark: Adding_a_MOSFET_Transistor7531A256]Adding a MOSFET Transistor
Coming soon...
12.2.7.4. [bookmark: Adding_a_MESFET_TransistorFF94DAB8]Adding a MESFET Transistor
Coming soon...
12.2.7.5. [bookmark: The_Switch5F59F3F8]Adding a Switch
Coming soon...
12.2.7.6. [bookmark: Custom_Model998D29AD]Adding a Custom Device
Coming soon...
12.3. [bookmark: Adding_Voltage_And_Current_Sourc467F3453]Adding Voltage and Current Sources
Independent Sources
To add an independent source click on one of the buttons in the Simulate→Source ribbon button group 
.
Dependent Sources
To add an dependent source click on one of the buttons in the Simulate→Source ribbon button group

12.3.1. [bookmark: Adding_Independent_Sources5A2BB9B5]Adding Independent Sources
Coming soon...
12.4. [bookmark: Adding_Instruments41479800]Adding Instruments
You can add virtual electrical instruments to your schematics.
Adding a Power Supply
Adding a Signal Generator
Adding an Oscilloscope
Adding a Chart
12.4.1. [bookmark: Adding_a_Power_Supply2016B13B]Adding a Power Supply
Coming soon...
12.4.2. [bookmark: Adding_a_Signal_Generator8FC6D3D2]Adding a Signal Generator
Coming soon...
12.4.3. [bookmark: Adding_an_OscilloscopeB85790C3]Adding an Oscilloscope
Coming soon...
12.4.4. [bookmark: Adding_a_ChartE5FB31BA]Adding a Chart
Coming soon...
12.5. [bookmark: Always_Add_A_GroundAC08F425]Always Add a Ground
For the simulator to work you must include a ground connection.

No ground, simulation not possible

Ground present, simulation now possible
12.6. [bookmark: The_Analysis_ProbeA69572F3]The Analysis Probe
To display the Analysis Probe click the Simulate→Analysis→ button.

The Analysis Probe
https://dexpcb.com/downloadfiles/chart.project


12.7. [bookmark: Spice_Reference_ManualEF681B77]The Spice Reference Manual
SPICE (Simulation Program with Integrated Circuit Emphasis) is a general-purpose, open source analog electronic circuit simulator. It is a powerful program that is used in integrated circuit and board-level design to check the integrity of circuit designs and to predict circuit behavior.
12.7.1. [bookmark: Spice_Reference_Manual_Introduct8C245B1C]Introduction
SPICE is a general-purpose circuit simulation program for nonlinear dc, nonlinear transient, and linear ac analysis.
It was developed at the Electronics Research Laboratory of the University of California, Berkeley by Laurence Nagel with direction from his research adviser, Prof. Donald Pederson. 
The version used in AutoTRAX is version 3f5.
SPICE is a general-purpose circuit simulation program for nonlinear dc, nonlinear transient, and linear ac analysis. Circuits may contain resistors, capacitors, inductors, mutual inductors, independent voltage and current sources, four types of dependent sources, loss-less and lossy transmission lines (two separate implementations), switches, uniform distributed RC lines, and the five most common semiconductor devices: diodes, BJTs, JFETs, MESFETs, and MOSFETs.
The SPICE3 version is based directly on SPICE 2G.6. While SPICE3 is being developed to include new features, it continues to support those capabilities and models that remain in extensive use in the SPICE2 program.
SPICE has built-in models for the semiconductor devices, and the user need specify only the pertinent model parameter values. The model for the BJT is based on the integral-charge model of Gummel and Poon; however, if the Gummel- Poon parameters are not specified, the model reduces to the simpler Ebers-Moll model. In either case, charge-storage effects, ohmic resistances, and a current-dependent output conductance may be included. The diode model can be used for either junction diodes or Schottky barrier diodes. The JFET model is based on the FET model of Shichman and Hodges. Six MOSFET models are implemented: MOS1 is described by a square-law I-V characteristic, MOS2 is an analytical model, while MOS3  is a semi-empirical model; MOS6 [2] is a simple analytic model accurate in the short-channel region; MOS4 and MOS5 are the BSIM (Berkeley Short-channel IGFET Model) and BSIM2. MOS2, MOS3, and MOS4 include second-order effects such as channel-length modulation, sub threshold conduction, scattering-limited velocity saturation, small-size effects, and charge-controlled capacitance.

12.7.1.1. [bookmark: Types_Of_AnalysisD10E6A1A]Types of Analysis
DC Analysis
The dc analysis portion of SPICE determines the dc operating point of the circuit with inductors shorted and capacitors opened. The dc analysis options are specified on the .DC, .TF, and .OP control lines. A dc analysis is automatically performed prior to a transient analysis to determine the transient initial conditions, and prior to an ac small-signal analysis to determine the linearized, small-signal models for nonlinear devices. If requested, the dc small-signal value of a transfer function (ratio of output variable to input source), input resistance, and output resistance is also computed as a part of the dc solution. The dc analysis can also be used to generate dc transfer curves: a specified independent voltage or current source is stepped over a user-specified range and the dc output variables are stored for each sequential source value.
AC Small-Signal Analysis
The ac small-signal portion of SPICE computes the ac output variables as a function of frequency. The program first computes the dc operating point of the circuit and determines linearized, small-signal models for all of the nonlinear devices in the circuit. The resultant linear circuit is then analyzed over a user-specified range of frequencies. The desired output of an ac small- signal analysis is usually a transfer function (voltage gain, transimpedance, etc). If the circuit has only one ac input, it is convenient to set that input to unity and zero phase, so that output variables have the same value as the transfer function of the output variable with respect to the input.
Transient Analysis
The transient analysis portion of SPICE computes the transient output variables as a function of time over a user-specified time interval. The initial conditions are automatically determined by a dc analysis. All sources that are not time dependent (for example, power supplies) are set to their dc value. The transient time interval is specified on a .TRAN control line.
Pole-Zero Analysis
The pole-zero analysis portion of SPICE computes the poles and/or zeros in the small-signal ac transfer function. The program first computes the dc operating point and then determines the linearized, small-signal models for all the nonlinear devices in the circuit. This circuit is then used to find the poles and zeros of the transfer function.
Two types of transfer functions are allowed : one of the form (output voltage)/(input voltage) and the other of the form (output voltage)/(input current). These two types of transfer functions cover all the cases and one can find the poles/zeros of functions like input/output impedance and voltage gain. The input and output ports are specified as two pairs of nodes.
The pole-zero analysis works with resistors, capacitors, inductors, linear-controlled sources, independent sources, BJTs, MOSFETs, JFETs and diodes. Transmission lines are not supported.
The method used in the analysis is a sub-optimal numerical search. For large circuits it may take a considerable time or fail to find all poles and zeros. For some circuits, the method becomes "lost" and finds an excessive number of poles or zeros.
Small-Signal Distortion Analysis
The distortion analysis portion of SPICE computes steady-state harmonic and intermodulation products for small input signal magnitudes. If signals of a single frequency are specified as the input to the circuit, the complex values of the second and third harmonics are determined at every point in the circuit. If there are signals of two frequencies input to the circuit, the analysis finds out the complex values of the circuit variables at the sum and difference of the input frequencies, and at the difference of the smaller frequency from the second harmonic of the larger frequency.
Distortion analysis is supported for the following nonlinear devices: diodes (DIO), BJT, JFET, MOSFETs (levels 1, 2, 3, 4/BSIM1, 5/BSIM2, and 6) and MESFETS. All linear devices are automatically supported by distortion analysis. If there are switches present in the circuit, the analysis continues to be accurate provided the switches do not change state under the small excitations used for distortion calculations.
Sensitivity Analysis
Spice3 will calculate either the DC operating-point sensitivity or the AC small-signal sensitivity of an output variable with respect to all circuit variables, including model parameters. Spice calculates the difference in an output variable (either a node voltage or a branch current) by perturbing each parameter of each device independently. Since the method is a numerical approximation, the results may demonstrate second order affects in highly sensitive parameters, or may fail to show very low but non-zero sensitivity. Further, since each variable is perturbed by a small fraction of its value, zero-valued parameters are not analyized (this has the benefit of reducing what is usually a very large amount of data).
Noise Analysis
The noise analysis portion of SPICE does analysis device-generated noise for the given circuit. When provided with an input source and an output port, the analysis calculates the noise contributions of each device (and each noise generator within the device) to the output port voltage. It also calculates the input noise to the circuit, equivalent to the output noise referred to the specified input source. This is done for every frequency point in a specified range - the calculated value of the noise corresponds to the spectral density of the circuit variable viewed as a stationary gaussian stochastic process.
After calculating the spectral densities, noise analysis integrates these values over the specified frequency range to arrive at the total noise voltage/current (over this frequency range). This calculated value corresponds to the variance of the circuit variable viewed as a stationary gaussian process.
12.7.1.2. [bookmark: AnalysisAtDifferentTemperatures]Analysis at Different Temperatures
All input data for SPICE is assumed to have been measured at a nominal temperature of 27 C, which can be changed by use of the TNOM parameter on the .OPTION control line. This value can further be overridden for any device which models temperature effects by specifying the TNOM parameter on the model itself. The circuit simulation is performed at a temperature of 27 C, unless overridden by a TEMP parameter on the .OPTION control line. Individual instances may further override the circuit temperature through the specification of a TEMP parameter on the instance. 
Temperature dependent support is provided for resistors, diodes, JFETs, BJTs, and level 1, 2, and 3 MOSFETs. BSIM (levels 4 and 5) MOSFETs have an alternate temperature dependency scheme which adjusts all of the model parameters before input to SPICE. For details of the BSIM temperature adjustment, see [6] and [7]. 
Temperature appears explicitly in the exponential terms of the BJT and diode model equations. In addition, saturation currents have a built-in temperature dependence. The temperature dependence of the saturation current in the BJT models is determined by: 
where k is Boltzmann's constant, q is the electronic charge, e.g. is the energy gap which is a model parameter, and XTI is the saturation current temperature exponent (also a model parameter, and usually equal to 3). 
The temperature dependence of forward and reverse beta is according to the formula: 
where T1 and T0 are in degrees Kelvin, and XTB is a user-supplied model parameter. Temperature effects on beta are carried out by appropriate adjustment to the values of F, ISE, R, and ISC (spice model parameters BF, ISE, BR, and ISC, respectively). 
Temperature dependence of the saturation current in the junction diode model is determined by: 
where N is the emission coefficient, which is a model parameter, and the other symbols have the same meaning as above. Note that for Schottky barrier diodes, the value of the saturation current temperature exponent, XTI, is usually 2. 
Temperature appears explicitly in the value of junction potential, (in spice PHI), for all the device models. The temperature dependence is determined by: 
where k is Boltzmann's constant, q is the electronic charge, Na is the acceptor impurity density, Nd is the donor impurity density, Ni is the intrinsic carrier concentration, and Eg is the energy gap. 
Temperature appears explicitly in the value of surface mobility, 0 (or UO), for the MOSFET model. The temperature dependence is determined by: 
The effects of temperature on resistors is modeled by the formula: 
where T is the circuit temperature, T0 is the nominal temperature, and TC1 and TC2 are the first- and second-order temperature coefficients. 
12.7.1.3. [bookmark: Convergence]Convergence
Both dc and transient solutions are obtained by an iterative process which is terminated when both of the following conditions hold:
1. The nonlinear branch currents converge to within a tolerance of 0.1% or 1 picoamp (1.0e-12 Amp), whichever is larger.
1. The node voltages converge to within a tolerance of 0.1% or 1 microvolt (1.0e-6Volt),whichever is larger.
Although the algorithm used in SPICE has been found to be very reliable, in some cases it fails to converge to a solution. When this failure occurs, the program terminates the job.
Failure to converge in dc analysis is usually due to an error in specifying circuit connections, element values, or model parameter values. Regenerative switching circuits or circuits with positive feedback probably will not converge in the dc analysis unless the OFF option is used for some of the devices in the feedback path, or the .NODESET control line is used to force the circuit to converge to the desired state.
12.7.2. [bookmark: Circuit_Description18051020]Circuit Description
The circuit to be analyzed is described to SPICE by a set of element lines, which define the circuit topology and element values, and a set of control lines, which define the model parameters and the run controls. 
12.7.2.1. [bookmark: Circuit_Elements_And_ModelsF57D3902]Circuit Elements and Models
The circuit element include:
· Transistors and Diodes 
· Transmission Lines
· Voltage and Current Sources


12.7.2.1.1. [bookmark: Transistors_And_Diodes1B1B7705]Transistors and Diodes
Spice includes models for transistors:
· Bipolar Junction Transistors (BJTs)
· BJT Models (NPN/PNP)
· JFET Models (NJF/PJF)[****]
· Junction Field-Effect Transistors (JFETs)
· MESFET Models (NMF/PMF)
· MOSFETs
· MOSFET Models (NMOS/PMOS)
And the following diode models:
· Diode Model
· Junction Diodes
12.7.2.1.1.1. [bookmark: Introduction2]Introduction
The area factor used on the diode, BJT, JFET, and MESFET devices determines the number of equivalent parallel devices of a specified model. The affected parameters are marked with an asterisk under the heading 'area' in the model descriptions below. Several geometric factors associated with the channel and the drain and source diffusions can be specified on the MOSFET device line. 
Two different forms of initial conditions may be specified for some devices. The first form is included to improve the dc convergence for circuits that contain more than one stable state. If a device is specified OFF, the dc operating point is determined with the terminal voltages for that device set to zero. After convergence is obtained, the program continues to iterate to obtain the exact value for the terminal voltages. If a circuit has more than one dc stable state, the OFF option can be used to force the solution to correspond to a desired state. If a device is specified OFF when in reality the device is conducting, the program still obtains the correct solution (assuming the solutions converge) but more iterations are required since the program must independently converge to two separate solutions. The .NODESET control line serves a similar purpose as the OFF option. The .NODESET option is easier to apply and is the preferred means to aid convergence. 
The second form of initial conditions are specified for use with the transient analysis. These are true 'initial conditions' as opposed to the convergence aids above. See the description of the .IC control line and the .TRAN control line for a detailed explanation of initial conditions. 
12.7.2.1.1.2. [bookmark: Bipolar_Junction_Transistors719D6DB7]Bipolar Junction Transistors (BJTs)
General form: 
QXXXXXXX NC NB NE <NS> MNAME <AREA> <OFF> <IC=VBE, VCE> 
<TEMP=T> 
Examples: 
Q23 10 24 13 QMOD IC=0.6, 5.0 Q50A 11 26 4 20 MOD1 
NC, NB, and NE are the collector, base, and emitter nodes, respectively. NS is the (optional) substrate node. If unspecified, ground is used. MNAME is the model name, AREA is the area factor, and OFF indicates an (optional) initial condition on the device for the dc analysis. If the area factor is omitted, a value of 1.0 is assumed. The (optional) initial condition specification using IC=VBE, VCE is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. See the .IC control line description for a better way to set transient initial conditions. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line. 
12.7.2.1.1.3. [bookmark: BJT_ModelsEA20806F]BJT Models (NPN/PNP)
The bipolar junction transistor model in SPICE is an adaptation of the integral charge control model of Gummel and Poon. This modified Gummel-Poon model extends the original model to include several effects at high bias levels. The model automatically simplifies to the simpler Ebers-Moll model when certain parameters are not specified. The parameter names used in the modified Gummel-Poon model have been chosen to be more easily understood by the program user, and to reflect better both physical and circuit design thinking.
The dc model is defined by the parameters IS, BF, NF, ISE, IKF, and NE which determine the forward current gain characteristics, IS, BR, NR, ISC, IKR, and NC which determine the reverse current gain characteristics, and VAF and VAR which determine the output conductance for forward and reverse regions. Three ohmic resistances RB, RC, and RE are included, where RB can be high current dependent. Base charge storage is modeled by forward and reverse transit times, TF and TR, the forward transit time TF being bias dependent if desired, and nonlinear depletion layer capacitances which are determined by CJE, VJE, and MJE for the B-E junction , CJC, VJC, and MJC for the B-C junction and CJS, VJS, and MJS for the C-S (Collector-Substrate) junction. The temperature dependence of the saturation current, IS, is determined by the energy-gap, EG, and the saturation current temperature exponent, XTI. Additionally base current temperature dependence is modeled by the beta temperature exponent XTB in the new model. The values specified are assumed to have been measured at the temperature TNOM, which can be specified on the .OPTIONS control line or overridden by a specification on the .MODEL line.
The BJT parameters used in the modified Gummel-Poon model are listed below. The parameter names used in earlier versions of SPICE2 are still accepted.
	name
	parameter
	units
	default
	example
	area

	IS
	transport saturation current
	A
	1.0e-16
	1.0e-15
	*

	BF
	ideal maximum forward beta
	-
	100
	100
	

	NF
	forward current emission coefficient
	-
	1.0
	1
	

	VAF
	forward Early voltage
	V
	infinite
	1
	

	IKF
	corner for forward beta high current roll-off
	A
	infinite
	200
	*

	ISE
	B-E leakage saturation current
	A
	0
	0.01
	*

	NE
	B-E leakage emission coefficient
	-
	1.5
	1.0e-13
	

	BR
	ideal maximum reverse beta
	-
	1
	2
	

	NR
	reverse current emission coefficient
	-
	1
	0.11
	

	VAR
	reverse Early voltage
	V
	infinite
	1200
	

	IKR
	corner for reverse beta high current roll-off
	A
	infinite
	2000.01
	*

	ISC
	leakage saturation current
	A
	0
	0.01.0e-13
	*

	NC
	leakage emission coefficient
	-
	2
	1.5
	

	RB
	zero bias base resistance
	Ohm
	0
	100
	*

	IRB
	current where base resistance falls halfway to its min value
	A
	infinite
	0.1
	*

	RBM
	minimum base resistance at high currents
	Ohm
	RB
	10
	*

	RE
	emitter resistance
	Ohm
	0
	1
	*

	RC
	collector resistance
	Ohm
	0
	10
	*

	CJE
	B-E zero-bias depletion capacitance
	F
	0
	2pF
	*

	VJE
	B-E built-in potential
	V
	0.75
	0.6
	

	MJE
	B-E junction exponential factor
	-
	0.33
	0.33
	

	TF
	ideal forward transit time
	sec
	0
	0.1ns
	

	XTF
	coefficient for bias dependence of TF
	-
	0
	
	

	VTF
	voltage describing VBC dependence of TF
	V
	infinite
	
	

	ITF
	high-current parameter for effect on TF
	A
	0
	
	*

	PTF
	excess phase at freq=1.0/(TF*2PI) Hz
	deg
	0
	
	

	CJC
	B-C zero-bias depletion capacitance
	F
	0
	2pF
	*

	VJC
	B-C built-in potential
	V
	0.75
	0.5
	

	MJC
	B-C junction exponential factor
	-
	0.33
	0.5
	

	XCJC
	fraction of B-C depletion capacitance connected to internal base node
	-
	1
	
	

	TR
	ideal reverse transit time
	sec
	0
	10ns
	

	CJS
	zero-bias collector-substrate capacitance
	F
	0
	2pF
	*

	VJS
	ubstrate junction built-in potential
	V
	0.75
	
	

	MJS
	substrate junction exponential factor
	-
	0
	0.5
	

	XTB
	forward and reverse beta temperature exponent
	-
	0
	
	

	EG
	energy gap for temperature
	eV
	1.11
	
	

	XTI
	temperature exponent for effect on IS
	-
	3
	
	

	KF
	flicker-noise coefficient
	-
	0
	
	

	AF
	flicker-noise exponent
	-
	1
	
	

	FC
	coefficient for forward-bias depletion capacitance formula
	-
	-.5
	
	

	TNOM
	Parameter measurement temperature
	ºC
	27
	50
	



12.7.2.1.1.4. [bookmark: Diode_ModelDE9FF71F]Diode Model
The dc characteristics of the diode are determined by the parameters IS and N. An ohmic resistance, RS, is included. Charge storage effects are modeled by a transit time, TT, and a nonlinear depletion layer capacitance which is determined by the parameters CJO, VJ, and M. The temperature dependence of the saturation current is defined by the parameters EG, the energy and XTI, the saturation current temperature exponent. The nominal temperature at which these parameters were measured is TNOM, which defaults to the circuit-wide value specified on the .OPTIONS control line. Reverse breakdown is modeled by an exponential increase in the reverse diode current and is determined by the parameters BV and IBV (both of which are positive numbers). 
12.7.2.1.1.5. [bookmark: JFET_ModelsAC949540]JFET Models (NJF/PJF)
The JFET model is derived from the FET model of Shichman and Hodges. The dc characteristics are defined by the parameters VTO and BETA, which determine the variation of drain current with gate voltage, LAMBDA, which determines the output conductance, and IS, the saturation current of the two gate junctions. Two ohmic resistances, RD and RS, are included. Charge storage is modeled by nonlinear depletion layer capacitances for both gate junctions which vary as the -1/2 power of junction voltage and are defined by the parameters CGS, CGD, and PB.
Note that in Spice3f and later, a fitting parameter B has been added. For details, see [9].
	name
	parameter
	units
	default
	example
	area

	VTO
	threshold voltage (VT0)
	V
	-2.0
	-2.0
	

	BETA
	transconductance parameter (Beta)
	A/V2
	1.0e-4
	1.0e-3
	*

	LAMBDA
	channel-length modulation parameter ( )
	1/V
	0
	1.0e-4
	

	RD
	drain ohmic resistance
	Ohm
	0
	100
	*

	RS
	source ohmic resistance
	Ohm
	0
	100
	*

	CGS
	zero-bias G-S junction capacitance (Cgs)
	F
	0
	5pF
	*

	CGD
	zero-bias G-D junction capacitance (Cgs)
	F
	0
	1pF
	*

	PB
	gate junction potential
	V
	1
	0.6
	

	IS
	gate junction saturation current (IS)
	A
	1.0e-14
	1.0E-14
	*

	B
	doping tail parameter
	-
	1
	
	

	KF
	flicker noise coefficient
	-
	0
	
	

	AF
	flicker noise exponent
	-
	1
	
	

	FC
	coefficient for forward-bias
	-
	0.5
	
	

	TNOM
	parameter measurement temperature
	ºC
	
	50
	



12.7.2.1.1.6. [bookmark: Junction_Diodes468B259D]Junction Diodes
General form: 
DXXXXXXX N+ N- MNAME <AREA>> <OFF> <IC=VD> <TEMP> 
Examples: 
DBRIDGE 2 10 DIODE1 DCLMP 3 7 DMOD 3.0 IC=0.2 
N+ and N- are the positive and negative nodes, respectively. MNAME is the model name, AREA is the area factor, and OFF indicates an (optional) starting condition on the device for dc analysis. If the area factor is omitted, a value of 1.0 is assumed. The (optional) initial condition specification using IC=VD is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line. 
12.7.2.1.1.7. [bookmark: JFets]Junction Field-Effect Transistors (JFETs)
General form: 
JXXXXXXX ND NG NS MNAME <AREA> <OFF> <IC=VDS, VGS> <TEMP> 
Examples: 
J1 7 2 3 JM1 OFF 
ND, NG, and NS are the drain, gate, and source nodes, respectively. MNAME is the model name, AREA is the area factor, and OFF indicates an (optional) initial condition on the device for dc analysis. If the area factor is omitted, a value of 1.0 is assumed. The (optional) initial condition specification, using IC=VDS, VGS is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. See the .IC control line for a better way to set initial conditions. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line. 
12.7.2.1.1.8. [bookmark: MESFET_Models89B9A73D]MESFET Models (NMF/PMF)
The MESFET model is derived from the GaAs FET model of Statz et al. as described in [11]. The dc characteristics are defined by the parameters VTO, B, and BETA, which determine the variation of drain current with gate voltage, ALPHA, which determines saturation voltage, and LAMBDA, which determines the output conductance. The formula are given by:
Two ohmic resistances, RD and RS, are included. Charge storage is modeled by total gate charge as a function of gate-drain and gate-source voltages and is defined by the parameters CGS, CGD, and PB.
	name
	parameter
	units
	default
	example
	area

	VTO
	pinch-off voltage
	V
	-2.0
	-2.0
	

	BETA
	transconductance parameter
	A/V2
	1.0e-4
	1.0e-3
	*

	B
	doping tail extending parameter
	1/V
	0.3
	0.3
	*

	ALPHA
	saturation voltage parameter
	1/V
	2
	2
	*

	LAMBDA
	channel-length modulation parameter
	1/V
	0
	1.0e-4
	

	RD
	drain ohmic resistance
	Ohms
	0
	100
	*

	RS
	source ohmic resistance
	Ohms
	0
	100
	*

	CGS
	zero-bias G-S junction capacitance
	F
	0
	5pF
	*

	CGD
	zero-bias G-D junction capacitance
	F
	0
	1pF
	*

	PB
	gate junction potential
	V
	1
	0.6
	

	KF
	flicker noise coefficient
	-
	0
	
	

	AF
	flicker noise exponent
	-
	1
	
	

	FC
	coefficient for forward-bias depletion capacitance formula
	-
	0.5
	
	


.
12.7.2.1.1.9. [bookmark: MESFET]MESFETs
General form: 
ZXXXXXXX ND NG NS MNAME <AREA> <OFF> <IC=VDS, VGS> 
Examples: 
Z1 7 2 3 ZM1 OFF 
12.7.2.1.1.10. [bookmark: MOSFET_Models957DD43B]MOSFET Models (NMOS/PMOS)
SPICE provides four MOSFET device models, which differ in the formulation of the I-V characteristic. The variable LEVEL specifies the model to be used:
LEVEL=1 -> Shichman-Hodges
LEVEL=2 -> MOS2 (as described in [1])
LEVEL=3 -> MOS3, a semi-empirical model(see [1])
LEVEL=4 -> BSIM (as described in [3])
LEVEL=5 -> new BSIM (BSIM2; as described in [5])
LEVEL=6 -> MOS6 (as described in [2])The dc characteristics of the level 1
through level 3 MOSFETs are defined by the device parameters VTO, KP, LAMBDA, PHI and GAMMA. These parameters are computed by SPICE if process parameters (NSUB, TOX, ...) are given, but user-specified values always override. VTO is positive (negative) for enhancement mode and negative (positive) for depletion mode N-channel (P-channel) devices. Charge storage is modeled by three constant capacitors, CGSO, CGDO, and CGBO which represent overlap capacitances, by the nonlinear thin-oxide capacitance which is distributed among the gate, source, drain, and bulk regions, and by the nonlinear depletion-layer capacitances for both substrate junctions divided into bottom and periphery, which vary as the MJ and MJSW power of junction voltage respectively, and are determined by the parameters CBD, CBS, CJ, CJSW, MJ, MJSW and PB. Charge storage effects are modeled by the piecewise linear voltages-dependent capacitance model proposed by Meyer. The thin-oxide charge-storage effects are treated slightly different for the LEVEL=1 model. These voltage-dependent capacitances are included only if TOX is specified in the input description and they are represented using Meyer's formulation.
There is some overlap among the parameters describing the junctions, e.g. the reverse current can be input either as IS (in A) or as JS (in A/m2). Whereas the first is an absolute value the second is multiplied by AD and AS to give the reverse current of the drain and source junctions respectively. This methodology has been chosen since there is no sense in relating always junction characteristics with AD and AS entered on the device line; the areas can be defaulted. The same idea applies also to the zero-bias junction capacitances CBD and CBS (in F) on one hand, and CJ (in F/m2) on the other. The parasitic drain and source series resistance can be expressed as either RD and RS (in ohms) or RSH (in ohms/sq.), the latter being multiplied by the number of squares NRD and NRS input on the device line.
A discontinuity in the MOS level 3 model with respect to the KAPPA parameter has been detected (see [10]). The supplied fix has been implemented in Spice3f2 and later. Since this fix may affect parameter fitting, the option "BADMOS3" may be set to use the old implementation (see the section on simulation variables and the ".OPTIONS" line).
SPICE level 1, 2, 3 and 6 parameters:
	name
	parameter
	units
	default
	example

	LEVEL
	model
	-
	1
	

	VTO
	zero-bias threshold voltage (VT0)
	V
	0
	1

	KP
	transconductance parameter
	A/V2
	2.0e-5
	3.1e-5

	GAMMA
	bulk threshold parameter ( )
	V1/2
	0
	0.37

	PHI
	surface potential ( )
	V
	0.6
	0.65

	LAMBDA
	channel-length modulation (MOS1 and MOS2 only) ( )
	1/V
	0
	0.02

	RD
	drain ohmic resistance
	Ohm
	0
	1

	RS
	source ohmic resistance
	Ohm
	0
	1

	CBD
	zero-bias B-D junction capacitance
	F
	0
	20fF

	CBS
	zero-bias B-S junction capacitance
	F
	0
	20fF

	IS
	bulk junction saturation current (IS)
	A
	1.oe-14
	1.0e-15

	PB
	bulk junction potential
	V
	0.8
	0.87

	CGSO
	gate-source overlap capacitance per meter channel width
	F/m
	0
	4.0e-11

	CGDO
	gate-drain overlap capacitance per meter channel width
	F/m
	0
	4.0e-11

	CGBO
	gate-bulk overlap capacitance per meter channel length
	F/m
	0
	2e-1-

	RSH
	drain and source diffusion sheet resistance
	Ohm/square
	0
	10

	CJ
	zero-bias bulk junction bottom cap. per sq-meter of junction area
	F/m2
	0
	2.0e-4

	MJ
	bulk junction bottom grading coeff.
	-
	0.5
	0.5

	CJSW
	zero-bias bulk junction sidewall cap. per meter of junction perimeter
	F/m
	10
	1.0e-9

	MJSWE
	bulk junction sidewall grading coeff.
	-
	0.5 (level1)
0.33(level 2,3)
	

	FS
	bulk junction saturation current per sq-meter of junction area
	A/m2
	
	1.0e-8

	TOX
	oxide thickness
	meter
	1.0e-7
	1.0e-7

	NSUB
	substrate doping
	1/cm3
	0
	4.0e15

	NSS
	surface state density
	1/cm2
	0
	1.0e10

	NFS
	fast surface state density
	1/cm2
	0
	1.0e10

	TPG
	type of gate material: +1 opp. to substrate -1 same as substrate 0 Al gate
	-
	1.0
	

	XJ
	metallurgical junction depth
	meter
	0
	1 micron

	LD
	lateral diffusion
	meter
	0
	0.8 micron

	UO
	surface mobility
	cm2/Vs
	600
	700

	UCRIT
	critical field for mobility degradation (MOS2 only
	V/cm
	600
	1.0e-4

	UEXP
	critical field exponent in mobility degradation (MOS2 only)
	-
	1.0e04
	0.1

	UTRA
	transverse field coeff. (mobility) (deleted for MOS2)
	-
	0
	0.3

	VMAX
	maximum drift velocity of carriers
	m/s
	0
	5.0e40.3

	NEFF
	total channel-charge (fixed and mobile) coefficient (MOS2 only
	-
	0
	5.0

	KF
	flicker noise exponent
	-
	0
	1.0e-26

	AF
	flicker noise exponent
	-
	1
	1.2

	FC
	coefficient for forward-bias depletion capacitance formula
	-
	0.5
	

	DELTA
	width effect on threshold voltage (MOS2 and MOS3)
	-
	0
	1.0

	THETA
	mobility modulation (MOS3 only
	1/V
	0
	0.1

	ETA
	static feedback (MOS3 only)
	-
	0
	1.0

	KAPPA
	saturation field factor (MOS3 only)
	-
	0.2
	0.5

	TNOM
	parameter measurement temperature
	ºC
	25
	50


The level 4 and level 5 (BSIM1 and BSIM2) parameters are all values obtained from process characterization, and can be generated automatically. J. Pierret [4] describes a means of generating a 'process' file, and the program Proc2Mod provided with SPICE3 converts this file into a sequence of BSIM1 ".MODEL" lines suitable for inclusion in a SPICE input file. Parameters marked below with an * in the l/w column also have corresponding parameters with a length and width dependency. For example, VFB is the basic parameter with units of Volts, and LVFB and WVFB also exist and have units of Volt- meter The formula
is used to evaluate the parameter for the actual device specified with
and
Note that unlike the other models in SPICE, the BSIM model is designed for use with a process characterization system that provides all the parameters, thus there are no defaults for the parameters, and leaving one out is considered an error. For an example set of parameters and the format of a process file, see the SPICE2 implementation notes[3].
For more information on BSIM2, see reference [5].
SPICE BSIM (level 4) parameters:
	name
	parameter
	units
	1/w

	VFB
	flat-band voltage
	V
	*

	PHI
	surface inversion potential
	V
	*

	K1
	body effect coefficient
	V1/2
	*

	K2
	drain/source depletion charge-sharing coefficient
	-
	*

	ETA
	zero-bias drain-induced barrier-lowering coefficient
	-
	*

	MUZ
	zero-bias mobility
	cm2/V-s
	

	DL
	shortening of channel
	micron
	

	DW
	narrowing of channel
	micron
	

	U0
	zero-bias transverse-field mobility degradation coefficient
	V-1
	*

	U1
	zero-bias velocity saturation coefficient
	micron/V
	*

	X2MZ
	sens. of mobility to substrate bias at vds=0
	cm2/V-s
	*

	X2E
	sens. of drain-induced barrier lowering effect to substrate bias
	V-1
	*

	X3E
	sens. of drain-induced barrier lowering effect to drain bias at Vds=Vdd
	V-1
	*

	X2U0
	sens. of transverse field mobility degradation effect to substrate bias
	V-2
	*

	X2U1
	sens. of velocity saturation effect to substrate bias
	micron/V2
	*

	MUS
	mobility at zero substrate bias and at Vds=Vdd
	cm2/V-s
	

	X2MS
	sens. of mobility to substrate bias at Vds=Vdd
	cm2/V-s
	*

	X3MS
	sens. of mobility to drain bias at Vds=Vdd
	cm2/V-s
	*

	X3U1
	sens. of velocity saturation effect on drain bias at Vds=Vdd
	cm2/V-s
	*

	TOX
	TOX &#9;gate oxide thickness
	micron
	

	TEMP
	temperature at which parameters were measured
	ºC
	

	VDD
	measurement bias range
	V
	

	CGD0
	gate-drain overlap capacitance per meter channel width
	F/m
	

	CGSO
	gate-source overlap capacitance per meter channel width
	F/m
	

	CGBO
	gate-bulk overlap capacitance per meter channel length
	F/m
	

	XPART
	gate-oxide capacitance-charge model flag
	-
	*

	NO
	zero-bias subthreshold slope coefficient
	-
	*

	NB
	sens. of subthreshold slope to substrate bias
	-
	*

	ND
	sens. of subthreshold slope to drain bias
	-
	

	RSH
	drain and source diffusion sheet resistance
	Ohm/square
	

	JS
	source drain junction current density
	A/m2
	

	PB
	built in potential of source drain junction
	V
	

	MJ
	Grading coefficient of source drain junction
	-
	

	PBSW
	built in potential of source, drain junction sidewall
	V
	

	MJSW
	grading coefficient of source drain junction sidewall
	-
	

	CJ
	Source drain junction capacitance per unit area
	F/m2
	

	CJSW
	source drain junction sidewall capacitance per unit length
	F/m
	

	WDF
	source drain junction default width
	m
	

	DELL
	Source drain junction length reduction
	m
	


XPART = 0 selects a 40/60 drain/source charge partition in saturation, while XPART=1 selects a 0/100 drain/source charge partition.
ND, NG, and NS are the drain, gate, and source nodes, respectively. MNAME is the model name, AREA is the area factor, and OFF indicates an (optional) initial condition on the device for dc analysis. If the area factor is omitted, a value of 1.0 is assumed. The (optional) initial condition specification, using IC=VDS, VGS is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. See the .IC control line for a better way to set initial conditions.
12.7.2.1.1.11. [bookmark: MOSFET]MOSFETs
General form: 
MXXXXXXX ND NG NS NB MNAME <L=VAL> <W=VAL> <AD=VAL> <AS=VAL> 
+ <PD=VAL> <PS=VAL> <NRD=VAL> <NRS=VAL> <OFF> 
+ <IC=VDS, VGS, VBS> <TEMP=T> 
Examples: 
M1 24 2 0 20 TYPE1 M31 2 17 6 10 MODM L=5U W=2U M1 2 9 3 0 MOD1 L=10U W=5U AD=100P AS=100P PD=40U PS=40U 
ND, NG, NS, and NB are the drain, gate, source, and bulk (substrate) nodes, respectively. MNAME is the model name. L and W are the channel length and width, in meters. AD and AS are the areas of the drain and source diffusions, in m2. Note that the suffix U specifies microns (1e-6 m) and P sq-microns (1e-12 m2). If any of L, W, AD, or AS are not specified, default values are used. The use of defaults simplifies input file preparation, as well as the editing required if device geometries are to be changed. PD and PS are the perimeters of the drain and source junctions, in meters. NRD and NRS designate the equivalent number of squares of the drain and source diffusions; these values multiply the sheet resistance RSH specified on the .MODEL control line for an accurate representation of the parasitic series drain and source resistance of each transistor. PD and PS default to 0.0 while NRD and NRS to 1.0. OFF indicates an (optional) initial condition on the device for dc analysis. The (optional) initial condition specification using IC=VDS, VGS, VBS is intended for use with the UIC option on the .TRAN control line, when a transient analysis is desired starting from other than the quiescent operating point. See the .IC control line for a better and more convenient way to specify transient initial conditions. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line. The temperature specification is ONLY valid for level 1, 2, 3, and 6 MOSFETs, not for level 4 or 5 (BSIM) devices. 
12.7.2.1.2. [bookmark: Transmission_Line6E33D559]Transmission Lines
There are several different transmission line models:
Lossless Transmission Lines 
Lossy Transmission Line Model (LTRA)
Lossy Transmission Lines
Uniform Distributed RC Lines (Lossy)
Uniform Distributed RC Model (URC)
12.7.2.1.2.1. [bookmark: Lossless_Transmission_Line53603C8C]Lossless Transmission Lines
General form:
TXXXXXXX N1 N2 N3 N4 Z0=VALUE <TD=VALUE> <F=FREQ
<NL=NRMLEN>>
+ <IC;=V1, I1, V2, I2>
Examples:
T1 1 0 2 0 Z0=50 TD=10NS 
N1 and N2 are the nodes at port 1; N3 and N4 are the nodes at port 2. Z0 is the characteristic impedance. The length of the line may be expressed in either of two forms. The transmission delay, TD, may be specified directly (as TD=10ns, for example). Alternatively, a frequency F may be given, together with NL, the normalized electrical length of the transmission line with respect to the wavelength in the line at the frequency F. If a frequency is specified but NL is omitted, 0.25 is assumed (that is, the frequency is assumed to be the quarter-wave frequency). Note that although both forms for expressing the line length are indicated as optional, one of the two must be specified.
Note that this element models only one propagating mode. If all four nodes are distinct in the actual circuit, then two modes may be excited. To simulate such a situation, two transmission-line elements are required. (see the example in \\*(AA for further clarification.)
The (optional) initial condition specification consists of the voltage and current at each of the transmission line ports. Note that the initial conditions (if any) apply 'only' if the UIC option is specified on the .TRAN control line.
Note that a lossy transmission line (see below) with zero loss may be more accurate than than the lossless transmission line due to implementation details.
12.7.2.1.2.2. [bookmark: Lossy_Transmission_Line_Model7E66FC56]Lossy Transmission Line Model (LTRA)
The uniform RLC/RC/LC/RG transmission line model (referred to as the LTRA model henceforth) models a uniform constant-parameter distributed transmission line. The RC and LC cases may also be modeled using the URC and TRA models; however, the newer LTRA model is usually faster and more accurate than the others. The operation of the LTRA model is based on the convolution of the transmission line's impulse responses with its inputs (see [8]).
The LTRA model takes a number of parameters, some of which must be given and some of which are optional.
	name
	parameter
	unirts/type
	default
	example

	R
	resistance/length
	ohm/unit
	0
	0.2

	L
	nductance/length
	henrys/unit
	0
	9.13e-9

	G
	conductance/length
	mhos/unit
	0
	0

	C
	capacitance/length
	farads/unit
	0
	3.65e-12

	LEN
	lenght of line
	
	no default
	1

	REL
	breakpoint control
	arbitary unit
	1
	0.5

	ABS
	don't limit timestep to less than line delay
	
	1
	5

	NOSTEPLIMIT
	
	flag
	not set
	set

	NOCONTROL
	use lineiaairinterpolation
	flag
	not set
	set

	LININTERP
	use lineair when quadratic seems bad
	flag
	not set
	set

	MIXEDINTERP
	special reltol for history compaction
	flag
	not set
	set

	COMPACTREL
	special abstol for history compaction
	flag
	RELTOL
	1.0e-3

	COMPACTABS
	use Newton-Raphson method for timestep control
	
	ABSTOL
	1.0e-9

	TRUNCNR
	use Newton-Raphson method for timestep control
	flag
	not set
	set

	TRUNCDONTCUT
	don't limit timestep to keep impulse-response errors low
	flag
	not set
	set


The following types of lines have been implemented so far: RLC (uniform transmission line with series loss only), RC (uniform RC line), LC (lossless transmission line), and RG (distributed series resistance and parallel conductance only). Any other combination will yield erroneous results and should not be tried. The length LEN of the line must be specified.
NOSTEPLIMIT is a flag that will remove the default restriction of limiting time-steps to less than the line delay in the RLC case. NOCONTROL is a flag that prevents the default limiting of the time-step based on convolution error criteria in the RLC and RC cases. This speeds up simulation but may in some cases reduce the accuracy of results. LININTERP is a flag that, when specified, will use linear interpolation instead of the default quadratic interpolation for calculating delayed signals. MIXEDINTERP is a flag that, when specified, uses a metric for judging whether quadratic interpolation is not applicable and if so uses linear interpolation; otherwise it uses the default quadratic interpolation. TRUNCDONTCUT is a flag that removes the default cutting of the time-step to limit errors in the actual calculation of impulse-response related quantities. COMPACTREL and COMPACTABS are quantities that control the compaction of the past history of values stored for convolution. Larger values of these lower accuracy but usually increase simulation speed. These are to be used with the TRYTOCOMPACT option, described in the .OPTIONS section. TRUNCNR is a flag that turns on the use of Newton-Raphson iterations to determine an appropriate timestep in the timestep control routines. The default is a trial and error procedure by cutting the previous timestep in half. REL and ABS are quantities that control the setting of breakpoints.
The option most worth experimenting with for increasing the speed of simulation is REL. The default value of 1 is usually safe from the point of view of accuracy but occasionally increases computation time. A value greater than 2 eliminates all breakpoints and may be worth trying depending on the nature of the rest of the circuit, keeping in mind that it might not be safe from the viewpoint of accuracy. Breakpoints may usually be entirely eliminated if it is expected the circuit will not display sharp discontinuities. Values between 0 and 1 are usually not required but may be used for setting many breakpoints.
COMPACTREL may also be experimented with when the option TRYTOCOMPACT is specified in a .OPTIONS card. The legal range is between 0 and 1. Larger values usually decrease the accuracy of the simulation but in some cases improve speed. If TRYTOCOMPACT is not specified on a .OPTIONS card, history compaction is not attempted and accuracy is high. NOCONTROL, TRUNCDONTCUT and NOSTEPLIMIT also tend to increase speed at the expense of accuracy.
12.7.2.1.2.3. [bookmark: Lossy_Transmission_Line45E64A26]Lossy Transmission Lines
General form: 
OXXXXXXX N1 N2 N3 N4 MNAME 
Examples: 
O23 1 0 2 0 LOSSYMOD OCONNECT 10 5 20 5 INTERCONNECT 
This is a two-port convolution model for single-conductor lossy transmission lines. N1 and N2 are the nodes at port 1; N3 and N4 are the nodes at port 2. Note that a lossy transmission line with zero loss may be more accurate than than the lossless transmission line due to implementation details. 
12.7.2.1.2.4. [bookmark: Uniform_Distributed_RC_LineB800E039]Uniform Distributed RC Lines (Lossy)
General form: 
UXXXXXXX N1 N2 N3 MNAME L=LEN <N=LUMPS>
Examples: 
U1 1 2 0 URCMOD L=50U URC2 1 12 2 UMODL l=1MIL N=6 
N1 and N2 are the two element nodes the RC line connects, while N3 is the node to which the capacitances are connected. MNAME is the model name, LEN is the length of the RC line in meters. LUMPS, if specified, is the number of lumped segments to use in modeling the RC line (see the model description for the action taken if this parameter is omitted). 
12.7.2.1.2.5. [bookmark: Uniform_Distributed_RC_ModelE860D398]Uniform Distributed RC Model (URC)
The URC model is derived from a model proposed by L. Gertzberrg in 1974. The model is accomplished by a subcircuit type expansion of the URC line into a network of lumped RC segments with internally generated nodes. The RC segments are in a geometric progression, increasing toward the middle of the URC line, with K as a proportionality constant. The number of lumped segments used, if not specified for the URC line device, is determined by the following formula:
The URC line is made up strictly of resistor and capacitor segments unless the ISPERL parameter is given a non-zero value, in which case the capacitors are replaced with reverse biased diodes with a zero-bias junction capacitance equivalent to the capacitance replaced, and with a saturation current of ISPERL amps per meter of transmission line and an optional series resistance equivalent to RSPERL ohms per meter.
	name
	parameter
	units
	default
	example
	area

	K
	Propagation Constant
	-
	2
	1.2
	-

	FMAX
	Maximum Frequency of interest
	Hz
	1.0G
	6.5Meg
	-

	RPERL
	Resistance per unit length
	ohm/m
	o1000
	10
	-

	CPERL
	Capacitance per unit length
	F/m
	1.0e015
	1pF
	-

	ISPERL
	Saturation Current per unit length
	A/m
	0
	-
	-

	RSPERL
	Diode Resistance per unit length
	ohm/m
	0
	-
	-



12.7.2.1.3. [bookmark: Voltag_And_Current_Source8CBD266B]Voltage and Current Sources
Spice has the following voltage and current sources:
· Independent Sources
· Linear Dependent Sources
12.7.2.1.3.1. [bookmark: Independent_Source66462BCA]Independent Sources
Spice has the following independant sources:
· Exponential
· Independent Sources
· Piece-Wise Linear
· Pulse
· Single Frequency FM
· Sinusoidal

[bookmark: Exponential]Exponential
General Form:
EXP(V1 V2 TD1 TAU1 TD2 TAU2)
Examples:
VIN 3 0 EXP(-4 -1 2NS 30NS 60NS 40NS) 
	parameter
	default value
	units

	V1 (initial value)
	-
	Volts or Amps

	V2 (pulsed value)
	-
	Volts or Amps

	TD1 (rise delay time)
	0
	seconds

	TAU1 (rise time constant)
	TSTEP
	seconds

	TD2 (fall delay time)
	TD1+TSTEP
	seconds

	TAU2 (fall time)
	TSTEP
	seconds


The shape of the waveform is described by the following table:
	time
	value

	0 to TD1
	V1

	TD1 to TD2
	

	TD2 to TSTOP
	



[bookmark: Independent_Sources2DC95B11]Independent Sources
General form:
VXXXXXXX N+ N- <DC<> DC/TRAN VALUE> <AC <ACMAG <ACPHASE>>>
+ <DISTOF1 <F1MAG <F1PHASE>>> <DISTOF2 <F2MAG <F2PHASE>>>
IYYYYYYY N+ N- <<DC> DC/TRAN VALUE> <AC <ACMAG <ACPHASE>>>
+ <DISTOF1 <F1MAG <F1PHASE>>> <DISTOF2 <F2MAG <F2PHASE>>>
Examples:
VCC 10 0 DC 6 VIN 13 2 0.001 AC 1 SIN(0 1 1MEG) ISRC 23 21 AC 0.333 45.0 SFFM(0 1 10K 5 1K) VMEAS 12 9 VCARRIER 1 0 DISTOF1 0.1 -90.0 VMODULATOR 2 0 DISTOF2 0.01 IIN1 1 5 AC 1 DISTOF1 DISTOF2 0.001 
N+ and N- are the positive and negative nodes, respectively. Note that voltage sources need not be grounded. Positive current is assumed to flow from the positive node, through the source, to the negative node. A current source of positive value forces current to flow out of the N+ node, through the source, and into the N- node. Voltage sources, in addition to being used for circuit excitation, are the 'ammeters' for SPICE, that is, zero valued voltage sources may be inserted into the circuit for the purpose of measuring current. They of course have no effect on circuit operation since they represent short-circuits.
DC/TRAN is the dc and transient analysis value of the source. If the source value is zero both for dc and transient analyses, this value may be omitted. If the source value is time-invariant (e.g., a power supply), then the value may optionally be preceded by the letters DC.
ACMAG is the ac magnitude and ACPHASE is the ac phase. The source is set to this value in the ac analysis. If ACMAG is omitted following the keyword AC, a value of unity is assumed. If ACPHASE is omitted, a value of zero is assumed. If the source is not an ac small-signal input, the keyword AC and the ac values are omitted.
DISTOF1 and DISTOF2 are the keywords that specify that the independent source has distortion inputs at the frequencies F1 and F2 respectively (see the description of the .DISTO control line). The keywords may be followed by an optional magnitude and phase. The default values of the magnitude and phase are 1.0 and 0.0 respectively.
Any independent source can be assigned a time-dependent value for transient analysis. If a source is assigned a time-dependent value, the time-zero value is used for dc analysis. There are five independent source functions: pulse, exponential, sinusoidal, piece-wise linear, and single-frequency FM. If parameters other than source values are omitted or set to zero, the default values shown are assumed. (TSTEP is the printing increment and TSTOP is the final time (see the .TRAN control line for explanation)).
[bookmark: Piece_Wise_LinearD07CF9DF]Piece-Wise Linear
General Form:
PWL(T1 V1 <T2; V2 T3 V3 T4 V4 ...>)
Examples:
VCLOCK 7 5 PWL(0 -7 10NS -7 11NS -3 17NS -3 18NS -7 50NS -7) 
Each pair of values (Ti, Vi) specifies that the value of the source is Vi (in Volts or Amps) at time=Ti. The value of the source at intermediate values of time is determined by using linear interpolation on the input values.
[bookmark: Pulse]Pulse
General form:
PULSE(V1 V2 TD TR TF PW PER)
Examples:
VIN 3 0 PULSE(-1 1 2NS 2NS 2NS 50NS 100NS) 
	parameter
	default value
	units

	V1 (initial value)
	-
	Volts orAmps

	V2 (pulsed value)
	-
	Volts orAmps

	V2 (pulsed value)
	0
	seconds

	TR (rise time)
	TSTEP
	seconds

	TF (fall time)
	TSTEP
	seconds

	PW (pulse width)
	TSTOP
	seconds

	PER(period)
	TSTOP
	seconds


A single pulse so specified is described by the following table:
	time
	value

	0
	V1

	TD
	V1

	TD+TR
	V2

	TD+TR+PW
	V2

	TD+TR+PW V2
	V1

	TSTOP
	V1


Intermediate points are determined by linear interpolation..
[bookmark: Single_Frequency_FM691601A5]Single Frequency FM
General Form:
SFFM(VO VA FC MDI FS)
Examples:
V1 12 0 SFFM(0 1M 20K 5 1K) 
	parameter
	default value
	units

	VO (offset)
	-
	Volts or Amps

	VA (amplitude)
	-
	Volts or Amps

	FC (carrier frequency)
	1/TSTOP
	Hz

	MDI (modulation index)
	-
	-

	FS (signal frequency)
	1/TSTOP
	Hz


The shape of the waveform is described by the following equation:
[bookmark: Sinusoidal]Sinusoidal
General form:
SIN(VO VA FREQ TD THETA)
Examples:
VIN 3 0 SIN(0 1 100MEG 1NS 1E10) 
	parameter
	default value
	units

	VO (offset)
	-
	Volts or Amps

	VA (amplitude)
	-
	Volts or Amps

	FREQ (frequency)
	1/TSTOP
	Hz

	TD (delay)
	0
	seconds

	THETA (damping factor)
	0
	1/seconds


The shape of the waveform is described by the following table:
	time
	value

	0 to TD
	V0

	TD to TSTOP
	



12.7.2.1.3.2. [bookmark: Linear_Dependent_SourcesD4A2D48E]Linear Dependent Sources
Spice has the following  dependant sources:
· Current-Controlled Current Sources
· Current-Controlled Voltage Sources
· Voltage-Controlled Current Sources
· Voltage-Controlled Voltage Sources
[bookmark: Linear_Dependent_Source_sIntrodu8153B0CD]Introduction
SPICE allows circuits to contain linear dependent sources characterized by any of the four equations
	i = g v
	v = e v
	i = f i
	= h i


where g, e, f, and h are constants representing transconductance, voltage gain, current gain, and transresistance, respectively.
[bookmark: Current_Controlled_Current480313AE]Current-Controlled Current Sources
General form:
FXXXXXXX N+ N- VNAM VALUE
Examples:
F1 13 5 VSENS 5 
N+ and N- are the positive and negative nodes, respectively. Current flow is from the positive node, through the source, to the negative node. VNAM is the name of a voltage source through which the controlling current flows. The direction of positive controlling current flow is from the positive node, through the source, to the negative node of VNAM. VALUE is the current gain.
[bookmark: Current_Controlled_Voltage0917EBF7]Current-Controlled Voltage Sources
General form:
HXXXXXXX N+ N- VNAM VALUE
Examples:
HX 5 17 VZ 0.5K 
N+ and N- are the positive and negative nodes, respectively. VNAM is the name of a voltage source through which the controlling current flows. The direction of positive controlling current flow is from the positive node, through the source, to the negative node of VNAM. VALUE is the transresistance (in ohms).
[bookmark: Voltage_Controlled_Current0AEEDBD9]Voltage-Controlled Current Sources
General form:
GXXXXXXX N+ N- NC+ NC- VALUE
Examples:
G1 2 0 5 0 0.1MMHO 
N+ and N- are the positive and negative nodes, respectively. Current flow is from the positive node, through the source, to the negative node. NC+ and NC- are the positive and negative controlling nodes, respectively. VALUE is the transconductance (in mhos).
[bookmark: Voltage_Controlled_VoltageCC03B422]Voltage-Controlled Voltage Sources
General form:
EXXXXXXX N+ N- NC+ NC- VALUE
Examples:
E1 2 3 14 1 2.0 
N+ is the positive node, and N- is the negative node. NC+ and NC- are the positive and negative controlling nodes, respectively. VALUE is the voltage gain..
12.7.2.1.3.3. [bookmark: Non_Linear_Dependant_Sources42F99152]Non-Linear Dependant Sources
General form:
BXXXXXXX N+ N- <I=EXPR> <V=EXPR>
Examples:
B1 0 1 I=cos(v(1))+sin(v(2)) B1 0 1 V=ln(cos(log(v(1,2)^2)))-v(3)^4+v(2)^v(1) B1 3 4 I=17 B1 3 4 V=exp(pi^i(vdd)) 
N+ is the positive node, and N- is the negative node. The values of the V and I parameters determine the voltages and currents across and through the device, respectively. If I is given then the device is a current source, and if V is given the device is a voltage source. One and only one of these parameters must be given.
The small-signal AC behavior of the nonlinear source is a linear dependent source (or sources) with a proportionality constant equal to the derivative (or derivatives) of the source at the DC operating point.
The expressions given for V and I may be any function of voltages and currents through voltage sources in the system. The following functions of real variables are defined:
	abs
	asinh
	cosh
	sin

	acos
	atan
	exp
	sinh

	acosh
	atanh
	ln
	sqrt

	asin
	cos
	log
	tan


The function "u" is the unit step function, with a value of one for arguments greater than one and a value of zero for arguments less than zero. The function "uramp" is the integral of the unit step: for an input x, the value is zero if x is less than zero, or if x is greater than zero the value is x. These two functions are useful in sythesizing piece-wise non-linear functions, though convergence may be adversely affected.
The following standard operators are defined:
+ - * / ^ unary -
If the argument of log, ln, or sqrt becomes less than zero, the absolute value of the argument is used. If a divisor becomes zero or the argument of log or ln becomes zero, an error will result. Other problems may occur when the argument for a function in a partial derivative enters a region where that function is undefined.
To get time into the expression you can integrate the current from a constant current source with a capacitor and use the resulting voltage (don't forget to set the initial voltage across the capacitor). Non-linear resistors, capacitors, and inductors may be synthesized with the nonlinear dependent source. Non-linear resistors are obvious. Non-linear capacitors and inductors are implemented with their linear counterparts by a change of variables implemented with the nonlinear dependent source. The following subcircuit will implement a nonlinear capacitor:
.Subckt nlcap pos neg
* Bx: calculate f(input voltage)
Bx 1 0 v = f(v(pos,neg))
* Cx: linear capacitance
Cx 2 0 1
* Vx: Ammeter to measure current into the capacitor
Vx 2 1 DC 0Volts
* Drive the current through Cx back into the circuit
Fx pos neg Vx 1
.ends
Non-linear inductors are similar.
12.7.2.1.4. [bookmark: Capacitor]Capacitors
General form:
CXXXXXXX N+ N- VALUE <IC=INCOND>
Examples:
CBYP 13 0 1UF COSC 17 23 10U IC=3V 
N+ and N- are the positive and negative element nodes, respectively. VALUE is the capacitance in Farads.
The (optional) initial condition is the initial (time-zero) value of capacitor voltage (in Volts). Note that the initial conditions (if any) apply 'only' if the UIC option is specified on the .TRAN control line.
12.7.2.1.5. [bookmark: Coupled_Mutual_Inductors88211951]Coupled (Mutual) Inductors
General form:
KXXXXXXX LYYYYYYY LZZZZZZZ VALUE
Examples:
K43 LAA LBB 0.999 KXFRMR L1 L2 0.87 
LYYYYYYY and LZZZZZZZ are the names of the two coupled inductors, and VALUE is the coefficient of coupling, K, which must be greater than 0 and less than or equal to 1. Using the 'dot' convention, place a 'dot' on the first node of each inductor.
12.7.2.1.6. [bookmark: Inductor]Inductors
General form:
LYYYYYYY N+ N- VALUE <IC=INCOND>
Examples:
LLINK 42 69 1UH LSHUNT 23 51 10U IC=15.7MA 
N+ and N- are the positive and negative element nodes, respectively. VALUE is the inductance in Henries.
The (optional) initial condition is the initial (time-zero) value of inductor current (in Amps) that flows from N+, through the inductor, to N-. Note that the initial conditions (if any) apply only if the UIC option is specified on the .TRAN analysis line. 
12.7.2.1.7. [bookmark: Resistor]Resistors
General form:
RXXXXXXX N1 N2 VALUE
Examples:
R1 1 2 100 RC1 12 17 1K 
N1 and N2 are the two element nodes. VALUE is the resistance (in ohms) and may be positive or negative but not zero.
12.7.2.1.8. [bookmark: Semiconductor_Capacitor_Model47CD720E]Semiconductor Capacitor Model
The capacitor model contains process information that may be used to compute the capacitance from strictly geometric information.
	name
	parameter
	units
	default
	example

	CJ
	junction bottom capacitance
	F/meter/meter
	-
	5e-5

	CJSW
	junction sidewall capacitance
	F/meter
	-
	2e-11

	DEFW
	default device width
	meters
	1e-6
	2e-6

	NARROW
	narrowing due to side etching
	meters
	0
	1e-7


The capacitor has a capacitance computed as
12.7.2.1.9. [bookmark: Semiconductor_Capacitors0DCC0E2D]Semiconductor Capacitors
General form:
CXXXXXXX N1 N2 <VALUE> <MNAME> <L=LENGTH> <W=WIDTH> <IC=VAL>
Examples:
CLOAD 2 10 10P CMOD 3 7 CMODEL L=10u W=1u 
This is the more general form of the Capacitor presented in section 6.2, and allows for the calculation of the actual capacitance value from strictly geometric information and the specifications of the process. If VALUE is specified, it defines the capacitance. If MNAME is specified, then the capacitance is calculated from the process information in the model MNAME and the given LENGTH and WIDTH. If VALUE is not specified, then MNAME and LENGTH must be specified. If WIDTH is not specified, then it is taken from the default width given in the model. Either VALUE or MNAME, LENGTH, and WIDTH may be specified, but not both sets. 
12.7.2.1.10. [bookmark: Semiconductor_Resistor_Model0BDBF2B5]Semiconductor Resistor Model
The resistor model consists of process-related device data that allow the resistance to be calculated from geometric information and to be corrected for temperature. The parameters available are:
	name
	parameter
	units
	default
	example

	TC1
	first order temperature coeff.
	Ohm/ºC
	0
	-

	TC2
	second order temperature coeff.
	Ohm/ºC/ºC
	0
	-

	RSH
	sheet resistance
	Ohm/q
	-
	50

	DEFW
	default width
	meters
	1e-6
	2e-6

	NARROW
	narrowing due to side etching
	meters
	0
	1e-7

	TNOM
	parameter measurement temperature
	ºC
	27
	50


The sheet resistance is used with the narrowing parameter and L and W from the resistor device to determine the nominal resistance by the formula
DEFW is used to supply a default value for W if one is not specified for the device. If either RSH or L is not specified, then the standard default resistance value of 1k is used. TNOM is used to override the circuit-wide value given on the .OPTIONS control line where the parameters of this model have been measured at a different temperature. After the nominal resistance is calculated, it is adjusted for temperature by the formula:
12.7.2.1.11. [bookmark: SemiconductorResistors]Semiconductor Resistors
General form:
RXXXXXXX N1 N2 <VALUE> <MNAME> <L=LENGTH> <W=WIDTH> <TEMP=T>
Examples:
RLOAD 2 10 10K RMOD 3 7 RMODEL L=10u W=1u 
This is the more general form of the resistor presented in section 6.1, and allows the modeling of temperature effects and for the calculation of the actual resistance value from strictly geometric information and the specifications of the process. If VALUE is specified, it overrides the geometric information and defines the resistance. If MNAME is specified, then the resistance may be calculated from the process information in the model MNAME and the given LENGTH and WIDTH. If VALUE is not specified, then MNAME and LENGTH must be specified. If WIDTH is not specified, then it is taken from the default width given in the model. The (optional) TEMP value is the temperature at which this device is to operate, and overrides the temperature specification on the .OPTION control line.
12.7.2.1.12. [bookmark: Switch_ModelEC564570]Switch Model
The switch model allows an almost ideal switch to be described in SPICE. The switch is not quite ideal, in that the resistance can not change from 0 to infinity, but must always have a finite positive value. By proper selection of the on and off resistances, they can be effectively zero and infinity in comparison to other circuit elements. The parameters available are:
	name
	parameter
	units
	default
	switch

	VT
	threshold voltage
	Volts
	0
	S

	IT
	threshold current
	Amps
	0
	W

	VH
	hysteresis voltage
	Volts
	0
	S

	IH
	hysteresis current
	Amps
	0
	W

	RON
	on resistance
	Ohms
	1
	both

	ROFF
	off resistance
	Ohms
	1/GMIN*
	both


*(See the .OPTIONS control line for a description of GMIN, its default value results in an off-resistance of 1.0e+12 ohms.)
The use of an ideal element that is highly nonlinear such as a switch can cause large discontinuities to occur in the circuit node voltages. A rapid change such as that associated with a switch changing state can cause numerical roundoff or tolerance problems leading to erroneous results or timestep difficulties. The user of switches can improve the situation by taking the following steps:
First, it is wise to set ideal switch impedances just high or low enough to be negligible with respect to other circuit elements. Using switch impedances that are close to "ideal" in all cases aggravates the problem of discontinuities mentioned above. Of course, when modeling real devices such as MOSFETS, the on resistance should be adjusted to a realistic level depending on the size of the device being modeled.
If a wide range of ON to OFF resistance must be used in the switches (ROFF/RON >1e;+12), then the tolerance on errors allowed during transient analysis should be decreased by using the .OPTIONS control line and specifying TRTOL to be less than the default value of 7.0. When switches are placed around capacitors, then the option CHGTOL should also be reduced. Suggested values for these two options are 1.0 and 1e-16 respectively. These changes inform SPICE3 to be more careful around the switch points so that no errors are made due to the rapid change in the circuit.
12.7.2.1.13. [bookmark: Switch]Switches
General form:
SXXXXXXX N+ N- NC+ NC- MODEL <ON><OFF>
WYYYYYYY N+ N- VNAM MODEL <ON><OFF>
Examples:
s1 1 2 3 4 switch1 ONs2 5 6 3 0 sm2 off Switch1 1 2 10 0 smodel1 w1 1 2 vclock switchmod1 W2 3 0 vramp sm1 ON wreset 5 6 vclck lossyswitch OFF 
Nodes 1 and 2 are the nodes between which the switch terminals are connected. The model name is mandatory while the initial conditions are optional. For the voltage controlled switch, nodes 3 and 4 are the positive and negative controlling nodes respectively. For the current controlled switch, the controlling current is that through the specified voltage source. The direction of positive controlling current flow is from the positive node, through the source, to the negative node. 
12.7.2.2. [bookmark: Combining_FilesE8FA72F6]Combining Files. .include lines
General form:
.INCLUDE filename
Examples:
.INCLUDE /users/spice Simulation Program for Integrated Circuit Emulation./common/wattmeter.cir 
Frequently, portions of circuit descriptions will be reused in several input files, particularly with common models and sub-circuits. In any spice input file, the ".include" line may be used to copy some other file as if that second file appeared in place of the ".include" line in the original file. There is no restriction on the file name imposed by spice beyond those imposed by the local operating system.
12.7.2.3. [bookmark: Device_Models18E76501]Device Models
General form:
.MODEL MNAME TYPE(PNAME1=PVAL1 PNAME2=PVAL2 ... )
Examples:
.MODEL MOD1 NPN (BF=50 IS=1E-13 VBF=50) 
Most simple circuit elements typically require only a few parameter values. However, some devices (semiconductor devices in particular) that are included in SPICE Simulation Program for Integrated Circuit Emulation. require many parameter values. Often, many devices in a circuit are defined by the same set of device model parameters. For these reasons, a set of device model parameters is defined on a separate .MODEL line and assigned a unique model name. The device element lines in SPICE then refer to the model name.
For these more complex device types, each device element line contains the device name, the nodes to which the device is connected, and the device model name. In addition, other optional parameters may be specified for some devices: geometric factors and an initial condition (see the following section on Transistors and Diodes for more details).
MNAME in the above is the model name, and type is one of the following fifteen types:
	R
	Semiconductor resistor model

	C
	Semiconductor capacitor model

	SW
	Voltage controlled switch

	CSW
	Current controlled switch

	URC
	Uniform distributed RC model

	LTRA
	Lossy transmission line model

	D
	Diode model

	NPN
	NPN BJT model

	PNP
	PNP BJT model

	NJF
	N-channel JFET model

	PJF
	P-channel JFET model

	NMOS
	N-channel MOSFET model

	PMOS
	P-channel MOSFET model

	NMF
	N-channel MESFET model

	PMF
	P-channel MESFET model


Parameter values are defined by appending the parameter name followed by an equal sign and the parameter value. Model parameters that are not given a value are assigned the default values given below for each model type. Models, model parameters, and default values are listed in the next section along with the description of device element lines.
12.7.2.4. [bookmark: General_StructureD6B237DA]GENERAL STRUCTURE AND CONVENTIONS
The circuit to be analyzed is described to SPICE by a set of element lines, which define the circuit topology and element values, and a set of control lines, which define the model parameters and the run controls. The first line in the input file must be the title, and the last line must be ".END". The order of the remaining lines is arbitrary (except, of course, that continuation lines must immediately follow the line being continued).
Each element in the circuit is specified by an element line that contains the element name, the circuit nodes to which the element is connected, and the values of the parameters that determine the electrical characteristics of the element. The first letter of the element name specifies the element type. The format for the SPICE element types is given in what follows. The strings XXXXXXX, YYYYYYY, and ZZZZZZZ denote arbitrary alphanumeric strings. For example, a resistor name must begin with the letter R and can contain one or more characters. Hence, R, R1, RSE, ROUT, and R3AC2ZY are valid resistor names. Details of each type of device are supplied in a following section.
Fields on a line are separated by one or more blanks, a comma, an equal ('=') sign, or a left or right parenthesis; extra spaces are ignored. A line may be continued by entering a '+' (plus) in column 1 of the following line; SPICE continues reading beginning with column 2.
A name field must begin with a letter (A through Z) and cannot contain any delimiters.
A number field may be an integer field (12, -44), a floating point field (3.14159), either an integer or floating point number followed by an integer exponent (1e-14, 2.65e3), or either an integer or a floating point number followed by one of the following scale factors:
T = 1012 G = 109 Meg = 106 K = 103 mil = 25.4 10-6
m = 10-3 u = 10-6 n = 10-9 p = 10-12 f = 10-15
Letters immediately following a number that are not scale factors are ignored, and letters immediately following a scale factor are ignored. Hence, 10, 10V, 10Volts, and 10Hz all represent the same number, and M, MA, MSec, and MMhos all represent the same scale factor. Note that 1000, 1000.0, 1000Hz, 1e3, 1.0e3, 1KHz, and 1K all represent the same number.
Nodes names may be arbitrary character strings. The datum (ground) node must be named '0'. Note the difference in SPICE3 where the nodes are treated as character strings and not evaluated as numbers, thus '0' and '00' are distinct nodes in SPICE3 but not in SPICE2. The circuit cannot contain a loop of voltage sources and/or inductors and cannot contain a cut-set of current sources and/or capacitors. Each node in the circuit must have a dc path to ground. Every node must have at least two connections except for transmission line nodes (to permit unterminated transmission lines) and MOSFET substrate nodes (which have two internal connections anyway).
12.7.2.5. [bookmark: SubCircuits]SubCircuits
A subcircuit that consists of SPICE Simulation Program for Integrated Circuit Emulation. elements can be defined and referenced in a fashion similar to device models. The subcircuit is defined in the input file by a grouping of element lines; the program then automatically inserts the group of elements wherever the subcircuit is referenced. There is no limit on the size or complexity of subcircuits, and subcircuits may contain other subcircuits. An example of subcircuit usage is given in \\*(AA.
.SUBCKT
General form:
.SUBCKT subnam N1 &ltN2; N3 ...>
Examples:
.SUBCKT OPAMP 1 2 3 4 
A circuit definition is begun with a .SUBCKT line. SUBNAM is the subcircuit name, and N1, N2, ... are the external nodes, which cannot be zero. The group of element lines which immediately follow the .SUBCKT line define the subcircuit. The last line in a subcircuit definition is the .ENDS line (see below). Control lines may not appear within a subcircuit definition; however, subcircuit definitions may contain anything else, including other subcircuit definitions, device models, and subcircuit calls (see below). Note that any device models or subcircuit definitions included as part of a subcircuit definition are strictly local (i.e., such models and definitions are not known outside the subcircuit definition). Also, any element nodes not included on the .SUBCKT line are strictly local, with the exception of 0 (ground) which is always global.
.ENDS
General form:
.ENDS &ltSUBNAM;>
Examples:
.ENDS OPAMP
The "Ends" line must be the last one for any subcircuit definition. The subcircuit name, if included, indicates which subcircuit definition is being terminated; if omitted, all subcircuits being defined are terminated. The name is needed only when nested subcircuit definitions are being made.
Subcircuit Calls
General form:
XYYYYYYY N1 &ltN2; N3 ...> SUBNA
Examples:
X1 2 4 17 3 1 MULTI
Subcircuits are used in SPICE by specifying pseudo-elements beginning with the letter X, followed by the circuit nodes to be used in expanding the subcircuit.
12.7.2.6. [bookmark: Title_Line2C31E875]Title Line, Comment Lines and .end line
Title Line
Examples:
POWER AMPLIFIER CIRCUIT
TEST OF CAM CELL
The title line must be the first in the input file. Its contents are printed verbatim as the heading for each section of output.
End line
Examples:
.END 
The "End" line must always be the last in the input file. Note that the period is an integral part of the name.
Comments
General Form:
* &ltany; comment>
Examples:
* RF=1K Gain should be 100 * Check open-loop gain and phase margin 
The asterisk in the first column indicates that this line is a comment line. Comment lines may be placed anywhere in the circuit description. Note that SPICE3 also considers any line with leading white space to be a comment.
12.7.3. [bookmark: AnalysisAndOutput]Analysis and output Control
The following analyzes are available:
· DC or Small-Signal AC Sensitivity Analysis
· DC Transfer Function
· Distortion Analysis
· Fourier Analysis
· Initial Conditions
· Noise Analysis
· Operating Point Analysis
· Pole-Zero Analysis
· Small-Signal AC Analysis
· Transfer Function Analysis
· Transient Analysis

12.7.3.1. [bookmark: Small_Signal09A5AFB2]DC or Small-Signal AC Sensitivity Analysis
General form:
.SENS OUTVAR
.SENS OUTVAR AC DEC ND FSTART FSTOP
.SENS OUTVAR AC OCT NO FSTART FSTOP
.SENS OUTVAR AC LIN NP FSTART FSTOP
Examples:
.SENS V(1,OUT) .SENS V(OUT) AC DEC 10 100 100k .SENS I(VTEST) 
The sensitivity of OUTVAR to all non-zero device parameters is calculated when the SENS analysis is specified. OUTVAR is a circuit variable (node voltage or voltage-source branch current). The first form calculates sensitivity of the DC operating-point value of OUTVAR. The second form calculates sensitivity of the AC values of OUTVAR. The parameters listed for AC sensitivity are the same as in an AC analysis (see ".AC" above). The output values are in dimensions of change in output per unit change of input (as opposed to percent change in output or per percent change of input).
12.7.3.2. [bookmark: DC_Transfe_rFunctionFF3DE9D2]DC Transfer Function
General form:
.DC SRCNAM VSTART VSTOP VINCR [SRC2 START2 STOP2 INCR2]
Examples:
.DC VIN 0.25 5.0 0.25 .DC VDS 0 10 .5 VGS 0 5 1 .DC VCE 0 10 .25 IB 0 10U 1U 
The DC line defines the dc transfer curve source and sweep limits (again with capacitors open and inductors shorted). SRCNAM is the name of an independent voltage or current source. VSTART, VSTOP, and VINCR are the starting, final, and incrementing values respectively. The first example causes the value of the voltage source VIN to be swept from 0.25 Volts to 5.0 Volts in increments of 0.25 Volts. A second source (SRC2) may optionally be specified with associated sweep parameters. In this case, the first source is swept over its range for each value of the second source. This option can be useful for obtaining semiconductor device output characteristics. See the second example circuit description in Appendix A.
12.7.3.3. [bookmark: Distortion_AnalysisA20D78C4]Distortion Analysis
General form:
.DISTO DEC ND FSTART FSTOP &ltF2OVERF1;>
.DISTO OCT NO FSTART FSTOP &ltF2OVERF1;>
.DISTO LIN NP FSTART FSTOP &ltF2OVERF1;>
Examples:
.DISTO DEC 10 1kHz 100Mhz .DISTO DEC 10 1kHz 100Mhz 0.9 
The Disto line does a small-signal distortion analysis of the circuit. A multi-dimensional Volterra series analysis is done using multi-dimensional Taylor series to represent the nonlinearities at the operating point. Terms of up to third order are used in the series expansions.
If the optional parameter F2OVERF1 is not specified, .DISTO does a harmonic analysis - i.e., it analyses distortion in the circuit using only a single input frequency F1, which is swept as specified by arguments of the .DISTO command exactly as in the .AC command. Inputs at this frequency may be present at more than one input source, and their magnitudes and phases are specified by the arguments of the DISTOF1 keyword in the input file lines for the input sources (see the description for independent sources). (The arguments of the DISTOF2 keyword are not relevant in this case). The analysis produces information about the A.C. values of all node voltages and branch currents at the harmonic frequencies 2 F1 and 3 F1, vs. the input frequency F1 as it is swept. (A value of 1 (as a complex distortion output) signifies cos( 2 (2 F1) t) at 2 F1 and cos (2 (3 F1) t ) at 3 F1, using the convention that 1 at the input fundamental frequency is equivalent to cos( 2 F1 t ).) The distortion component desired (2 F1 or 3 F1) can be selected using commands in nutmeg, and then printed or plotted. (Normally, one is interested primarily in the magnitude of the harmonic components, so the magnitude of the AC distortion value is looked at). It should be noted that these are the A.C. values of the actual harmonic components, and are not equal to HD2 and HD3. To obtain HD2 and HD3, one must divide by the corresponding A.C. values at F1, obtained from an .AC line. This division can be done using nutmeg commands.
If the optional F2OVERF1 parameter is specified, it should be a real number between (and not equal to) 0.0 and 1.0; in this case, .DISTO does a spectral analysis. It considers the circuit with sinusoidal inputs at two different frequencies F1 and F2. F1 is swept according to the .DISTO control line options exactly as in the .AC control line. F2 is kept fixed at a single frequency as F1 sweeps - the value at which it is kept fixed is equal to F2OVERF1 times FSTART. Each independent source in the circuit may potentially have two (superimposed) sinusoidal inputs for distortion, at the frequencies F1 and F2. The magnitude and phase of the F1 component are specified by the arguments of the DISTOF1 keyword in the source's input line (see the description of independent sources); the magnitude and phase of the F2 component are specified by the arguments of the DISTOF2 keyword. The analysis produces plots of all node voltages/branch currents at the intermodulation product frequencies F1 + F2, F1 - F2, and (2 F1) - F2, vs the swept frequency F1. The IM product of interest may be selected using the setplot command, and displayed with the print and plot commands. It is to be noted as in the harmonic analysis case, the results are the actual AC voltages and currents at the intermodulation frequencies, and need to be normalized with respect to .AC values to obtain the IM parameters.
If the DISTOF1 or DISTOF2 keywords are missing from the description of an independent source, then that source is assumed to have no input at the corresponding frequency. The default values of the magnitude and phase are 1.0 and 0.0 respectively. The phase should be specified in degrees.
It should be carefully noted that the number F2OVERF1 should ideally be an irrational number, and that since this is not possible in practice, efforts should be made to keep the denominator in its fractional representation as large as possible, certainly above 3, for accurate results (i.e., if F2OVERF1 is represented as a fraction A/B, where A and B are integers with no common factors, B should be as large as possible; note that A < B because F2OVERF1 is constrained to be < 1). To illustrate why, consider the cases where F2OVERF1 is 49/100 and 1/2. In a spectral analysis, the outputs produced are at F1 + F2, F1 - F2 and 2 F1 - F2. In the latter case, F1 - F2 = F2, so the result at the F1-F2 component is erroneous because there is the strong fundamental F2 component at the same frequency. Also, F1 + F2 = 2 F1 - F2 in the latter case, and each result is erroneous individually. This problem is not there in the case where F2OVERF1 = 49/100, because F1-F2 = 51/100 F1 < > 49/100 F1 = F2. In this case, there are two very closely spaced frequency components at F2 and F1 - F2. One of the advantages of the Volterra series technique is that it computes distortions at mix frequencies expressed symbolically (i.e. n F1 m F2), therefore one is able to obtain the strengths of distortion components accurately even if the separation between them is very small, as opposed to transient analysis for example. The disadvantage is of course that if two of the mix frequencies coincide, the results are not merged together and presented (though this could presumably be done as a postprocessing step). Currently, the interested user should keep track of the mix frequencies himself or herself and add the distortions at coinciding mix frequencies together should it be necessary. 
12.7.3.4. [bookmark: Fourier_Analysis7644CE71]Fourier Analysis
General form:
.FOUR FREQ OV1 <OV2 OV3 ...>
Examples:
.FOUR 100K V(5) 
The Four (or Fourier) line controls whether SPICE performs a Fourier analysis as a part of the transient analysis. FREQ is the fundamental frequency, and OV1, ..., are the output variables for which the analysis is desired. The Fourier analysis is performed over the interval &ltTSTOP-period;, TSTOP>, where TSTOP is the final time specified for the transient analysis, and period is one period of the fundamental frequency. The dc component and the first nine harmonics are determined. For maximum accuracy, TMAX (see the .TRAN line) should be set to period/100.0 (or less for very high-Q circuits).
12.7.3.5. [bookmark: Initial_Conditions4989AAE1]Initial Conditions
.NODESET: Specify Initial Node Voltage Guesses
General form:
.NODESET V(NODNUM)=VAL V(NODNUM)=VAL ...
Examples:
.NODESET V(12)=4.5 V(4)=2.23 
The Nodeset line helps the program find the dc or initial transient solution by making a preliminary pass with the specified nodes held to the given voltages. The restriction is then released and the iteration continues to the true solution. The .NODESET line may be necessary for convergence on bistable or a-stable circuits. In general, this line should not be necessary.
.IC: Set Initial Conditions
General form: .IC V(NODNUM)=VAL V(NODNUM)=VAL ... Examples: .IC V(11)=5 V(4)=-5 V(2)=2.2 
The IC line is for setting transient initial conditions. It has two different interpretations, depending on whether the UIC parameter is specified on the .TRAN control line. Also, one should not confuse this line with the .NODESET line. The .NODESET line is only to help dc convergence, and does not affect final bias solution (except for multi-stable circuits). The two interpretations of this line are as follows:
1. When the UIC parameter is specified on the .TRAN line, then the node voltages specified on the .IC control line are used to compute the capacitor, diode, BJT, JFET, and MOSFET initial conditions. This is equivalent to specifying the IC=... parameter on each device line, but is much more convenient. The IC=... parameter can still be specified and takes precedence over the .IC values. Since no dc bias (initial transient) solution is computed before the transient analysis, one should take care to specify all dc source voltages on the .IC control line if they are to be used to compute device initial conditions.
2. When the UIC parameter is not specified on the .TRAN control line, the dc bias (initial transient) solution is computed before the transient analysis. In this case, the node voltages specified on the .IC control line is forced to the desired initial values during the bias solution. During transient analysis, the constraint on these node voltages is removed. This is the preferred method since it allows SPICE to compute a consistent dc solution.
12.7.3.6. [bookmark: Noise_AnalysisB96B6CB7]Noise Analysis
General form:
.NOISE V(OUTPUT <,REF>) SRC ( DEC | LIN | OCT ) PTS FSTART FSTOP <PTS_PER_SUMMARY>
Examples:
.NOISE V(5) VIN DEC 10 1kHZ 100Mhz .NOISE V(5,3) V1 OCT 8 1.0 1.0e6 1 
The Noise line does a noise analysis of the circuit. OUTPUT is the node at which the total output noise is desired; if REF is specified, then the noise voltage V(OUTPUT) - V(REF) is calculated. By default, REF is assumed to be ground. SRC is the name of an independent source to which input noise is referred. PTS, FSTART and FSTOP are .AC type parameters that specify the frequency range over which plots are desired. PTS_PER_SUMMARY is an optional integer; if specified, the noise contributions of each noise generator is produced every PTS_PER_SUMMARY frequency points.
The .NOISE control line produces two plots - one for the Noise Spectral Density curves and one for the total Integrated Noise over the specified frequency range. All noise voltages/currents are in squared units V2/Hz and A2/Hz for spectral density, V2 and A2 for integrated noise).
12.7.3.7. [bookmark: Operating_Point_Analysis0BB71E4D]Operating Point Analysis
General form: 
.OP 
The inclusion of this line in an input file directs SPICE to determine the dc operating point of the circuit with inductors shorted and capacitors opened. Note: a DC analysis is automatically performed prior to a transient analysis to determine the transient initial conditions, and prior to an AC small-signal, Noise, and Pole-Zero analysis to determine the linearized, small-signal models for nonlinear devices (see the KEEPOPINFO variable above).
12.7.3.8. [bookmark: PLOT_LinesFADFFE5B]PLOT Lines
General form:
.PLOT PLTYPE OV1 <(PLO1, PHI1)> <OV2 <(PLO2, PHI2)> ... OV8>
Examples:
.PLOT DC V(4) V(5) V(1) .PLOT TRAN V(17, 5) (2, 5) I(VIN) V(17) (1, 9) .PLOT AC VM(5) VM(31, 24) VDB(5) VP(5) .PLOT DISTO HD2 HD3(R) SIM2 .PLOT TRAN V(5, 3) V(4) (0, 5) V(7) (0, 10) 
The Plot line defines the contents of one plot of from one to eight output variables. PLTYPE is the type of analysis (DC, AC, TRAN, NOISE, or DISTO) for which the specified outputs are desired. The syntax for the OVI is identical to that for the .PRINT line and for the plot command in the interactive mode.
The overlap of two or more traces on any plot is indicated by the letter X.
When more than one output variable appears on the same plot, the first variable specified is printed as well as plotted. If a printout of all variables is desired, then a companion .PRINT line should be included.
There is no limit on the number of .PLOT lines specified for each type of analysis.
12.7.3.9. [bookmark: Pole_Zero_Analysis1C500850]Pole-Zero Analysis
General form:
.PZ NODE1 NODE2 NODE3 NODE4 CUR POL
.PZ NODE1 NODE2 NODE3 NODE4 CUR ZER
.PZ NODE1 NODE2 NODE3 NODE4 CUR PZ
.PZ NODE1 NODE2 NODE3 NODE4 VOL POL
.PZ NODE1 NODE2 NODE3 NODE4 VOL ZER
.PZ NODE1 NODE2 NODE3 NODE4 VOL PZ
Examples:
.PZ 1 0 3 0 CUR POL .PZ 2 3 5 0 VOL ZER .PZ 4 1 4 1 CUR PZ 
CUR stands for a transfer function of the type (output voltage)/(input current) while VOL stands for a transfer function of the type (output voltage)/(input voltage). POL stands for pole analysis only, ZER for zero analysis only and PZ for both. This feature is provided mainly because if there is a nonconvergence in finding poles or zeros, then, at least the other can be found. Finally, NODE1 and NODE2 are the two input nodes and NODE3 and NODE4 are the two output nodes. Thus, there is complete freedom regarding the output and input ports and the type of transfer function.
In interactive mode, the command syntax is the same except that the first field is PZ instead of .PZ. To print the results, one should use the command 'print all'.
12.7.3.10. [bookmark: Print_Lines4BA4A14B]PRINT Lines
General form:
.PRINT PRTYPE OV1 <OV2 ... OV8>
Examples:
.PRINT TRAN V(4) I(VIN) .PRINT DC V(2) I(VSRC) V(23, 17) .PRINT AC VM(4, 2) VR(7) VP(8, 3) 
The Print line defines the contents of a tabular listing of one to eight output variables. PRTYPE is the type of the analysis (DC, AC, TRAN, NOISE, or DISTO) for which the specified outputs are desired. The form for voltage or current output variables is the same as given in the previous section for the print command; Spice2 restricts the output variable to the following forms (though this restriction is not enforced by Spice3):
V(N1<,N2>)
specifies the voltage difference between nodes N1 and N2. If N2 (and the preceding comma) is omitted, ground (0) is assumed. See the print command in the previous section for more details. For compatibility with spice2, the following five additional values can be accessed for the ac analysis by replacing the "V" in V(N1,N2) with:
VR - real part
VI - imaginary part
VM - magnitude
VP - phase
VDB - 20 log10(magnitude)
I(VXXXXXXX) specifies the current flowing in the independent voltage source named VXXXXXXX. Positive current flows from the positive node, through the source, to the negative node. For the ac analysis, the corresponding replacements for the letter I may be made in the same way as described for voltage outputs.Output variables for the noise and distortion analyses have a different general form from that of the other analyses.
There is no limit on the number of .PRINT lines for each type of analysis. 
12.7.3.11. [bookmark: Save_LinesB7B8645F]SAVE Lines
General form:
.SAVE vector vector vector ...
Examples:
.SAVE i(vin) input output .SAVE @m1[id] 
The vectors listed on the .SAVE line are recorded in the rawfile for use later with spice3 or nutmeg (nutmeg is just the data-analysis half of spice3, without the ability to simulate). The standard vector names are accepted. If no .SAVE line is given, then the default set of vectors are saved (node voltages and voltage source branch currents). If .SAVE lines are given, only those vectors specified are saved. For more discussion on internal device data, see Appendix B. See also the section on the interactive command interpretor for information on how to use the rawfile.
12.7.3.12. [bookmark: AnalysisOptions]Analysis Options
The Analysis Options dialog box is shown below.
Select the option to change by clicking the left mouse button over the option name.
For full details on the options see Simulator variables.
Reset to default. Click to set the options back to the SPICE defaults.
Use default value. Check to use the default value. Uncheck to change the value.
OK. Click to accept your changes.
Cancel. Cancel your changes.
Help. Display this help topic.
12.7.3.13. [bookmark: Simulator_VariablesD2F546FE]Simulator Variables
SIMULATOR VARIABLES (.OPTIONS)
Various parameters of the simulations available in Spice3 can be altered to control the accuracy, speed, or default values for some devices. These parameters may be changed via the "set" command (described later in the section on the interactive front-end) or via the ".OPTIONS" line:
General form:
.OPTIONS OPT1 OPT2 ... (or OPT=OPTVAL ...)
Examples:
.OPTIONS RELTOL=.005 TRTOL=8 
The options line allows the user to reset program control and user options for specific simulation purposes. Additional options for Nutmeg may be specified as well and take effect when Nutmeg reads the input file. Options specified to Nutmeg via the 'set' command are also passed on to SPICE3 as if specified on a .OPTIONS line. See the following section on the interactive command interpreter for the parameters which may be set with a .OPTIONS line and the format of the 'set' 'command. Any combination of the following options may be included, in any order. 'x' (below) represents some positive number.
	Option
	Effect

	ABSTOL=x
	resets the absolute current error tolerance of the program. The default value is 1 picoamp.

	BADMOS3
	Use the older version of the MOS3 model with the "kappa" discontinuity.

	CHGTOL=x
	resets the charge tolerance of the program. The default value is 1.0e-14.

	DEFAD=x
	resets the charge tolerance of the program. The default value is 1.0e-14.

	DEFAS=x
	resets the value for MOS source diffusion area; the default is 0.0.

	DEFL=x
	resets the value for MOS source diffusion area; the default is 0.0.

	DEFW=x
	resets the value for MOS channel width; the default is 100.0 micrometer

	GMIN=x
	resets the value of GMIN, the minimum conductance allowed by the program. The default value is 1.0e-12.

	ITL1=x
	resets the dc iteration limit. The default is 100.

	ITL2=x
	resets the dc transfer curve iteration limit. The default is 50.

	ITL3=x
	resets the lower transient analysis iteration limit. the default value is 4. (Note: not implemented in Spice3).

	ITL4=x
	resets the transient analysis timepoint iteration limit. the default is 10.

	ITL5=x
	resets the transient analysis total iteration limit. the default is 5000. Set ITL5=0 to omit this test. (Note: not implemented in Spice3).

	KEEPOPINFO
	Retain the operating point information when either an AC, Distortion, or Pole-Zero analysis is run. This is particularly useful if the circuit is large and you do not want to run a (redundant) ".OP" analysis.

	METHOD=name
	resets the numerical integration method used by SPICE. Possible names are "Gear" or "trapezoidal" (or just "trap"). The default is trapezoidal.

	PIVREL=x
	resets the relative ratio between the largest column entry and an acceptable pivot value. The default value is 1.0e-3. In the numerical pivoting algorithm the allowed minimum pivot value is determined by EPSREL=AMAX1(PIVREL*MAXVAL, PIVTOL) where MAXVAL is the maximum element in the column where a pivot is sought (partial pivoting).

	PIVTOL=x
	resets the absolute minimum value for a matrix entry to be accepted as a pivot. The default value is 1.0e-13.

	RELTOL=x
	resets the relative error tolerance of the program. The default value is 0.001 (0.1%).

	TEMP=x
	Resets the operating temperature of the circuit. The default value is 27 deg C (300 deg K). TEMP can be overridden by a temperature specification on any temperature dependent instance.

	TNOM=x
	resets the nominal temperature at which device parameters are measured. The default value is 27 deg C (300 deg K). TNOM can be overridden by a specification on any temperature dependent device model.

	TRTOL=x
	resets the transient error tolerance. The default value is 7.0. This parameter is an estimate of the factor by which SPICE overestimates the actual truncation error.

	TRYTOCOMPACT
	Applicable only to the LTRA model. When specified, the simulator tries to condense LTRA transmission lines' past history of input voltages and currents.

	VNTOL=x
	resets the absolute voltage error tolerance of the program. The default value is 1 microvolt.


In addition, the following options have the listed effect when operating in spice2 emulation mode:
	Option
	Effect

	ACCT
	causes accounting and run time statistics to be printed

	LIST
	causes the summary listing of the input data to be printed

	NOMOD
	suppresses the printout of the model parameters

	NOPAGE
	suppresses page ejects

	NODE
	causes the printing of the node table.

	OPTS
	causes the option values to be printed.



12.7.3.14. [bookmark: Small_Signal_AC_AnalysisA4E227E4]Small-Signal AC Analysis
General form:
.AC DEC ND FSTART FSTOP
.AC OCT NO FSTART FSTOP
.AC LIN NP FSTART FSTOP
Examples:
.AC DEC 10 1 10K .AC DEC 10 1K 100MEG .AC LIN 100 1 100HZ 
DEC stands for decade variation, and ND is the number of points per decade. OCT stands for octave variation, and NO is the number of points per octave. LIN stands for linear variation, and NP is the number of points. FSTART is the starting frequency, and FSTOP is the final frequency. If this line is included in the input file, SPICE Simulation Program for Integrated Circuit Emulation. performs an AC analysis of the circuit over the specified frequency range. Note that in order for this analysis to be meaningful, at least one independent source must have been specified with an ac value. 
12.7.3.15. [bookmark: Transfer_Function_Analysis4DC8A72B]Transfer Function Analysis
General form:
.TF OUTVAR INSRC
Examples:
.TF V(5, 3) VIN .TF I(VLOAD) VIN 
The TF line defines the small-signal output and input for the dc small-signal analysis. OUTVAR is the small-signal output variable and INSRC is the small-signal input source. If this line is included, SPICE computes the dc small-signal value of the transfer function (output/input), input resistance, and output resistance. For the first example, SPICE would compute the ratio of V(5, 3) to VIN, the small 
12.7.3.16. [bookmark: Transient_Analysis3D702F63]Transient Analysis
General form:
.TRAN TSTEP TSTOP &ltTSTART; &ltTMAX;>>
Examples:
.TRAN 1NS 100NS .TRAN 1NS 1000NS 500NS .TRAN 10NS 1US 
TSTEP is the printing or plotting increment for line-printer output. For use with the post-processor, TSTEP is the suggested computing increment. TSTOP is the final time, and TSTART is the initial time. If TSTART is omitted, it is assumed to be zero. The transient analysis always begins at time zero. In the interval &ltzero;, TSTART>, the circuit is analyzed (to reach a steady state), but no outputs are stored. In the interval &ltTSTART;, TSTOP>, the circuit is analyzed and outputs are stored. TMAX is the maximum stepsize that SPICE uses; for default, the program chooses either TSTEP or (TSTOP-TSTART)/50.0, whichever is smaller. TMAX is useful when one wishes to guarantee a computing interval which is smaller than the printer increment, TSTEP.
UIC (use initial conditions) is an optional keyword which indicates that the user does not want SPICE to solve for the quiescent operating point before beginning the transient analysis. If this keyword is specified, SPICE uses the values specified using IC=... on the various elements as the initial transient condition and proceeds with the analysis. If the .IC control line has been specified, then the node voltages on the .IC line are used to compute the initial conditions for the devices. Look at the description on the .IC control line for its interpretation when UIC is not specified. 
12.8. [bookmark: Independent_Sources_for_Voltag2F8B2AEF]Independent Sources for Voltage or Current
Enter topic text here.
12.8.1. [bookmark: Exponential_SourcesF5283930] Exponential Sources


The shape of the waveform is described by the following formula:






13. [bookmark: Text_Sheets_Chapter44EE8ED0]Text Document Sheets
You can add text documents to your design.
Adding Text Document Sheets

A Text Document

13.1. [bookmark: Adding_Text_SheetsA3E0D2BC]Adding Text  Document Sheets
To add a text documents to your design click the Home→Sheet→ button.


14. [bookmark: PCB]The PCB
A printed circuit board, or PCB, is used to mechanically support and electrically connect electronic components using conductive pathways, tracks or signal traces etched from copper sheets laminated onto a non-conductive substrate. When the board has only copper tracks and features, and no circuit elements such as capacitors, resistors or active devices have been manufactured into the actual substrate of the board, it is more correctly referred to as printed wiring board (PWB) or etched wiring board. Use of the term PWB or printed wiring board although more accurate and distinct from what would be known as a true printed circuit board, has generally fallen by the wayside for many people as the distinction between circuit and wiring has become blurred. Today printed wiring (circuit) boards are used in virtually all but the simplest commercially produced electronic devices, and allow fully automated assembly processes that were not possible or practical in earlier era tag type circuit assembly processes.
A printed circuit board (PCB) mechanically supports and electrically connects electronic components or electrical components using conductive tracks, pads and other features etched from one or more sheet layers of copper laminated onto and/or between sheet layers of a non-conductive substrate. Components are generally soldered onto the PCB to both electrically connect and mechanically fasten them to it.
Printed circuit boards are used in all but the simplest electronic products. They are also used in some electrical products, such as passive switch boxes.
PCBs can be single-sided (one copper layer), double-sided (two copper layers on both sides of one substrate layer), or multi-layer (outer and inner layers of copper, alternating with layers of substrate). Multi-layer PCBs allow for much higher component density, because circuit traces on the inner layers would otherwise take up surface space between components. The rise in popularity of multilayer PCBs with more than two, and especially with more than four, copper planes was concurrent with the adoption of surface mount technology. However, multilayer PCBs make repair, analysis, and field modification of circuits much more difficult and usually impractical.

A PCB populated with electronic components is called a printed circuit assembly (PCA), printed circuit board assembly or PCB Assembly (PCBA). In informal use the term "PCB" is used both for bare and assembled boards, the context clarifying the meaning.
Viewing the PCB
Viewing the PCB in 3D
Semi-Transparent PCBs
PCB Internals
The PCB Border
14.1. [bookmark: How_PCB_Are_Made36AAFD91]How PCBs Are Made


14.2. [bookmark: Design_for_manufacturability30D2E30B]Design for manufacturability
In the PCB design process, DFM leads to a set of design guidelines that attempt to ensure manufacturability. By doing so, probable production problems may be addressed during the design stage.
Ideally, DFM guidelines take into account the processes and capabilities of the manufacturing industry. Therefore, DFM is constantly evolving.
As manufacturing companies evolve and automate more and more stages of the processes, these processes tend to become cheaper. DFM is usually used to reduce these costs. For example, if a process may be done automatically by machines (i.e. SMT component placement and soldering), such process is likely to be cheaper than doing so by hand.

14.3. [bookmark: PCB_Standards83252404]PCB Standards
The IPC
IPC, the Association Connecting Electronics Industries, is a trade association whose aim is to standardize the assembly and production requirements of electronic equipment and assemblies. It was founded in 1957 as the Institute for Printed Circuits. Its name was later changed to the Institute for Interconnecting and Packaging Electronic Circuits to highlight the expansion from bare boards to packaging and electronic assemblies. In 1999, the organization formally changed its name to IPC with the accompanying tagline, Association Connecting Electronics Industries.

IPC is accredited by the American National Standards Institute (ANSI) as a standards developing organization[2] and is known globally for its standards. It publishes the most widely used acceptability standards in the electronics industry.

IPC is headquartered in Bannockburn, Illinois, United States and maintains additional offices in Washington, D.C.; Taos, New Mexico; Arlington County, Virginia, in the United States; Stockholm, Sweden; Brussels, Belgium; Moscow, Russia; Bangalore, India; and Shanghai, Shenzhen and Beijing, China.

Find out more...

14.4. [bookmark: Panelised_PCBsE3404FE8]Panelised PCBs
When you submit your design to your PCB manufacturer, in addition to just sending a single PCB design and allowing the manufacturer to create the PCB as they wish, you can also ask the manufacturer to create a PCB panel.
Number of PCB's Per Panel
Having a higher number of PCB's per panel will reduce manufacturing costs and is essential for automated assembly using pick and place machines if the PCB is small. 
For an order with a small number of units, single-up panels are usually OK.
But when orders get larger, over 25 pieces, you are best to consider making the panels larger in order to improve the assembly process.
If the individual PCB's themselves are large, then a single-up panel may be necessary, regardless of the number of units ordered. For example if the individual PCB is over say 200mm then it is probable that it would need to remain a single-up panel. 
However, if the PCB is under that, and the quantity is sufficient, then putting more PCB's into a panel would be preferred. 

2 x 2 PCB Panel (4 PCBs)



14.4.1. [bookmark: Creating_a_PCB_Panel0978225E]Creating a PCB Panel
To create a PCB panel, in the properties panel while viewing the PCB with nothing selected you will see the PCB Panel section.
If you expand it, you will see the controls below.
The PCB Panel Control in the Properties Panel

With the PCB Panel control you can:
Set the number of columns and rows of the PCB in the panel.

Set the spacing between the  columns and rows.

Optionally add a pair of vertical rails on the left and right of the panel.

Optionally add a pair of horizontal rails on the top and bottom of the panel.

Add Breakouts - useful for non-rectangular PCBs.

Add 3 fiducials to allow setup for a pick and place machine.

Add 4 Tooling holes.

Add V-Grooves around the border of all the PCBs.

Add V-Grooves between the rows and columns of PCBs. 

Add twin cuts if you have non-zero column/row spacings.

You can also edit most of the parameters in the CAM settings pop up.




14.4.2. [bookmark: PCB_Breakaway_Panels67DD4745]PCB Breakaway Panels
To produce a cost-effective layout through optimum PCB material usage, you are recommended to consult with your PCB manufacturer to determine the optimum panel size.  The PCB should be design to utilize the manufacturers suggested usable area. Smaller PCBs may be ganged of red in the uniform apparel format to simplify fixture and reduce excessive angling during assembly.
The main reason for having your boards delivered in an array is to make automated assembly faster and less expensive. Running an array of boards through a pick-and-place machine is far more efficient than sending them through one at a time. Arrays are also desirable because they allow the addition of tooling rails, tooling holes, and fiducials, all of which help your assembler.
Tooling Rails are the 'holding frame' for the array. They provide stability and make it easier to handle the arrays throughout the assembly process. Tooling holes and fiducials are usually added to the tooling rails.
Tooling Holes are non-plated holes added to the rails so the array can be pinned down to prevent unwanted shifting during assembly. They are typically 0.125" in diameter but can be drilled to your required specification.
Fiducials are copper markers on the rails, which aid automated pick-and-place assembly equipment by providing a uniform reference point. The copper fiducial is typically 0.04" in diameter and will not be covered with mask to make it easier for assembly equipment to see.
A PCB panel may include several into circuit boards arranged in a matrix or simply one printer circuit board requiring additional material retained for efficient assembly. The large PCB are several smaller PCBs are retained in the panel separated after all assembly is completed. Separating the individual PCBs from the panel can be done using several methods which include the – will scarring, and see routing and slotted routes with breakaway tabs.
What type of array to use?
There are 3 types of arrays:
1. Scored
1. Tab Routed 
1. A mixture of both. 
So how do you decide which one is right for your design?
Scoring is the preferred choice for two reasons. 
1. Scoring has the advantage of a more consistently smooth board edge, 
1. and it wastes less material, which can mean cost savings especially for larger quantities or high layer count printed circuit boards where every square inch counts.
You should consider tab routing when your design has an irregular shape or if you need space between your boards to allow for overhanging components.
A mix of scoring and tab routing can be used when some board sides are straight, which can be scored, while irregular sides must be tab routed.
There are two ways to create PCB Breakaway Panels.
· Mouse bites (a.k.a. breakaway This is a test of the font height tab on routing)
· V – score (a.k.a. V–Grove)
V–Grooves
V–Groves are cuts, usually on both sides of a PCB and generally in a straight line. They are made with a cutter with a cut angle of 30° or 45°
You need tooling rails along the two longest sides and there should be no space between the boards. The score will be made along the shared board outline. Scoring is performed only parallel to the x- and y-axes, not diagonally. Because scoring runs all the way across the array in a straight line, the board outline should be straight for scored arrays.
The score depth is approximately ⅓ of the total material thickness. Score lines will be made on the top and bottom sides of the PCB. This will leave a remaining web of material equal to approximately ⅓ of the total thickness of the board. If your board is1mm thick, the remaining material will be ~0..33mm.
Standard PCB material is basically fiberglass. Even though your board is scored, it will still be sturdy so be careful when separating the boards. You should expect some amount of flexing before the score line will give. Some fiberglass strands are common along a scored edge. A quick skim with a sander will take care of any rough areas.
Jump Scoring
It is possible to stop a score from continuing all the way across an array; this is referred to as jump scoring. However, this is not a recommended array solution due to the limitations and expense of this process. We strongly encourage the use of tab routing rather than jump scoring.
Scoring cannot be stopped precisely enough to end a score line like a CNC route. To make a complete score, the scoring blade must travel past the end point and come to a stop. You need a minimum of a 7 mm gap between the stop score location and anything that is not intended to be scored.

Tab Routed Arrays
If your design has an irregular shape, then tab routing may be required. AutoTRAX will add a gap, equal to the router cut width, between the boards to allow the router bit to pass between them. Small tabs of material will remain to hold the boards in place. To make separation easier, you can add small non-plated holes to the tabs called 'mouse bites to perforate the tab. If you desire a smooth edge on your PCBs, these areas will need to be sanded after the boards are removed from the array.
Because tab routed arrays are inherently less sturdy than scored arrays,You should add tooling rails to all 4 sides of the array. This will give your array of PCBs  more support during handling and assembly processes.  

Mouse Bites
Each break-out tab has it's own set of 5 automatically created mouse-bite holes.
Break-apart tab with mouse-bites

Breakout
The spacing between breakaway tabs can range from 60 mm to 90 mm, but the IPC recommend 75mm or 3" . Try not to exceed 100 mm between tabs and try to evenly space them apart.

14.4.3. [bookmark: Tab_Routed_ArraysDCB257F8]Tab Routed Arrays
If your design has an irregular shape, then tab routing may be required. AutoTRAX will add a gap, equal to the router cut width, between the boards to allow the router bit to pass between them. Small tabs of material will remain to hold the boards in place. To make separation easier, you can add small non-plated holes to the tabs called 'mouse bites to perforate the tab. If you desire a smooth edge on your PCBs, these areas will need to be sanded after the boards are removed from the array.
Because tab routed arrays are inherently less sturdy than scored arrays,You should add tooling rails to all 4 sides of the array. This will give your array of PCBs  more support during handling and assembly processes.  

Single PCB with routed break-apart tabs on 4 sides


Magnified View of break-apart tab with mouse-bites
14.4.4. [bookmark: Adding_V_Grooves1C6BB162]Adding V-Grooves
You can add V-Grooves to your panel. These are used to quickly snap apart the panel to separate out the individual PCBs.

Add V-Grooves around the border of all the PCBs.

V-Grooves on all 4 edges of the PCB array

Add V-Grooves between the rows and columns of PCBs. 

V-Grooves on all 4 edges of the PCB array and between PCBs

Add twin cuts if you have non-zero column/row spacings.

Twin cuts between PCB rows and columns

14.4.5. [bookmark: Adding_Panel_Fiducials9E140AB1]Adding Fiducials
To add 3 fiducial marks to your panel check the  checkbox in the Panels control.
If checked, 3 fiducial marks in copper will be added to 3 corners of your panel as shown below.
Panel fiducials are called global fiducials by the IPC.
You can also added local 
Pick and Place Origin
If you add automatic fiducial to your panel then the origin for the Pick and Place file coordinates is set to the lower left fiducial else it is set to the bottom left corner of the panel.


14.4.6. [bookmark: Adding_Tooling_Holes9E90DBEC]Adding Tooling Holes
Tooling holes, while not as relevant as they used to be, are still valuable to have and do not usually cost any extra to add. You can put 4 of them in the corners and they are 3.175mm in diameter (which is 1/8" which was a standard pin support size that most of the industry standardized on in the 80's)

You can add 4 tooling holes 1/8" in diameter to the 4 corners of the panel

Check Add Tooling Holes to automatically add 4 tooling holes.



14.4.7. [bookmark: Assembly_Rails04ED8E56]Assembly Rails
When using pick and place machines to populate your PCBs you should add assembly rails to the edges of your panel.
The purpose of a frame around the panel is to make sure that if there are any parts that hang over the edges, they have clearance from machinery.
Rails should typically have a width of half an inch or 12.7mm. 
In order to save money, you may want just 2 rails instead of 4. In other words you will sometimes want rails on 2 sides instead of rails on all 4 sides.
If you are using only 2 rails then they should be on the long edge of the panel, not the short edge.
You can add optional assembly rails on:
1. Both the left and right side of the array of PCBs and/or
1. Both the top and bottom side of the PCB array.
Below are some examples of using assembly rails.
Single Design Before Panelization


Panel for a PCB arrayed 56 times (8x7) With No Assembly Rails
	
	


Top and Bottom Assembly Rails
	1. 
	


Left and Right Assembly Rails
	
	


Assembly Rails on all 4 Sides
	
	



14.4.8. [bookmark: The_Panel_HeaderDFBB3DD6]The Panel Header
You can optionally add a text header to your panel. The header will only appear if you have added a set of vertical or horizontal rails. The header will appear on the top rail if the rail exists else it is added to the left rail.


Header on top rail

Header on the left rail

14.4.9. [bookmark: The_Panel_Pick_and_Place_File45D7D203]The Panel's Pick and Place File
Pick and Place Origin
If you add automatic fiducial to your panel then the origin for the Pick and Place file coordinates is set to the lower left fiducial else it is set to the bottom left corner of the panel.
Creating the Pick and Place File
The pick and place file is added to your zip file if you use the Prepare for Manufacturing option.

Part of a typical pick and place file
Note: the duplication of part references for each part on each arrayed PCB


14.5. [bookmark: Viewing_The_PCB731763E7]Viewing the PCB
To view the PCB for a design:
· Click on the  button in the Schematics/Panels button group or 
· the Panels→Windows button group or right-click in a schematic view and click on the View PCB button or
· In the Project Panel, double-click on the PCB in the project tree.
14.6. [bookmark: Viewing_PCB_In_3DEBDAA2E3]Viewing the PCB in 3D
To view the PCB or part in 3D:
Click on the  button in the Panels→Window button group or the PCB→Panels button group.
Alternately right-click in the PCB view and click on the View in 3D menu item.
The 3D view includes:
· Real-time shadows
· Reflective surfaces
· Texture maps and images
· Surface bump textures
· Automatic solder added
· 3D copper tracks
· Parametrically generated 3D parts
· Exploded PCB view

3D view of a PCB

3D Exploded View

3D view of a part


14.6.1. [bookmark: The_3D_Viewport_Menu_CommandsB61BE997]The 3D Viewport Menu Commands

You'll find several useful commands for controlling the views and layouts of the 3D viewport in the top ribbon menu under the 3D ribbon tab.
The import/export ribbon group contains several useful commands for importing and exporting 3-D.
Import/Export

Import
Click on the  button to import 3D into your design.
Find Out More...
Export
STL
Click on the  button to export a STL file.
STL (an abbreviation of "stereolithography") is a file format native to the stereolithography CAD software created by 3D Systems.The STL format specifies both ASCII and binary representations. Binary files are more common, since they are more compact.An STL file describes a raw, unstructured triangulated surface by the unit normal and vertices (ordered by the right-hand rule) of the triangles using a three-dimensional Cartesian coordinate system. In the original specification, all STL coordinates were required to be positive numbers, but this restriction is no longer enforced and negative coordinates are commonly encountered in STL files today. STL files contain no scale information, and the units are arbitrary.
OBJ
Click the  will export the 3-D to a Wavefront OBJ file.
OBJ (or .OBJ) is a geometry definition file format first developed by Wavefront Technologies for its Advanced Visualizer animation package. The file format is open and has been adopted by other 3D graphics application vendors.
The OBJ file format is a simple data-format that represents 3D geometry alone — namely, the position of each vertex, the UV position of each texture coordinate vertex, vertex normals, and the faces that make each polygon defined as a list of vertices, and texture vertices. Vertices are stored in a counter-clockwise order by default, making explicit declaration of face normals unnecessary. OBJ coordinates have no units, but OBJ files can contain scale information in a human readable comment line.
Collada
The   will export the 3-D to a Collada file.
COLLADA (COLLAborative Design Activity) is an interchange file format for interactive 3D applications. It is managed by the nonprofit technology consortium, the Khronos Group, and has been adopted by ISO as a publicly available specification.
POVRAY
The  button will create a POV RAY photorealistic render file. 
If you have POV RAY installed then the POV RAY program will start and render your file in 3D. The  Persistence of Vision Ray Tracer, or POV-Ray, is a ray tracing program which generates images from a text-based scene description, and is available for a variety of computer platforms.
Find Out More...
Views

Model

Command

Pan

Rotate

Add

Find Out More...
Multiple Viewports
You can have anywhere from 1 to 4 views  into the same scene. Click on any of the five buttons in the viewport's menu to select the view configuration. The pattern in the buttons show you the layout of the individual views



Find Out More...
14.6.2. [bookmark: Floating_The_3D_Viewport65CB46F7]Floating the 3D Viewport
To float the 3D viewport double click on the 3D viewport's name tab.  You can also hold down the left mouse button over the name tab and drag it, the viewport will then float when you release the left mouse button.. You can then re-size and move the 3D viewport. You can even move it to another screen. If you save the design, then the next time the design is opened the floating 3D viewport will appear.
Floating 3D Viewport

14.6.3. [bookmark: 3D_View_Control20C51289]3D View Control

You can set several viewing options for 3D using the 3D tab in the properties panel. Click on  to expand the control.

Viewing
This set of controls set the visibility of various parts of the PCB and also the thickness of the PCB.

Board Thickness. This is the total thickness of the board including the copper layers on the upper and lower surfaces.
Copper Thickness. This is the thickness of the copper on the top and bottom side of the PCB.
Explode. Check this to create an exploded view of the PCB. This will show you the internals of the PCB.
Exploded View of the PCB

Show Parts. Uncheck this to hide the parts and show only the PCB.
Show Parts Unchecked

Show Holes. Check this to show the PCB holes. If unchecked the holes will not be visible.
Show Parts and Show Holes Unchecked

Display Copper as Layer Color. Check this to display the copper with the same color as the color in the to the PCB view.

Show Pads as Yellow. Check this to show all pads colored yellow.

Draw All Copper Yellow. Check this to show all copper colored yellow.
All copper on the top and bottom of the PCB drawn as yellow.

3D Tracks, Pads etc. Check to show the tracks, pads and other copper areas as 3-D. If unchecked then they will be added as texture to the surface of the PCB and will draw a lot faster but the quality will not be as good.
3D Copper

2D Copper

3D Add Solder. Checking this will add 3-D solder to all pad connections. 
3D Solder

No 3D Solder


Board Color
This sets the color of the board material. It does not set the color of the solder mask.

Green Board

Check  to give the board a glass fiber type weave.

Drag the  slider to enhance the appearance of the weave.
	No Weave

	Enhanced Weave




Solder Mask
This sets the visibility and color of the solder mask.
Check to show the solder mask.

No Solder Mask

Lighting

Check  to fix the position of the light relative to the PCB. If unchecked then the light is attached to the camera (Your viewing position) and move when you alter the viewpoint.
Hold down the left mouse button and drag it over the light track ball  to set the position of the light.

Drag the  slider to the right to increase the level of background/fill lighting.

Background Color
The 3D background is a vertical gradient from a top color to a bottom color.
At the top of the Background Color expansion group is a palette of preset gradient. Click on any of the 


14.6.4. [bookmark: The_3D_Viewport3A79107E]The 3D Viewport

You'll find several useful commands for controlling the views and layouts of the 3D viewport in the top ribbon menu under the 3D ribbon tab.
The import/export ribbon group contains several useful commands for importing and exporting 3-D.
Import/Export

Import
Click on the  button to import 3D into your design. Read More...
Export
Read More...
Multiple Viewports
You can have anywhere from 1 to 4 views  into the same scene. Click on any of the five buttons in the viewport's menu to select the view configuration. The pattern in the buttons show you the layout of the individual views

 Read More...

14.6.4.1. [bookmark: Importing_a_3D_ModelF7185219]Importing a 3D Model
Click on the Click on the  to display the Import 3D Dialog.
You can import any of the following 3-D file format types:
· STL This format was designed for 3-D printing and unfortunately only contains white objects as no material properties are defined in STL files. If possible you should use a different file format such as  XGL. Find Out More...
· VRML Both VRML version 1 and version 2 are fully supported.Find Out More...
· XGL This is the recommended file format as it can contain material and colors.
Drop-down list of supported file formats

The Import 3D Dialog

 Units and Scale
Both VRML and STL files do not contains units, so you may have to set the import scale.  XGL files have units defined so you do not need to define units or scale.

Rotate
Different source define different direction for the vertical direction (distance from ground)
AutoTRAX designs the UP direction as the +Z However others use the +Y. 
Check the  checkbox to rotate the model 90° to switch between Z up and Y up.
Import Size
The import size is shown in the information box at the lower left. of the Import 3D Dialog.

3D Model Imported

When you import the model, the position or rotation may not be to your liking.
To rotate the model about an axis, select it and click on any of the 3 axis rotate button. 
To move the imported model, select it and hold down the left mouse button and drag on either the red, green or blue axis in the 3D viewport.
Drag the red, green or blue boxes to scale the model.
Drag on the red, green or blue circles to rotate the model.
 

14.6.4.2. [bookmark: 3D_ExportingDDAC163E]3D Exporting
The import/export ribbon group contains several useful commands for exporting 3-D.

Click on the  button to export a STL file.
Exporting a STL File

Click the  will export the 3-D to a Wavefront OBJ file.

Export a Wavefront OBJ File
The   will export the 3-D to a Collada file.
Exporting a Collada 3D File
The  button will create a POV RAY photo-realistic render file. If you have POV RAY installed then the POV RAY program will start and render your file in 3D. 
Exporting and Rendering with POVRAY
14.6.4.2.1. [bookmark: Exporting_a_STL_FileD878CF0D]Exporting a STL File
STL (an abbreviation of "stereolithography") is a file format native to the stereolithography CAD software created by 3D Systems. STL has several after-the-fact backronyms such as "Standard Triangle Language" and "Standard Tessellation Language". This file format is supported by many other software packages; it is widely used for rapid prototyping, 3D printing and computer-aided manufacturing.[5] STL files describe only the surface geometry of a three-dimensional object without any representation of color, texture or other common CAD model attributes. The STL format specifies both ASCII and binary representations. Binary files are more common, since they are more compact.
An STL file describes a raw, unstructured triangulated surface by the unit normal and vertices (ordered by the right-hand rule) of the triangles using a three-dimensional Cartesian coordinate system. In the original specification, all STL coordinates were required to be positive numbers, but this restriction is no longer enforced and negative coordinates are commonly encountered in STL files today. STL files contain no scale information, and the units are arbitrary.
Find Out More...
The Export to STL Dialog

Set the units by click on the appropriate unit button .
Check the appropriate radio button  to set the output format. 
Check to export only the top copper.
Check to export only the bottom copper.
Check  to optimize the 3D output for printing. 
14.6.4.2.2. [bookmark: Export_a_Wavefront_OBJ_FileB36604D0]Export a Wavefront OBJ File
OBJ (or .OBJ) is a geometry definition file format first developed by Wavefront Technologies for its Advanced Visualizer animation package. The file format is open and has been adopted by other 3D graphics application vendors.
The OBJ file format is a simple data-format that represents 3D geometry alone — namely, the position of each vertex, the UV position of each texture coordinate vertex, vertex normals, and the faces that make each polygon defined as a list of vertices, and texture vertices. Vertices are stored in a counter-clockwise order by default, making explicit declaration of face normals unnecessary. OBJ coordinates have no units, but OBJ files can contain scale information in a human readable comment line. You are
An OBJ file may contain vertex data, free-form curve/surface attributes, elements, free-form curve/surface body statements, connectivity between free-form surfaces, grouping and display/render attribute information. The most common elements are geometric vertices, texture coordinates, vertex normals and polygonal faces.
Find Out More...
The Export to OBJ Dialog

Set the units by click on the appropriate unit button .
Check to export only the top copper.
Check to export only the bottom copper.
14.6.4.2.3. [bookmark: Exporting_a_Collada_3D_File91AAC0F6]Exporting a Collada 3D File
COLLADA (Collaborative Design Activity) is an interchange file format for interactive 3D applications. It is managed by the nonprofit technology consortium, the Khronos Group, and has been adopted by ISO as a publicly available specification.
Find Out More...
The Export to Collada Dialog

Check the  to export all copper as 3D. This will make the files considerably larger in size and slower to render.
14.6.4.2.4. [bookmark: Exporting_and_Rendering_with_PD3E9BC83]Exporting and Rendering with POVRAY
The  Persistence of Vision Ray Tracer, or POV-Ray, is a ray tracing program which generates images from a text-based scene description, and is available for a variety of computer platforms.
Find Out More...
The Export to POVRAY dialog

Click the to download the POV ray tracer.
14.6.4.3. [bookmark: Multiple_3D_ViewportsB18FC4D2]Multiple 3D Viewports
If there is more than 1 view visible then the active view has a red border.
View can have separators that you can drag to re-size.

You have 5 preset view configurations.

	
	Single


	
	1+1


	
	2+1



	
	1+2



	
	4








14.6.5. [bookmark: Adding_3D_Objects2BEB9461A]Adding 3D Objects
14.6.6. [bookmark: Moving__Rotating_and_Scaling_3BFA7A600]Moving, Rotating and Scaling 3D Objects

14.7. [bookmark: Semi_Transparent_PCBs0014FCEE]Semi-Transparent PCBs
You can make your PCB semi-transparent and even separate the layers so you can see the internal structure of your PCB.

14.8. [bookmark: PCB_InternalsBDE62254]PCB Internals
You can make your PCB semi-transparent and even separate the layers so you can see the internal structure of your PCB.

14.9. [bookmark: The_PCB_Border7D85E74E]The PCB Border

The PCB border defines the physical board on which your parts are placed and is the support for the copper tracks that connect the electrical terminals of the parts.
Creating a Rectangular PCB 
Creating a Circular/Elliptical PCB
Adding Holes to a PCB
Adding Cutouts to a PCB

Basic rectangular PCB

PCB with pads for components and tracks

3D view of PCB

3D View of PCB with parts mounted


14.9.1. [bookmark: Creating_a_Rectangular_PCB612A7924]Creating a Rectangular PCB
A rectangular PCB is a PCB defined by a rectangle only. All corners are 90°.
To set the PCB border click on one of the 3 buttons in the PCB→PCB button group 
To create a simple rectangular PCB click the  button. 
Now as you move the mouse inside the PCB viewport you will see the PCB first corner cursor shown below.

PCB first corner cursor
To set the first corner, click the left mouse button or type in the actual X and Y coordinate (press the Enter key to start numeric input from the keyboard).
Now as you drag the mouse the PCB will change shape as shown below. As you drag the mouse the width and height of the board will be instantly updated.
Making the Rectangle Square. If you hold down the CTRL key then the x dimension (width) and y dimension (height) are the same. 
Centering the Rectangle. If you hold down the Shift key then the rectangular PCB you are adding is centered at the start point. 
Creating a centered Rectangle. You can use both the CTRL key and the Shift key at the same time.
Left-click and hold to complete the PCB border when it is the size you want or enter the width and height using the keyboard (press the Enter key to start numeric input from the keyboard).

PCB shape defined as you drag the mouse

3D view of a rectangular PCB



14.9.2. [bookmark: Creating_a_Circular_Elliptical7C59728F]Creating a Circular/Elliptical PCB
To create a circular or elliptical PCB click the   button in the PCB→PCB button group 
To create a simple rectangular PCB click the  button. 
Now as you move the mouse inside the PCB viewport you will see the PCB first corner cursor shown below.

To set the first corner, click or press the Enter key followed by the X value, Enter key, the Y value of the starting point, then Enter.
Now as you drag the mouse the PCB will change shape as shown below. As you drag the mouse the width and height of the board will be instantly updated.
Making the Ellipse a Circle. If you hold down the CTRL key then the x dimension (diameter) and y dimension (diameter) are the same. 
Centering the Circle/Ellipse. If you hold down the Shift key then the circular or elliptical PCB you are adding is centered at the start point. 
Creating a centered Circle. You can use both the CTRL key and the Shift key at the same time.
Left-click to complete the PCB border when it is the size you want or enter the width and height using the keyboard (press the Enter key to start numeric input from the keyboard).

PCB shape defined as you drag the mouse

3D view of an elliptical PCB

14.9.3. [bookmark: Creating_a_Polygonal_PCB]Creating a Polygonal PCB
To create a polygonal PCB border click the Add→PCB→ button.
14.9.4. [bookmark: Adding_Holes_to_a_PCBFCE7975F]Adding Holes to a PCB
To add a hole to a PCB click on the  button in the Add→Cutouts button group. You will then be prompted for the diameter of the hole. Enter the hole diameter and click the button to add it. The value you enter is remembered by AutoTRAX and used the next time you add a hole.

As you move the cursor in the PCB viewport the hole will move. You will notice that the PCB will now be shown as a solid color, this is so you can see a true representation of the hole. The X and Y coordinate of the center of the hole will be displayed as shown below.
You can either:
· Move the mouse so the hole is positioned where you want it and left-click hold and drag, then release to create the hole 
· Left-click to start the hole then hit Enter, enter the X value, Enter, then the Y value, and finally enter to place the hole.

NOTE: PCB holes are different to circular cutouts as they will be output as commands to the drill file. Circular cutouts are not output as drill commands.
14.9.5. [bookmark: Adding_Cutouts_to_A_PCB5C6AE80B]Adding Cutouts to a PCB
A cutout is a section of PCB that has been removed.
You can add 3 different types of PCB cutouts, rectangular, polygonal or circular/elliptical as shown below. Cutouts can extend to outside the basic PCB shape as shown in the elliptical cutout on the right of the PCB.
Adding a Rectangular PCB Cutout
Adding a Circular/Elliptical PCB Cutout
Adding a Polygonal PCB Cutout

Cutouts in a PCB

3D view of cutouts


14.9.6. [bookmark: Adding_a_Rectangular_PCB_Cutout1A6A0839]Adding a Rectangular PCB Cutout
To create a rectangular PCB cutout click the Add→Cutout→ button.
14.9.7. [bookmark: Adding_an_Elliptical_PCB_CutoutB275E49E]Adding a Circular/Elliptical PCB Cutout
To create a rectangular PCB cutout click the Add→Cutout→ button.
14.9.8. [bookmark: Adding_a_Polygonal_PCB_Cutout653B2C4A]Adding a Polygonal PCB Cutout
To create a rectangular PCB cutout click the Add→Cutout→ button.

14.9.9. [bookmark: Editing_The_PCB_BorderD6940C93]Editing the PCB Border
To edit a PCB, double-click on one of its edges.
You can also use its properties dialog by first selecting it.

The PCB properties dialog

14.10. [bookmark: PCB_Layers8D1E1814]PCB Layers
The number of layers you can have in AutoTRAX is limited only by the amount of memory in your PC. AutoTRAX can cope with hundreds of layers; far more than your PCB manufacturer can make.
To set the current layer and the layer visibilities use the Layers panel. 
PCB-Layers
 Editing the PCB Layers
14.10.1. [bookmark: PCB_Layers2B40E0B5E]PCB-Layers
Printed circuits and footprints both contain the following layers.
Document 
the document layer contains graphics that you can add to document your design. There are no restrictions on color and style etc.
Net 
the net layer displays unrouted track segments.
If a footprint is placed outside the PCB area and the footprint  net does not connect to any footprints inside the PCB area then the net that connect to the footprint will not appear. This is to avoid clutter. However when you move the footprint that is outside the PCB area the nets will be displayed.
Top Package
the top package layer contains graphics that define the 3-D content on the top of the PCB/footprint.
Top Silkscreen
the top silk screen layer defines the graphics that will be used to print a graphics design on the top of the PCB.
Top Copper
The top copper is used to define the copper tracks, but shapes, copper filled regions etc. that will be on the underside of the PCB.
Bottom Copper
The bottom copper is used to define the copper tracks, but shapes, copper filled regions etc. that will be on the underside of the PCB.
Bottom Silkscreen
The top silk screen layer defines the graphics that will be used to print a graphics design on the top of the PCB.
Bottom Package
The bottom package layer contains graphics that define the 3-D content on the underside of the PCB/footprint.
Background
The background can be used for graphics that you want to be displayed underneath all the other layers. It is useful for adding objects such as images that you want to use as a trace pattern.
Inner Layers
PCBs can also have a number of inner layers.

14.10.2. [bookmark: Editing_The_PCB_Layers2B61F3A1]Editing the PCB Layers
You can set and edit the layers using the  button at the top left of the layers panel.
The layer editor dialog box shown below will appear.

Set the number of layers using the  control.
To edit the properties of an individual layer first select it using the left layers list box.
Each layer can have it's own name. Se it using the  control.
All layers except the top and bottom package layers. the documentation layer, and the background layer have a fixed color. You can set the fixed color for these layers using the  layer color control.
Check/uncheck  to set the preferred auto-routing direction of the layer. This only applies to electrical layers.
Check/uncheck  to hide/show a layer.
Signals
Layers can act as signal planes. Enter the name of the signal for the layer. If a layer has a signal name then it will be filled with copper with holes for pads and vias that do not connect to the layer.
Tracks with the same net name as the layer will connect to that layers via any pads/vias that pass through to that layer. These pads/vias will connect directly to the signal layer. 
Enter the signal name in the  control. 
Clear the signal name (set it to nothing) to make the layer act as a normal layer.



14.10.3. [bookmark: Solder_Mask_Differences70F06301]Solder Mask Differences
This video shows you solder mask differences in PCBs
14.10.4. [bookmark: Split_Power_Planes2B75C9DA]Split Power Planes
Split power planes work with the Electra router. Spread power planes will not work with the internal router. 
To add a split power plane click on the PCB→Split Buttons 
A split power plane can only be added to an internal layer.
The Electra router will also be enabled.
Once add you will be prompted for a signal/node name.

14.10.5. [bookmark: Editing_Split_Power_RegionsFB5D6D87]Editing Split Power Regions

14.11. [bookmark: Pad]Pads
There are two different classes of pads, surface mount technology SMT pads and thru-plated hole technology TPH pads
SMT Pads
SMT pads are cover areas on only one side of the PCB. Electronic parts adhere to the pads using the solder on the pads.
TPH Pads
 TPH pads have copper areas on both the top and the bottom sides of the PCB. In addition a hole is drill through the circuit board to connect the top pad area to the pad area on the bottom. The electronic pin for the part is inserted through the hole and often the sides of the hole are plated with copper. However, if you are making a single sided board then the copper will most likely be placed on the underneath side of the PCB unless the PCB is being made with SMT parts, in which case you will need to have the copper pads on the side of the board where you mount the SMT parts, in other words the top side.

You can add the following types of pads.

Pads

14.11.1. [bookmark: Adding_Pads_To_Pcbs40DFA4E5]Adding Pads
To add a pad to a PCB or footprint click the one of the 4  buttons in the Add→Pads in the ribbon button group. 
 Adding TPH pads
Click the  button to add a round/elliptical TPH pad.
Click the  button to add a rectangular TPH pad.
 Adding SMT pads
Click the  button to add a round/elliptical SMT pad.
Click the  button to add a round/elliptical SMT pad.
Placing the Pad
After you have clicked on one of the 4 buttons you will see the pad with a point input cursor. Move the pad to the position you wish and left-click or press the Enter key followed by the X value, Enter key, the Y value, and then Enter to exactly place the center of the pad.

Pad with point input cursor
Settings
 sets the size of square/circular pads 
 sets the size of rectangular/elliptical pads 
Adding Pads in PCBs
If you add a pad in a PCB, a schematic symbol for the pad is automatically created and added to your first schematic. You can then use this to make connections.

14.11.2. [bookmark: Editing_PadsDF11E835]Editing Pads
To edit a pad you can select it and then drag it to its new position. You can also rotate and scale it.
Drag any of the 4  rotate manipulator points to rotate it.
Drag any of the 6  manipulator points to scale it.
 

Selected Pad
You can also use the Pads Properties dialog in the properties panel.

Pad Properties Panel
14.12. [bookmark: Vias]Vias
A via is a hole that is used to form an electrical connection between two signal layers of a PCB.  Vias are like round pads, which are drilled and usually through-plated when the board is fabricated.
 (
A through-hole via
)[image: ]
There are 2 types of vias in AutoTRAX.
Automatic Vias
The first type of via is one that is automatically created by a track in order to switch layers. 
Manually Created Vias
The second type of via is one created by you to provide an electrical connection between layers.
A via consists of two pads, in corresponding positions on different layers of the board, that are electrically connected by a hole through the board. The hole is made conductive by electroplating, or is lined with a tube or a rivet. High-density multi-layer PCBs may have micro vias: blind vias are exposed only on one side of the board, while buried vias connect internal layers without being exposed on either surface. Thermal vias carry heat away from power devices and are typically used in arrays of about a dozen.
A via consists of:
Barrel — a conductive tube filling the drilled hole
Pad — connects each end of the barrel to the component, plane or trace
Antipad — a clearance hole between barrel and no-connect metal layer
A via may be at the edge of the board so that it is cut in half when the board is separated; this is known as a castellated hole and is used for a variety of reasons, including allowing one PCB to be soldered to another in a stack.

 (
Different types of vias
(1) Through hole.
(2) Blind via.
(3) Buried via.
The grey and green layers are non-conducting, while the thin orange layers and vias are conductive
)[image: ]
14.12.1. [bookmark: Track_Vias019ECD13]Track Vias
A track via, is a via automatically added. You cannot delete them as they are required to ensure that the net is fully connected.
14.12.2. [bookmark: Automatic_Vias65D2CCFF]Automatic Vias
These are vias that are automatically created by a track in order to move between layers.
14.12.3. [bookmark: Manually_Created_Vias]Manually Created Vias
 This type of via is one that is created by you to provide an electrical connection between layers.
14.12.4. [bookmark: Tented_Vias6A513C7C]Tented Vias
A tented via is a via with dry film solder mask which completely covers both the via pad and its plated-through hole. In some cases this may also be referred to as a Capped Via or Cap plating, although the phrase tented via is much more common.

 A Vented Via
14.13. [bookmark: PCB_Sheet_Editor75B34FFD]PCB Sheet Editor
The addition properties for the PCB are settable in the setting sections below. The sheet editor is displayed in the Properties Panel when nothing is selected.

14.14. [bookmark: Setting_All_Track_Widths3C4A877C]Setting All Track Widths
To set the width of all tracks on a PCB enter the width into the Set All Tracks Widths section of the PCB Sheet Properties Editor.

Enter the new track width and click 




14.15. [bookmark: Fiducials]Fiducials
A fiducial marker or fiducial is an object placed in the field of view of an imaging system which appears in the image produced, for use as a point of reference or a measure. It may be either something placed into or on the imaging subject, or a mark or set of marks in the reticule of an optical instrument.
A fiducial mark is a printed board artwork feature that is created in the same process as the conductive pattern and that of is a measurable point for component mounting with respect to a land pattern or land patterns.
A PCB fiducial is a circular area of copper on either the top of the bottom side of the PCB that is used for Alignment using optical recognition systems. The fiducial mark and this PCB copper tracks must be etched in the same step to ensure alignment.




A PCB fiducial in the 2D View

A PCB fiducial in the 3D View
A fiducial marks is made up of 3 parts.
1. A solid circle of copper on the top or bottom copper layer. This is the alignment target.
1. An opening in the solder mask so the circular alignment target is clearly visible.
1. An option text label to the side of the opening in the solder mask

A Fiducial Mark
The fiducial marks provide a common set of data points for all steps in the PCB assembly process. This allows all pieces of equipment used for assembly to accurately locate the parts based on the circuit pattern.
In printed circuit board (PCB) manufacturing, fiducial marks, also known as circuit pattern recognition marks, allow SMT placement equipment to accurately locate and place parts on boards. These devices locate the circuit pattern by providing common measurable points. They are usually made by leaving a circular area of the board bare from solder-mask coating. Inside this area is a circle exposing the copper plating beneath. This center metallic disc can be solder-coated, gold-plated or otherwise treated, although bare copper is most common if not a current-carrying contact. Alternatively, it is possible to use clear solder-mask lacquer to cover the fiducials. In order to minimize rounding errors it was good practice to place fiducials in the same grid (or some multiple of it) that was used to place the parts, however, this isn't always possible on high-density boards nor is it a requirement any more with modern high-precision machines.
Most placement machines are fed boards for assembly by a rail conveyor, with the board being clamped down in the assembly area of the machine. Each board will clamp slightly differently than the others, and the variance—which will generally be only tenths of a millimeter—is sufficient to ruin a board without proper calibration. Consequently, a typical PCB will have multiple fiducials to allow placement robots to precisely determine the board's orientation. By measuring the location of the fiducials relative to the board plan stored in the machine's memory, the machine can reliably compute the degree to which parts must be moved relative to the plan, called offset, to ensure accurate placement.
Using three fiducials enables the machine to determine PCB offset in both the X and Y axes, as well as to determine if the board has rotated during clamping, allowing the machine to rotate parts to be placed to match. Such fiducials are also called global fiducials. Global fiducials are also used in conjunction with stencil printing. Without them the printer would not print the solder paste in exact alignment with the pads. Parts requiring a very high degree of placement precision, such as ball grid array packages, may have additional local fiducials near the package placement area of the board to further fine-tune the targeting. Local fiducial, however, cannot be used in the stencil printing process.
Conversely, low end, low-precision boards may only have two fiducials, or use fiducials applied as part of the screen printing process applied to most circuit boards. Some very low-end boards may use the plated mounting screw holes as ersatz fiducials, although this yields very low accuracy.
For prototyping and small batch production runs, the use of a fiducial camera can greatly improve the process of board fabrication. By automatically locating fiducial markers, the camera automates board alignment. This helps with front to back and multilayer applications, eliminating the need for set pins.
There are 3 types of fiducial marks. These are panel fiducials, global fiducials and local fiducials.
Panel fiducials are used on board panels where 2 are more PCBs are manufactured together.

PCB with global and local fiducials.
Global Fiducials
Global fiducials are used to locate the position of all circuit features on an individual PCB. When multiple PCBs are created on the same PCB panel then these global fiducials are referred to as panel fiducials.
A minimum of three fiducial panel/global marks are required for correction of offsets (X, Y positions), rotational offsets (angle position). These should be located orthogonally as far as possible on the PCB panel.

Very small PCB with 3 global fiducials F1, F2 and F3
It is good practice to locate global fiducials in a three point grade are shown below. The first fiducial is located at the lower left usually at the Norton – not location. The second and third fiducials are located vertically or horizontally aligned to the first fiducial. These fiducials should be located on both the top and bottom layers of your PCB that contains surface mount as well as through all components since even so all assemblies systems are beginning to utilize visual alignment systems. 
Local Fiducials
Local fiducial marks are used to locate the position of an individual component requiring more precise placement.
For these components, 2 local fiducial marks are required for correction of translational offsets (X and Y position) and rotational offsets (θ position ). This can be to marks located directly opposite each other within the outside perimeter of the land pattern.
All fine pitch components should have 2 local fiducial marks designed into the footprint to ensure that enough fiducials are available every time a component is placed, removed and/ or replaced on the PCB. Fiducial must have a solder mask opening large enough to keep the optical target absolutely free of solder mask. If solder mask should get into the optical target area them some vision alignment systems may fail due to insufficient contrast in the target.
If space is limited, you may be able to share fiducial from adjacent component within the local constraint. Also, in such a space limited situation and the PCB is deemed by your manufacturer to be sufficiently small, component fiducials can be omitted and global fiducials used in their place.




QFP with 2 corner local fiducials (FD1 and FD2)

QFP with 2 corner local fiducials (FD1 and FD2)
The size and shape of fiducials
The best fiducial shape is a solid full-circle and that is what AutoTRAX does. The preferred diameter of the fiducial mark is 1 mm as per the IPC – 7351B specification. You are recommended to keep the size is 1 mm although you can change it if you wish.
Fiducial marks should not vary in size on the same printer circuit board by more than 25 µm. A clear area devoid of any other circuit features are markings should exist around the fiducial mark. The minimum size of the clear area is recommended to be twice the radius of the central mark.

Recommended Fiducial Dimensions  - IPC 7351B
Zonal fiducials
To facilitate the accurate placement of multiple SMD components that are not near component specific local fiducials are global fiducials you can place additional solo fiducial targets within an area of the PCB to compensate for PCB dimensional stability.
Material
the fiducial mark is copper which may or may not be tend. If you have a solder mask on the PCB it must not cover the fiducial mark of the clearance area. Note: that excessive oxidation of a fiducial marks copper may degrade the readability.
Edge clearance
the age of the fiducial should be no closer to the edge of the PCB than the sum of 4.75 mm and the minimum fiducial clearance required. If less then you may need to add a PCB board only fixture.
Contrast
the best performance is achieved when a consistent high contrast is present between the fiducial mark and the PCB base material.
The background of all fiducial marks must be the same.  
14.15.1. [bookmark: Adding_FiducialsE7B934DE]Adding Fiducials
Unlike practically all other EDA programs, AutoTRAX is internally fiducials as first class objects and you do not need to and make them using a variety of different graphical objects. Your life is made a lot easier and fiducials are far easier to add to your designs.
It is possible to automatically add fiducials to a PCB.
It is also possible to automatically add fiducials to footprints using the parametric part builder.
In both cases it simply involves checking a tick box.

14.15.2. [bookmark: Adding__A_Fiducial5B997E16]Adding  A Fiducial
You can manually add a fiducial to a Project PCB or to a Footprint land pattern.
To add a fiducial.
1. Click the Fiducial button   in the Add / PCB menu.
1. Move the mouse cursor in the PCB/land pattern viewport and click the left mouse button to finish.

14.15.2.1. [bookmark: Automatically_Addding_Global_F5E35BE08]Automatically Addding Global Fiducials
You can automatically add global footprints to a PCB using the PCB board is property panel.
Select the PCB border by clicking on it.
In the PCB border properties panel click the add fiducials checkbox to automatically add three global fiducials.
The first one at the lower left of the PCB.
Another one above the first fiducial for.
Another one horizontally to the right of the first fiducial.
The origin of the PCB will be set to the center point of the first fiducial.

14.15.2.2. [bookmark: Adding_Global_Fiducials13BF26DC]Adding Global Fiducials
There are two different ways of adding global  fiducials to your PCB.
Global fiducials are used globally by all parts of the PCB and not by any specific part. Specific parts use what are called local fiducials. This naming convention is from the IPC specification.

1. The first way is to use the automatic features that are built into the PCB border properties panel. This is the easiest way to add fiducials.
1. The second way is to manually place the fiducial is by first clicking on the fiducial button in the add ribbon menu then moving the mouse cursor to the location that you want the fiducial to be and then clicking the mouse button.

14.15.3. [bookmark: Adding_Fiducials_to_a_FootprinC5F06760]Adding Fiducials to a Footprint
You can quickly add fiducials to a footprint by either using the Part Builder or by actually manually placing the fiducials.
Fiducials added to a footprint of called local fiducials as opposed to the global fiducials that are added to a PCB. Generally you will use these local fiducials only for locating the individual footprint and it would not be used for located other footprints.
Using the Part Builder

A court QFP device with no fiducials

Check the 'Add Fiducial' checkbox to add local fiducials.

A QFP device with 2 fiducials
Adding a Fiducial Inside a Part Editor
To add a local fiducial to a footprint inside the part editor click on the fiducial button  in the add ribbon group and move the mouse cursor inside the viewport and click the left mouse button to position the fiducial.

Adding a Fiducial to a Placed Part
To add a local fiducial to a footprint inside the a project click on the fiducial button  in the add ribbon group and move the mouse cursor inside the viewport and click the left mouse button to position the fiducial.
Next you need to place the fiducial inside the footprint. You can do this by first selecting the footprint and then, while holding down the shift key, selecting the fiducial that you placed and then by clicking and selecting the group menu item. This will move the fiducial inside the footprint.

Using the Parametric Part Builder you can add local fiducials to BGAs,QFPs, SOICs and DIPs
Check the button in the Properties Panel

BGA

QFP

SOIC

DIP




14.15.4. [bookmark: Fiducial_Properties_Editor7177581F]Fiducial Properties Editor

The fiducial properties editor


Clicking this button displays this help page.

Sets the x and y location of the center of the fiducial.

Sets the inner and outer diameter. The inner diameter is the diameter of the central copper circular area.
The outer diameter is the diameter of the circular clearance in the solder mask. 

A typical fiducial showing both the inner and outer diameters

This sets the side to the PCB that the fiducial is on.

Top
This will place the fiducial on only the top side of the PCB.
Both
This will place the fiducial on both the top and the bottom of the PCB.
Bottom
This will place the fiducial on the bottom side of the PCB


You can optionally add a name to the fiducial and this will appear on the silkscreen layer at the side of the fiducial. 

You can enter the full name of the fiducial. Obviously, if no name is entered then a name level will not appear the side of the fiducial.
Location
This sets the position of the fiducial label relative to the center of the fiducial. Click any of the eight rectangles to place the fiducial at the location relative to the center.
In the viewport with the fiducial selected, pressing the space key will change the location of the label and it will cycle around the locations in this control each time the space key is pressed..



14.15.5. [bookmark: Fiducial_Settings_Editor4DBD63BF]Fiducial Settings Editor

The fiducial settings are the settings that will be used whenever a new fiducial is created.
You can set these default settings by clicking on the ribbon page group caption button and this will display the fiducial settings editor below.
· 
The fiducial settings editor

Clicking this button displays this help page.

Sets the x and y location of the center of the fiducial.

Sets the inner and outer diameter. The inner diameter is the diameter of the central copper circular area.
The outer diameter is the diameter of the circular clearance in the solder mask.

This sets the side to the PCB that the fiducial is on.

Top
This will place the fiducial on only the top side of the PCB.
Both
This will place the fiducial on both the top and the bottom of the PCB.
Bottom
This will place the fiducial on the bottom side of the PCB


You can optionally set the prefix for all fiducials. For example you may this select F or FD. Whenever a prefix is added a number will be added to the end of the prefix to form the fiducial's name. If no prefix is defined then the fiducial will be simply a number
14.15.6. [bookmark: Fiducials_in_the_Pick_and_Plac52E0AF7B]Fiducials in the Pick and Place File
Information for all fiducials is placed in the pick and place file. Example is shown below.

An example pick and place file showing the fiducials in rows 2 to 4.
14.15.7. [bookmark: Renumbering_All_FiducialsFF8397B7]Renumbering All Fiducials
To renumber all the fiducial labels go to the tools menu and click on the Renumber Fiducials button  in the utilities button group.
This will rename all the fiducials in a left-to-right and bottom to top order. So the lowest numbered fiducial would be at the bottom left the highest number will be at the top right.
14.16. [bookmark: Nets]Nets
A net connects two or more pads on a PCB. The connections are made using tracks, so a net appears as one of more tracks.

14.16.1. [bookmark: Adding_Nets84607FA2]Adding Nets
To add a net to a PCB:
1. Click on the Add→Add Net button in the menu.
1. Move the mouse so it is over a pad, via or track and the cursor will turn to a green tick. 
1. Left-click when you see the green tick to start a net.
1. Now move the mouse. As you move it a yellow line will be drawn from the source pad, via or track.
1. When the cursor goes over a valid end point for the net, the cursor will turn into a  green tick.
1. Left-click when you see the cursor turn to green tick. The net will then optimize itself.

14.16.2. [bookmark: Editing_NetsDF0F9AA3]Editing Nets
To edit a net click on one of it's tracks.

14.16.3. [bookmark: Track_SettingsBB069431]Track Settings
There are several settings that you can use for creating tracks. 
To view the dialog, click on the small button at the bottom right of the Tracks button group. 
The track settings dialog is shown below.

Track Settings Popup
This dialog is also part of the PCB settings in the properties panel.
Auto-Dimming 
Check this to have automatic dimming when manual routing. Auto dimming will dim non-selected tracks when you are routing a PCB, this makes it easier for you to do the routing.

Tented Vias 
When checked all your vias will be tented.
The role of the PCB’s solder-mask is to protect the copper traces from damage, oxidation, and solder bridging. 
This protections also apply to the vias. Tented vias will be more resistant to physical damage and electrical shorts. 
If your PCB design has through-hole components that will be wave soldered then a tented via will prevent the solder from flowing up into the via and over the other side of the PCB where it can potentially short out components. 
Vias that are also in close proximity to SMT pads should also be tented. This will prevent the solder paste from wicking into the via and creating a poor solder joint. 

Non-Tented Vias (no solder mask on the vias)


Tented Vias (solder-mask covers the vias)


3D Tracks, Pads etc. 
Check to show true 3D tracks and pads in the 3D viewport. If not checked then tracks and pads are shown as images on the PCB; this speeds up drawing and is useful for slower machine. For the best quality use 3D  tracks and pads.
Track Corner Rounding
You can optionally round the corners of all you PCB tracks.
 (
Automatic Rounded Track Corners
)[image: ]

Drag the slider to the right ti increase rounding.

You can also enter the rounding percentage

No rounding


100% Rounding



Default Track Vias
You can set the default track via diameter and the default track via hole diameter.
You can also set all track via sizes from the default sizes.


Default Track Via Diameter

This sets the default via diameter. It is used to set the via diameter for newly created PCB nets. You can override this by editing either the PCB net of the associated schematic node using their respective properties panels.
Default Track Via Hole Diameter

This sets the default via hole diameter. It is used to set the via hole diameter for newly created PCB nets. You can override this by editing either the PCB net of the associated schematic node using their respective properties panels.
Setting All Track Via Diameters and Track Via Hole Diameters
Click  to set all track via diameters and hole diameters from the default via diameter and hole diameter. This will also set all net and node all track via diameters and hole diameters.

Default Track Width

You can set the default track width.   It is used to set the via diameter for newly created PCB nets.
Click  to set all track widths from the default track width.




14.17. [bookmark: Tracks]Tracks
A track is a section of a net that is on a single layer. It starts and ends on a pad, a via or a track junction. A track junction is where 3 or more tracks that are all on the same layer meet.
A track consists of one or more straight segments.

14.17.1. [bookmark: Change_Track_Segment_LayerF75FD794]Changing a track segments layer index
To change the layer for a track segment, first select it by left-clicking it and then either press either the Space key or press a number key.
Obviously it is not possible to change the track segment's layer for single sided PCB.
Pressing the space key will send the current track segment backwards in the PCB layers. However if the track segment is on the bottom layer, then it will be cycled around to the top layer. For a 2-sided board pressing the space key appears to swap a track segment to the other side of the board.
When a layer segment is swapped, vias and/or track junctions will be added and/or removed as required.
Pressing a number key will move the selected track segment to the layer defined by the number entered or to the bottom layer if the number is greater than the number of electrical layers on the PCB.
e,g, pressing '1' moves the selected track segment to the top layer while pressing '2' moved it to the second layer, in the case of a 2-layered PCB, to the bottom of the PCB.
Pressing 't' or 'T' moves the track segment to the top layer
Pressing 'b' or ''B' moves the track segment to the top layer.
You can convert a track segment to a jumper on the top or the bottom side of the board. pressing the 'H' to create a jumper on the bottom side of the board or the 'J' key  to create a jumper on the top side of the board.
14.17.2. [bookmark: jumpers]Jumpers
A jumper is a short length of conductor just to jump over a routing obstacle on a PCB. There are uses, rarely, when it is impossible to finish a route due to an already routed track. A 3D model of the jumper is automatically created. Insulation is also added to the jumper if the jumper is long enough.
Adding a Jumper When Manual Routing
When you are manually routing a track:
1. Press the 'J' key to start a jumper. AutoTRAX will automatically add a via and start a jumper on the top side of the board.
2.  Drag the mouse and the jumper's end point will follow the cursor. Press the 'J' or Space key to end the jumper. AutoTRAX will add another via to complete the jumper and return you to the layer you were on before you started adding the jumper.
Instead of pressing the 'J' key you can start the jumper on the bottom side of the board by pressing the 'H' key.
Editing a Track
To convert an existing track segment to a jumper:
1. Select the track segment by clicking on it.
2. Press the 'J' key to convert it to a jumper on the top side of the board or press the 'H' key to convert it to a jumper on the bottom side of the board.
Removing a Jumper
1. Select the track segment by clicking on it.
2. Press the Space bar to convert a jumper to a regular copper track.
Swapping the Jumpers Side
1. Select the jumper by clicking on it.
2. Press the 'J' key to convert it to a jumper on the top side of the board. Press the 'H' key to convert it to a jumper on the bottom side of the board.
14.18. [bookmark: Pcb_Routing02ADC824]Routing
There are two methods whereby you can route the tracks on your PCB.
· Manual Routing
· Automatic Routing
14.18.1. [bookmark: Manual_Routing700D733F]Manual Routing
To manually route your PCB first double-click the PCB track.
14.18.2. [bookmark: Interactive_Routing0E53EB53]Interactive Routing
14.18.3. [bookmark: More_Manual_Routing908B99AF]More Manual Routing
14.18.4. [bookmark: Track_JumpersFCB5A5DA]Track Jumpers
14.18.5. [bookmark: Swapping_LayersAD84E4DA]Swapping Layers


14.18.6. [bookmark: Teardrops]Teardrops
14.18.7. [bookmark: Manually_Routing_a_TrackC37D7F6A]Manually Routing a Track
To start manually routing a track double click on any segment. Double click again or press the ESC key to end manual routing. The routing will automatically end when you reach the target (see below).

Double Click to start manual routing
  

Routing starts from nearest vertex (pad/via/junction or corner). Normal cursor (left) Full cross cursor (right)

Pressing Space key automatically adds a via
(see more commands below)

Cross cursor turns green to indicate end. 
Click to end the route or

Double click or press ESC to end partial routing

Keyboard Shortcuts
	KEY
	ACTION

	Backspace
	Undo the last manual route, e.g. undo a track layer change.

	F12
	 Redo the last undone manual route, e.g. redo a track layer change.

	Escape
	End the manual routing.

	Space
	Change to the next layer and automatically add/remove vias.

	+
	Change up to the next layer and automatically add/remove vias, this will wrap round to the bottom layer if the current track layer if the top layer.

	-
	Move down one layer and automatically add/remove vias, this will wrap round to the top layer if the current track layer if the bottom layer.

	J 
	Start or end a jumper

	T
	Change to the top layer, adding/removing vias if necessary

	B
	Change to the bottom layer, adding/removing vias if necessary

	S
	Toggle snap to grid. Turns it on/off




14.18.8. [bookmark: Electra]Electra

Electra is a Shape based Auto-routing powered by a multi-pass cost-based conflict reduction algorithm to find an optimal routing solution adapting to the natural flow of the nets while following advanced DFM and timing constraints.
Running Electra
Lean about running Electra.
The Electra View
Lean about the Electra viewport.
Initializing-Electra
Find out how to authorize Electra.
Using Electra Interactively
Lean how to use Electra interactively with AutoTRAX.
Electra Router Settings
This details all settings for using Electra.
The Electra DO Commands
Here you will discover how to set the Electra route commands.
Importing Electra Route File
Lean about importing an Electra route file.
Route Report
Viewing the route report.
Differential pair routing
Electra can route differential pairs.
Length Constrained Auto-routing
Find out how to restrain and match track lengths.
View website...
14.18.8.1. [bookmark: Running_Electra80B68A24]Running Electra
To run the Electra auto-router click on the  button in the PCB->Route menu.
You need to have the Use Electra option selected in the Router Settings.
You can set the Electra options using the Electra Router Settings
14.18.8.2. [bookmark: The_Electra_Autorouter5B0D430F]The Electra Autorouter
ELECTRA is a third party shape based PCB router that works well with AutoTRAX.
It is a new generation of Shape-Based Auto routing software for PC boards. ELECTRA uses a  multi-pass, cost-based conflict reduction algorithm to find a routing solution adapting to the natural flow of the nets. Adaptive routing algorithm is the only proven approach to reach a high completion rate.  ELECTRA gives immediate feedback on the routing progress and conflict reduction rate.
AutoTRAX, by default, does not come with an ELECTRA license. You will need to purchase a separate ELECTRA license. Find out more...
ELECTRA uses industry standard format by reading design file (DSN). Routing results are saved into standard route file format (RTE) or session file (SES). 

Click to View the DSN Specification

Typical board routed with ELECTRA


14.18.8.3. [bookmark: Initializing_Electra54384692]Initializing-Electra
When you first run Electra you have a 15 grace period before you have to buy it. It is the full version during this period and you will be prompted with the following dialog:

Click the  button to route your board.
After the grace period you will no longer be able to run Electra for free.
If you wish to purchase Electra please go tohttp://konekt.com/wp/
After purchasing Electra you will be asked for the Site code and MID for Electra. These are shown below:

The actual values for your machine will be different from the values shown above.
Once you have sent the details to us you will receive an activation code. To enter it click the  button and enter the code below:


14.18.8.4. [bookmark: Differential_pair_routingE29AD1C1]Differential pair routing
Differential signaling is a method for electrically transmitting information using two complementary signals. The technique sends the same electrical signal as a differential pair of signals, each in its own conductor. The pair of conductors can be wires (typically twisted together) or traces on a circuit board. The receiving circuit responds to the electrical difference between the two signals, rather than the difference between a single wire and ground. The opposite technique is called single-ended signaling. Differential pairs are usually found on printed circuit boards, in twisted-pair and ribbon cables, and in connectors.
Differential signaling is often used in computers to reduce electromagnetic interference, because complete screening is not possible with micro-strips and chips in computers, due to geometric constraints and the fact that screening does not work at DC. If a DC power supply line and a low-voltage signal line share the same ground, the power current returning through the ground can induce a significant voltage in it. A low-resistance ground reduces this problem to some extent. A balanced pair of micro-strip lines is a convenient solution, because it does not need an additional PCB layer, as a strip line does. Because each line causes a matching image current in the ground plane, which is required anyway for supplying power, the pair looks like four lines and therefore has a shorter crosstalk distance than a simple isolated pair. In fact, it behaves as well as a twisted pair. Low crosstalk is important when many lines are packed into a small space, as on a typical PCB.
In single-ended signaling, the transmitter generates a single voltage that the receiver compares with a fixed reference voltage, both relative to a common ground connection shared by both ends. In many instances single-ended designs are not feasible. Another difficulty is the electromagnetic interference that can be generated by a single-ended signaling system that attempts to operate at high speed.
Provided that the source and receiver impedances in the differential signaling circuit are equal, external electromagnetic interference tends to affect both conductors identically. Since the receiving circuit only detects the difference between the wires, the technique resists electromagnetic noise compared to one conductor with an un-paired reference (ground). The technique works for both analog signaling, as in balanced audio—and digital signaling, as in RS-422, RS-485, Ethernet over twisted pair, PCI Express, DisplayPort, HDMI, and USB.
A differential signaling system is where a signal is transmitted down a pair of tightly coupled tracks with one of these carrying the signal and the other carrying an equal but opposite image of the signal. Differential signaling was developed to resolve situations where the logic reference ground of the signal source could not be well connected to the logic reference ground of the load. Differential signaling is inherently immune to common mode electrical noise, the most common interference artifact present in an electronic product. Differential signaling also minimizes electromagnetic interference (EMI) generated from the signal on the PCB.
The electronics industry, particularly in portable and mobile devices, continually strives to lower supply voltage to save power and reduce emitted electromagnetic radiation. A low supply voltage, however, reduces noise immunity. Differential signaling helps to reduce these problems because, for a given supply voltage, it provides twice the noise immunity of a single-ended system.
To see why, consider a single-ended digital system with supply voltage Vs. The high logic level is Vs, and the low logic level is 0 V. The difference between the two levels is therefore Vs-0 = Vs.

Now consider a differential system with the same supply voltage. The voltage difference in the high state, where one wire is at Vs , and the other at 0 V, is Vs-0 = Vs. The voltage difference in the low state, where the voltages on the wires are exchanged, is 0-Vs = -Vs  The difference between high and low logic levels is therefore Vs-(-Vs) = 2Vs,. This is twice the difference of the single-ended system. If the voltage noise on one wire is uncorrelated to the noise on the other one, it takes twice as much noise to cause an error with the differential system as with the single-ended system. In other words, differential signaling doubles the noise immunity.
The technique minimizes electronic crosstalk and electromagnetic interference, both noise emission and noise acceptance, and can achieve a constant or known characteristic impedance, allowing impedance matching techniques important in a high-speed signal transmission line or high quality balanced line and balanced circuit audio signal path.
Resistance to electromagnetic interference
This advantage is not directly due to differential signaling itself, but to the common practice of transmitting differential signals on balanced lines. Single-ended signals are still resistant to interference if the lines are balanced and terminated by a differential amplifier.
Electra
You create differential pairs in the schematic, not in the PCB. The PCB nets will be automatically used to differential pair status.
Differential pair routing process starts by identifying gather points at the proximity of the fan out vias. The main part of the connections are then auto-routed between the gather points. The auto router applies the same multipass conflict reduction strategy to the differential pair nets and length constrained nets in order to reach the highest completion rate. 
No T-junction or vias are used during routing of the differential pairs. 
45 degree routing style can be predefined for the differential pair routing.
Differential pairs are treated as signal nets and take part into the adaptive auto-routing strategy with conflict resolution. 

14.18.8.5. [bookmark: Length_Constrained_Autorouting9909EDD5]Length Constrained Autorouting
For min length and match length constraint, the router meanders routed wire to increase length by following an accordion pattern. 
Includes the ability to define Signal Path containing connections within a net of a set of connections of different nets.

14.18.8.6. [bookmark: The_Electra_View23C06414]The Electra View
If you have checked then during routing the Electra application window will be displayed similar to the view below.
Please review the Electra manual on how to interact with Electra. Click on the Help menu item at the top of the Window.
Below you can see a list of the AutoTRAX electrical layer by name at the upper left. The name are capitalized due to limitation in Electra.
Similarly, below the layer names you will see a list of AutoTRAX net names. Again the name are capitalized due to limitation in Electra. If the AutoTRAX net name is not set you will see it as _UNNAMED_<XXXX> where XXXX is a unique numeric identifier. Clock on the net name to see it in the Electra viewport.
The Electra routed nets have the same color as in AutoTRAX.

14.18.8.7. [bookmark: Using_Electra_InteractivelyAC4888B7]Using Electra Interactively
You can interactively route with Electra using AutoTRAX.
 (
This video show you how you can easily auto-route a PCB using AutoTRAX and Electra. In particular it shows you an example of restricting routing of a net to a specific layer.
)[image: ]

To use Electra interactively check in Run Electra

at the top of the Electra Router Settings

Next click on the  button in the PCB->Route menu.
The main AutoTRAX window will disappear and you will see the dialog below and Electra will start.


Do whatever you feel you need to do in Electra to route your PCB, see below.
You can click  to minimize the above dialog.
You can also close it and even close AutoTRAX as so long as you have saved the project you can import the Electra route file.
Click  to copy the write routes command to the clipboard so you can paste it into the Electra command: window to export the Electra route file. As soon as you save the route file, the above dialog will automatically disappear and the AutoTRAX main window will appear with the routed tracks.
Inside Electra
In Electra you will see the AutoTRAX layers and named nets as shown below
.

After routing/editing your PCB in Electra you need to save your route file using the Electra File menu.


As soon as you save the route file, the above dialog will automatically disappear and the AutoTRAX main window will appear with the routed tracks. If you export as a different name click on the  in the above dialog to import the route information into AutoTRAX.



14.18.8.8. [bookmark: Electra_Router_SettingsA18853D8]Electra Router Settings
The Electra router settings dialog is shown below.
Electra is installed by default in C:\Program Files\AutoTRAX Software\AutoTRAX\Electra
It is C:\Program Files\AutoTRAX Software\AutoTRAX\Electra\Electra.exe
This is the full version and will work for 15 days. You will then need to purchase it from http://konekt.com/c5/index.php
Unroute all before routing
If checked the PCB will be totally unrouted and the Auto-route will be a full route. You are strongly advised to keep this checked.
Show Route-Report
Check  to display a Route Report after routing.
Running Electra
There are 4 ways you can run Electra.

Show and Keep Open
Electra will open, route and stay open. AutoTRAX will automatically read in the Electra routes at the end of routing.
Show and Close
Electra will open, route and automatically close when routing is done. AutoTRAX will automatically read in the Electra routes at the end routing.
Don't Show
Electra will not appear during routing but you will see the routing being done inside AutoTRAX's CB viewport. This is not available when running the freeware version on Electra.
 (
Embedded Electra Routing Inside AutoTRAX
)[image: ]
Interactive
1. This will open Electra with the current PCB but Electra will not automatically route the PCB.
1. You will need to route the PCB inside Electra using Electra commands
1. When you save the route file in Electra AutoTRAX will automatically read be in. Optionally you can quit AutoTRAX and import a later date.
 (
This video show you how you can easily auto-route a PCB using AutoTRAX and Electra. In particular it shows you an example of restricting routing of a net to a specific layer.
)[image: ]
Temp Directory
This is the directory used to store temporary files used by Electra during the routing process. Click the  button on the right to browse for a directory location.
Check the  button to have AutoTRAX automatically delete them after Electra has routed your PCB and AutoTRAX has read in the results.
Electra uses the following files.
· bestsave.rte - intermediate routing results.
· electraCommand.do - Routing strategy file produced by AutoTRAX.
· projectName.dsn - This is the file produced by AutoTRAX to describe the circuit to Electra.
· projectName.log - Routing log file produced by Electra.
· projectName.ses - Session file produced by Electra.
· projectName.sts - Routing file produced by Electra.
· projectName.rte - This is the result of routing the PCB and is generated by Electra and read in by AutoTRAX.
Electra Directory
This is the directory that the Electra router is installed in to. AutoTRAX comes complete with a full working copy of Electra. If you wish to use a different copy of Electra then enter the directory here. Click the  button on the right to browse for a directory location.
AutoTRAX looks for the Electra program in the following directories:
1. The Electra directory you specify
1. C:\Program Files\ELECTRA
1. C:\Program Files (x86)\ELECTRA
If it does not find it in any of the about directories it tries to run the freeware version distributed with AutoTRAX.
If it cannot find Electra in any of the above directories then it will display the following dialogue box:

Max Vias per Net
Enter the maximum number of vias to use for routing between any 2 pads in a net.
Via Cost
These is a relative via cost. Move the slider to increase the cost of using vias. Electra will then try 'harder' to not use vias.
Via Size
Enter the diameter to use for vias.
Minimum Spacings
Track to Track
This is the minimum track to track spacing.
Pad to Pad
This is the minimum pad to pad spacing.
Track to Pad
This is the minimum track to pad spacing.
Via to Via
This is the minimum via to via spacing.
Pad to Via
This is the minimum pad to via spacing.
TPH Pad to Turn
This is the minimum track distance from a TPH pad to the first corner.
SMT Pad to Turn
This is the minimum track distance from a surface mount  pad to the first corner.
Grid
Track
This is the track grid.
Via
This is the via grid.
Click on the  button to display the The Electra DO Commands
Click the  to display the Electra manual.



14.18.8.9. [bookmark: The_Electra_DO_Commands1E446CCB]The Electra DO Commands
You can set your own Electra route command from the Electra Router Settings
Click on the  button in  Electra Router Settings to display the commands as shown below.

Click  to save the Do file. This will then be used on all subsequent Electra routing.
Click the  to reset the commands to the factory settings.
bestsave 
bestsave on | off
Controls automatic saving of the best routing solution during a multi-pass routing run. Routing result is saved into a file named “bestsave.rte” at the same location as the design file. 
bus
bus [diagonal] 
Invokes a “collinear pins” routing pass only on regular array of pins with collinear connections where the pins share a common X or Y coordinate. This is particularly effective on memory arrays. In this mode, the router will not generate conflicts, so rules must allow for sufficient space. By default traces are routed orthogonally, unless the diagonal option is specified. 
check
This command can be used to run a DRC (design rules check) and visually tag the violations. This is used in particular when a rule is changed. A check is automatically invoked after every routing pass. The total number of violations is shown on the status line and visual feedback is added to the layout view to indicate conflict locations. 
clean 
clean [<passes>] 
The clean command reroutes all the connections with higher costs settings and helps achieve 
· Wire optimization with minimum bends 
· Vias minimization 
· Less off-center SMD pad entry 
· Exit SMD pad on long edge
fanout 
fanout [<passes>] 
[(direction[in_out | in | out])] 
[(pin_share [on | off])] [(via_share [on | off])] 
{[(pin_type [active | signal | power | unused | all | single])]} 
[(max_len <positive_dimension>)] 
AutoRoutes short escape wires with a via from SMD pads. Recommended on SMD boards having more than 2 routing layers. Fanout direction can be set so that fanout vias are added inside SMD components, and/or outside. Fanout can be limited by pin type, for example pins connected to power nets only. 
Examples: 
# 5 fanout passes 
fanout 5 
# Depth for blind & buried vias 
fanout (depth opposite 2) (share_len 500)
5 (pin_type signal) (via_share on) 
# Sets via to microvia & grid 25 
grid via 25 MICROVIA 
# Fanout using a grid of 25 
fanout (via_grid 25) 
filter 
filter [<passes>] 
At the end of a routing session you may end up with wires/vias in conflicts (crossing or too close to each other), so in order to remove these conflicts the router has to unroute the minimum number of connections that get into conflict, "Filter 5" will do that. 
grid
grid [via <positive_value> [<via_id>] | 
wire <positive_value> [<layer_name>] 
Specifies wire and via grid spacing. 
Examples: 
# use a routing grid of 8.333
grid wire 8.333 
# use a different routing grid 5 on layer 1 
grid wire 5 layer 1
limit 
limit [cross [<positive_integer> | -1] | 
via [<positive_integer> | -1] | 
bend [<positive_integer> | -1] | 
way [<positive_dimension> | -1]] 
The limit command sets absolute limit values to be applied to each connection. Control is provided to limit maximum allowed number of intersecting wire, number of vias per connection, number of bends, and the maximum distance of non preferred (wrong-way) routing. The range of limit for <positive_integer> is 0 through 255. You can set limit values, perform some routing passes, and return to the default system values by executing a limit command with a value of –1. If you don’t supply limit values, computed default values are used by the autorouter. 
Examples: 
limit via 2 
limit way 200 
# resets routing limit to default value 
limit way –1 
lock
lock net <name>
Prevents router from changing or deleting locked wires, Note that the router is not allowed to connect to locked wires. 
miter 
miter [diagonal] <pin_setback> <slant_setback> <tjunction setback> <bend_<start_setback> <end_setback>> 
The miter command charges 90 degree wire corners to 135 degrees. It is performed on wire corners exiting pins and vias, as well as bend and slant wire configuration. 
Pin_setback, slant_setback, tjunction and bend_setback options can be used to control which corner type is changed and you can override the default setback values as well: 
miter pin .2 
miter slant .2 
miter bend .2 
miter tjunction .2 
In comparaison to the recorner command, the miter functionality adds control for tjunction and start/end setback value for the bends.
recorner 
recorner [diagonal] <pin_setback> <slant_setback> <bend_setback> 
The recorner command charges 90 degree wire corners to 135 degrees. It is performed on wire corners exiting pins and vias, as well as bend and slant wire configuration. 
Pin_setback, slant_setback and bend_setback options can be used to control which corner type is changed and you can override the default setback values as well: 
recorner pin .2 
recorner slant .2 
recorner bend .2 
Pin option is for wires that are connected to pin or via. 
Slant is two consecutive 90 degree bends 
recorner diagonal .25 .25 .25 
You can make multiple calls with decreasing values. 
recorner diagonal .50 .50 .50 
recorner diagonal .25 .25 .25 
recorner diagonal .10 .10 .10
route 
route [<passes>[<start_pass>]] 
When the number of completed passes (n) is less than 15, the <start_pass> should be n+1. 
When the number is higher than 15, then the <start_pass> should be 16.
status_file 
Creates a status file with routing history and located in the design directory. The status filename is named after the design name, with the extension .sts. 
tax
tax [way | cross | via | off_grid | off_center | side_exit | 
squeeze | layer <layer_name>] [<real> | positive_integer>] 
This is an alternative method of using the cost command. This is the recommended way to adjust costing. The tax command applies a multiplier to control internal costing. The default value for tax is 1.
write 
write [routes | session | script] [<filename>] 
Command to save results to a routes file or a session file.The session file provides an integrated file to manage design data and routing data. 




14.18.8.10. [bookmark: Importing_Electra_Route_FileCE21FD1F]Importing Electra Route File
To import an Electra route files (*.rte) click on the  button in the Pcb->Route menu.
You will prompted for the route file. Enter the file name and the route information will be imported.

NOTE: The Electra route file MUST have been produced by the current state of the PCB, otherwise it will fail as Part Count/positions could differ and schematic routing could also differ (making a different set of nets in the PCB).
If it fails you will see as dialog like the one below. To fix it, reroute the PCB with Electra.

14.18.8.11. [bookmark: Route_Report5A4F1968]Route Report
Check  in the Electra Router Settings  to display a route report after routing. Below is a typical route report.

14.18.9. [bookmark: Automatic_Routing11CF6B44]Automatic Routing
AutoTRAX has an internal auto-router. 
14.18.10. [bookmark: Keepout_Regions36CB5DA7]Keep Out Regions
Keep-out regions are areas of a PCB that must remain free of electrical tracks and copper pour fill. You define these by adding keep-out regions to your board on the layer you wish to restrict

Keepout Regions
Adding Keepout Regions
Editing Keepout Regions
14.18.10.1. [bookmark: Adding_Keepout_RegionsE4C1878B]Adding Keep Out Regions
To add a keep out region click on one of the buttons in the Add→Keepout ribbon button group/ 
Click  to add a rectangular keep out region.
Click  to add an elliptical keep out region.
Click  to add a polygonal keep out region.



14.18.10.2. [bookmark: Editing_Keep_Out_Regions18671B21]Editing Keep Out Regions
To edit a keepout first select it.
14.18.11. [bookmark: Router_Settings7CAB9E57]Router Settings
To set the auto-router/manual router settings click the small  button at the bottom right of PCB→Route ribbon button group.
Selecting The Auto-Router
To select which router to use for automatic routing check the appropriate control shown below.

Micro Vias
Check the  box to enable micro vias.
Router Specific Settings
There are 3 different tabs with each relating to a specific area of routing:
· Manual Router Settings
· Internal Router Settings






14.18.11.1. [bookmark: Manual_Router_Settings14F9BFEC]Manual Router Settings
The manual router settings dialog is shown below
.
Check  to start routing on the top layer. Uncheck to start routing on the bottom layer. This only applies to PCB with 2 or more electrical layers.

14.18.11.2. [bookmark: Internal_Router_Settings91328303]Internal Router Settings
The internal router settings dialog is shown below
.
Track
Width - The default width for tracks. You can override this by setting the width for the track/net using the tracks properties box.
Spacing - The spacing between tracks. The internal router is a grid router and this is the size of the grid.
Grid 
Track - The internal router is a grid router and this is the size of the grid for tracks.
Via - This is the size of the grid for vias.

14.18.12. [bookmark: Snap_To_Pad01160F5C]Snap To Pad
14.19. [bookmark: Auto_Layout24887A28]Auto-Layout
To auto-layout your PCB click the Layout→PCB→ button.
14.19.1. [bookmark: An_Insight_into_PCB_AutoLayoutF3972D0F]An Insight into PCB Auto-Layout
14.20. [bookmark: Copper_Pour_Regions358DB1A6]Copper Pour Regions
You can add copper pour areas to your PCB.
The term "copper pour" refers to an area on a printed circuit board filled with copper (the metal used to make connections in printed circuit boards). Copper pour is commonly used to create a power or ground plane. Another reason for using copper pour is to reduce the amount of etching fluid used during manufacturing.
A distinctive feature of copper pour is the backoff/margin (or stand-off) - a certain distance between the copper pour and any tracks or pads not belonging to the same electrical net. A copper pour therefore looks like it flows around other components, with the exception of pads which are connected to the copper pour using thermal connections.
While solid copper pour provides better resistive characteristics, hatched copper pour is used to balance the heat and open space on both sides of the board in order to avoid warping of certain substrates. Heating might cause gas bubbles between solid copper pour and certain substrates. Furthermore, it might be possible to adjust the impedance of high frequency traces by using hatched copper pour in order to reach better signal quality.

Copper Pour Area
Adding Copper Pour Regions 
Editing Copper Pour Regions
Copper Pour Settings
14.20.1. [bookmark: Adding_Copper_Pour_Regions61F0104A]Adding Copper Pour Regions
To add a copper pour areas click on one of the 3 buttons in the Add→Pour ribbon button group.
There are 3 basic shape type.
1. Rectangular
1. Elliptical/Circular
1. Polygonal.
14.20.2. [bookmark: Editing_Copper_Pour_Regions2EB4820D]Editing Copper Pour Regions
To edit a copper pour, use the copper pour's properties dialog in the Properties panel.

Copper Pour Properties
14.20.3. [bookmark: Copper_Pour_SettingsBC93754C]Copper Pour Settings
You can set the initial setting of copper pours by clicking on the small  button at the lower left of the Add→Copper ribbon button group.

14.21. [bookmark: The_SoldermaskA986A395]The Solder Mask
Solder mask or solder resist is a thin lacquer-like layer of polymer that is usually applied to the copper traces of a printed circuit board (PCB) for protection against oxidation and to prevent solder bridges from forming between closely spaced solder pads. A solder bridge is an unintended electrical connection between two conductors by means of a small blob of solder. PCBs use solder masks to prevent this from happening. Solder mask is not always used for hand soldered assemblies, but is essential for mass produced boards that are soldered automatically using reflow or solder bath techniques. Once applied, openings must be made in the solder mask wherever components are soldered, which is accomplished using photolithography. Solder mask is traditionally green but is now available in many colors.
Solder mask comes in different media depending upon the demands of the application. The lowest-cost solder mask is epoxy liquid that is silk-screened through the pattern onto the PCB. Other types are the liquid photoimageable solder mask (LPSM) inks and dry film photoimageable solder mask (DFSM). LPSM can be silkscreened or sprayed on the PCB, exposed to the pattern and developed to provide openings in the pattern for parts to be soldered to the copper pads. DFSM is vacuum laminated on the PCB then exposed and developed. All three processes go through a thermal cure of some type after the pattern is defined.
In electronic design automation, the solder mask is treated as a layer of the printed circuit board, and is described as a Gerber file like any other layer, such as the copper and silkscreen layers.
The solder mask is generated by default and covers all the PCB except pads and no solder mask areas. There is no explicit Solder Mask layer in AutoTRAX. The mask is automatically generated for the top and bottom sides of the PCB. Normally you would not need to make any changes yourself.
Color Me Beautiful
For a seemingly endless time, solder-mask has been green and only green. But all that has started to change. 
There is a trend towards clear or colorful electronics, in everything from toasters to blenders and from phones to computers. With OEMs trending toward clear appliances and electronics, boards are taking on much more of a personality. Any marketing professional will tell you if you're going to see the guts of something, it better look interesting and it had better be cool. 
Today there are a variety of commercially available colors from which to choose. Alternative colors certainly aren't new. But the past several years have seen a growing use of colors other than green, primarily driven by assemblers and OEMs. 


14.21.1. [bookmark: Adding_Soldermask_Cutouts69C8C91F]Adding Solder Mask Cutouts
In addition to the automatic cutouts for pads, you can add mask cutouts.

Rectangular, elliptical and polygonal solder mask cutout
You can add solder mask cutout using the buttons in the Add->No Mask button group.

Adding a rectangular solder mask cutout
To add a rectangular no solder mask area click on .
1. Move the cursor to the top left or bottom right corner for the cutout.
1. Click the left mouse button and drag the mouse to define the cutout or just hold down the left mouse button and drag.
1.  If you hold down the Shift key the cutout rectangle will be centered at the position you first clicked. 
1. If you hold down the Ctrl key the  cutout rectangle will be square.
1. You can hold down both the Shift and Ctrl key to create a square cutout centered at the original left click.
1. Click again to end adding the cutout or release the left mouse button if you started by holding down and dragging.
Adding an elliptical or circular solder mask cutout
To add an elliptical or circular no solder mask area click on .
1. Move the cursor to the top left or bottom right corner for the cutout.
1. Click the left mouse button and drag the mouse to define the cutout or just hold down the left mouse button and drag.
4.  If you hold down the Shift key the cutout ellipse/circle will be centered at the position you first clicked. 
4. If you hold down the Ctrl key the cutout will be a circle.
4. You can hold down both the Shift and Ctrl key to create a circle cutout centered at the original left click.
1. Click again to end adding the cutout or release the left mouse button if you started by holding down and dragging.
Adding a polygonal solder mask cutout
To add an elliptical or circular no solder mask area click on .
1. Move the cursor to the first corner of the cutout and click the left mouse button.
1. Now drag the cursor to define the first edge and click to start the second edge.
1. Repeated drag and click to define additional edge.
1. Double click the complete the polygonal cutout.

14.21.2. [bookmark: Editing_Soldermasks1DDADFD9]Editing Solder Masks
Setting the color of the solder mask
To set the color of the solder mask click on the  button. The color selector dialog will appear. Make sure to make it semi-transparent so you can see through it when it is displayed. You can make it semi-transparent by dragging the T slider shown below.

Solder mask color

Removing a pad's  cutout
Normally a pad generates its own solder mask cutout. However you may want to define a custom no solder mask area and do not want the pad to automatically create a no solder mask region. You do this by selecting the pad and unchecking the Add Solder Cutouts checkbox in the pads properties panel.
Adding a custom soldermask cutout
You can add a custom solder mask cutout to the top or bottom side of the PCB. To add one you must have either the top copper layer or the bottom copper layer selected. You can do this using the layers panel.
A custom solder mask cutout can be rectangular (with optional rounded corners) or circular/elliptical or polygonal/curved.
Rotating a soldermask cutout
1. To rotate a cutout select the cutout by clicking on one of its edges.
1. Drag one of the corner manipulators to rotate it. See rotation snap  and rotating objects for more.

Scaling a soldermask cutout
1. To cutout a cutout select the cutout by clicking on one of its edges.
1. Drag one of the edge manipulators to scale it. See scaling objects for more.

Moving a soldermask cutout
To move a soldermask cutout, hold down the left mouse key over the cutouts edge and drag it.
Deleting a soldermask cutout
Select the cutout and press the DEL key.
14.21.3. [bookmark: Changing_a_Soldermask_Shape719EBF5D]Changing a Solder Mask Cutout's Shape
Solder mask cutouts come in 3 different forms. Rectangular, elliptical and polygonal/curved.
To change the shape first select the cutout.
To switch between rectangular, elliptical and polygonal/curved cutouts, click on the top tab.




14.21.3.1. [bookmark: Rectangular_Cutouts803792A0]Rectangular Cutouts
Solder mask cutouts can be rectangular. To change to  rectangular cutout click on the Rectangle tab in the cutouts properties in the properties panel.
Rectangular cutout can have rounded corners.

without and with rounded corners
To edit the parameters of a cutout, first select it. The properties panel will display the properties for the selected cutout.
X 
The x coordinate of the center of the cutout
Y 
The y coordinate of the center of the cutout
Width
The width of the cutout.
Height
The height of the cutout.
Roundness
Drag to from left to right to increase the rounding of the corners.
Layer
Select the layer for the cutout

14.21.3.2. [bookmark: Elliptical_Circular_Soldermask_C350AF1C2]Elliptical/Circular Cutout
Solder mask cutouts can be elliptical or circular. To change to an elliptical/circular cutout click on the Ellipse tab in the cutouts properties in the properties panel.
To edit the parameters of a cutout, first select it. The properties panel will display the properties for the selected cutout.

X 
The x coordinate of the center of the cutout
Y 
The y coordinate of the center of the cutout
Width
The width of the cutout.
Height
The height of the cutout.
Layer
Select the layer for the cutout

14.21.3.3. [bookmark: Polygonal_Curved_Soldermask_CutoBD927EBB]Polygonal/Curved Cutouts
Solder mask cutouts can be polygonal with optional curved edges. To change to  curved cutout click on the Curve tab in the cutouts properties in the properties panel.
To edit the parameters of a cutout, first select it. The properties panel will display the properties for the selected cutout.

Click the  button to show this help topic.
Vertex
This is the selected vertex/segment. The selected vertex is drawn as a solid red square. The selected segment id drawn in red.
X
The X coordinate of the selected vertex.
Y
The Y coordinate of the selected vertex.
Tension
Slide the  slider to change the 'curvature' of the curve.
Click  to add a vertex.
Click  to delete the selected vertex.
All Segments
Check the Smooth button to smooth the entire curve.
Check the Straight button to straighten the entire curve.
Check the Editable button to make the entire curve editable.
Segment
Click the button to straighten the selected segment.
Click the button to smooth the selected segment.
Layer
Use this drop-down to set the layer for the rectangle.
Click  to fillet the polygon
Editable Curves
Drag any of the control points to change the shape.
Uncheck the  button to make the control points for the vertex independent of each other.
14.21.4. [bookmark: Setting_The_Soldermask_MarginE094D5AD]Setting The Solder Mask Margin
You set the margin or soldermask expansion in the Solder Mask properties in the Layers panel. The margin is the gap between the pad and the solder mask. A value of 2-4 mils is usual.
The reason you have a margin > 0 is that during manufacture the layers never match up perfectly. The actual hole in the solder mask may be slightly less than what you specified, and that hole is always be placed in a slightly different location than what you specified. If your solder mask expansion is too small, then these misalignments cause the solder mask to partially or completely overlap SMT pads and through-hole pads.
With some designs, you want to make sure that the solder mask  never overlaps SMD pads. This is especially critical with QFN or LGA packages where the contacts of the parts do not stick out over the plastic molding or with parts that have a very fine pitch: Even small registration issues would cause the solderable areas of the  pads to be reduced. 

The solder mask properties
Below is a 100 Mil diameter pad with 3 different margins.

No margin

1 mil margin

5 mil margin
Below is what happens if the soldermask is misaligned. (Solder mask set to blue). So, the margin is to allow for manufacturing error and to ensure that all of the pad will have solder.

Perfect

Misaligned but acceptable

Misaligned and not acceptable
However, you do not want to make the margin too large because it could remove the solder mask between pad and risk solder bridging.

OK

Margin too large. No solder mask between pads.

14.21.5. [bookmark: Soldermask_Viewing_OptionsCC6A7F9A]Solder Mask Viewing Options
Hiding and displaying the solder mask
The solder mask is normally not visible in the PCB/Footprint view. However you can show/hide the mask by checking the   in the solder mask properties in the layers panel.

The Layers panel


A TPH pad on the left connected to a SMT pad on the right

Show pads as yellow. SMT pads have yellow border

Solder mask visible. Color gray with semi-transparency

Outline mask holes checked. Yellow outline for cutouts

Show PCB filled
14.21.6. [bookmark: Adding_Solder_Paste_to_a_SoldermC5B31568]Adding Solder Paste to a Solder Mask Cutout
Normally a solder mask cutout will not have a solder paste applied.
To add solder paste, check 

14.21.7. [bookmark: Adding_Soldermask_Cutout_to_Foot5133DD15]Adding Solder Mask Cutout to Footprints
You can add solder mask cutouts to footprints. When the part if placed on the PCB, the cutouts in the footprint will be added to the PCB. Swapping the side of a footprint will swap the side for all the cutouts.
14.21.8. [bookmark: Pad_Soldermask_Cutout59A6B786]Pad Solder Mask Cutout
By default, pads automatically add cutouts to the top/bottom soldermask as required. The shape of the cutout is automatically adjusted to the pads shape. 
You can turn off the automatic cutout generation by unchecking in the pads properties panel.
You would do this is you wanted to replace the automatic cutout with a custom one of your own design.

14.21.9. [bookmark: Soldermask_Cutouts_by_Combing_]Solder Mask Cutouts by Combining Shapes
You can combine 2 or more shapes into a soldermask cutout. See combing shapes.
To combine graphics objects into a cutout first select them and then click the Edit→Combine→ button. This button will only be enables if you have selected  objects than can be combined. These include:
· Rectangles
· Ellipses
· Polygons 
· Closed Curves
· Solder Mask Cutouts
Select the objects to combine.
Click  the Edit→Combine→ button

Click on  in the drop down.  


Several shapes on different layer to combine together to make a  cutout

The final cutout

14.22. [bookmark: Adding_Solder_Paste6FFD3CC3]Adding Solder Paste
AutoTRAX can automatically add solder paste for you.
You can optionally and your own custom solder paste areas.
SMT pads
Surface mounted pads automatically add a solder paste area. You can turn off the automatically added solder paste using the pad's properties panel.
TPH pads
Thru-plated hole (TPH) pads do not have solder paste automatically added.
No mask cutouts
No mask cutouts normally do not have solder paste but you can optionally have automatically generated solder paste added to the no mask cutouts.
Custom solder paste areas
Finally, you can add your own custom solder paste areas by adding any graphics to either the top solder mask layer or the bottom solder mask layer.
Layers panel
in the layers panel you will see to solder mask areas. The first one is above the top copper layer and the second one is below the bottom copper layer.
Normally this solder mask layers are off but you can easily turn them on using the layers panel.
14.22.1. [bookmark: Solder_Paste771563B7]Solder Paste
When generating Gerber files, AutoTRAX will automatically generate up to 2 additional file for the top and bottom layer solder paste stencils, but only if there are SMT pads on the top or bottom side. You can optionally add solder mask areas to no mask areas and also add your own custom no mask shapes. No file is generated for a side if there are Solder paste areas on that side.
No holes are output for TPH pads.
The 2 files with a (.gbr) extension are called:
· Top Solder Paste 
· Bottom Solder Paste
Solder paste (or solder cream) is used to connect the leads of surface mount integrated chip packages to attachment points (pads/lands) in the circuit patterns on a printed circuit board. The paste is typically applied to the pads using a stencil to "print" the paste, although other methods, like dispensing from a tube, are also used.
A majority of the defects in circuit-board assembly are caused due to issues in the solder-paste printing process or due to defects in the solder paste. There are many different types of defects—too much solder, and the solder melts and connects too many wires (bridging), resulting in a short circuit. Insufficient amounts of paste result in incomplete circuits. Head-in-pillow defects, or incomplete coalescence of ball grid array (BGA) sphere and solder paste deposit, is a failure mode that has seen increased frequency since the transition to lead-free soldering. Often missed during inspection, a head-in-pillow (HIP) defect appears like a small head resting on a pillow with a visible separation in the solder joint at the interface of the BGA sphere and paste deposit. An electronics manufacturer needs experience with the printing process, specifically the paste characteristics, to avoid costly re-work on the assemblies. The paste's physical characteristics, like viscosity and flux levels, need to be monitored periodically by performing in-house tests.
Solder paste is typically used in a screen-printing process, in which paste is deposited over a stainless steel or polyester mask to create the desired pattern on a printed circuit board. The paste may be dispensed pneumatically, by pin transfer (where a grid of pins is dipped in solder paste and then applied to the board), or by jet printing (where the paste is sprayed on the pads through nozzles, like an ink-jet printer).
As well as forming the solder joint itself, the paste carrier/flux must have sufficient tackiness to hold the components while the assembly passes through the various manufacturing processes, perhaps moved around the factory.
Printing is followed by preheating and reflow (melting).
The paste manufacturer will suggest a suitable reflow temperature profile to suit their individual paste; however, one can expend too much energy on this. The main requirement is a gentle rise in temperature to prevent explosive expansion ("solder balling"), yet activate the flux. Thereafter, the solder melts. The time in this area is known as Time Above Liquidus. A reasonably rapid cool-down period is required after this time.
A good tin/lead solder joint will be shiny and relatively concave. This will be less so with lead-free solders.
As with all fluxes used in electronics, residues left behind may be harmful to the circuit, and standards (e.g., J-std, JIS, IPC) exist to measure the safety of the residues left behind.
In most countries, "no-clean" solder pastes are the most common; in the United States, water-soluble pastes (which have compulsory cleaning requirements) are common.

14.22.2. [bookmark: Adding_Solder_paste_to_SMT_pads6AEDE05F]Adding Solder paste to SMT pads
By default SMT pads automatically add solder paste. However, you can disable this using the pads properties panel, see below.


Enabling and disabling automatic solder paste generation

Without solder paste

With auto-generated solder paste

Auto-generated solder paste disabled and 
custom shape added to solder paste layer

14.22.3. [bookmark: Adding_Solder_paste_to_no_mask_aB225915D]Adding Solder paste to no mask areas
To add solder paste to a no mask area first select either the top or bottom solder paste layer and add a graphic shape to that layer. The graphics shape will generate a solder paste area.


Auto-generated solder paste disabled and 
custom shape added to solder paste layer
14.22.4. [bookmark: Adding_custom_solde__paste_areas5B7023A3]Adding custom solder paste areas
To add solder paste to a no mask area first select either the top or bottom solder paste layer and add a graphic shape to that layer. The graphics shape will generate a solder paste area.


Auto-generated solder paste disabled and 
custom shape added to solder paste layer

14.22.5. [bookmark: Viewing_the_solder_paste6FA1A563]Viewing the solder paste
To view the solder paste set either the top and/or bottom solder paste layers visible.

The top and bottom solder paste layers
14.23. [bookmark: Checking_Your_PCB_Design26CF0E8F]Checking Your PCB Design

To check your design use the Design Checker panel.
You can  and  the design rules.
The Design Rules Checker tests for:
· Unrouted Tracks
· Minimum Track Width
· Track Intersections
· Track to Track Clearance
· Track to Pad Clearance
· Track to Via Clearance
· Track to Hole Clearance
· Track to Cutout Clearance
· Track to Keepout Clearance
· Track to Border Clearance

· Minimum Pad hole Diameters
· Minimum Pad Annular Ring Size
· Pad to Pad Clearance
· Pad to Via Clearance
· Pad to Hole Clearance
· Pad to Cutout Clearance
· Pad to Border Clearance

· Minimum Via Hole Diameters
· Minimum Via Annular Ring Size
· Via to Via Clearance
· Via to Hole Clearance
· Via to Cutout Clearance
· Via to Keepout Clearance
· Via to Border Clearance

· Hole to Hole Clearance
· Hole to Cutout Clearance
· Hole to Border Clearance

· Cutout to Cutout Clearance
· Cutout to Border Clearance

· Courtyard to Courtyard Clearance
· Courtyard to Holes Clearance
· Courtyard to Cutouts Clearance
· Courtyard to Border Clearance

· Silkscreen to Pad Clearance

Each test can be optionally turned on or off. All tests are on by default.
14.23.1. [bookmark: Unrouted_Tracks]Unrouted Tracks
All unrouted tracked segments will be marked as unrouted.

Unrouted track - marked with green circle (and arrow if error selected)
14.23.2. [bookmark: Minimum_Track_Width]Minimum Track Width
All routed track segments whose width is less than the minimum track width will be marked.
Move the mouse over the marker to display a tooltip showing the width and the minimum track width.

Track width minimum track width - marked with green circle (and arrow if error selected)
14.23.3. [bookmark: Track_Intersections98533670]Track Intersections
All tracks that intersect another track segments will be marked as shown below.

Intersecting tracks - marked with green circle (and arrow if error selected)
14.23.4. [bookmark: Track_to_Track_Clearance8054BC32]Track to Track Clearance
All track to track spacings that are less than the minimum track to track clearance will be marked as shown below.

Tracks too close together - marked with green circle (and arrow if error selected)
14.23.5. [bookmark: Track_to_Pad_Clearance07F9C862]Track to Pad Clearance
All track to pad spacings that are less than the minimum track to pad clearance will be marked as shown below.

Track too close to a pad - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.6. [bookmark: Track_to_Via_Clearance3DE69895]Track to Via Clearance
All track to via spacings that are less than the minimum track to via pad clearance will be marked as shown below.

Track too close to a via - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.7. [bookmark: Track_to_Hole_Clearance181F29CB]Track to Hole Clearance
All track to PCB hole (not pad or via holes) spacings that are less than the minimum track to hole pad clearance will be marked as shown below.

Track too close to a hole - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.8. [bookmark: Track_to_Cutout_ClearanceF41C7277]Track to Cutout Clearance
All track to PCB cutout spacings that are less than the minimum track to cutout clearance will be marked as shown below.

Track too close to a cutout - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.9. [bookmark: Track_to_Keepout_Clearance6AE8ECD4]Track to Keepout Clearance
All track to PCB keepout spacings that are less than the minimum track to cutout keepout will be marked as shown below.

Track too close to a keepout - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.10. [bookmark: Track_to_Border_ClearanceE69C6D2B]Track to Border Clearance
All track to PCB border spacings that are less than the minimum track to PCB border clearance will be marked as shown below.

Track too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.11. [bookmark: Minimum_Pad_Hole_Diameters]Minimum Pad hole Diameters
All TPH pads whose holes are less than the minimum hole diameter will be marked as below.

Pad hole too small  - marked with green circle (and arrow if error selected)
14.23.12. [bookmark: Minimum_Pad_Annular_Ring_Size]Minimum Pad Annular Ring Size
All  pads whose copper dimensions are less than the minimum pad annular ring will be marked as below.

Pad annular ring too small  - marked with green circle (and arrow if error selected)
14.23.13. [bookmark: Pad_to_Pad_Clearance]Pad to Pad Clearance
All pad to pad spacings that are less than the minimum pad to pad clearance will be marked as shown below.

Pads too close together - marked with green circle (and arrow if error selected)
14.23.14. [bookmark: Pad_to_Via_Clearance]Pad to Via Clearance
All pad to via spacings that are less than the minimum pad to via clearance will be marked as shown below.

Pads too close to a via - marked with green circle (and arrow if error selected)
14.23.15. [bookmark: Pad_to_Hole_Clearance]Pad to Hole Clearance
All pad to hole (not pad or via holes) spacings that are less than the minimum pad to hole clearance will be marked as shown below.

Pads too close to a hole - marked with green circle (and arrow if error selected)
14.23.16. [bookmark: Pad_to_Cutout_Clearance]Pad to Cutout Clearance
All pad to cutout spacings that are less than the minimum pad to cutout clearance will be marked as shown below.

Pads too close to a cutout - marked with green circle (and arrow if error selected)
14.23.17. [bookmark: Pad_to_Border_Clearance]Pad to Border Clearance
All pad to PCB border spacings that are less than the minimum pad to PCB border clearance will be marked as shown below.

Pad too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.18. [bookmark: Minimum_Via_Hole_Diameters]Minimum Via Hole Diameters
All vias whose holes are less than the minimum via hole diameter will be marked as below.

Via hole too small  - marked with green circle (and arrow if error selected)
14.23.19. [bookmark: Minimum_Via_Annular_Ring_Size]Minimum Via Annular Ring Size
All  vias whose copper dimensions are less than the minimum via annular ring will be marked as below.

Via annular ring too small  - marked with green circle (and arrow if error selected)
14.23.20. [bookmark: Via_to_Via_Clearance]Via to Via Clearance
.All via to via spacings that are less than the minimum via to via clearance will be marked as shown below.

Via too close together - marked with green circle (and arrow if error selected)
14.23.21. [bookmark: Via_to_Hole_Clearance]Via to Hole Clearance
All via to hole (not pad or via holes) spacings that are less than the minimum via to hole clearance will be marked as shown below.

Via too close to a hole - marked with green circle (and arrow if error selected)
14.23.22. [bookmark: Via_to_Cutout_Clearance]Via to Cutout Clearance
All via to cutout spacings that are less than the minimum via to cutout clearance will be marked as shown below.

Via too close to a cutout - marked with green circle (and arrow if error selected)
14.23.23. [bookmark: Via_to_Keepout_Clearance03421BAD]Via to Keep Out Clearance
All via to keepout spacings that are less than the minimum via to cutout clearance will be marked as shown below.

Via too close to a keepout - marked with green circle (and arrow if error selected)
14.23.24. [bookmark: Via_to_Border_Clearance]Via to Border Clearance
All via to PCB border spacings that are less than the minimum via to PCB border clearance will be marked as shown below.

Via too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.25. [bookmark: Hole_to_Hole_Clearance]Hole to Hole Clearance
.All hole to hole spacing that are less than the minimum hole to hole clearance will be marked as shown below.

Hole too close together - marked with green circle (and arrow if error selected)
14.23.26. [bookmark: Hole_to_Cutout_Clearance]Hole to Cutout Clearance
All hole to cutout spacings that are less than the minimum hole to cutout clearance will be marked as shown below.

Hole too close to a cutout - marked with green circle (and arrow if error selected)
14.23.27. [bookmark: Hole_to_Border_Clearance]Hole to Border Clearance
All hole to PCB border spacings that are less than the minimum hole to PCB border clearance will be marked as shown below.

Hole too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.28. [bookmark: Cutout_to_Cutout_Clearance]Cutout to Cutout Clearance
.All cutout to cutout spacings that are less than the minimum cutout to cutout clearance will be marked as shown below.

Cutouts too close together - marked with green circle (and arrow if error selected)
14.23.29. [bookmark: Cutout_to_Border_Clearance]Cutout to Border Clearance
All cutout to PCB border spacings that are less than the minimum cutout to PCB border clearance will be marked as shown below.

Cutout too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.30. [bookmark: Courtyard_to_Courtyard_Clearance8F06661A]Courtyard to Courtyard Clearance
All courtyard to courtyard spacings that are less than the minimum courtyard to courtyard clearance will be marked as shown below.

Courtyard too close to a hole - marked with green circle (and arrow if error selected)
14.23.31. [bookmark: Courtyard_to_Holes_ClearanceCB7F4060]Courtyard to Holes Clearance
All courtyard to hole (not pad or via holes) spacings that are less than the minimum courtyard to hole clearance will be marked as shown below.

Courtyard too close to a hole - marked with green circle (and arrow if error selected)
14.23.32. [bookmark: Courtyard_to_Cutouts_Clearance958C19B4]Courtyard to Cutouts Clearance
All courtyard to cutout spacings that are less than the minimum courtyard to cutout clearance will be marked as shown below.

Courtyard too close to a cutout - marked with green circle (and arrow if error selected)
14.23.33. [bookmark: Courtyard_to_Border_Clearance7505AD41]Courtyard to Border Clearance
All courtyard to PCB border spacings that are less than the minimum courtyard to PCB border clearance will be marked as shown below.

Courtyard too close to the PCB border - marked with green circle and line segment showing the distance (and arrow if error selected)
14.23.34. [bookmark: Silkscreen_to_Pad_Clearance]Silkscreen to Pad Clearance
All silkscreen to pad spacings that are less than the minimum pad to PCB border clearance will be marked as shown below.

Silkscreen too close to the pad - marked with green circle and line segment showing the distance (and arrow if error selected)
14.24. [bookmark: 3D]3D
14.24.1. [bookmark: Adding_3D_objects51D4AE48]Adding 3D objects
There are 2 ways to add 3D objects to a PCB or footprint.
The first is using the Add→3D menu item.
· Adding Internal 3D Objects
The second is to import 3D from an external file.
· Adding Internal 3D Objects


14.24.2. [bookmark: Adding_Internal_3D_Objects71C4BCC4]Adding Internal 3D Objects
Using the  Add→3D menu item
Use the  button group in the Add→3D ribbon button group when editing the PCB.
1. Select either the top or bottom layer as the current layer.
1. Add your graphics.
1. Set the height and base of the graphic using the properties panel of the Edit 3D Object dialog that opens and click Done when finished.
See the example of adding a cylinder to the PCB below...
Adding a cylinder to a PCB using the 3D object tools from the Add→3D ribbon button Group
14.24.3. [bookmark: Adding_External_3D_ObjectsF6D5B90E]Adding External 3D Objects
You can add  3D from an external file to both a PCB and a Footprint
Click on the Tools→Import→  button.
The import 3D file will be shown as shown below.

Select a file and click  to add it to the PCB.
The 3D model will be imported and embedded in a 3D Model.
Currently AutoTRAX will only import XGL files.
The XGL file format is designed to represent 3D information for the purpose of visualization.  It attempts to capture all of the 3D information that can be rendered by SGI's OpenGL rendering library.  It uses XML 1.0 syntax.  These features make XGL the ideal format to use when data must be exchanged between two graphics systems for the purposes of visualization.
Autodesk Inventor will export to XGL.
You can find loads of free 3D models at http://www.3dcontentcentral.com/
To turn them into XGL files:
1. Download the 3D file from http://www.3dcontentcentral.com/ as a .SAT file.
1. Start Autodesk Inventor.
1. Open the downloaded .SAT file.
1. Export to a XGL file.
1. Import it into AutoTRAX.
14.24.4. [bookmark: 3D_Models7849A242]3D Models
A 3D model is a 3D object imported from an external source.

A Transformer 3D model
To set the vertical height of the object use its properties dialog in the The Properties Panel

Drag the  thumb-wheel to the left or right to raise or lower the object in above/below the PCB.


14.24.5. [bookmark: External_Designs2446275F]External Designs
14.25. [bookmark: Creating_Complex_Shapes0FA384BB]Creating Complex Shapes
You can create a polygon from a collection of connected shapes.
In addition, on PCBs and Footprints you can create any of the following from a collection of connected shapes.
· PCB Border
· PCB Cutout
· Keepout region
· Copper Pour region
· TPH polygonal pad.



14.26. [bookmark: Drilling]Drilling
Backdrill and Controlled Depth Drilling 
The backdrill process removes stubs from plated-through-holes (vias). Stubs are the unnecessary /unused portions of vias, which extend further than the last connected inner layer.
Stubs can lead to reflections, as well as disturbances of capacity, inductance and impedance. This discontinuity errors become critical with increasing propagation speed.
Back-planes and thick Printed Circuit Boards in particular, can endure significant signal integrity disturbances through stubs. For High Frequency PCBs (e.g. with Impedance control), the application of backdrilling, as well as the application of blind and buried vias, can be part of the solution.
Backdrill can be applied to any type of circuit board where stubs cause signal integrity degradation, with minimal design and layout considerations. In contrast, when using blind vias, the aspect ratio has to be kept in mind.
Advantages of Backdrill
· Reduced deterministic jitter
· Lower bit error rate (BER)
· Less signal attenuation with improved impedance matching
· Increased channel bandwidth
· Increased data rates
· Reduced EMI radiation from the stubs
· Reduced excitation of resonance modes
· Reduced via-to-via crosstalk
· Aspect ratio can be neglected (in contrast to blind vias)

15. [bookmark: Printing_And_Plotting082C1185]Printing and Plotting
AutoTRAX can print any view and produce a series of plots for your PCB.
You can optionally add watermarks to your printed pages.
15.1. [bookmark: Printing]Printing
To print any view click the Home→Print→ button.

Print Preview
The print preview shown above consists of a ribbon menu, a options panel on the left and a preview window to the right of the options panel and below the ribbon menu.
click  to print the selected pages.
Ribbon Menu
The ribbon menu can be split into 2 parts, the View button group on the left and the common ribbon button groups on the right.
The  button shows/hides the option panel shown below.
Click to read about the Common Print Menu
The Option Panel
The options panel lets you scale the printing or have the sheets automatically fill the printed page,
Check  to have the sheets automatically fill the printed page, If you uncheck it, you can set the print scale. Note, it is possible to set the scale such that the sheet will not all fit on the printed page.
Check/uncheck the check boxes in the Print column to include/exclude the sheet in the print run.
Clicking displays this help topic.


Options Dialog

15.2. [bookmark: Plottings]Plottings
To plot your PCB click the Tools→CAM→ button.

Plot Preview
The ploy preview shown above consists of a ribbon menu, a options panel on the left and a preview window to the right of the options panel and below the ribbon menu.
click  to print the selected pages.
Ribbon Menu
The ribbon menu can be split into 2 parts, the View button group on the left and the common ribbon button groups on the right.
The  button shows/hides the option panel shown below.
Click to read about the Common Print Menu
The Option Panel
The options panel lets you scale the printing or have the sheets automatically fill the printed page.
Scale
Check  to have the sheets automatically fill the printed page, If you uncheck it, you can set the print scale. Note, it is possible to set the scale such that the sheet will not all fit on the printed page.
Labels
 Check to print plot layer labels 
 Check to add a the file name to each plot. 
 Check to add a date to each plot. 
Show
 Check add small drill target/centers to each pad/via that has a hole.
 Check to add targets to  the printed output.
 Check to include the PCB border in the printed output.
Layers to Plot
Check/uncheck the check boxes in the Plot column to include/exclude the layer in the print run.
Check/uncheck the check boxes in the Negative column to print that sheet in negative.
Check/uncheck the check boxes in the Reverse column to print that sheet reversed in the horizontal direction.
Clicking displays this help topic.

Options Dialog


15.3. [bookmark: Print_MenuF5DB4137]Print Menu
The common print menu is shown below.

Print common menu items
Print
	
	 Select a printer, number of copies, and other printing options before printing.


	
	 Send the document directly to the default printer without making changes.

	
	Open the Print Options dialog, in which you can change printing options.


Page Setup
	
	Edit the header and footer of the document.

	
	Stretch or shrink the printed output to a percentage of its actual size.

The scaling dialog


	
	Select the margin sizes for the entire document. To apply specific margin sizes to the document, click Custom Margins.

The margins dialog
Custom Margins
Click this to display the custom margins dialog.

The  custom margins dialog

	
	Switch the pages between portrait and landscape layouts.

The  orientation selector


	
	Choose a paper size for the current section.

The page size selector


Navigation

	

	Display the find dialog.


	

	Open the document map which allows you to which allows you to view a structural view of the design.

	

	Navigate to the first page of the design.

	

	Navigate to the previous page of the design.

	

	Navigate to the next page of the design.

	
	Navigate to the last page of the design.



Zoom
	
	Mouse Pointer
Show the mouse pointer.

	
	Hand Tool
Invoke the Hand tool to manually scroll through pages.

	
	Magnifier
Invoke the Magnifier tool. Clicking once on a document zooms it so that a single page becomes entirely visible, while clicking another time zooms it to 100% of the normal size.

	
	Choose the page layout to arrange the document pages in preview.


	
	Zoom out to see more of the page at a reduced size.

	
	Change the zoom level of the document preview.


	
	Zoom in to get a close-up view of the document.


Page Background
	
	Choose a color for the background of the document pages.

The background color dialog

	
	Insert ghosted text or image behind the content of a page. This is often used to indicate that a document is to be treated specially see Watermarks


The watermark dialog





15.4. [bookmark: Watermarks]Watermarks
AutoTRAX can add watermarks to your printed output. There are 2 basic types of watermark.
1. Text Watermarks
1. Picture Watermarks
To set the watermark click the  button in the print preview menu.

15.4.1. [bookmark: Text_WatermarksCE95298F]Text Watermarks


A Text Watermark
Select the Text Watermark in the watermark dialog to add a text watermark and define its properties.

The text watermark dialog
Preview
You can see a preview of the watermark on the left of the dialog.
Text
Enter the text for the watermark.
Direction
Select the direction for the text from one of four options.

Set the watermark's direction
Color
Select the color for the watermark text.

Set the watermark color
Font
Select the font for the watermark text. You can also select a bold and/or italic  font.
Size
Select the height for the watermark text.
Position
You can set the position of the watermark to be in front of the page or behind all graphics on the page.

Set the watermark's position
Transparency
You can set the level of transparency for the text so you can 'see through' the watermark.

Set the watermark's transparency
Page Range
Enter the page numbers and/or page ranges separated by commas. For example: 1,3,5-12 to add watermarks to pages 1,3 and 5 to 12.

Finally
Click to reset the watermark.
Click the button to accept your changes.



15.4.2. [bookmark: Picture_Watermarks9ACA100E]Picture Watermarks

A Picture Watermark
Select the Picture Watermark to add an image watermark add define its properties.

The picture watermark dialog
Preview
You can see a preview of the watermark on the left of the dialog.
Load Image
Click  to display the load image file dialog.
Size Mode
Select the sizing mode for the picture.

The picture's sizing mode
Horizontal alignment
Select the horizontal alignment.

The picture's horizontal alignment
Vertical alignment
Select the vertical alignment.

The  picture's vertical alignment
Tiling
Check  to tile the image.
Position
You can set the position of the watermark to be in front of the page or behind all graphics on the page.

Set the watermark's position
Transparency
You can set the level of transparency for the text so you can 'see through' the watermark.

Set the watermark's transparency
Page Range
Enter the page numbers and/or page ranges separated by commas. For example: 1,3,5-12 to add watermarks to pages 1,3 and 5 to 12.

Finally
Click to reset the watermark.
Click the button to accept your changes.



16. [bookmark: Manufacturing_YourPCB6CA1BF6D]Manufacturing Your PCB
AutoTRAX gives you a complete set of tools to help make your PCBs.
· Plotting Your PCBs
· Previewing Your Gerber Files
· Generating Gerber Files
· Generating Drill Files
· Creating a Pick and Place File
· Your Bill of Materials (BOM)
· Putting It All Together in a Zip File


16.1. [bookmark: Plotting_PCBs0358D422]Plotting Your PCBs
To plot your PCB click the Tools→CAM→ button.
See Plottings for more on plotting.
16.2. [bookmark: True_type_fontsB9F74674]True-type fonts
With AutoTRAX you can choose between classic simple 'stick' text or professional looking True-type fonts for your PCB silkscreens. This video shows you the difference and how to make your choice.
 (
True-type fonts for PCB production
)[image: ]


16.3. [bookmark: Previewing_Gerber_FilesEBB57AA0]Previewing Your Gerber Files
You can preview your Gerber files using AutoTRAX's own Gerber viewer.
To display the Gerber viewer click the Tools→CAM→ button.

The Gerber Viewer
16.4. [bookmark: Generating_Gerber_FilesBA95B938]Generating Gerber Files
To generate a set of Gerber files click the Tools→CAM→ button.
16.5. [bookmark: Generating_Drill_Files36079D1E]Generating Drill Files
To generate a NC drill file click the Tools→CAM→ button.
16.6. [bookmark: Creating_a_Pick_and_Place_FileC38E2D70]Creating a Pick and Place File
To generate a NC drill file click the Tools→CAM→ button.
The pick and place file is a comma separated file (CSV) compatible with Microsoft Exel and the spreadsheet programs.
Pick and Place Origin
If you add automatic fiducial to your panel then the origin for the Pick and Place file coordinates is set to the lower left fiducial else it is set to the bottom left corner of the panel.
Check the appropriate units in the radio check box.



16.7. [bookmark: Bill_Of_Materials368D5FB4]Your Bill of Materials
To generate a Bill of Materials (BOM) file click the Tools→CAM→ button.
A bill of materials or product structure (sometimes bill of material, BOM or associated list) is a list of the raw materials, sub-assemblies, intermediate assemblies, sub-components, parts and the quantities of each needed to manufacture an end product. A BOM may be used for communication between manufacturing partners, or confined to a single manufacturing plant. A bill of materials is often tied to a production order whose issuance may generate reservations for components in the bill of materials that are in stock and requisitions for components that are not in stock.
A BOM can define products as they are designed (engineering bill of materials), as they are ordered (sales bill of materials), as they are built (manufacturing bill of materials), or as they are maintained (service bill of materials or pseudo bill of material). The different types of BOMs depend on the business need and use for which they are intended. In process industries, the BOM is also known as the formula, recipe, or ingredients list. The phrase "bill of material" (or BOM) is frequently used by engineers as an adjective to refer not to the literal bill, but to the current production configuration of a product, to distinguish it from modified or improved versions under study or in test.
In electronics, the BOM represents the list of components used on the printed wiring board or printed circuit board. Once the design of the circuit is completed, the BOM list is passed on to the PCB layout engineer as well as component engineer who will procure the components required for the design.
Items in a Bill of Materials


16.7.1. [bookmark: Items_in_a_Bill_of_Materials2EFB4C35]Items in a Bill of Materials
You can include the follow items in a bill of materials:
Reference
The reference is the footprint reference that you will see in the PCB. This identifies the part both on your PCB and in your schematics e.g. R1 for a resistor.
Value
The value is the type of the part for instance it could be a capacitor where the value might be 100pF or it could be a device type such as 7400. You will most likely see the value in the schematic and sometimes it will be displayed in the PCB as a marker on the 3-D component.
Package
The package is the type of physical packaging for the part. For instance, it might be a DIP 40.
Pad Count
The pad count is a number of pads that make up the footprint for the part. For instance a DIP 40 would have 40 pads
Placement
The placement is the placement point for the part on the PCB and is defined by the placement point in the footprint.
Rotation
The rotation is the rotation of the footprint on the PCB and is given in degrees
Side
The side details which side of the PCB the parties mounted. It can be either the top side on the bottom side.
SMT/TPH
This despair is whether the part is a Surface mount technology part (SMT) or a Through-plated-hole (TPH) part.
Description
The description is a short textual description of your part.
Datasheet
The datasheet is the web address of the datasheet for the part. This is often a link to a PDF file
Comment
The comment is what it says it is: a comment!
Part Number
This is the part number that you want to use to specify the part in your own organization.
Manufacturer
This is the manufacturer of the part
Manufacturer's Website
This is the website for the manufacturer.
Manufacturer's Part Number
This is the part number for the part as specified by the manufacturer.
Vendor
This is the vendor formal you will actually purchase the part. For instance it could be Stock, Mouser, Farnell or Digikey.
Vendor's Website
This is the website for the vendor.
Vendor's Part Number
This is the part number for the part as specified by the vendor.
Price
This is the price for a part.
16.8. [bookmark: Putting_It_All_TogetherB73C816C]Putting It All Together in a Zip File
To create a complete set of files for making your PCB, click the Tools→CAM→ button.
16.9. [bookmark: Manufacturing_SettingsC50B9572]Manufacturing Settings
To set the Gerber and plotting settings click on the small  button at the bottom right of the Tools→Cam Rules ribbon button group.





16.9.1. [bookmark: Design_RulesCC6A7BAC]Design Rules
To set Design Rules, click on the small  button at the bottom right of the Tools→Design Rules ribbon button group.

17. [bookmark: GettingSupport]Getting Support
There are several ways to get help.
The first obvious place for help is this help file which is available by clicking on  button from the Help tab of the ribbon menu.
Next you can use the Support site.
You can also send Feedback or use the Wish List site.

Tutorial Videos
Getting Daily Tips
Find Out About Your Version
Find Out About Your Version
What's New
Getting the Latest Version
Subscribing to the Newsletter
Reporting Problems
Adding to Your Wish-list
Sending Feedback
The AutoTRAX Website
17.1. [bookmark: Find_Out_About_Your_Version75D23031]Find Out About Your Version
Information about AutoTRAX can be obtained by using the  button from the Home tab of the ribbon menu.
This will display the About AutoTRAX Design Express dialog below
About AutoTRAX Design Express
The build version is displayed towards the top right of the dialog. In this case AutoTRAX was built on the 3rd. February, 2012 at 9.45 GMT.
View Installation Directory - Displays the file location where AutoTRAX has been installed. This includes the program itself, all supporting assemblies and this help file.
View Data Directory - Displays the file location of the local database of parts.
View Settings Directory - Displays the file location of the settings files for AutoTRAX

Clicking OK closes the dialog box and clicking on the Help button shows this help topic.
17.2. [bookmark: Whats_NewA9832C2A]What's New
To find out What's New in AutoTRAX click on the  button in the Home→Account ribbon menu button group.

17.3. [bookmark: News_Letter69FA3C3C]Subscribing to the NewsLetter

You can subscribe to the AutoTRAX newsletter at http://dexpcb.com/newsletter/
17.4. [bookmark: AutoTRAX_WebsiteE7776B26]The AutoTRAX Website
The AutoTRAX website is at http://dexpcb.com

On the web site you fill find many useful features including:
· Download Details
· Download Archives
· Tutorial Videos
· Screen Shots and Slide Shows
· Support Topics
· Free Gerber Viewers
· Running AutoTRAX on Apple Macs.
· Purchase Details
· Renewal Details and how to get updates for another 12 months.
· Contacting Us
· Company Details

17.5. [bookmark: Getting_The_Latest_Version1AF413AB]Getting the Latest Version
You can manually download the latest version of AutoTRAX at http://dexpcb.com/download/
You can see an archive of older versions of AutoTRAX at http://dexpcb.com/Download/Archive
17.6. [bookmark: Downloading_Older_VersionsC822DD17]Downloading Older Versions
An archive of older versions of AutoTRAX is available at http://dexpcb.com/Download/Archive
You can install more than one version of AutoTRAX on the same machine. They will share a common set of configuration files. However you will need to disable auto-updating otherwise whenever you run an old version it will prompt you to download the latest. You can disable auto-updating when AutoTRAX asks you if you wish to auto-update, see dialog below:

Click the cancel button to cancel auto-updating.  AutoTRAX will then ask you if you wish to check again next time the program runs. Click the No button to disable auto-updatings.

To re-enable auto-update click on the Get Latest Version button  in the Home→Account menu 
17.7. [bookmark: Sending_FeedbackC626F25C]Sending Feedback

We would love to have feedback from you on improving both this manual and AutoTRAX so that your design experience is improved.
To send feedback please go to the AutoTRAX website and use the send feedback page at http://dexpcb.com/Support/Feedback
If you wish to send feedback on AutoTRAX, click on the  button in the Help→Support ribbon menu button group.

17.8. [bookmark: Wishlist]Adding to Your Wish List
If you have a useful feature you would like to have in AutoTRAX, please select the  button from the Help→Support ribbon menu button group. This will take you to the AutoTRAX Software Wish-list web page.
17.9. [bookmark: Getting_Daily_Tips48236121]Getting Daily Tips
AutoTRAX has a helpful Tip of the Day dialog that you can view on demand or optionally have appear every time you start AutoTRAX.
To display the Tip of the Day dialog use the  button from Help tab of the ribbon menu.
The dialog is shown below and contains handy tips on using AutoTRAX.
Tip of the Day dialog box
 Shows the next 'tip of the day'.
 Shows the previous 'tip of the day'.
 Displays this help topic.
 Closes the 'tip of the day' dialog.
 If checked, then the 'tip of the day' will be displayed every time AutoTRAX starts; otherwise, you will need to use the  button from Help tab of the ribbon menu.
17.10. [bookmark: Reporting_Problems277CD66B]Reporting Problems
If you have a problem with AutoTRAX and you can run AutoTRAX, click the Help→Support→ button. This is the preferred method of reporting problems.
If you are unable to run AutoTRAX, you can use the Support site to report problems.  
Every effort possible is made to ensure that your problem gets resolved in a timely manner. Your patronage is appreciated and valued. You continued usage of AutoTRAX, problem reporting, and suggestions help us to improve the product to your benefit.
17.11. [bookmark: The_User_GroupD4B61B2D]The User Group
AutoTRAX has a strong users group of over 2700 users. Here you can discuss topics relating to AutoTRAX. Please go to the user group for more information by click the Help→Support→ button.

Sample page for the user group
17.12. [bookmark: Fonts]Using Graphic Symbols Fonts
The Windows True Type Symbol Font MARVOSYM.TTF is a valuable addition for AutoTRAX. It contains often-needed but rarely available symbols as the CE Symbol, Fax Machine, Answering Machine, Cellular Phone, Steel Profile Symbols, the original Euro Currency Symbol and lots more.
These are ideal for symbols to place on your PCB silkscreens or copper layers as well as in your schematic. These symbols will output to Gerber files.
NOTE: You must install this font on all machines you wish to view designs using this font. There are not needed once you generate Gerber files as the symbols are converted to Gerber commands.

Sample Symbols
View the PDF documentation http://dexpcb.com/DownloadFiles/marvosym.pdf
Installing and Using The Font
Download the font from http://dexpcb.com/DownloadFiles/marvosym.zip
Open the zip file and double click on marvosym.ttf

This shows the font dialog below. Click the button to install it.

To use it, add text to your schematic/PCB and set the font to MARVOSYM and set the font or scale the text.

17.13. [bookmark: Contacting_Us444A399D]Contacting Us
We love hearing from our customers as their feedback helps us improve AutoTRAX, so please feel free to contact us.
Email
You can contact us by email using the Send us email web page at http://dexpcb.com/Support/SendUsAnEmail
Location
You can find out more information about AutoTRAX at http://dexpcb.com/Company or by sending us an email. 

18. [bookmark: Importing_FilesF523E063]Importing Files
You can import the following file types into AutoTRAX:
· AutoTRAX EDA
· AutoTRAX EDA Library
· AutoCAD DXF Files
· Eagle Libraries and Files 


18.1. [bookmark: Importing_EDA_Designs1FEEDB22]Importing Your AutoTRAX EDA Designs
To read AutoTRAX EDA files into AutoTRAX open either the schematic file or the PCB file. AutoTRAX will read both and combine them into a single design.
18.2. [bookmark: Importing_EDA_Library05D2381C]Importing Your AutoTRAX EDA Library
To import your AutoTRAX EDA library click the Tools→Utilities→ button.
18.3. [bookmark: Importing_DXF7CE0F58E]Importing AutoCAD DXF Files
To import an AutoCAD DXF file into AutoTRAX click the Tools→Import → button.
The objects will be imported on to the current layer and added to a single group. 3D dimensions will be ignored.

DXF import dialog
Color for 'White' lines etc.
Click the  button to select the color to use for DXF entities.
Scale
Select the scale for importing entities. The larger the number, the larger the entities will be when imported.
DXF Units
 Select the units in the DXF file. 
 Click to display this help topic.

18.4. [bookmark: Importing_Eagle_ProjectsAC859C7B]Importing Eagle Projects
You can import Eagle schematic and board files into AutoTRAX. They will combined into a single project.
18.5. [bookmark: Importing_Eagle_Libraries0AA77F1C]Importing Eagle Libraries
To import an Eagle library file into AutoTRAX click the Tools→Import→ button.
AutoTRAX will combine the part schematic symbols and the footprints (if found) into a single AutoTRAX part.

Eagle import dialog
Source Directory
Enter the directory containing the Eagle libraries.
Target Directory
Enter the target directory for the converted parts.
Recursive Search of Source Directory
Check to search the source directory and all it's child directories for Eagle libraries.
Compress Part Files
Check to automatically compress the resulting AutoTRAX parts. This is highly recommended and will save you over 90% of the disk space for uncompressed files.
Optimize for AutoTRAX
Check to have terminal magnets and parametric footprints automatically created for each part whenever possible.
 Click to convert all libraries found.
 Click to cancel this dialog.
 Click to show this help topic.


18.6. [bookmark: Importing_3D504CA979]Importing 3D
To import a 3D file into AutoTRAX click the Tools→Import→ button.
19. [bookmark: Exporting]Exporting Data
You can export your design to the following formats:
· A CNC File
· A PDF File
· An IDF File
· A SVG File
· A Net List File
· An Image File
· 
19.1. [bookmark: CNC]CNC
AutoTRAX can directly create the CNC files you need to create a PCB.
Creating a CNC File
Printed circuit board milling (also: isolation milling) is the process of removing areas of copper from a sheet of printed circuit board material to recreate the pads, signal traces and structures according to patterns from a digital circuit board plan known as a layout file. Similar to the more common and well known chemical PCB etch process, the PCB milling process is subtractive: material is removed to create the electrical isolation and ground planes required. However, unlike the chemical etch process, PCB milling is typically a non-chemical process and as such it can be completed in a typical office or lab environment without exposure to hazardous chemicals. High quality circuit boards can be produced using either process. In the case of PCB milling, the quality of a circuit board is chiefly determined by the system's true, or weighted, milling accuracy and control as well as the condition (sharpness, temper) of the milling bits and their respective feed/rotational speeds. By contrast, in the chemical etch process, the quality of a circuit board depends on the accuracy and/or quality of the photo-masking and the state of the etching chemicals.

Milled Printed Circuit Board
PCB milling has advantages for both prototyping and also for some specialist PCB designs.
Prototyping can provide a fast-turnaround board production process without the need for wet processing. If a CNC mill is already used for drilling, this single machine can carry out both parts of the process.
Some PCBs, requiring extensive drilling or profiling of the board outline are particularly suitable for production by milling. Where the tracks must precisely follow the board shape, using the same CNC mill for both reduces registration and scaling errors. Many boards that are simple for milling would be almost impossible by wet etching and manual drilling afterwards.
In mass production, milling is unlikely to replace etching although the use of CNC is already standard practice for drilling the boards.
PCB milling system is a single machine that can perform all of the required actions to create a prototype board, with the exception of inserting vias and through hole plating. Most of these machines require only a standard AC mains outlet and a shop-type vacuum cleaner for operation.
he mechanics behind a PCB milling machine are fairly straightforward and have their roots in CNC milling technology. A PCB milling system is similar to a miniature and highly accurate NC milling table. For machine control, positioning information and machine control commands are sent from the controlling software via a serial port or parallel port connection to the milling machine's on-board controller. The controller is then responsible for driving and monitoring the various positioning components which move the milling head and gantry and control the spindle speed. Spindle speeds can range from 30,000 RPM to 100,000 RPM depending on the milling system, with higher spindle speeds equating to better accuracy. Typically this drive system comprises non-monitored stepper motors for the X/Y axis, an on-off non-monitored solenoid or pneumatic piston for the Z-axis, and a DC motor control circuit for spindle speed, none of which provide positional feedback. More advanced systems provide a monitored stepper motor Z-axis drive for greater control during milling and drilling as well as more advanced RF spindle motor control circuits that provide better control over a wider range of speeds.
X and Y axis control
For the X and Y axis drive systems most PCB milling machines use stepper motors that drive a precision lead screw. The lead screw is in turn linked to the gantry or milling head by a special precision machined connection assembly. To maintain correct alignment during milling, the gantry or milling head's direction of travel is guided along using linear or dovetailed bearing(s). Most X/Y drive systems provide user control, via software, of the milling speed, which determines how fast the stepper motors drive their respective axes.
Z axis control
Z axis drive and control are handled in several ways. The first and most common is a simple solenoid that pushes against a spring. When the solenoid is energized it pushes the milling head down against a spring stop which is attached to a pressure foot assembly that limits the milling head's downward travel. The rate of descent as well as the amount of force exerted on the spring stop must be manually set by mechanically adjusting the position of the solenoid's plunger. The second type of Z-axis control is through the use of a pneumatic cylinder - this system functions in the same manner as the solenoid type, pushing against a spring stop/pressure foot assembly. Air for the cylinder is provided by an external compressor with the air flow being controlled by a manually operated regulator and software driven gate valve. Due to the small cylinder size and the amount of air pressure used to drive it there is little range of control between the up and down stops. Both the solenoid and pneumatic system provide no positional feedback while in motion, and are therefore useful for only simple 'up/down' milling tasks. The final type of Z-axis control uses a stepper motor with dynamic positioning feedback. This system allows the milling head to be moved in small accurate steps up or down through its whole range of vertical motion. Further, the speed of these steps can be adjusted to allow tool bits to be eased into the board material rather than hammered into it. The depth (number of steps required) as well as the downward/upward speed is under user control via the controlling software.
Tooling 
PCBs may be machined with conventional end-mills, conical d-bit cutters, and spade mills. D-bits and spade mills are cheap and as they have a small point allow the traces to be close together. 
Alternatives
A method with similar advantages to mechanical milling is laser etching. Etching PCBs with lasers offers the same advantages as mechanical milling in regards to quick turnaround times, but the nature of the laser etching process is preferable to both milling and chemical etching when it comes to physical variations exerted on the object. Whereas mechanical milling and chemical etching exact physical stress on the board, laser etching offers non-contact surface removal, making it a superior option for PCBs where precision and geometric accuracy are at a premium, such as RF & Microwave designs.


19.1.1. [bookmark: Export_To_CNC3FBB957F]Creating a CNC File
To create/export to a CNC file click the Tools→Export→ button. The dialog box show below will appear.
AutoTRAX will generate.
1. A top side CNC file named XXXX-Top.nc
1. A bottom side CNC file named XXXX-Bottom.nc
1. A Board profile file named XXXX-Profile.nc
1. A Drilling file named XXXX-Drill.nc
1. Where XXXX is the name you select.

Generate CNC files dialog
 Check to show a report of files generated.

Typical Report File
 Check to show a view of the files generated. See CNC Viewer

Move Height
This is the vertical (Z) height for movements of the tool when not cutting.
Fast Feed-Rate
Enter the feed rate when the cutter is moving without cutting at the move height.
Cutter Diameter
Enter the diameter for the cutter.
Cut Feed-Rate
Enter the feed rate when the drill is cutting.
Surface Height 
This is the vertical (Z) height for below which the feed-rate is given by the cut feed-rate.
Target Depth
This is the vertical (Z) height for the cutter when cutting copper.
Output Top Layer
Check to output the top layer.
Output Bottom Layer
Check to output the bottom layer.
Quality
Select quality.
To see the effect of the quality setting consider the following sample PCB...



High
The high setting gives you the best quality of CNC cut as shown below.

Low
The low setting gives you the best quality of CNC cut as shown below. Note, the rounded corners of the rectangles are replaced by beveled corners. This setting gives you a lot faster production of your CNC files compared to the high setting but is much slower than the Quick setting.

Quick
The quick setting gives you the poorest quality of CNC cut as shown below. Note, elliptical and rounded pad shapes are replaced by rectangular budgets and vias are replaced by rectangles. This will give you the quickest production of your CNC files and is useful for complicated PCBs.


 Click to display this help topic.
Click  to generate the CNC files. You will see 3 progress dialogs like the one shown below; one for the top side and one for the bottom side.

File generation progress dialog.
After the files have been generated you will see the report and/or the CNC Viewer

19.1.2. [bookmark: CNC_ViewerC5E5713F]CNC Viewer
The CNC viewer is shown below.

Click  to view the top side of the PCB and click  to view the bottom of the PCB.
 Click this to view an area in the viewport. Then hold down and drag the mouse to define the area to view.
 Zoom in to see a magnified view of the PCB.
 Zoom out to see more of the PCB.
 View all the PCB.
 Display/hide rulers around the edge of the viewport.
 Click to show/hide the grid.
 Click to display this help topic.
 Click to close the viewer.
CNC Print Preview
 Click this to print a the side being viewed. This will display the Print preview dialog shown below.

Print Preview
The print preview shown above consists of a ribbon menu, a options panel on the left and a preview window to the right of the options panel and below the ribbon menu.
click  to print the selected pages.
Ribbon Menu
The ribbon menu can be split into 2 parts, the View button group on the left and the common ribbon button groups on the right.
The  button shows/hides the option panel shown below.
Click to read about the Common Print Menu
The Option Panel
The options panel lets you scale the printing or have the sheets automatically fill the printed page,
Check  to have the sheets automatically fill the printed page, If you uncheck it, you can set the print scale. Note, it is possible to set the scale such that the sheet will not all fit on the printed page.
Check/uncheck the check boxes in the Print column to include/exclude the sheet in the print run.
Clicking displays this help topic.


Options Dialog










19.2. [bookmark: Creating_a_DXF_File20C4575F]Creating a DXF File
To create/export to a DXF file click the Tools→Export→ button.

DXF export dialog
 Click to show this help topic.
Auto CAD DXF (Drawing Interchange Format, or Drawing Exchange Format) is a CAD data file format developed by Autodesk for enabling data interoperability between AutoCAD and other programs.
DXF was originally introduced in December 1982 as part of AutoCAD 1.0, and was intended to provide an exact representation of the data in the AutoCAD native file format, DWI (Drawing), for which Autodesk for many years did not publish specifications. Because of this, correct imports of DXF files have been difficult. Autodesk now publishes the DXF specifications on its website for versions of DXF dating from AutoCAD Release 13 to AutoCAD 2010.
Versions of AutoCAD from Release 10 (October 1988) and up support both ASCII and binary forms of DXF. Earlier versions support only ASCII.
As AutoCAD has become more powerful, supporting more complex object types, DXF has become less useful. Certain object types, including ACIS solids and regions, are not documented. Other object types, including AutoCAD 2006's dynamic blocks, and all of the objects specific to the vertical market versions of AutoCAD, are partially documented, but not well enough to allow other developers to support them. For these reasons many CAD applications use the DWG format which can be licensed from Autodesk or non-natively from the Open Design Alliance.


19.3. [bookmark: Export_To_PDF3FBBF1B9]Creating a PDF File
To create/export to a PDF file click the Tools→Export→ button.


PDF export dialog
All Schematic - Click to add all schematic diagrams to the PDF file.
PCB - Click to add all schematic diagrams to the PDF file.
Layers - Click to a separate page for each layer to the PDF file.
Top View - Click to add a view of the top of the PCB to the PDF file.
Bottom View - Click to add a view of the bottom of the PCB to the PDF file.
 Click to show this help topic.
Portable Document Format (PDF) is a file format used to represent documents in a manner independent of application software, hardware, and operating systems. Each PDF file encapsulates a complete description of a fixed-layout flat document, including the text, fonts, graphics, and other information needed to display it. In 1991, Adobe Systems co-founder John Warnock outlined a system called "Camelot" that evolved into PDF.
While Adobe Systems made the PDF specification available free of charge in 1993, PDF remained a proprietary format, controlled by Adobe, until it was officially released as an open standard on July 1, 2008, and published by the International Organization for Standardization as ISO 32000-1:2008. In 2008, Adobe published a Public Patent License to ISO 32000-1 granting royalty-free rights for all patents owned by Adobe that are necessary to make, use, sell and distribute PDF compliant implementations.


19.4. [bookmark: Export_To_IDF3FBBBF2A]Creating a IDF File
To export to an IDF file click the Tools→Export→ button.
The Intermediate Data Format (IDF) is a format for exchanging printed circuit assembly information between ECAD and MCAD systems.

19.5. [bookmark: Export_To_SVG3FBC0A6B]Creating a SVG File
To create/export to a SVG file click the Tools→Export→ button.

SVG export dialog
Maximum Size - Enter the maximum dimension of the image in pixels. The other dimension will be set by the aspect ratio of the contents.
 Click to show this help topic.
Scalable Vector Graphics (SVG) is an XML-based vector image format for two-dimensional graphics that has support for interactivity and animation. The SVG specification is an open standard developed by the World Wide Web Consortium (W3C) since 1999.
SVG images and their behaviors are defined in XML text files. This means that they can be searched, indexed, scripted, and, if need be, compressed. As XML files, SVG images can be created and edited with any text editor, but it is often more convenient to create them with drawing programs such as Inkscape.
All major modern web browsers—including Mozilla Firefox, Internet Explorer 9 and 10, Google Chrome, Opera, and Safari—have at least some degree of support for SVG and can render the markup directly.
19.6. [bookmark: Export_Spice_Deck58F24E65]Creating a Spice Deck File
To create/export to a SPICE deck file click the Tools→Export→ button.

19.7. [bookmark: Export_To_NetList1A5DFE2A]Creating a Net List File
To create/export to a Netlist file click the Tools→Export→ button.
A "netlist" describes the connectivity of your electronic design.

19.8. [bookmark: Saving_to_an_Image0CA9E32E]Saving to an Image File
To save the current view to an image file click the Tools→Export→ button.
Maximum Size
Enter the maximum pixel/resolution size. The image saved is the same aspect ratio of the current viewport. So, to change the viewport aspect ratio, re-size the viewport.

Save to Image Dialog
Maximum Size - Enter the maximum dimension of the image in pixels. The other dimension will be set by the aspect ratio of the current viewport.
 Click to show this help topic.
You can save to the following formats:
BMP
The BMP file format, also known as bitmap image file or device independent bitmap (DIB) file format or simply a bitmap, is a raster graphics image file format used to store bitmap digital images, independently of the display device (such as a graphics adapter), especially on Microsoft Windows and OS/2 operating systems.
EMF
In 1993, the 32-bit version of Win32/GDI introduced the Enhanced Metafile (EMF), a newer version with additional commands. EMF is also used as a graphics language for printer drivers. Microsoft recommends that "Windows-format" (WMF) functions only "rarely" be used and "enhanced-format" (EMF) functions be used instead.
EXIF
Exchangeable image file format (Exif) is a standard that specifies the formats for images, sound, and ancillary tags used by digital cameras (including smart phones), scanners and other systems handling image and sound files recorded by digital cameras
GIF
The Graphics Interchange Format (GIF) is a bitmap image format that was introduced by CompuServe in 1987 and has since come into widespread usage on the World Wide Web due to its wide support and portability. The format supports up to 8 bits per pixel thus allowing a single image to reference a palette of up to 256 distinct colors. The colors are chosen from the 24-bit RGB color space. It also supports animations and allows a separate palette of 256 colors for each frame. The color limitation makes the GIF format unsuitable for reproducing color photographs and other images with continuous color, but it is well-suited for simpler images such as graphics or logos with solid areas of color.
GIF images are compressed using the Lempel-Ziv-Welch (LZW) lossless data compression technique to reduce the file size without degrading the visual quality. This compression technique was patented in 1985. Controversy over the licensing agreement between the patent holder, Unisys, and CompuServe in 1994 spurred the development of the Portable Network Graphics (PNG) standard. All the relevant patents have now expired.
PNG
Portable Network Graphics (PNG) is a raster graphics file format that supports lossless data compression. PNG was created as an improved, non-patented replacement for Graphics Interchange Format (GIF), and is the most used lossless image compression format on the World Wide Web. The motivation for creating the PNG format was in early 1995, after it became known that the Lempel–Ziv–Welch (LZW) data compression algorithm used in the Graphics Interchange Format (GIF) format was patented by Unisys. There were also other problems with the GIF format that made a replacement desirable, notably its limit of 256 colors at a time when computers able to display far more than 256 colors were growing common. Although GIF allows for animation, it was decided that PNG should be a single-image format.
JPG
JPEG is a commonly used method of lossy compression for digital photography (image). The degree of compression can be adjusted, allowing a selectable tradeoff between storage size and image quality. JPEG typically achieves 10:1 compression with little perceptible loss in image quality.
TIFF
TIFF (originally standing for Tagged Image File Format) is a file format for storing images, popular among graphic artists, the publishing industry,]and both amateur and professional photographers in general. As of 2009, it is under the control of Adobe Systems. Originally created by the company Aldus for use with "desktop publishing", the TIFF format is widely supported by image-manipulation applications, by publishing and page layout applications, by scanning, faxing, word processing, optical character recognition and other applications.[3] Adobe Systems, which acquired Aldus, now holds the copyright to the TIFF specification. TIFF has not had a major update since 1992.
WMF
Windows Metafile (WMF) is an image file format originally designed for Microsoft Windows in the 1990s. Windows Metafiles are intended to be portable between applications and may contain both vector graphics and bitmap components. It acts in a similar manner to SVG files.
19.9. [bookmark: Exporting_3D_to_Collada84C0DA6D]Exporting 3D to Collada
You can export your PCB as a 3D model to a Collada format file.
Collada files can be imported by Autodesk 3D Studio MAX, Blender and Sketchup.
19.10. [bookmark: Creating_a_STL_FileC2FCBCAA]Creating a STL File
To create/export to a STL file click the Tools→Export→ button.
A STL file contains a description of the PCB in 3D and is suitable for 3D printing.
STL (Stereo Lithography) is a file format native to the stereo lithography CAD software created by 3D Systems. STL is also known as Standard Tessellation Language. This file format is supported by many other software packages; it is widely used for rapid prototyping and computer-aided manufacturing. STL files describe only the surface geometry of a three dimensional object without any representation of color, texture or other common CAD model attributes. The STL format specifies both ASCII and binary representations. Binary files are more common, since they are more compact.
An STL file describes a raw unstructured triangulated surface by the unit normal and vertices (ordered by the right-hand rule) of the triangles using a three-dimensional Cartesian coordinate system. STL coordinates must be positive numbers, there is no scale information, and the units are arbitrary
The Save to STL dialog is shown below.

Save to STL Dialog
 Select your output units. NOTE: The STL files do not contain unit definitions so you will need to tell the person using the STL file what units they are in. It is common practice to use units of mm.
 You can create a binary file or human readable ASCII text file. The binary file will be much smaller and will be easier to transit electronically over the Internet.
STL files have no color.

20. [bookmark: Scripting]Scriptiing
AutoTRAX has it's own scripting engine based on the Python programming language. (IronPython).
See the language reference.
You can create your own command plug-ins that can be linked to a menu button.
A command plug-in consists of:
IronPython Script
This is a Python program that is run on demand by clicking the commands button in the menu or by clicking on the Run in the scripting panel.
AutoTRAX exposes a large API that you can call from your IronPython program.
In addition IronPython exposes the complete Microsoft .NET API for you to use.
Button Icons
You can optionally add 2 buttons icons to be displayed in the menu button. You can set a 16x16 pixel small icon and a 32x32 pixel large icon.
Button Caption
You can optionally add a text caption for the button.
ToolTip
You can optionally add a toolTip to be displayed when the mouse is moved over the button. This gives you information on the command. The toolTip has a title and text content.
If you enable a command plug-in, then it will be added to the menu as a button.




20.1. [bookmark: The_Scripting_PanelA97B49C2]The Scripting Panel
The scripting panel allows you to create command and command buttons to add to the AutoTRAX menu. It is shown below.

The Scripting Panel
Help
 Click to see this help topic.
Plug-in Directory

This is the directory that the command plug-in collection files are kept. Each file is an XML text file with a .xml file extension. This allows you to view and edit them in third part XML programs. 
 Click to browse to set a directory.
Command Sets
Command plug-ins are contained in a plug-in collection files. You can have any number of  plug-in collection files in the plug-ins directory. When AutoTRAX starts, it loads all  plug-in collection files found and adds menu items for each command plug-in the file if the collection is enabled.
 Click to update the menu with the commands.
 Click to create a new empty command plug-in collection file.
 Click to delete the selected command plug-in collection file. It will be moved to the recycle bin.
The grid displays all collection files loaded on startup. 
Name is the name of the collection file (less the .xml extension)
Description is a brief description of what the collection contains.
Enable - if checked then the commands in the collection file will be added to the menu as buttons subject to the individual commands being enabled (see below).
Commands
This lists the command plug-ins found in the selected collection file.
 Click to create a new empty command plug-in.
 Click to delete the selected command plug-in. Once deleted, it s gone forever. You will be prompted before deletion occurs. So please keep a backup.
Name is the name of the command plug-in.
Description is a brief description of the command..
Enable - if checked then the command will be added to the menu as a buttons subject to  it's collection file being enable (see above).
Command
 Click to view the AutoTRAX API.
 Click to save the command. This will only be displayed if you have made any changes and the command has not been saved.
 This is the name of the command.
 Click either of the icon areas to set the small or large icon. The small icon but be 16x16 pixels and the large icon must be 32x32 pixels. 
 Click to remove the icon. You can have buttons with no icons and only the text will be displayed.
 Selects the Ribbon Page/Tab that the button will be added to.
 Selects the button group  that the button will be added to.
Tooltip
 This is the title for the tooltip.
 This is the main tooltip text.
 This is a preview of what the button will look like. Hover the mouse over it to see the tooltip.
Command Script
This is the IronPython program script for the command. See the API for more details.
 Click to run the program script.
 This is the program script.
 This is the output after running the script. It will also list any errors found.

20.2. [bookmark: The_DEX_API5584DC54]The DEX API
AutoTRAX create the following global reset variables for you.
window
This is a Window object that lets you access functionality on the main window of AutoTRAX.
design
This is the Design being edited.
app
Various useful methods.

20.2.1. [bookmark: The_Window_VariableF2F2E33D]The Window Variable
The window variable give you access to the AutoTRAX main window commands. 
Useage
Call method on the window variable e.g.
	 window.CreateNewPart()

Methods (Loads more to come in the next few days)

CreateNewProject - create a new project

ShowPartWizard - Start the part wizard.

CreateNewPart - create a new part

ImportAutoTRAXFile - read an AutoTRAX EDA file.

OpenProject - open an existing project

OpenPart - open an existing part

RecoverDesign - display the recover design dialog

OpenEagle - open an existing Eagle schematic/board file, combing them both.

Close -  close the current design.


Save - save the current design

SaveAs - save the design to a different file name

Exit - close AutoTRAX





20.2.2. [bookmark: The_Design_VariableEBDC6A4F]The Design Variable
The design variable give you access to the current design data.
Properties (Loads more to come in the next few days)
	bool
	IsProject
	True if the design is a project. (read only)

	bool
	IsPart
	True if the design is a part. (read only)

	bool
	IsArt
	True if the design is artwork. (read only)

	bool
	Modifed
	True if the design has been modified but not saved. (read only)

	bool
	NeverBeenSaved
	True if the design has never been saved (A new design). (read only)

	string
	DocumentName
	Name of design document. Includes full path and extension

	string
	ShortName
	The name of the design document without path and with the extension

	
	
	


Useage
if  design.IsProject:
	print 'The design is a project'
else:
	print 'The design is not a project'

Methods (Loads more to come in the next few days)
	none
	Save
	Save the design.

	none
	AddLine ( startX, startY,edX,endY)
	Add a line  

	List<Symbol>
	Symbols()
	List of symbols in the design


Useage
Call method on the window variable e.g.
design.AddLine(1,2,5,6 )


20.2.2.1. [bookmark: Design_Structure]Design Structure
20.2.2.1.1. [bookmark: Design]Design
20.2.2.1.1.1. [bookmark: Schematic_Sheets2]Schematic Sheets
Symbols
Nodes
[bookmark: Symbols2]Symbols
The Symbol Reference
The Symbol Value
[bookmark: The_Symbol_Reference]The Symbol Reference
[bookmark: The_Symbol_Value]The Symbol Value
[bookmark: Nodes2]Nodes
20.2.2.1.1.2. [bookmark: The_Pcb2]The Pcb
Built in variable PCB
Properties

	Type
	Name
	Description

	IEnumerable<Point> Border
	Border
	The PCB border

	float
	Thickness
	The thickness of the PCB


[bookmark: Footprints2]Footprints
The Footprint Reference
The Footprint Value
[bookmark: The_Footprint_Reference]The Footprint Reference
[bookmark: The_Footprint_Value]The Footprint Value
[bookmark: Nets2]Nets
20.2.2.1.1.3. [bookmark: Graphical_Objects]Graphical Objects
Lines
Rectangles
Ellipses and Circles
Text
Images


[bookmark: Lines3]Lines
[bookmark: Rectangles3]Rectangles
[bookmark: Ellipses_and_Circles]Ellipses and Circles
[bookmark: Text3]Text
[bookmark: Images2]Images
20.2.2.1.2. [bookmark: Geometry]Geometry
20.2.3. [bookmark: The_ui_Variable]The ui Variable
The ui variable give you some useful user interface functions.
Methods (Loads more to come in the next few days)
	none
	ShowFile
	Display the contents of a file  


Useage
Call method on the window variable e.g.
ui.ShowFile( '\myFileName.txt' )

20.2.4. [bookmark: Built_in_variables5C79F9AE]Built-in variables


20.2.4.1. [bookmark: Pcb2]pcb
To create a Rectangular PCB
pcb.MakeRectangular( centerX = 1, centerY = 2, width = 3, height = 4 )

To create an Elliptical PCB
pcb.MakeElliptical( centerX = 1, centerY = 2, width = 3, height = 4 )

To create a Polygonal PCB
width = 5
height = 4
profile = [         Point( 0, 0 ),        Point( 0, height ),        Point( width/2.0, height*.15 ),        Point( width, height ),        Point( width,0 ) ]
pcb.MakePolygonal( profile )

Setting the Color of the PCB
pcb.Color = Color.DarkGreen

pcb.Color = Color.FromArgb( red,green,blue ) #  0 <= red,green,blue <= 255

pcb.Color = Color.FromArgb( alpha, red,green,blue ) #  0 <= alpha, red,green,blue <= 255. alpha will give you transparency 255 is opaque

Setting the Thickness of the PCB
To set the thickness of the PCB.
pcb.Thickness = 0.01
Removing All Holes and Cutouts
To set the thickness of the PCB.
pcb.RemoveAllHolesAndCutouts()
Adding Automatic Mounting Holes (Projects only)
pcb.AddMountingHoles = True

Setting the Size of Automatic Mounting Holes (Projects only)
pcb.MountingHoleDiameter = 0.1
To add a Rectangular Cutout
pcb.AddRectangularCutout( centerX = 1, centerY = 2, width = 3, height = 4 )

To add an Elliptical Cutout
pcb.AddEllipticalCutout( centerX = 1, centerY = 2, width = 3, height = 4 )

To add a Polygonal Cutout
width = 5
height = 4
profile = [         Point( 0, 0 ),        Point( 0, height ),        Point( width/2.0, height*.15 ),        Point( width, height ),        Point( width,0 ) ]
pcb.AddPolygonalCutout( profile )
To create a Regular Polygonal PCB
pcb.MakePolygonal( geom.Polygon( sides = 8, centerX = 4, centerY = 4, radius = 1 ) )

20.3. [bookmark: Python]Python
Python is an easy to learn, powerful programming language. It has efficient high-level data structures and a simple but effective approach to object-oriented programming. Python’s elegant syntax and dynamic typing, together with its interpreted nature, make it an ideal language for scripting and rapid application development in many areas on most platforms.
The one new syntax component in Python is the colon character (:). All Python compound statements—statements that have other statements nested inside them—follow the same general pattern of a header line terminated in a colon, followed by a nested block of code usually indented underneath the header line
Header line:
	Nested statement block
The colon at the end of the header line is required.

You don’t need to terminate statements with semicolons in Python the way you do in C-like languages. The general rule is that the end of a line automatically terminates the statement that appears on that line.

You do not type anything explicit in your code to mark the beginning and end of a nested block of code. Instead, you need to consistently indent all the statements in a given single nested block the same distance to the right, and Python uses the statements’ physical indentation to determine where the block starts and stops. e.g.
if x > y:
	x = 1
	y = 2

Python doesn’t care how you indent (you may use either spaces or tabs), or how much you indent (you may use any number of spaces or tabs).

Control Statement
20.3.1. [bookmark: An_Informal_Introduction_to_Py]An Informal Introduction to Python
In the following examples, input and output are distinguished by the presence or absence of prompts (>>> and ...): to repeat the example, you must type everything after the prompt, when the prompt appears; lines that do not begin with a prompt are output from the interpreter. Note that a secondary prompt on a line by itself in an example means you must type a blank line; this is used to end a multi-line command.
Many of the examples in this manual, even those entered at the interactive prompt, include comments. Comments in Python start with the hash character, #, and extend to the end of the physical line. A comment may appear at the start of a line or following whitespace or code, but not within a string literal. A hash character within a string literal is just a hash character. Since comments are to clarify code and are not interpreted by Python, they may be omitted when typing in examples.
Some examples:
# this is the first comment
spam = 1  # and this is the second comment
          # ... and now a third!
text = "# This is not a comment because it's inside quotes."

Using Python as a Calculator
Let’s try some simple Python commands. Start the interpreter and wait for the primary prompt, >>>. (It shouldn’t take long.)
Numbers
The interpreter acts as a simple calculator: you can type an expression at it and it will write the value. Expression syntax is straightforward: the operators +, -, * and / work just like in most other languages (for example, Pascal or C); parentheses (()) can be used for grouping. For example:
>>>
>>> 2 + 2
4
>>> 50 - 5*6
20
>>> (50 - 5.0*6) / 4
5.0
>>> 8 / 5.0
1.6

The integer numbers (e.g. 2, 4, 20) have type int, the ones with a fractional part (e.g. 5.0, 1.6) have type float. We will see more about numeric types later in the tutorial.
The return type of a division (/) operation depends on its operands. If both operands are of type int, floor division is performed and an int is returned. If either operand is a float, classic division is performed and a float is returned. The // operator is also provided for doing floor division no matter what the operands are. The remainder can be calculated with the % operator:
>>>>>> 17 / 3  # int / int -> int5>>> 17 / 3.0  # int / float -> float5.666666666666667>>> 17 // 3.0  # explicit floor division discards the fractional part5.0>>> 17 % 3  # the % operator returns the remainder of the division2>>> 5 * 3 + 2  # result * divisor + remainder17
With Python, it is possible to use the ** operator to calculate powers [1]:
20.3.2. [bookmark: Comments]Comments
Comments begin with the # symbol.
hash-mark comments are the most basic way to document your code. Python simply ignores all the text following a # (as long as it’s not inside a string literal), so you can follow this character with any words and descriptions meaningful to you.
# comments are best limited to smaller code documentation (e.g., “make sure file exists before opening it” ) and are best limited in scope to a statement or small group of statements within a script or function.

20.3.3. [bookmark: Control_Statements]Control Statement
The If Statement
The For Statement
The While Statement

20.3.3.1. [bookmark: The_If_Statement]The If Statement
Conditional Execution
The if, else, and elif statements control conditional code execution.The general format of a conditional statement is as follows:

if design.IsProject:
	print 'The design is a project'
elif design.IsPart:
	print 'The design is a part
elif design.IsArt:
	print 'The design is an artwork file'
else:
	print 'The design type is unknown'

There can be zero or more elif parts, and the else part is optional. The keyword ‘elif‘ is short for ‘else if’, and is useful to avoid excessive indentation. 
An if ... elif ... elif ... sequence is a substitute for the switch or case statements found in other languages.
20.3.3.2. [bookmark: Loops_and_Iterations]Loops and Iterations
You implement loops using the for and while statements.
The For Statement
The While Statement

20.3.3.3. [bookmark: The_For_Statement]The For Statement
The for statement iterates over all the elements of s until no more elements are available.The for statement works with any object that supports iteration.
for part in design.Parts:
	statements

20.3.3.4. [bookmark: The_While_Statement]The While Statement
The while statement executes statements until the associated expression evaluates to false.
i = 10
while i > 0:
	print i
	i = i-1

20.3.4. [bookmark: Functions]Functions
A function is a device that groups a set of statements so they can be run more than once in a program. Coding an operation as a function makes it a generally useful tool, which we can use in a variety of contexts.

def name(arg1, arg2,... argN):
	statements

Functions can have an optional return statement.

def name(arg1, arg2,... argN):
	...
	return value

Example
Defining the function
# Get file name to save to
def GetFileFile():
	dialog = SaveFileDialog()
	filter = 'Text files (*.txt)|*.txt|All files (*.*)|*.*'
	dialog.Filter = filter
	dialog.Title = 'Save Parts'
	dialog.FileName = design.ShortName
	result = dialog.ShowDialog()
	if result == DialogResult.OK:
		return dialog.FileName
	else:
		return None

Calling the function
fileName = GetFileFile()

20.4. [bookmark: Cookbook]CookBook
Here are some sample IronPython programs.
Save Parts List - saves the parts details to a file.
20.4.1. [bookmark: Save_Parts_ListB2FC43D3]Save Parts List
This program saves the parts details to a file.
# write all symbol references and values to a file 

from System.Windows.Forms import SaveFileDialog, DialogResult
from System.IO import StreamWriter, File

# Get file name to save to
def GetFileFile():
	dialog = SaveFileDialog()
	filter = 'Text files (*.txt)|*.txt|All files (*.*)|*.*'
	dialog.Filter = filter
	dialog.Title = 'Save Parts'
	dialog.FileName = design.ShortName
	result = dialog.ShowDialog()
	if result == DialogResult.OK:
		return dialog.FileName
	else:
		return None

# Save part details to a file
def SaveParts( fileName ):
	writer = File.CreateText( fileName )
	writer.WriteLine( 'Parts List' )
	writer.WriteLine()
	for part in design.Symbols():
		writer.WriteLine( part.SymbolReference.TextValue +  ' ' +  part.SymbolValue.TextValue )
	writer.Close()

# Program

fileName = GetFileFile()
if fileName is not None:
	SaveParts( fileName )
	# display the output
	app.ViewFile( fileName )

20.5. [bookmark: _NET_IntegrationD6AFCC78].NET Integration
IronPython aims to be a fully compatible implementation of the Python language. At the same time, the value of a separate implementation than CPython is to make available the .NET ecosystem of libraries. IronPython does this by exposing .NET concepts as Python entities. Existing Python syntax and new Python libraries (like CLR) are used to make .NET features available to IronPython code.
Loading .NET assemblies
The smallest unit of distribution of functionality in .NET is an assembly which usually corresponds to a single file with the .dll file extension. The assembly is available either in the installation folder of the application, or in the GAC (Global assembly cache). Assemblies can be loaded by using the methods of the CLR module. The following code will load the System.Xml.dll assembly which is part of the standard .NET implementation, and installed in the GAC:
>>> import clr
>>> clr.AddReference("System.Xml")
The full list of assemblies loaded by IronPython is available in CLR.References:
>>> "System.Xml" in [assembly.GetName().Name for assembly in clr.References]
True
All .NET assemblies have a unique version number which allows using a specific version of a given assembly. The following code will load the version of System.Xml.dll that ships with .NET 2.0 and .NET 3.5:
>>> import clr
>>> clr.AddReference("System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")

You can load assemblies that are neither in the GAC nor in the appbase (typically, the folder of ipy.exe or your host application executable) either by using clr.AddReferenceToFileAndPath or by setting sys.path. See clr.AddReference-methods for details.
Note
IronPython only knows about assemblies that have been loaded using one of clr.AddReference-methods. It is possible for other assemblies to already be loaded before IronPython is loaded, or for other assemblies to be loaded by other parts of the application by calling System.Reflection.Assembly.Load, but IronPython will not be aware of these.
Assemblies loaded by default

When you use ipy.exe, mscorlib.dll and System.dll are automatically loaded. This enables you to start using these assemblies (which IronPython itself is dependent on) without having to call clr.AddReference-methods.

When IronPython code is embedded in an application, the application controls which assemblies are loaded by default.

Using .NET types

Once an assembly is loaded, the namespaces and types contained in the assembly can be accessed from IronPython code.

Importing .NET namespaces

.NET namespaces and sub-namespaces of loaded assemblies are exposed as Python modules:

>>> import System
>>> System #doctest: +ELLIPSIS
<module 'System' (CLS module, ... assemblies loaded)>
>>> System.Collections #doctest: +ELLIPSIS
<module 'Collections' (CLS module, ... assemblies loaded)>
The types in the namespaces are exposed as Python types, and are accessed as attributes of the namespace. The following code accesses the System.Environment class from mscorlib.dll:

>>> import System
>>> System.Environment
<type 'Environment'>
Just like with normal Python modules, you can also use all the other forms of import as well:

>>> from System import Environment
>>> Environment
<type 'Environment'>
>>> from System import *
>>> Environment
<type 'Environment'>
Warning
Using from <namespace> import * can cause Python builtins (elements of __builtins__) to be hidden by .NET types or sub-namespaces. Specifically, after doing from System import *, Exception will access the System.Exception .NET type, not Python's Exception type.
The root namespaces are stored as modules in sys.modules:

>>> import System
>>> import sys
>>> sys.modules["System"] #doctest: +ELLIPSIS
<module 'System' (CLS module, ... assemblies loaded)>
When new assemblies are loaded, they can add attributes to existing namespace module objects.

Import precedence relative to Python modules

import gives precedence to .py files. For example, if a file called System.py exists in the path, it will get imported instead of the System namespace:

>>> # create System.py in the current folder
>>> f = open("System.py", "w")
>>> f.write('print "Loading System.py"')
>>> f.close()
>>>
>>> # unload the System namespace if it has been loaded
>>> import sys
>>> if sys.modules.has_key("System"):
...     sys.modules.pop("System") #doctest: +ELLIPSIS
<module 'System' (CLS module, ... assemblies loaded)>
>>>
>>> import System
Loading System.py
>>> System #doctest: +ELLIPSIS
<module 'System' from '...System.py'>
Note
Do make sure to delete System.py:

>>> import os
>>> os.remove("System.py")
>>> sys.modules.pop("System") #doctest: +ELLIPSIS
<module 'System' from '...System.py'>
>>> import System
>>> System #doctest: +ELLIPSIS
<module 'System' (CLS module, ... assemblies loaded)>
Accessing generic types

.NET supports generic types which allow the same code to support multiple type parameters which retaining the advantages of types safety. Collection types (like lists, vectors, etc) are the canonical example where generic types are useful. .NET has a number of generic collection types in the System.Collections.Generic namespace.

IronPython exposes generic types as a special type object which supports indexing with type object(s) as the index (or indices):

>>> from System.Collections.Generic import List, Dictionary
>>> int_list = List[int]()
>>> str_float_dict = Dictionary[str, float]()
Note that there might exist a non-generic type as well as one or more generic types with the same name [1]. In this case, the name can be used without any indexing to access the non-generic type, and it can be indexed with different number of types to access the generic type with the corresponding number of type parameters. The code below accesses System.EventHandler and also System.EventHandler<TEventArgs>

>>> from System import EventHandler, EventArgs
>>> EventHandler # this is the combo type object
<types 'EventHandler', 'EventHandler[TEventArgs]'>
>>> # Access the non-generic type
>>> dir(EventHandler) #doctest: +ELLIPSIS
['BeginInvoke', 'Clone', 'DynamicInvoke', 'EndInvoke', ...
>>> # Access the generic type with 1 type paramter
>>> dir(EventHandler[EventArgs]) #doctest: +ELLIPSIS
['BeginInvoke', 'Call', 'Clone', 'Combine', ...
[1]	
This refers to the user-friendly name. Under the hoods, the .NET type name includes the number of type parameters:

>>> clr.GetClrType(EventHandler[EventArgs]).Name
'EventHandler`1'
Accessing nested types

Nested types are exposed as attributes of the outer class:

>>> from System.Environment import SpecialFolder
>>> SpecialFolder
<type 'SpecialFolder'>
Importing .NET members from a type

.NET types are exposed as Python classes. Like Python classes, you usually cannot import all the attributes of .NET types using from <name> import *:

>>> from System.Guid import *
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: no module named Guid
You can import specific members, both static and instance:

>>> from System.Guid import NewGuid, ToByteArray
>>> g = NewGuid()
>>> ToByteArray(g) #doctest: +ELLIPSIS
Array[Byte](...
Note that if you import a static property, you will import the value when the import executes, not a named object to be evaluated on every use as you might mistakenly expect:

>>> from System.DateTime import Now
>>> Now #doctest: +ELLIPSIS
<System.DateTime object at ...>
>>> # Let's make it even more obvious that "Now" is evaluated only once
>>> a_second_ago = Now
>>> import time
>>> time.sleep(1)
>>> a_second_ago is Now
True
>>> a_second_ago is System.DateTime.Now
False
Importing all .NET members from a static type

Some .NET types only have static methods, and are comparable to namespaces. C# refers to them as static classes , and requires such classes to have only static methods. IronPython allows you to import all the static methods of such static classes. System.Environment is an example of a static class:

>>> from System.Environment import *
>>> Exit is System.Environment.Exit
True
Nested types are also imported:

>>> SpecialFolder is System.Environment.SpecialFolder
True
However, properties are not imported:

>>> OSVersion
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
NameError: name 'OSVersion' is not defined
>>> System.Environment.OSVersion #doctest: +ELLIPSIS
<System.OperatingSystem object at ...>
Type-system unification (type and System.Type)

.NET represents types using System.Type. However, when you access a .NET type in Python code, you get a Python type object [2]:

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> isinstance(type(ba), type)
True
This allows a unified (Pythonic) view of both Python and .NET types. For example, isinstance works with .NET types as well:

>>> from System.Collections import BitArray
>>> isinstance(ba, BitArray)
True
If need to get the System.Type instance for the .NET type, you need to use clr.GetClrType. Conversely, you can use clr.GetPythonType to get a type object corresponding to a System.Type object.

The unification also extends to other type system entities like methods. .NET methods are exposed as instances of method:

>>> type(BitArray.Xor)
<type 'method_descriptor'>
>>> type(ba.Xor)
<type 'builtin_function_or_method'>
[2]	
Note that the Python type corresponding to a .NET type is a sub-type of type:

>>> isinstance(type(ba), type)
True
>>> type(ba) is type
False
This is an implementation detail.
Similarity with builtin types

.NET types behave like builtin types (like list), and are immutable. i.e. you cannot add or delete descriptors from .NET types:

>>> del list.append
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: cannot delete attribute 'append' of builtin type 'list'
>>>
>>> import System
>>> del System.DateTime.ToByteArray
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: can't set attributes of built-in/extension type 'DateTime'
Instantiating .NET types

.NET types are exposed as Python classes, and you can do many of the same operations on .NET types as with Python classes. In either cases, you create an instance by calling the type:

>>> from System.Collections import BitArray
>>> ba = BitArray(5) # Creates a bit array of size 5
IronPython also supports inline initializing of the attributes of the instance. Consider the following two lines:

>>> ba = BitArray(5)
>>> ba.Length = 10
The above two lines are equivalent to this single line:

>>> ba = BitArray(5, Length = 10)
You can also call the __new__ method to create an instance:

>> ba = BitArray.__new__(BitArray, 5)
Invoking .NET methods

.NET methods are exposed as Python methods. Invoking .NET methods works just like invoking Python methods.

Invoking .NET instance methods

Invoking .NET instance methods works just like invoking methods on a Python object using the attribute notation:

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> ba.Set(0, True) # call the Set method
>>> ba[0]
True
IronPython also supports named arguments:

>>> ba.Set(index = 1, value = True)
>>> ba[1]
True
IronPython also supports dict arguments:

>>> args = [2, True] # list of arguments
>>> ba.Set(*args)
>>> ba[2]
True
IronPython also supports keyword arguments:

>>> args = { "index" : 3, "value" : True }
>>> ba.Set(**args)
>>> ba[3]
True
Argument conversions

When the argument type does not exactly match the parameter type expected by the .NET method, IronPython tries to convert the argument. IronPython uses conventional .NET conversion rules like conversion operators , as well as IronPython-specific rules. This snippet shows how arguments are converted when calling the Set(System.Int32, System.Boolean) method:

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> ba.Set(0, "hello") # converts the second argument to True.
>>> ba[0]
True
>>> ba.Set(1, None) # converts the second argument to False.
>>> ba[1]
False
See appendix-type-conversion-rules for the detailed conversion rules. Note that some Python types are implemented as .NET types and no conversion is required in such cases. See builtin-type-mapping for the mapping.

Some of the conversions supported are:

Python argument type	.NET method parameter type
int	System.Int8, System.Int16
float	System.Float
tuple with only elements of type T	System.Collections.Generic.IEnumerable<T>
function, method	System.Delegate and any of its sub-classes
Method overloads

.NET supports overloading methods by both number of arguments and type of arguments. When IronPython code calls an overloaded method, IronPython tries to select one of the overloads at runtime based on the number and type of arguments passed to the method, and also names of any keyword arguments. In most cases, the expected overload gets selected. Selecting an overload is easy when the argument types are an exact match with one of the overload signatures:

>>> from System.Collections import BitArray
>>> ba = BitArray(5) # calls __new__(System.Int32)
>>> ba = BitArray(5, True) # calls __new__(System.Int32, System.Boolean)
>>> ba = BitArray(ba) # calls __new__(System.Collections.BitArray)
The argument types do not have be an exact match with the method signature. IronPython will try to convert the arguments if an unamibguous conversion exists to one of the overload signatures. The following code calls __new__(System.Int32) even though there are two constructors which take one argument, and neither of them accept a float as an argument:

>>> ba = BitArray(5.0)
However, note that IronPython will raise a TypeError if there are conversions to more than one of the overloads:

>>> BitArray((1, 2, 3))
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: Multiple targets could match: BitArray(Array[Byte]), BitArray(Array[bool]), BitArray(Array[int])
If you want to control the exact overload that gets called, you can use the Overloads method on method objects:

>>> int_bool_new = BitArray.__new__.Overloads[int, type(True)]
>>> ba = int_bool_new(BitArray, 5, True) # calls __new__(System.Int32, System.Boolean)
>>> ba = int_bool_new(BitArray, 5, "hello") # converts "hello" to a System.Boolan
>>> ba = int_bool_new(BitArray, 5)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: __new__() takes exactly 2 arguments (1 given)

Using unbound class instance methods

It is sometimes desirable to invoke an instance method using the unbound class instance method and passing an explicit self object as the first argument. For example, .NET allows a class to declare an instance method with the same name as a method in a base type, but without overriding the base method. See System.Reflection.MethodAttributes.NewSlot for more information. In such cases, using the unbound class instance method syntax allows you chose precisely which slot you wish to call:

>>> import System
>>> System.ICloneable.Clone("hello") # same as : "hello".Clone()
'hello'
The unbound class instance method syntax results in a virtual call, and calls the most derived implementation of the virtual method slot:

>>> s = "hello"
>>> System.Object.GetHashCode(s) == System.String.GetHashCode(s)
True
>>> from System.Runtime.CompilerServices import RuntimeHelpers
>>> RuntimeHelpers.GetHashCode(s) == System.String.GetHashCode(s)
False
Calling explicitly-implemented interface methods

.NET allows a method with a different name to override a base method implementation or interface method slot. This is useful if a type implements two interfaces with methods with the same name. This is known as explicity implemented interface methods. For example, Microsoft.Win32.RegistryKey implements System.IDisposable.Dispose explicitly:

>>> from Microsoft.Win32 import RegistryKey
>>> clr.GetClrType(RegistryKey).GetMethod("Flush") #doctest: +ELLIPSIS
<System.Reflection.RuntimeMethodInfo object at ... [Void Flush()]>
>>> clr.GetClrType(RegistryKey).GetMethod("Dispose")
>>>
In such cases, IronPython tries to expose the method using its simple name - if there is no ambiguity:

>>> from Microsoft.Win32 import Registry
>>> rkey = Registry.CurrentUser.OpenSubKey("Software")
>>> rkey.Dispose()
However, it is possible that the type has another method with the same name. In that case, the explicitly implemented method is not accessible as an attribute. However, it can still be called by using the unbound class instance method syntax:

>>> rkey = Registry.CurrentUser.OpenSubKey("Software")
>>> System.IDisposable.Dispose(rkey)
Invoking static .NET methods

Invoking static .NET methods is similar to invoking Python static methods:

>>> System.GC.Collect()
Like Python static methods, the .NET static method can be accessed as an attribute of sub-types as well:

>>> System.Object.ReferenceEquals is System.GC.ReferenceEquals
True


Invoking generic methods

Generic methods are exposed as attributes which can be indexed with type objects. The following code calls System.Activator.CreateInstance<T>

>>> from System import Activator, Guid
>>> guid = Activator.CreateInstance[Guid]()
Type parameter inference while invoking generic methods

In many cases, the type parameter can be inferred based on the arguments passed to the method call. Consider the following use of a generic method [3]:

>>> from System.Collections.Generic import IEnumerable, List
>>> list = List[int]([1, 2, 3])
>>> import clr
>>> clr.AddReference("System.Core")
>>> from System.Linq import Enumerable
>>> Enumerable.Any[int](list, lambda x : x < 2)
True
With generic type parameter inference, the last statement can also be written as:

>>> Enumerable.Any(list, lambda x : x < 2)
True
See appendix for the detailed rules.

[3]	System.Core.dll is part of .NET 3.0 and higher.
ref and out parameters

The Python language passes all arguments by-value. There is no syntax to indicate that an argument should be passed by-reference like there is in .NET languages like C# and VB.NET via the ref and out keywords. IronPython supports two ways of passing ref or out arguments to a method, an implicit way and an explicit way.

In the implicit way, an argument is passed normally to the method call, and its (potentially) updated value is returned from the method call along with the normal return value (if any). This composes well with the Python feature of multiple return values. System.Collections.Generic.Dictionary has a method bool TryGetValue(K key, out value). It can be called from IronPython with just one argument, and the call returns a tuple where the first element is a boolean and the second element is the value (or the default value of 0.0 if the first element is False):

>>> d = { "a":100.1, "b":200.2, "c":300.3 }
>>> from System.Collections.Generic import Dictionary
>>> d = Dictionary[str, float](d)
>>> d.TryGetValue("b")
(True, 200.2)
>>> d.TryGetValue("z")
(False, 0.0)
In the explicit way, you can pass an instance of clr.Reference[T] for the ref or out argument, and its Value field will get set by the call. The explicit way is useful if there are multiple overloads with ref parameters:

>>> import clr
>>> r = clr.Reference[float]()
>>> d.TryGetValue("b", r)
True
>>> r.Value
200.2
Extension methods

Extension methods are currently not natively supported by IronPython. Hence, they cannot be invoked like instance methods. Instead, they have to be invoked like static methods.

Accessing .NET indexers

.NET indexers are exposed as __getitem__ and __setitem__. Thus, the Python indexing syntax can be used to index .NET collections (and any type with an indexer):

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> ba[0]
False
>>> ba[0] = True
>>> ba[0]
True
The indexer can be called using the unbound class instance method syntax using __getitem__ and __setitem__. This is useful if the indexer is virtual and is implemented as an explicitly-implemented interface method:

>>> BitArray.__getitem__(ba, 0)
True
Non-default .NET indexers

Note that a default indexer is just a property (typically called Item) with one argument. It is considered as an indexer if the declaraing type uses DefaultMemberAttribute to declare the property as the default member.

See property-with-parameters for information on non-default indexers.

Accessing .NET properties

.NET properties are exposed similar to Python attributes. Under the hood, .NET properties are implemented as a pair of methods to get and set the property, and IronPython calls the appropriate method depending on whether you are reading or writing to the properity:

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> ba.Length # calls "BitArray.get_Length()"
5
>>> ba.Length = 10 # calls "BitArray.set_Length()"
To call the get or set method using the unbound class instance method syntax, IronPython exposes methods called GetValue and SetValue on the property descriptor. The code above is equivalent to the following:

>>> ba = BitArray(5)
>>> BitArray.Length.GetValue(ba)
5
>>> BitArray.Length.SetValue(ba, 10)
Properties with parameters

COM and VB.NET support properties with paramters. They are also known as non-default indexers. C# does not support declaring or using properties with parameters.

IronPython does support properties with parameters. For example, the default indexer above can also be accessed using the non-default format as such:

>>> ba.Item[0]
False
Accessing .NET events

.NET events are exposed as objects with __iadd__ and __isub__ methods which allows using += and -= to subscribe and unsubscribe from the event. The following code shows how to subscribe a Python function to an event using +=, and unsubscribe using -=

>>> from System.IO import FileSystemWatcher
>>> watcher = FileSystemWatcher(".")
>>> def callback(sender, event_args):
...     print event_args.ChangeType, event_args.Name
>>> watcher.Created += callback
>>> watcher.EnableRaisingEvents = True
>>> import time
>>> f = open("test.txt", "w+"); time.sleep(1)
Created test.txt
>>> watcher.Created -= callback
>>>
>>> # cleanup
>>> import os
>>> f.close(); os.remove("test.txt")
You can also subscribe using a bound method:

>>> watcher = FileSystemWatcher(".")
>>> class MyClass(object):
...     def callback(self, sender, event_args):
...         print event_args.ChangeType, event_args.Name
>>> o = MyClass()
>>> watcher.Created += o.callback
>>> watcher.EnableRaisingEvents = True
>>> f = open("test.txt", "w+"); time.sleep(1)
Created test.txt
>>> watcher.Created -= o.callback
>>>
>>> # cleanup
>>> f.close(); os.remove("test.txt")
You can also explicitly create a delegate instance to subscribe to the event. Otherwise, IronPython automatically does it for you. [4]:

>>> watcher = FileSystemWatcher(".")
>>> def callback(sender, event_args):
...     print event_args.ChangeType, event_args.Name
>>> from System.IO import FileSystemEventHandler
>>> delegate = FileSystemEventHandler(callback)
>>> watcher.Created += delegate
>>> watcher.EnableRaisingEvents = True
>>> import time
>>> f = open("test.txt", "w+"); time.sleep(1)
Created test.txt
>>> watcher.Created -= delegate
>>>
>>> # cleanup
>>> f.close(); os.remove("test.txt")
[4]	The only advantage to creating an explicit delegate is that it is uses less memory. You should consider it if you subscribe to lots of events, and notice excessive System.WeakReference objects.
Special .NET types

.NET arrays

IronPython supports indexing of System.Array with a type object to access one-dimensional strongly-typed arrays:

>>> System.Array[int]
<type 'Array[int]'>
IronPython also adds a __new__ method that accepts a IList<T> to initialize the array. This allows using a Python list literal to initialize a .NET array:

>>> a = System.Array[int]([1, 2, 3])
Further, IronPython exposes __getitem__ and __setitem__ allowing the array objects to be indexed using the Python indexing syntax:

>>> a[2]
3
Note that the indexing syntax yields Python semantics. If you index with a negative value, it results in indexing from the end of the array, whereas .NET indexing (demonstrated by calling GetValue below) raises a System.IndexOutOfRangeException exception:

>>> a.GetValue(-1)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
IndexError: Index was outside the bounds of the array.
>>> a[-1]
3
Similarly, slicing is also supported:

>>> a[1:3]
Array[int]((2, 3))
Multi-dimensional arrays



.NET Exceptions

raise can raise both Python exceptions as well as .NET exceptions:

>>> raise ZeroDivisionError()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ZeroDivisionError
>>> import System
>>> raise System.DivideByZeroException()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ZeroDivisionError: Attempted to divide by zero.
The except keyword can catch both Python exceptions as well as .NET exceptions:

>>> try:
...    import System
...    raise System.DivideByZeroException()
... except System.DivideByZeroException:
...    print "This line will get printed..."
...
This line will get printed...
>>>
The underlying .NET exception object

IronPython implements the Python exception mechanism on top of the .NET exception mechanism. This allows Python exception thrown from Python code to be caught by non-Python code, and vice versa. However, Python exception objects need to behave like Python user objects, not builtin types. For example, Python code can set arbitrary attributes on Python exception objects, but not on .NET exception objects:

>>> e = ZeroDivisionError()
>>> e.foo = 1 # this works
>>> e = System.DivideByZeroException()
>>> e.foo = 1
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'DivideByZeroException' object has no attribute 'foo'
To support these two different views, IronPython creates a pair of objects, a Python exception object and a .NET exception object, where the Python type and the .NET exception type have a unique one-to-one mapping as defined in the table below. Both objects know about each other. The .NET exception object is the one that actually gets thrown by the IronPython runtime when Python code executes a raise statement. When Python code uses the except keyword to catch the Python exception, the Python exception object is used. However, if the exception is caught by C# (for example) code that called the Python code, then the C# code naturally catches the .NET exception object.

The .NET exception object corresponding to a Python exception object can be accessed by using the clsException attribute (if the module has excecuted import clr):

>>> import clr
>>> try:
...     1/0
... except ZeroDivisionError as e:
...     pass
>>> type(e)
<type 'exceptions.ZeroDivisionError'>
>>> type(e.clsException)
<type 'DivideByZeroException'>
IronPython is also able to access the Python exception object corresponding to a .NET exception object [5], thought this is not exposed to the user [6].

[5]	
The Python exception object corresponding to a .NET exception object is accessible (to the IronPython runtime) via the System.Exception.Data property. Note that this is an implementation detail and subject to change:

>>> e.clsException.Data["PythonExceptionInfo"] #doctest: +ELLIPSIS
<IronPython.Runtime.Exceptions.PythonExceptions+ExceptionDataWrapper object at ...>
[6]	... except via the DLR Hosting API ScriptEngine.GetService<ExceptionOperations>().GetExceptionMessage
Python exception	.NET exception
 	 	 
Exception	System.Exception	 
SystemExit	 	IP.O.SystemExit
StopIteration	System.InvalidOperationException subtype	 
StandardError	System.SystemException	 
KeyboardInterrupt	 	IP.O.KeyboardInterruptException
ImportError	 	IP.O.PythonImportError
EnvironmentError	 	IP.O.PythonEnvironmentError
IOError	System.IO.IOException	 
OSError	S.R.InteropServices.ExternalException	 
WindowsError	System.ComponentModel.Win32Exception	 
EOFError	System.IO.EndOfStreamException	 
RuntimeError	IP.O.RuntimeException	 
NotImplementedError	System.NotImplementedException	 
NameError	 	IP.O.NameException
UnboundLocalError	 	IP.O.UnboundLocalException
AttributeError	System.MissingMemberException	 
SyntaxError	 	IP.O.SyntaxErrorException (System.Data has something close)
IndentationError	 	IP.O.IndentationErrorException
TabError	 	IP.O.TabErrorException
TypeError	 	Microsoft.Scripting.ArgumentTypeException
AssertionError	 	IP.O.AssertionException
LookupError	 	IP.O.LookupException
IndexError	System.IndexOutOfRangeException	 
KeyError	S.C.G.KeyNotFoundException	 
ArithmeticError	System.ArithmeticException	 
OverflowError	System.OverflowException	 
ZeroDivisionError	System.DivideByZeroException	 
FloatingPointError	 	IP.O.PythonFloatingPointError
ValueError	ArgumentException	 
UnicodeError	 	IP.O.UnicodeException
UnicodeEncodeError	System.Text.EncoderFallbackException	 
UnicodeDecodeError	System.Text.DecoderFallbackException	 
UnicodeTranslateError	 	IP.O.UnicodeTranslateException
ReferenceError	 	IP.O.ReferenceException
SystemError	 	IP.O.PythonSystemError
MemoryError	System.OutOfMemoryException	 
Warning	System.ComponentModel.WarningException	 
UserWarning	 	IP.O.PythonUserWarning
DeprecationWarning	 	IP.O.PythonDeprecationWarning
PendingDeprecationWarning	 	IP.O.PythonPendingDeprecationWarning
SyntaxWarning	 	IP.O.PythonSyntaxWarning
OverflowWarning	 	IP.O.PythonOverflowWarning
RuntimeWarning	 	IP.O.PythonRuntimeWarning
FutureWarning	 	IP.O.PythonFutureWarning
Revisiting the rescue keyword

Given that raise results in the creation of both a Python exception object and a .NET exception object, and given that rescue can catch both Python exceptions and .NET exceptions, a question arises of which of the exception objects will be used by the rescue keyword. The answer is that it is the type used in the rescue clause. i.e. if the rescue clause uses the Python exception, then the Python exception object will be used. If the rescue clause uses the .NET exception, then the .NET exception object will be used.

The following example shows how 1/0 results in the creation of two objects, and how they are linked to each other. The exception is first caught as a .NET exception. The .NET exception is raised again, but is then caught as a Python exception:

>>> import System
>>> try:
...     try:
...         1/0
...     except System.DivideByZeroException as e1:
...         raise e1
... except ZeroDivisionError as e2:
...     pass
>>> type(e1)
<type 'DivideByZeroException'>
>>> type(e2)
<type 'exceptions.ZeroDivisionError'>
>>> e2.clsException is e1
True
User-defined exceptions

Python user-defined exceptions get mapped to System.Exception. If non-Python code catches a Python user-defined exception, it will be an instance of System.Exception, and will not be able to access the exception details:

>>> # since "Exception" might be System.Exception after "from System import *"
>>> if "Exception" in globals(): del Exception
>>> class MyException(Exception):
...     def __init__(self, value):
...         self.value = value
...     def __str__(self):
...         return repr(self.value)
>>> try:
...     raise MyException("some message")
... except System.Exception as e:
...     pass
>>> clr.GetClrType(type(e)).FullName
'System.Exception'
>>> e.Message
'Python Exception: MyException'
In this case, the non-Python code can use the ScriptEngine.GetService<ExceptionOperations>().GetExceptionMessage DLR Hosting API to get the exception message.

Enumerations

.NET enumeration types are sub-types of System.Enum. The enumeration values of an enumeration type are exposed as class attributes:

print System.AttributeTargets.All # access the value "All"
IronPython also supports using the bit-wise operators with the enumeration values:

>>> import System
>>> System.AttributeTargets.Class | System.AttributeTargets.Method
<enum System.AttributeTargets: Class, Method>
Value types

Python expects all mutable values to be represented as a reference type. .NET, on the other hand, introduces the concept of value types which are mostly copied instead of referenced. In particular .NET methods and properties returning a value type will always return a copy.

This can be confusing from a Python programmer’s perspective since a subsequent update to a field of such a value type will occur on the local copy, not within whatever enclosing object originally provided the value type.

While most .NET value types are designed to be immutable, and the .NET design guidelines recommend value tyeps be immutable, this is not enforced by .NET, and so there do exist some .NET valuetype that are mutable

For example, take the following C# definitions:

struct Point {
    # Poorly defined struct - structs should be immutable
    public int x;
    public int y;
}

class Line {
    public Point start;
    public Point end;

    public Point Start { get { return start; } }
    public Point End { get { return end; } }
}
If line is an instance of the reference type Line, then a Python programmer may well expect "line.Start.x = 1" to set the x coordinate of the start of that line. In fact the property Start returned a copy of the Point value type and it’s to that copy the update is made:

print line.Start.x    # prints ‘0’
line.Start.x = 1
print line.Start.x    # still prints ‘0’
This behavior is subtle and confusing enough that C# produces a compile-time error if similar code is written (an attempt to modify a field of a value type just returned from a property invocation).

Even worse, when an attempt is made to modify the value type directly via the start field exposed by Line (i.e. “`line.start.x = 1`”), IronPython will still update a local copy of the Point structure. That’s because Python is structured so that “foo.bar” will always produce a useable value: in the case above “line.start” needs to return a full value type which in turn implies a copy.

C#, on the other hand, interprets the entirety of the “`line.start.x = 1`” statement and actually yields a value type reference for the “line.start” part which in turn can be used to set the “x” field in place.

This highlights a difference in semantics between the two languages. In Python “line.start.x = 1” and “foo = line.start; foo.x = 1” are semantically equivalent. In C# that is not necessarily so.

So in summary: a Python programmer making updates to a value type embedded in an object will silently have those updates lost where the same syntax would yield the expected semantics in C#. An update to a value type returned from a .NET property will also appear to succeed will updating a local copy and will not cause an error as it does in the C# world. These two issues could easily become the source of subtle, hard to trace bugs within a large application.

In an effort to prevent the unintended update of local value type copies and at the same time preserve as pythonic and consistent a view of the world as possible, direct updates to value type fields are not allowed by IronPython, and raise a ValueError:

>>> line.start.x = 1 #doctest: +SKIP
Traceback (most recent call last):
   File , line 0, in input##7
ValueError Attempt to update field x on value type Point; value type fields can not be directly modified
This renders value types “mostly” immutable; updates are still possible via instance methods on the value type itself.

Proxy types

IronPython cannot directly use System.MarshalByRefObject instances. IronPython uses reflection at runtime to determine how to access an object. However, System.MarshalByRefObject instances do not support reflection.

You can use unbound-class-instance-method syntax to call methods on such proxy objects.

Delegates

Python functions and bound instance methods can be converted to delegates:

>>> from System import EventHandler, EventArgs
>>> def foo(sender, event_args):
...     print event_args
>>> d = EventHandler(foo)
>>> d(None, EventArgs()) #doctest: +ELLIPSIS
<System.EventArgs object at ... [System.EventArgs]>
Variance

IronPython also allows the signature of the Python function or method to be different (though compatible) with the delegate signature. For example, the Python function can use keyword arguments:

>>> def foo(*args):
...     print args
>>> d = EventHandler(foo)
>>> d(None, EventArgs()) #doctest: +ELLIPSIS
(None, <System.EventArgs object at ... [System.EventArgs]>)
If the return type of the delegate is void, IronPython also allows the Python function to return any type of return value, and just ignores the return value:

>>> def foo(*args):
...     return 100 # this return value will get ignored
>>> d = EventHandler(foo)
>>> d(None, EventArgs())
If the return value is different, IronPython will try to convert it:

>>> def foo(str1, str2):
...     return 100.1 # this return value will get converted to an int
>>> d = System.Comparison[str](foo)
>>> d("hello", "there")
100


Subclassing .NET types

Sub-classing of .NET types and interfaces is supported using class. .NET types and interfaces can be used as one of the sub-types in the class construct:

>>> class MyClass(System.Attribute, System.ICloneable, System.IComparable):
...     pass
.NET does not support multiple inheritance while Python does. IronPython allows using multiple Python classes as subtypes, and also multiple .NET interfaces, but there can only be one .NET class (other than System.Object) in the set of subtypes:

>>> class MyPythonClass1(object): pass
>>> class MyPythonClass2(object): pass
>>> class MyMixedClass(MyPythonClass1, MyPythonClass2, System.Attribute):
...     pass
Instances of the class do actually inherit from the specified .NET base type. This is important because this means that statically-typed .NET code can access the object using the .NET type. The following snippet uses Reflection to show that the object can be cast to the .NET sub-class:

>>> class MyClass(System.ICloneable):
...     pass
>>> o = MyClass()
>>> import clr
>>> clr.GetClrType(System.ICloneable).IsAssignableFrom(o.GetType())
True
Note that the Python class does not really inherit from the .NET sub-class. See type-mapping.

Overriding methods

Base type methods can be overriden by defining a Python method with the same name:

>>> class MyClass(System.ICloneable):
...    def Clone(self):
...        return MyClass()
>>> o = MyClass()
>>> o.Clone() #doctest: +ELLIPSIS
<MyClass object at ...>
IronPython does require you to provide implementations of interface methods in the class declaration. The method lookup is done dynamically when the method is accessed. Here we see that AttributeError is raised if the method is not defined:

>>> class MyClass(System.ICloneable): pass
>>> o = MyClass()
>>> o.Clone()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'MyClass' object has no attribute 'Clone'
Methods with multiple overloads

Python does not support method overloading. A class can have only one method with a given name. As a result, you cannot override specific method overloads of a .NET sub-type. Instead, you need to use define the function accepting an arbitrary argument list (see _tut-arbitraryargs), and then determine the method overload that was invoked by inspecting the types of the arguments:

>>> import clr
>>> import System
>>> StringComparer = System.Collections.Generic.IEqualityComparer[str]
>>>
>>> class MyComparer(StringComparer):
...     def GetHashCode(self, *args):
...          if len(args) == 0:
...              # Object.GetHashCode() called
...              return 100
...
...          if len(args) == 1 and type(args[0]) == str:
...              # StringComparer.GetHashCode() called
...              return 200
...
...          assert("Should never get here")
...
>>> comparer = MyComparer()
>>> getHashCode1 = clr.GetClrType(System.Object).GetMethod("GetHashCode")
>>> args = System.Array[object](["another string"])
>>> getHashCode2 = clr.GetClrType(StringComparer).GetMethod("GetHashCode")
>>>
>>> # Use Reflection to simulate a call to the different overloads
>>> # from another .NET language
>>> getHashCode1.Invoke(comparer, None)
100
>>> getHashCode2.Invoke(comparer, args)
200
Note
Determining the exact overload that was invoked may not be possible, for example, if None is passed in as an argument.
Methods with ref or out parameters

Python does not have syntax for specifying whether a method paramter is passed by-reference since arguments are always passed by-value. When overriding a .NET method with ref or out parameters, the ref or out paramter is received as a clr.Reference[T] instance. The incoming argument value is accessed by reading the Value property, and the resulting value is specified by setting the Value property:

>>> import clr
>>> import System
>>> StrFloatDictionary = System.Collections.Generic.IDictionary[str, float]
>>>
>>> class MyDictionary(StrFloatDictionary):
...     def TryGetValue(self, key, value):
...         if key == "yes":
...             value.Value = 100.1 # set the *out* parameter
...             return True
...         else:
...             value.Value = 0.0  # set the *out* parameter
...             return False
...     # Other methods of IDictionary not overriden for brevity
...
>>> d = MyDictionary()
>>> # Use Reflection to simulate a call from another .NET language
>>> tryGetValue = clr.GetClrType(StrFloatDictionary).GetMethod("TryGetValue")
>>> args = System.Array[object](["yes", 0.0])
>>> tryGetValue.Invoke(d, args)
True
>>> args[1]
100.1
Generic methods

When you override a generic method, the type parameters get passed in as arguments. Consider the following generic method declaration:

// csc /t:library /out:convert.dll convert.cs
public interface IMyConvertible {
    T1 Convert<T1, T2>(T2 arg);
}
The following code overrides the generic method Convert:

>>> import clr
>>> clr.AddReference("convert.dll")
>>> import System
>>> import IMyConvertible
>>>
>>> class MyConvertible(IMyConvertible):
...     def Convert(self, t2, T1, T2):
...         return T1(t2)
>>>
>>> o = MyConvertible()
>>> # Use Reflection to simulate a call from another .NET language
>>> type_params = System.Array[System.Type]([str, float])
>>> convert = clr.GetClrType(IMyConvertible).GetMethod("Convert")
>>> convert_of_str_float = convert.MakeGenericMethod(type_params)
>>> args = System.Array[object]([100.1])
>>> convert_of_str_float.Invoke(o, args)
'100.1'
Note
Generic method receive information about the method signature being invoked, whereas normal method overloads do not. The reason is that .NET does not allow normal method overloads to differ by the return type, and it is usually possible to determine the argument types based on the argument values. However, with generic methods, one of the type parameters may only be used as the return type. In that case, there is no way to determine the type paramter.
Calling from Python

When you call a method from Python, and the method overrides a .NET method from a base type, the call is performed as a regular Python call. The arguments do not undergo conversion, and neither are they modified in any way like being wrapped with clr.Reference. Thus, the call may need to be written differently than if the method was overriden by another language. For example, trying to call TryGetValue on the MyDictionary type from the overriding-ref-args section as shown below results in a TypeError, whereas a similar call works with System.Collections.Generic.Dictionary[str, float]:

>>> result, value = d.TryGetValue("yes")
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: TryGetValue() takes exactly 3 arguments (2 given)
Overriding properties

.NET properties are backed by a pair of .NET methods for reading and writing the property. The C# compiler automatically names them as get_<PropertyName> and set_<PropertyName>. However, .NET itself does not require any specific naming pattern for these methods, and the names are stored in the the metadata associated with the property definition. The names can be accessed using the GetGetMethod and GetSetMethods of the System.Reflection.PropertyInfo class:

>>> import clr
>>> import System
>>> StringCollection = System.Collections.Generic.ICollection[str]
>>> prop_info = clr.GetClrType(StringCollection).GetProperty("Count")
>>> prop_info.GetGetMethod().Name
'get_Count'
>>> prop_info.GetSetMethod() # None because this is a read-only property
>>>
Overriding a virtual property requires defining a Python method with the same names as the underlying getter or setter .NET method:

>>>
>>> class MyCollection(StringCollection):
...    def get_Count(self):
...        return 100
...    # Other methods of ICollection not overriden for brevity
>>>
>>> c = MyCollection()
>>> # Use Reflection to simulate a call from another .NET language
>>> prop_info.GetGetMethod().Invoke(c, None)
100
Overiding events

Events have underlying methods which can be obtained using EventInfo.GetAddMethod and EventInfo.GetRemoveMethod

>>> from System.ComponentModel import IComponent
>>> import clr
>>> event_info = clr.GetClrType(IComponent).GetEvent("Disposed")
>>> event_info.GetAddMethod().Name
'add_Disposed'
>>> event_info.GetRemoveMethod().Name
'remove_Disposed'
To override events, you need to define methods with the name of the underlying methods:

>>> class MyComponent(IComponent):
...     def __init__(self):
...         self.dispose_handlers = []
...     def Dispose(self):
...         for handler in self.dispose_handlers:
...             handler(self, EventArgs())
...
...     def add_Disposed(self, value):
...         self.dispose_handlers.append(value)
...     def remove_Disposed(self, value):
...         self.dispose_handlers.remove(value)
...     # Other methods of IComponent not implemented for brevity
>>>
>>> c = MyComponent()
>>> def callback(sender, event_args):
...     print event_args
>>> args = System.Array[object]((System.EventHandler(callback),))
>>> # Use Reflection to simulate a call from another .NET language
>>> event_info.GetAddMethod().Invoke(c, args)
>>>
>>> c.Dispose() #doctest: +ELLIPSIS
<System.EventArgs object at ... [System.EventArgs]>
Calling base constructor

.NET constructors can be overloaded. To call a specific base type constructor overload, you need to define a __new__ method (not __init__) and call __new__ on the .NET base type. The following example shows how a sub-type of System.Exception choses the base constructor overload to call based on the arguments it receives:

>>> import System
>>> class MyException(System.Exception):
...     def __new__(cls, *args):
...        # This could be implemented as:
...        #     return System.Exception.__new__(cls, *args)
...        # but is more verbose just to make a point
...        if len(args) == 0:
...            e = System.Exception.__new__(cls)
...        elif len(args) == 1:
...            message = args[0]
...            e = System.Exception.__new__(cls, message)
...        elif len(args) == 2:
...            message, inner_exception = args
...            if hasattr(inner_exception, "clsException"):
...               inner_exception = inner_exception.clsException
...            e = System.Exception.__new__(cls, message, inner_exception)
...        return e
>>> e = MyException("some message", IOError())
Accessing protected members of base types

Normally, IronPython does not allow access to protected members (unless you are using private-binding). For example, accessing MemberwiseClone causes a TypeError since it is a protected method:

>>> import clr
>>> import System
>>> o = System.Object()
>>> o.MemberwiseClone()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: cannot access protected member MemberwiseClone without a python subclass of object
IronPython does allow Python sub-types to access protected members of .NET base types. However, Python does not enforce any accessibility rules. Also, methods can be added and removed dynamically from a class. Hence, IronPython does not attempt to guard access to protected members of .NET sub-types. Instead, it always makes the protected members available just like public members:

>>> class MyClass(System.Object):
...     pass
>>> o = MyClass()
>>> o.MemberwiseClone() #doctest: +ELLIPSIS
<MyClass object at ...>
Declaring .NET types

Relationship of classes in Python code and normal .NET types

A class definition in Python does not map directly to a unique .NET type. This is because the semantics of classes is different between Python and .NET. For example, in Python it is possible to change the base types just by assigning to the __bases__ attribute on the type object. However, the same is not possible with .NET types. Hence, IronPython implements Python classes without mapping them directly to .NET types. IronPython does use some .NET type for the objects, but its members do not match the Python attributes at all. Instead, the Python class is stored in a .NET field called .class, and Python instance attributes are stored in a dictionary that is stored in a .NET field called .dict [7]

>>> import clr
>>> class MyClass(object):
...     pass
>>> o = MyClass()
>>> o.GetType().FullName #doctest: +ELLIPSIS
'IronPython.NewTypes.System.Object_...'
>>> [field.Name for field in o.GetType().GetFields()]
['.class', '.dict', '.slots_and_weakref']
>>> o.GetType().GetField(".class").GetValue(o) == MyClass
True
>>> class MyClass2(MyClass):
...    pass
>>> o2 = MyClass2()
>>> o.GetType() == o2.GetType()
True
Also see Type-system unification (type and System.Type)

[7]	These field names are implementation details, and could change.
__clrtype__

It is sometimes required to have control over the .NET type generated for the Python class. This is because some .NET APIs expect the user to define a .NET type with certain attributes and members. For example, to define a pinvoke method, the user is required to define a .NET type with a .NET method marked with DllImportAttribute , and where the signature of the .NET method exactly describes the target platform method.

Starting with IronPython 2.6, IronPython supports a low-level hook which allows customization of the .NET type corresponding to a Python class. If the metaclass of a Python class has an attribute called __clrtype__, the attribute is called to generate a .NET type. This allows the user to control the the details of the generated .NET type. However, this is a low-level hook, and the user is expected to build on top of it.

The ClrType sample available in the IronPython website shows how to build on top of the __clrtype__ hook.

Accessing Python code from other .NET code

Statically-typed languages like C# and VB.Net can be compiled into an assembly that can then be used by other .NET code. However, IronPython code is executed dynamically using ipy.exe. If you want to run Python code from other .NET code, there are a number of ways of doing it.

Using the DLR Hosting APIs

The DLR Hosting APIs allow a .NET application to embed DLR languages like IronPython and IronRuby, load and execute Python and Ruby code, and access objects created by the Python or Ruby code.

Compiling Python code into an assembly

The pyc sample can be used to compile IronPython code into an assembly. The sample builds on top of clr-CompileModules. The assembly can then be loaded and executed using Python-ImportModule. However, note that the MSIL in the assembly is not CLS-compliant and cannot be directly accessed from other .NET languages.

dynamic

Starting with .NET 4.0, C# and VB.Net support access to IronPython objects using the dynamic keyword. This enables cleaner access to IronPython objects. Note that you need to use the hosting-apis to load IronPython code and get the root object out of it.

Integration of Python and .NET features

Type system integration.

See "Type-system unification (type and System.Type)"
Also see extensions-to-python-types and extensions-to-dotnet-types
List comprehension works with any .NET type that implements IList

with works with with any System.Collections.IEnumerable or System.Collections.Generic.IEnumerable<T>

pickle and ISerializable

__doc__ on .NET types and members:

__doc__ uses XML comments if available. XML comment files are installed if . As a result, help can be used:

>>> help(System.Collections.BitArray.Set) #doctest: +NORMALIZE_WHITESPACE
Help on method_descriptor:
Set(...)
    Set(self, int index, bool value)
                    Sets the bit at a specific
     position in the System.Collections.BitArray to
     the specified value.
<BLANKLINE>
    index:
                    The zero-based index of the
     bit to set.
<BLANKLINE>
    value:
                    The Boolean value to assign
     to the bit.
If XML comment files are not available, IronPython generates documentation by reflecting on the type or member:

>>> help(System.Collections.Generic.List.Enumerator.Current) #doctest: +NORMALIZE_WHITESPACE
Help on getset descriptor System.Collections.Generic in mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089.Enumerator.Current:
<BLANKLINE>
Current
    Get: T Current(self)
Extensions to Python types

import clr exposes extra functionality on some Python types to make .NET features accessible:

method objects of any builtin or .NET types:
instance method
Overloads(t1 [, t2...])
type objects
instance method
__getitem__(t1 [, t2...]) - creates a generic instantiation
Extensions to .NET types

IronPython also adds extensions to .NET types to make them more Pythonic. The following instance methods are exposed on .NET objects (and .NET classes where explicitly mentioned):

Types with op_Implicit


Types with op_Explicit


Types inheriting from a .NET class or interface

.NET base-type
Synthesized Python method(s)
System.Object
all methods of object eg. __class__, __str__, __hash__, __setattr__
System.IDisposable
__enter__, __exit__
System.Collections.IEnumerator
next
System.Collections.ICollection System.Collections.Generic.ICollection<T>
__len__
System.Collections.IEnumerable System.Collections.Generic.IEnumerable<T> System.Collections.IEnumerator System.Collections.Generic.IEnumerator<T>
__iter__
System.IFormattable
__format__
System.Collections.IDictionary System.Collections.Generic.IDictionary<TKey, TValue> System.Collections.Generic.ICollection<T> System.Collections.Generic.IList<T> System.Collections.IEnumerable System.Collections.Generic.IEnumerable<T> System.Collections.IEnumerator System.Collections.Generic.IEnumerator<T>
__contains__
System.Array
Class methods:
Indexing of the type object with a type object to access a specific array type
__new__(l) where l is IList<T> (or supports __getitem__?)
__getitem__, __setitem__, __slice__
System.Delegate
Class method : __new__(type, function_or_bound_method)
__call__
System.Enum
__or__  ?
Types with a .NET operator method name

.NET operator method
Synthesized Python method
op_Addition, Add
__add__
Compare
__cmp__
get_<Name> [8]
__getitem__
set_<Name> [9]
__setitem__
[8]	where the type also has a property <Name>, and a DefaultMemberAttribute for <Name>
[9]	where the type also has a property <Name>, and a DefaultMemberAttribute for <Name>
Equality and hashing

 - This is currently just copied from IronRuby, and is known to be incorrect

Object equality and hashing are fundamental properties of objects. The Python API for comparing and hashing objects is __eq__ (and __ne__) and __hash__ respectively. The CLR APIs are System.Object.Equals and System.Object.GetHashCode respectively. IronPython does an automatic mapping between the two concepts so that Python objects can be compared and hashed from non-Python .NET code, and __eq__ and __hash__ are available in Python code for non-Python objects as well.

When Python code calls __eq__ and __hash__

If the object is a Python object, the default implementations of __eq__ and __hash__ get called. The default implementations call System.Object.ReferenceEquals and System.Runtime.CompileServices.RuntimeHelpers.GetHashCode respectively.
If the object is a CLR object, System.Object.Equals and System.Object.GetHashCode respectively get called on the .NET object.
If the object is a Python subclass object inheriting from a CLR class, the CLR's class's implementation of System.Object.Equals and System.Object.GetHashCode will get called if the Python subclass does not define __eq__ and __hash__. If the Python subclass defines __eq__ and __hash__, those will be called instead.
When static MSIL code calls System.Object.Equals and System.Object.GetHashCode

If the object is a Python objects, the Python object will direct the call to __eq__ and __hash__. If the Python object has implementations for these methods, they will be called. Otherwise, the default implementation mentioned above gets called.
If the object is a Python subclass object inheriting from a CLR class, the CLR's class's implementation of System.Object.Equals and System.Object.GetHashCode will get called if the Python subclass does not define __eq__ and __hash__. If the Python subclass defines __eq__ and __hash__, those will be called instead.
Hashing of mutable objects

The CLR expects that System.Object.GetHashCode always returns the same value for a given object. If this invariant is not maintained, using the object as a key in a System.Collections.Generic.Dictionary<K,V> will misbehave. Python allows __hash__ to return different results, and relies on the user to deal with the scenario of using the object as a key in a Hash. The mapping above between the Python and CLR concepts of equality and hashing means that CLR code that deals with Python objects has to be aware of the issue. If static MSIL code uses a Python object as a the key in a Dictionary<K,V>, unexpected behavior might happen.

To reduce the chances of this happenning when using common Python types, IronPython does not map __hash__ to GetHashCode for Array and Hash. For other Python classes, the user can provide separate implementations for __eq__ and Equals, and __hash__ and GetHashCode if the Python class is mutable but also needs to be usable as a key in a Dictionary<K,V>.

System.Object.ToString, __repr__ and __str__

ToString on Python objects

Calling ToString on Python objects calls the default System.Object.ToString implementation, even if the Python type defines __str__:

>>> class MyClass(object):
...     def __str__(self):
...         return "__str__ result"
>>> o = MyClass()
>>> # Use Reflection to simulate a call from another .NET language
>>> o.GetType().GetMethod("ToString").Invoke(o, None) #doctest: +ELLIPSIS
'IronPython.NewTypes.System.Object_...'
__repr__/__str__ on .NET objects

All Python user types have __repr__ and __str__:

>>> class MyClass(object):
...     pass
>>> o = MyClass()
>>> o.__repr__() #doctest: +ELLIPSIS
'<MyClass object at ...>'
>>> o.__str__() #doctest: +ELLIPSIS
'IronPython.NewTypes.System.Object_...'
>>> str(o) #doctest: +ELLIPSIS
'<MyClass object at ...>'
For .NET types which do not override ToString, IronPython provides __repr__ and __str__ methods which behave similar to those of Python user types [10]:

>>> from System.Collections import BitArray
>>> ba = BitArray(5)
>>> ba.ToString() # BitArray inherts System.Object.ToString()
'System.Collections.BitArray'
>>> ba.__repr__() #doctest: +ELLIPSIS
'<System.Collections.BitArray object at ... [System.Collections.BitArray]>'
>>> ba.__str__() #doctest: +ELLIPSIS
'<System.Collections.BitArray object at ... [System.Collections.BitArray]>'
For .NET types which do override ToString, IronPython includes the result of ToString in __repr__, and maps ToString directly to __str__:

>>> e = System.Exception()
>>> e.ToString()
"System.Exception: Exception of type 'System.Exception' was thrown."
>>> e.__repr__() #doctest: +ELLIPSIS
"<System.Exception object at ... [System.Exception: Exception of type 'System.Exception' was thrown.]>"
>>> e.__str__() #doctest:
"System.Exception: Exception of type 'System.Exception' was thrown."
For Python types that override ToString, __str__ is mapped to the ToString override:

>>> class MyClass(object):
...     def ToString(self):
...         return "ToString implemented in Python"
>>> o = MyClass()
>>> o.__repr__() #doctest: +ELLIPSIS
'<MyClass object at ...>'
>>> o.__str__()
'ToString implemented in Python'
>>> str(o) #doctest: +ELLIPSIS
'<MyClass object at ...>'
[10]	There is some inconsistency in handling of __str__ that is tracked by http://ironpython.codeplex.com/WorkItem/View.aspx?WorkItemId=24973
OleAutomation and COM interop

IronPython supports accessing OleAutomation objects (COM objects which support dispinterfaces).

IronPython does not support the win32ole library, but Python code using win32ole can run on IronPython with just a few modifications.

Creating a COM object

Different languages have different ways to create a COM object. VBScript and VBA have a method called CreateObject to create an OleAut object. JScript has a method called . There are multiple ways of doing the same in IronPython.

The first approach is to use System.Type.GetTypeFromProgID and System.Activator.CreateInstance . This method works with any registered COM object:

>>> import System
>>> t = System.Type.GetTypeFromProgID("Excel.Application")
>>> excel = System.Activator.CreateInstance(t)
>>> wb = excel.Workbooks.Add()
>>> excel.Quit()
The second approach is to use clr.AddReferenceToTypeLibrary to load the type library (if it is available) of the COM object. The advantage is that you can use the type library to access other named values like constants:

>>> import System
>>> excelTypeLibGuid = System.Guid("00020813-0000-0000-C000-000000000046")
>>> import clr
>>> clr.AddReferenceToTypeLibrary(excelTypeLibGuid)
>>> from Excel import Application
>>> excel = Application()
>>> wb = excel.Workbooks.Add()
>>> excel.Quit()
Finally, you can also use the interop assembly. This can be generated using the tlbimp.exe tool. The only advantage of this approach was that this was the approach recommeded for IronPython 1. If you have code using this approach that you developed for IronPython 1, it will continue to work:

>>> import clr
>>> clr.AddReference("Microsoft.Office.Interop.Excel")
>>> from Microsoft.Office.Interop.Excel import ApplicationClass
>>> excel = ApplicationClass()
>>> wb = excel.Workbooks.Add()
>>> excel.Quit()
Using COM objects

One you have access to a COM object, it can be used like any other objects. Properties, methods, default indexers and events all work as expected.

Properties

There is one important detail worth pointing out. IronPython tries to use the type library of the OleAut object if it can be found, in order to do name resolution while accessing methods or properties. The reason for this is that the IDispatch interface does not make much of a distinction between properties and method calls. This is because of Visual Basic 6 semantics where "excel.Quit" and "excel.Quit()" have the exact same semantics. However, IronPython has a strong distinction between properties and methods, and methods are first class objects. For IronPython to know whether "excel.Quit" should invoke the method Quit, or just return a callable object, it needs to inspect the typelib. If a typelib is not available, IronPython assumes that it is a method. So if a OleAut object has a property called "prop" but it has no typelib, you would need to write "p = obj.prop()" in IronPython to read the property value.

Methods with out parameters

Calling a method with "out" (or in-out) parameters requires explicitly passing in an instance of "clr.Reference", if you want to get the updated value from the method call. Note that COM methods with out parameters are not considered Automation-friendly [11]. JScript does not support out parameters at all. If you do run into a COM component which has out parameters, having to use "clr.Reference" is a reasonable workaround:

>>> import clr
>>> from System import Type, Activator
>>> command_type = Type.GetTypeFromProgID("ADODB.Command")
>>> command = Activator.CreateInstance(command_type)
>>> records_affected = clr.Reference[int]()
>>> command.Execute(records_affected, None, None) #doctest: +SKIP
>>> records_affected.Value
0
Another workaround is to leverage the inteorp assembly by using the unbound class instance method syntax of "outParamAsReturnValue = InteropAssemblyNamespace.IComInterface(comObject)".

[11]	Note that the Office APIs in particular do have "VARIANT*" parameters, but these methods do not update the value of the VARIANT. The only reason they were defined with "VARIANT*" parameters was for performance since passing a pointer to a VARIANT is faster than pushing all the 4 DWORDs of the VARIANT onto the stack. So you can just treat such parameters as "in" parameters.
Accessing the type library

The type library has names of constants. You can use clr.AddReferenceToTypeLibrary to load the type library.

Non-automation COM objects

IronPython does not fully support COM objects which do not support dispinterfaces since they appear likey proxy objects [12]. You can use the unbound class method syntax to access them.

[12]	This was supported in IronPython 1, but the support was dropped in version 2.
Miscellaneous

Security model

When running Python code using ipy.exe, IronPython behaves like Python and does not do any sand-boxing. All scripts execute with the permissions of the user. As a result, running Python code downloaded from the Internet for example could be potentially be dangerous.

However, ipy.exe is just one manifiestation of IronPython. IronPython can also be used in other scenarios like in Silverlight or embedded in an application. All the IronPython assemblies are security-transparent. As a result, IronPython code can be run in a sand-box and the host can control the security priviledges to be granted to the Python code. This is one of the benefits of IronPython building on top of .NET. For example, when running in a web browser via the Silverlight plugin, Python code will not be able to write to the file system or make network connections to hosts other than the host where the web page orginites from. This security is enforced at the .NET level itself, and hence is very secure.

Execution model and call frames

IronPython code can be executed by any of the following techniques:

Interpretation
Compiling on the fly using DynamicMethod
Compiling on the fly using DynamicMethod
Ahead-of-time compilation to an assembly on disk using the pyc sample
A combination of the above - ie. a method might initially be interpreted, and can later be compiled once it has been called a number of times.
As a result, call frames of IronPython code are not like frames of statically typed langauges like C# and VB.Net. .NET code using APIs like those listed below need to think about how it will deal with IronPython code:

StackTrace.__new__
GetExecutingAssembly
Exception.ToString
Accessing non-public members

It is sometimes useful to access private members of an object. For example, while writing unit tests for .NET code in IronPython or when using the interactive command line to observe the innner workings of some object. ipy.exe supports this via the -X:PrivateBinding` command-line option. It can also be enabled in hosting scenarios via the  property ; this requires IronPython to be executing with FullTrust.

Mapping between Python builtin types and .NET types

IronPython is an implementation of the Python language on top of .NET. As such, IronPython uses various .NET types to implement Python types. Usually, you do not have to think about this. However, you may sometimes have to know about it.

Python type	.NET type
object	System.Object
int	System.Int32
long	System.Numeric.BigInteger [13]
float	System.Double
str, unicode	System.String
bool	System.Boolean
[13]	This is true only in CLR 4. In previous versions of the CLR, long is implemented by IronPython itself.
import clr and builtin types

Since some Python builtin types are implemented as .NET types, the question arises whether the types work like Python types or like .NET types. The answer is that by default, the types work like Python types. However, if a module executes import clr, the types work like both Python types and like .NET types. For example, by default, object' does not have the System.Object method called GetHashCode:

>>> hasattr(object, "__hash__")
True
>>> # Note that this assumes that "import clr" has not yet been executed
>>> hasattr(object, "GetHashCode") #doctest: +SKIP
False
However, once you do import clr, object has both __hash__ as well as GetHashCode:

>>> import clr
>>> hasattr(object, "__hash__")
True
>>> hasattr(object, "GetHashCode")
True
LINQ

Language-integrated Query (LINQ) is a set of features that was added in .NET 3.5. Since it is a scenario rather than a specific feature, we will first compare which of the scenarios work with IronPython:

LINQ-to-objects

Python's list comprehension provides similar functionality, and is more Pythonic. Hence, it is recommended to use list comprehension itself.

DLinq - This is currently not supported.

Feature by feature comparison

LINQ consists of a number of language and .NET features, and IronPython has differing levels of support for the different features:

C# and VB.NET lambda function - Python supports lambda functions already.
Anonymous types - Python has tuples which can be used like anonymous types.
Extension methods - See
Generic method type parameter inference - See
Expression trees - This is not supported. This is the main reason DLinq does not work.
Appendix - Type conversion rules

Note that some Python types are implemented as .NET types and no conversion is required in such cases. See builtin-type-mapping for the mapping.

Python argument type	.NET method parameter type
int	System.Byte, System.SByte, System.UInt16, System.Int16
User object with __int__ method	Same as int
str or unicode of size 1	System.Char
User object with __str__ method	Same as str
float	System.Float
tuple with T-typed elements	System.Collections.Generic.IEnumerable<T> or System.Collections.Generic.IList<T>
function, method	System.Delegate and any of its sub-classes
dict with K-typed keys and V-typed values	System.Collections.Generic.IDictionary<K,V>
type	System.Type
Appendix - Detailed method overload resolution rules

: This is old information

Roughly equivalent to VB 11.8.1 with additional level of preferred narrowing conversions

Start with the set of all accessible members
Keep only those members for which the argument types can be assigned to the parameter types by a widening conversion
If there is one or more member in the set find the best member
If there is one best member then call it
If there are multiple best members then throw ambiguous
Add in those members for which the argument types can be assigned to the parameter types by either a preferred narrowing or a widening conversion
If there is one applicable member then call it
If there is more than one applicable member then throw ambiguous
Add in those members for which the argument types can be assigned to the parameter types by any narrowing or a widening conversion
If there is one applicable member then call it
If there is more than one applicable member then throw ambiguous
Otherwise throw no match
Applicable Members By Number of Arguments – Phase 1

The number of arguments is identical to the number of parameters
The number of arguments is less than the number of parameters, but all parameters without an argument are optional – have a non-DbNull default value.
The method includes a parameter array and the params-expanded form of the method is applicable to the arguments
The params-expanded form is constructed by replacing the parameter array in the declaration with zero or more value parameters of the element type of the parameter array such that the number of arguments matches the number of parameters in the expanded form
The method includes byref parameters and the byref-reduced form of the method is applicable to the arguments
The byref-reduced form is constructed by removing all out parameters from the list and replacing all ref parameters with their target type. The return information for such a match will be provided in a tuple of return values.
Applicable Members By Type Of Arguments – Phase 2

If a conversion of the given type exists from the argument object to the type of the parameter for every argument then the method is applicable
For ref or out parameters, the argument must be an instance of the appropriate Reference class – unless the byref-reduced form of the method is being used
Better Member (same as C# 7.4.2.2)

Parameter Types : Given an argument list A with a set of types {A1, A1, ..., An} and type applicable parameter lists P and Q with types {P1, P2, ..., Pn} and {Q1, Q2, ..., Qn} P is a better member than Q if

For each argument, the conversion from Ax to Px is not worse than the conversion from Ax to Qx, and
For at least one argument, the conversion from Ax to Px is better than the conversion from Ax to Qx
Parameter Modifications : The method that uses the minimal conversions from the original method is considered the better match. The better member is the one that matches the earliest rule in the list of conversions for applicable methods. If both members use the same rules, then the method that converts the fewest of its parameters is considered best. For example, if multiple params methods have identical expanded forms, then the method with the most parameters prior to params-expanded form will be selected

Static vs. instance methods : When comparing a static method and an instance method that are both applicable, then the method that matches the calling convention is considered better. If the method is called unbound on the type object then the static method is preferred; however, if the method is called bound to an instance than the instance method will be preferred.

Explicitly implemented interface methods: Methods implemented as public methods on a class are considered better than methods that are private on the declaring class which explicitly implement an interface method.

Generic methods: Non-generic methods are considered better than generic methods.

Better Conversion (same as C# 7.4.2.3)

If T1 == T2 then neither conversion is better
If S is T1 then C1 is the better conversion (and vice-versa)
If a conversion from T1 to T2 exists, and no conversion from T2 to T1 exists, then C1 is the better conversion (and vice versa)
Conversion to a signed numeric type is preferred over conversion to a non-signed type of equal or greater size (this means that sbyte is preferred over byte)
Special conversion rule for ExtensibleFoo: An ExtensibleFoo has a conversion to a type whenever there is an appropriate conversion from Foo to that type.

Implicit Conversions

Implicit numeric conversions (C# 6.1.2)
Implicit reference conversions (C# 6.1.4) == Type.IsAssignableFrom
null -> Nullable<T>
COM object to any interface type
User-defined implicit conversions (C# 6.1.7)
Conversion from DynamicType -> Type
Narrowing Conversions (see VB 8.9 but much more restrictive for Python) are conversions that cannot be proved to always succeed, conversions that are known to possibly lose information, and conversions across domains of types sufficiently different to merit narrowing notation. The following conversions are classified as narrowing conversions:

Preferred Narrowing Conversions

BigInteger -> Int64 – because this is how Python represents numbers larger than 32 bits
IList<object> -> IList<T>
IEnumerator<object> -> IEnumerator<T>
IDictionary<object,object> -> IDictionary<K,V>
<Need to edit from here on down>

Narrowing Conversions

Bool -> int
Narrowing conversions of numeric types when overflow doesn’t occur
String(length == 1) -> char and Char -> string(length == 1)
Generic Python protocols to CLS types
Callable (or anything?) -> Delegate
Object (iterable?) -> IEnumerator?
__int__ to int, __float__, __complex__
Troubling conversions planning to keep
Object -> bool (__nonzero__)
Double -> int – this is standard Python behavior, albeit deprecated behavior
Tuple -> Array<T>
All of the below will require explicit conversions

Enum to numeric type – require explicit conversions instead
From numeric types to char (excluded by C#)
Dict -> Hashtable
List -> Array<T>, List<T> and ArrayList
Tuple -> List<T> and ArrayList
Rules for going the other direction when C# methods are overridden by Python or delegates are implemented on the Python side:

This change alters our rules for how params and by ref parameters are handled for both overridden methods and delegates.

by ref (ref or out) parameters are always passed to Python as an instance of clr.Reference. The Value property on these can be used to get and set the underlying value and on return from the method this will be propogated back to the caller.
params parameters are ignored in these cases and the underlying array is passed to the Python function instead of splitting out all of the args.
The principle behind this change is to present the most direct reflection of the CLS signature to the Python programmer when they are doing something where the signature could be ambiguous. For calling methods with by ref parameters we support both explicit Reference objects and the implicit skipped parameters. When overriding we want to support the most direct signature to remove ambiguity. Similarly for params methods we support both calling the method with an explicit array of args or with n-args. To remove the ambiguity when overriding we only support the explicit array.

I’m quite happy with this principle in general. The one part that sucks for me is that these methods are now not callable from Python in the non-explict forms any more. For example, if I have a method void Foo(params object[] args) then I will override it with a Python method Foo(args) and not Foo(*args). This means that the CLS base type’s method can be called as o.Foo(1,2,3) but the Python subclass will have to be called as o.Foo( (1,2,3) ). This is somewhat ugly, but I can’t come up with any other relatively simple and clear option here and I think that because overriding overloaded methods can get quite complicated we should err on the side of simplicity.
20.6. [bookmark: The_Python_Tutorial]The Python Tutorial
Python is an easy to learn, powerful programming language. It has efficient high-level data structures and a simple but effective approach to object-oriented programming. Python’s elegant syntax and dynamic typing, together with its interpreted nature, make it an ideal language for scripting and rapid application development in many areas on most platforms.
The Python interpreter and the extensive standard library are freely available in source or binary form for all major platforms from the Python Web site, http://www.python.org/, and may be freely distributed. The same site also contains distributions of and pointers to many free third party Python modules, programs and tools, and additional documentation.
The Python interpreter is easily extended with new functions and data types implemented in C or C++ (or other languages callable from C). Python is also suitable as an extension language for customizable applications.
This tutorial introduces the reader informally to the basic concepts and features of the Python language and system. It helps to have a Python interpreter handy for hands-on experience, but all examples are self-contained, so the tutorial can be read off-line as well.
For a description of standard objects and modules, see The Python Standard Library. The Python Language Reference gives a more formal definition of the language. To write extensions in C or C++, read IronPython .NET API Reference Manual and c-api-index. There are also several books covering Python in depth.
This tutorial does not attempt to be comprehensive and cover every single feature, or even every commonly used feature. Instead, it introduces many of Python’s most noteworthy features, and will give you a good idea of the language’s flavor and style. After reading it, you will be able to read and write Python modules and programs, and you will be ready to learn more about the various Python library modules described in The Python Standard Library.
21. [bookmark: autotrax_data_stuctureAEA443C9]The AutoTRAX Data Stucture
There are 2 different types of files in AutoTRAX.
Project Files
Part Files

21.1. [bookmark: project]Project
The class diagram for the main classes in a AutoTRAX project are shown below.


21.2. [bookmark: part]Part
The class diagram for the main classes in a AutoTRAX part are shown below.

21.3. [bookmark: The_DEX_File_FormatE93FEE86]The DEX File Format
The AutoTRAX XML schema is available at http://dexpcb.com/XmlSchemas/Dex.xsd.
To see the complete documentation on the AutoTRAX XML format please go to http://dexpcb.com/DexXmlSchemaManual/
You can view the AutoTRAX XML for a design using the Source View panel.
22. [bookmark: SoftwareLicense]The Software License
License Agreement
THIS AutoTRAX SOFTWARE LICENSE AGREEMENT ("LICENSE AGREEMENT") IS A LEGAL AGREEMENT BETWEEN YOU AND AUTOCRAT SOFTWARE, FOR THE SOFTWARE PRODUCT. BY USING THE SOFTWARE PRODUCT, YOU ARE AGREEING UNCONDITIONALLY TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT, EVEN IF THIS LICENSE AGREEMENT IS DEEMED A MODIFICATION OF ANY PREVIOUS ARRANGEMENT OR CONTRACT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE AGREEMENT, DO NOT USE THE SOFTWARE PRODUCT. INSTEAD, YOU MAY RETURN THE SOFTWARE PRODUCT TO THE PLACE YOU OBTAINED IT FOR A FULL REFUND (IF APPLICABLE).
Software Product License
The Software Product is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The Software Product is licensed, not sold.
For purposes of this License Agreement, "Software Product" refers to the computer software and associated media, printed materials, and "online" or electronic documentation, including without limitation any and all executable files, addons, stencils, templates, databases, tutorials, help files and other files, that accompany the AutoTRAX Software product identified above or in the accompanying documentation; "Use" means storing, loading (whether into temporary memory (i.e., RAM) or into permanent memory (e.g., hard disk, CD-ROM or other storage device)), installing, executing or displaying the Software Product; and "You" means the company, entity or individual whose funds are used to pay the license fee or who has otherwise acquired the Software Product.
1. Grant of License
Software Product. AutoTRAX Software grants You the non-exclusive, non-sublicensable, limited license to Use one copy of the Software Product on a single computer, subject to the terms and conditions of this License Agreement.
Second Copy. The primary user of a computer on which a copy of the Software Product is installed may make a second copy for his or her exclusive Use on either a home or portable computer, but not both.
Storage/Network Use. You may also store or install a copy of the Software Product on a storage device, such as a network server, for the purpose of Using the Software Product on Your computers only over an internal network; however, You must acquire and dedicate a license for each separate computer on which the Software Product is Used from the storage device. A license for the Software Product may not be shared or Used concurrently on different computers. You shall inform all users of the Software Product of the terms and conditions of this License Agreement.
License Pack. If You have acquired this License Agreement in an AutoTRAX Software License Pack, You may make the number of additional copies of the computer software portion of the Software Product authorized on the printed copy of this License Agreement, and You may Use each copy only in the manner specified in this License Agreement. You are also entitled to make a corresponding number of second copies for home or portable computer Use only in the manner specified in this License Agreement.
2. Ownership
Title, ownership rights and intellectual property rights in and to the Software Product shall remain in AutoTRAX Software and its suppliers and are protected by US and international copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The Software Product is licensed, not sold. There is no transfer to You of any title to or ownership of the Software Product and the license granted under this License Agreement should not be construed as a sale of any right in the Software Product. You must treat the Software Product like any other copyrighted materials (e.g., a book or musical recording) except that You may make one copy of the Software Product solely for backup or archival purposes (with the inclusion of all copyright and other proprietary notices), only as long as You otherwise comply with the terms and conditions of this License Agreement. You may not make additional copies of the Software Product. You may not copy the printed materials accompanying the Software Product. All rights not specifically granted under this License Agreement are reserved by AutoTRAX Software.
3. Description of Other Rights and Limitations
Limitations on Reverse-Engineering, Decompilation and Disassembly; Other Restrictions. You acknowledge that the Software Product in source code form remains a confidential trade secret of AutoTRAX Software and therefore You agree not to reverse-engineer, decompile or disassemble the Software Product, or make any attempt to discover the source code to the Software Product, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation. Except as expressly permitted in this License Agreement, the Software Product may not be Used, copied, translated, redistributed, retransmitted, published, sold, rented, leased, marketed, sub licensed, pledged, assigned, disposed of, encumbered, transferred, altered, modified or enhanced, whether in whole or in part, nor may You create derivative works from or based on the Software Product. You may not remove any proprietary notices, marks or labels from the Software Product.
Separation of Components. The Software Product is licensed as a single product and its component parts may not be separated for Use on more than one computer.
Transfer of Software Product. You may transfer all Your rights under this License Agreement on a permanent basis only, provided You retain no copies, You transfer the License Agreement, the corresponding serial number (if applicable) and all the Software Product (including without limitation all component parts, media and printed materials, and any upgrades) and the recipient agrees to all the terms and conditions of this License Agreement. If the Software Product is an upgrade product, any transfer must include the latest release, all prior versions and any prior products used to obtain the Software Product.
Termination. This License Agreement is in effect until terminated. You may terminate it at any time by destroying the Software Product and all copies You have made. Unauthorized copying or duplication of the Software Product will result in automatic termination of this License Agreement. Without prejudice to any other rights, AutoTRAX Software may terminate this License Agreement if You fail to comply with any term or condition of this License Agreement. Upon termination of this License Agreement, You agree to destroy the Software Product and all copies You have made.
Academic Software Product. If the Software Product is identified as "Academic", You must be a Qualified Educational User (as defined by AutoTRAX Software) to Use the Software Product. If You are not a Qualified Educational User, You have no rights under this License Agreement. To determine whether You are a Qualified Educational User, please contact AutoTRAX Software - Academic Sales at the applicable address set forth below.
Not For Resale ("NFR") Software Product. If the Software Product is identified as "Not For Resale" or "NFR", then, notwithstanding any other terms and conditions of this License Agreement, You may not, for value or other consideration, distribute, resell, dispose of, or transfer the Software Product.
Support Services. AutoTRAX Software may provide You with customer and technical support services related to the Software Product ("Support Services"). Use of Support Services is governed by the AutoTRAX Software policies and programs described in the user manual, in "online" or electronic documentation, and/or in other AutoTRAX Software-provided materials. Any supplemental software code provided to You as part of the Support Services shall be considered part of the Software Product and subject to the terms and conditions of this License Agreement. With respect to any technical information You provide to AutoTRAX Software as part of the Support Services, AutoTRAX Software may use such information for its business purposes, including product support and development. AutoTRAX Software will not utilize such technical information in a manner that personally identifies You.
4. Upgrades
If the Software Product is identified as an "upgrade", You must be properly licensed to Use a product, whether from AutoTRAX Software or another supplier, that is specified by AutoTRAX Software as being eligible for the upgrade in order to Use the Software Product. A Software Product identified as an upgrade replaces or supplements the product that formed the basis for Your eligibility for the upgrade. Notwithstanding any other terms and conditions of this License Agreement, You may transfer the Software Product only in conjunction with the product that formed the basis for Your eligibility for the upgrade, unless You destroy such product. If the Software Product is an upgrade from a component of a package of software programs which You licensed as a single product, the Software Product may be Used or transferred only as part of that single product package and may not be separated for Use on more than one computer.
5. Dual-Media Software
You may receive the Software Product in more than one medium; for example, in disk media, on a CD-ROM or in both media. Regardless of the type or size of medium You receive, You may Use only one medium that is appropriate for Your computer. You may not Use the other medium on another computer. You may not distribute, transmit, sell, loan, rent, lease or otherwise transfer the other medium to another user, except as part of the permanent transfer of the Software Product pursuant to the terms and conditions of this License Agreement.
6. Reports and Audit Rights
You shall institute reasonable measures to ensure compliance with the terms and conditions of this License Agreement. Upon AutoTRAX Software's reasonable request, You agree to provide reports relating to Your Use of the Software Product as necessary to demonstrate Your compliance with the terms and conditions of this License Agreement. You further agree that AutoTRAX Software has the right, upon reasonable prior notice, to audit Your records and inspect Your facilities to verify Your compliance with the terms and conditions of this License Agreement.
7. US Government Restricted Rights
The Software Product and documentation are provided with RESTRICTED RIGHTS. Use, duplication or disclosure by the Government is subject to restrictions as set forth in sub-paragraph (c)(1)(ii) of The Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or sub-paragraphs (c)(1) and (2) of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. The contractor/manufacturer is AutoTRAX Software, AutoTRAX Software. Fair Oak, Skeath Lane, Sandon Bank, Stafford ST18 9TD, England.
8. Export Restrictions
You may not export or reexport the Software Product or any underlying information or technology except in full compliance with all United States and other applicable laws and regulations. In particular, but without limitation, none of the Software Product or underlying information or technology may be exported or reexported (a) into (or to a national or resident of) Cuba, Haiti, Iran, Iraq, Libya, Serbia, Montenegro, North Korea, Sudan or Syria or (b) to anyone on the US Treasury Department's list of Specially Designated Nationals or the US Commerce Department's Table of Deny Orders, as such countries, lists and orders may be amended or modified from time to time. By Using the Software Product, You are specifically agreeing to the foregoing and You are representing and warranting that You are not located in, under the control of, or a national or resident of any such country or on any such list.
9. Entire Agreement; Governing Law
This License Agreement constitutes the entire agreement between AutoTRAX Software and You with regard to the subject matter hereof and supersedes any and all prior agreements, understandings and representations, whether written or oral, concerning the subject matter of this License Agreement. This License Agreement shall not be modify except by a written agreement executed by a duly authorized representative of each of AutoTRAX Software and You.
Nothing in this License Agreement is intended to exclude, modify or restrict the operation of any applicable statute or other law, the provisions of which cannot lawfully be excluded, modified or restricted. If any court of competent jurisdiction determines that a provision of this License Agreement is illegal, invalid or unenforceable in any jurisdiction, then such provision shall be deemed modified to the minimum extent necessary to make it comply with the applicable statute or law of such jurisdiction, and the remaining provisions of this License Agreement shall continue in full force and effect. Any such modification shall not effect any provisions of this License Agreement in any other jurisdiction where this License Agreement governs the Use of the Software Product.
If You acquired the Software Product in Canada, You agree to the following: Each of AutoTRAX Software and You hereby confirm, desire and agree that this License Agreement has been and shall be written solely in the English Language.
IF YOU ACQUIRED THE SOFTWARE PRODUCT IN THE UNITED STATES, THIS LICENSE AGREEMENT IS GOVERNED BY THE LAWS OF THE STATE OF WASHINGTON, USA, EXCEPT FOR THAT BODY OF LAW DEALING WITH CONFLICTS OF LAW, WITHOUT REFERENCE TO THE 1980 UNITED NATIONS CONVENTION ON THE INTERNATIONAL SALE OF GOODS.
IF YOU ACQUIRED THE SOFTWARE PRODUCT OUTSIDE THE UNITED STATES, THIS LICENSE AGREEMENT IS GOVERNED BY THE LAWS OF THE REPUBLIC OF IRELAND.
Software Product Limited Warranty
To the original customer only, AutoTRAX Software provides the following warranties:
Limited Warranty. AutoTRAX SOFTWARE WARRANTS THAT (a) FOR A PERIOD OF SIXTY (60) DAYS FROM THE DATE OF ORIGINAL PURCHASE ("WARRANTY PERIOD") AS EVIDENCED BY YOUR RECEIPT OR OTHER PROOF OF PURCHASE (i) THE SOFTWARE PRODUCT, UNLESS MODIFIED OR OTHERWISE ALTERED BY YOU, WILL PERFORM SUBSTANTIALLY IN ACCORDANCE WITH THE ACCOMPANYING WRITTEN MATERIALS, AND (ii) THE MEDIA ON WHICH THE SOFTWARE PRODUCT IS FURNISHED WILL BE FREE FROM DEFECTS IN MATERIALS AND WORKMANSHIP UNDER NORMAL USE; AND (b) ANY SUPPORT SERVICES PROVIDED BY AutoTRAX SOFTWARE SHALL BE SUBSTANTIALLY AS DESCRIBED IN APPLICABLE WRITTEN MATERIALS PROVIDED TO YOU BY AutoTRAX SOFTWARE. AutoTRAX Software does not warrant that the Software Product will meet Your requirements or that Use of the Software Product will be uninterrupted or error-free. AutoTRAX Software is not responsible for problems caused by changes in the operating characteristics of computer hardware or computer operating systems which are made after the release of the Software Product, nor for problems in the interaction of the Software Product with non-AutoTRAX Software software products. Some jurisdictions do not allow limitations on duration of an implied warranty, so the above limitation may not apply to You. The Limited Warranty gives You specific legal rights. You may have others, which vary by jurisdiction.
Exclusive Remedy. AutoTRAX Software's entire liability, and Your exclusive remedy, shall be, at AutoTRAX Software's option, either (a) replacement of the defective media, (b) repair or replacement of the Software Product that does not meet AutoTRAX Software's Limited Warranty, or (c) return of the price paid, if any, and termination of this License Agreement. This remedy is subject to return of the Software Product to AutoTRAX Software with a copy of Your receipt within the Warranty Period or, solely for Software Product that was obtained electronically via "electronic software distribution", to delivery to AutoTRAX Software of an AutoTRAX Software-approved "certification of destruction" together with proof of purchase within the Warranty Period. This Limited Warranty is void if failure of the Software Product has resulted from accident, abuse or misapplication. Any replacement Software Product will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. Outside of the United States, neither these remedies nor any Support Services are available without proof of purchase from an authorized source.
No Other Warranties. THE ABOVE WARRANTIES ARE EXCLUSIVE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, AutoTRAX SOFTWARE AND ITS SUPPLIERS DISCLAIM ALL OTHER WARRANTIES AND CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT, AND THOSE ARISING OUT OF USAGE OF TRADE OR COURSE OF DEALING, CONCERNING THE SOFTWARE PRODUCT, AND THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY AutoTRAX SOFTWARE, ITS AGENTS, DEALERS, DISTRIBUTORS OR EMPLOYEES SHALL INCREASE THE SCOPE OF THE ABOVE WARRANTIES OR CREATE ANY OTHER WARRANTIES.
No Liability for Damages. REGARDLESS OF WHETHER ANY REMEDY SET FORTH HEREIN FAILS OF ITS ESSENTIAL PURPOSE, TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL AutoTRAX SOFTWARE OR ITS SUPPLIERS (OR THEIR RESPECTIVE AGENTS, DIRECTORS, EMPLOYEES OR REPRESENTATIVES) BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, CONSEQUENTIAL, INCIDENTAL, INDIRECT, SPECIAL, ECONOMIC, PUNITIVE OR SIMILAR DAMAGES, OR DAMAGES FOR LOSS OF BUSINESS PROFITS, LOSS OF GOODWILL, BUSINESS INTERRUPTION, COMPUTER FAILURE OR MALFUNCTION, LOSS OF BUSINESS INFORMATION OR ANY AND ALL OTHER COMMERCIAL OR PECUNIARY DAMAGES OR LOSSES) ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE PRODUCT OR THE PROVISION OF OR FAILURE TO PROVIDE SUPPORT SERVICES, HOWEVER CAUSED AND ON ANY LEGAL THEORY OF LIABILITY (WHETHER IN TORT, CONTRACT OR OTHERWISE), EVEN IF AutoTRAX SOFTWARE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. YOU ACKNOWLEDGE THAT THE LICENSE FEE REFLECTS THIS ALLOCATION OF RISK. In any event, if any statute implies warranties or conditions not stated in this License Agreement, AutoTRAX Software's entire liability under any provision of this License Agreement shall be limited to the greater of the amount actually paid by You to license the Software Product and Five United States Dollars (US$5.00), or, in the case of Support Services, providing such Support Services again or refunding the cost thereof. Because some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to You.
Copyright © 1999-2021 AutoTRAX Software.
All Rights Reserved.
2633 Lincoln Blvd., #310, Santa Monica, California 90405, USA
 
 
22.1. [bookmark: Refund_PolicyE6C2499B]Refund Policy
The products available for purchase on our web site are downloadable, fully-functional, and try-before-you-buy. We provide free trial periods to let you fully evaluate our products before you make a purchase decision.
Please use the trial period to make sure that the software meets your needs before purchasing a license. All of our software is fully-functional during the trial period. None of our software requires registration to fully enable it.
If you purchase one of our products, after your payment has cleared you will receive an email with the purchase code to activate the software. Once this information is emailed to you, no refunds will be given. We have this policy since it would be impossible for you to return your registered version of our software.
During your trial period, our support staff is available,via the website http://dexpcb.com/Support/, to assist with installation and configuration. We strongly recommend that all customers download, install, and test the trial version of any product prior to making a purchase.
In rare instances and only within 30 days of purchase, if due to technical difficulties or platform incompatibilities the software will not function, we may, at our discretion, issue a refund. In such instances, we require that you provide enough information for us to positively identify your purchase transaction (e.g., order number, your company name, date of transaction, purchase code, number of licenses purchased, etc.). If we are able to positively identify your order, and if your request is made within 30 days of purchase, you must submit to us a letter of destruction of software on your company letterhead before we will process the refund. AutoTRAX Software is not responsible for lost, delayed, or misdirected mail or email, delays for downloading, or other communication system delays.
Acceptance of this Refund Policy
It is your responsibility to familiarize yourself with this refund policy. By placing an order for any of our products, you indicate that you have read this refund policy and that you agree with and fully accept the terms of this refund policy.
If you do not agree with or fully accept the terms of this refund policy, we ask that you do not place an order with us.
23. [bookmark: Appendix]Appendix
The IPC
Device Package Types
Packages
Through-Hole Mounting (THM)
Surface Mount Technology (SMT)
Through-Hole vs. Surface Mount
Solder
23.1. [bookmark: The_IPCD2BD1F1C]The IPC
IPC, the Association Connecting Electronics Industries, is a trade association whose aim is to standardize the assembly and production requirements of electronic equipment and assemblies. It was founded in 1957 as the Institute for Printed Circuits. Its name was later changed to the Institute for Interconnecting and Packaging Electronic Circuits to highlight the expansion from bare boards to packaging and electronic assemblies. In 1999, the organization formally changed its name to IPC with the accompanying tagline, Association Connecting Electronics Industries.
IPC is accredited by the American National Standards Institute (ANSI) as a standards developing organization and is known globally for its standards. It publishes the most widely used acceptability standards in the electronics industry.
IPC standards are used by the electronics manufacturing industry. IPC-A-610, Acceptability of Electronic Assemblies, is used worldwide by original equipment manufacturers and EMS companies. There are more than 3600 trainers worldwide who are certified to train and test on the standard. Standards are created by committees of industry volunteers. Task groups have been formed in China, the United States, and Denmark
View website...
23.2. [bookmark: Device_Package_Types89BE660B]Device Package Types
SOIC
Small outline Integrated Circuit – These are good SMT alternatives to the duel in-line package (DIP), due to their dramatically reduced size. In general, they take up 30 – 50% less space and 70% less thickness than an average DIP.
TSOP
Thin Small Outline Package – TSOPs are low profile packages with fine-pitch leads. TSOPs are typically meant to accommodate large silicon chips in high density packages (RAM or flash memory ICs), largely because of their low volume/high pin count.
QFNs
Quad Flat Pack – QFNs are high lead count packages (44 – 304). Its leads are typically gull wing. There are many kinds of QFNs, and they are one of the most common surface-mount ICs.
PLCC
Plastic Leaded Chip Carrier  - Connections are made on all four edges of a square package with a relatively high pin count. PLCCs can have roughly 18 – 100 leads (usually J-leads). Many of them can fit into IC sockets and can be easily replaced in the field. PLCCs have long been a popular option.  
LCC
Lead-less Chip Carrier – Not to be confused with PLCC, LCCs have no leads. Rather, LCCs are soldered directly onto PCBs by their (castellation) solder pads. These are usually designed for Mil Spec because, with no leads to damage, they're quite "rugged." LCCs are great for high temperature and aerospace applications.  
PGA
Pin Grid Array – PGAs are typically square or rectangular, with pins arranged underneath the package. They're design was highly influential on the now ubiquitous BGA. 
Flip Chip
Flip chips are bare die packages, with small bottom-side solder bumps that act as leads. They are soldered directly onto the PCB.
BGA
Ball Grid Array – BGAs are perhaps one of the best performing SMT packages in use today, due to their high densities. The BGA is a descendent of the PGA, yet instead of pins, it has solder balls that can be placed directly onto the PCB. Because of their high density, BGAs are typically used to house microprocessors. 
Ball Grid Array BGA uses the underside of the package to place pads with balls of solder in grid pattern as connections to PCB.
FBGA	Fine-pitch ball-grid array	A square or rectangular array of solder balls on one surface
LBGA	Low-profile ball-grid array	Also known as laminate ball-grid array
TEPBGA Thermally-enhanced plastic ball-grid array	
CBGA	Ceramic ball-grid array	-
OBGA	Organic ball-grid array	-
TFBGA Thin fine-pitch ball-grid array	-
PBGA	Plastic ball-grid array	-
MAP-BGA Mold array process - ball-grid array	-
UCSP	Micro (μ) chip-scale package	Similar to a BGA (A Maxim trademark example)
μBGA	Micro ball-grid array	Ball spacing less than 1 mm
LFBGA	Low-profile fine-pitch ball-grid array	-
TBGA	Thin ball-grid array	-
SBGA	Super ball-grid array	Above 500 balls
UFBGA	Ultra-fine ball-grid array	

23.3. [bookmark: Packages]Packages
BCC - Bump Chip Carrier
BGA - Ball Grid Array
BGAs are perhaps one of the best performing SMT packages in use today, due to their high densities. The BGA is a descendent of the PGA, yet instead of pins, it has solder balls that can be placed directly onto the PCB. Because of their high density, BGAs are typically used to house microprocessors.  Ball Grid Array BGA uses the underside of the package to place pads with balls of solder in grid pattern as connections to PCB.
The BGA is descended from the pin grid array (PGA), which is a package with one face covered (or partly covered) with pins in a grid pattern which, in operation, conduct electrical signals between the integrated circuit and the printed circuit board (PCB) on which it is placed. In a BGA the pins are replaced by pads on the bottom of the package, each initially with a tiny solder ball stuck to it. These solder spheres can be placed manually or by automated equipment, and are held in place with a tacky flux. The device is placed on a PCB with copper pads in a pattern that matches the solder balls. The assembly is then heated, either in a reflow oven or by an infrared heater, melting the balls. Surface tension causes the molten solder to hold the package in alignment with the circuit board, at the correct separation distance, while the solder cools and solidifies, forming soldered connections between the device and the PCB.
In more advanced technologies, solder balls may be used on both the PCB and the package. Also, in stacked multi-chip modules, solder balls are used to connect two packages.
Advantages
High density
The BGA is a solution to the problem of producing a miniature package for an integrated circuit with many hundreds of pins. Pin grid arrays and dual-in-line surface mount (SOIC) packages were being produced with more and more pins, and with decreasing spacing between the pins, but this was causing difficulties for the soldering process. As package pins got closer together, the danger of accidentally bridging adjacent pins with solder grew.
Heat conduction
A further advantage of BGA packages over packages with discrete leads (i.e. packages with legs) is the lower thermal resistance between the package and the PCB. This allows heat generated by the integrated circuit inside the package to flow more easily to the PCB, preventing the chip from overheating.
Low-inductance leads
The shorter an electrical conductor, the lower its unwanted inductance, a property which causes unwanted distortion of signals in high-speed electronic circuits. BGAs, with their very short distance between the package and the PCB, have low lead inductances, giving them superior electrical performance to pinned devices
Disadvantages
Noncompliant connections
A disadvantage of BGAs is that the solder balls cannot flex in the way that longer leads can, so they are not mechanically compliant. As with all surface mount devices, bending due to a difference in coefficient of thermal expansion between PCB substrate and BGA (thermal stress) or flexing and vibration (mechanical stress) can cause the solder joints to fracture.
Thermal expansion issues can be overcome by matching the mechanical and thermal characteristics of the PCB to those of the package. Typically, plastic BGA devices more closely match PCB thermal characteristics than ceramic devices.
The predominant use of RoHS compliant lead-free solder alloy assemblies has presented some further challenges to BGAs including "head in pillow" soldering phenomenon, "pad cratering" problems as well as their decreased reliability versus lead-based solder BGAs in extreme operating conditions such as high temperature, high thermal shock and high gravitational force environments, in part due to lower ductility of RoHS-compliant solders.
Mechanical stress issues can be overcome by bonding the devices to the board through a process called "underfilling", which injects an epoxy mixture under the device after it is soldered to the PCB, effectively gluing the BGA device to the PCB. There are several types of underfill materials in use with differing properties relative to workability and thermal transfer. An additional advantage of underfill is that it limits tin whisker growth.
Another solution to non-compliant connections is to put a "compliant layer" in the package that allows the balls to physically move in relation to the package. This technique has become standard for packaging DRAMs in BGA packages.
Other techniques for increasing the board-level reliability of packages include use of low-expansion PCBs for ceramic BGA (CBGA) packages, interposers between the package and PCB, and re-packaging a device.
Difficulty of inspection
Once the package is soldered into place, it is difficult to find soldering faults. X-ray machines, industrial CT scanning machines special microscopes, and endoscopes to look underneath the soldered package have been developed to overcome this problem. If a BGA is found to be badly soldered, it can be removed in a rework station, which is a jig fitted with infrared lamp (or hot air), a thermocouple and a vacuum device for lifting the package. The BGA can be replaced with a new one, or it can be refurbished (or reballed) and re-installed on the circuit board. Pre-configured solder balls matching the array pattern can be used to reball BGAs when only one or a few need to be reworked.
Due to the cost of visual X-ray BGA inspection, electrical testing is very often used instead. Very common is boundary scan testing using an IEEE 1149.1 JTAG port.
A cheaper and easier inspection method, albeit destructive, is becoming increasingly popular because it does not require special equipment. Commonly referred to as dye and pry, the process includes immersing the entire PCB or just the BGA attached module into a dye, and after drying, the module is pried off and the broken joins are inspected. If a solder location contains the dye, then it indicates that the connection was imperfect.
Difficulties during circuit development
During development it is not practical to solder BGAs into place, and sockets are used instead, but tend to be unreliable. There are two common types of socket: the more reliable type has spring pins that push up under the balls, although it does not allow using BGAs with the balls removed as the spring pins may be too short.
The less reliable type is a ZIF socket, with spring pinchers that grab the balls. This does not work well, especially if the balls are small.
Cost of equipment
Expensive equipment is required to reliably solder BGA packages; hand-soldering BGA packages is very difficult and unreliable, usable only for the smallest packages in the smallest quantities. However, as more ICs have become available only in leadless (e.g. quad-flat no-leads package) or BGA packages, various DIY reflow methods have been developed using inexpensive heat sources such as heat guns, and domestic toaster ovens and electric skillets.
BQFP - Bumpered Quad Flat Pack
CABGA/SSBGA - Chip Array/Small Scale Ball Grid Array
CBGA - Ceramic Ball Grid Array
CCGA - Ceramic Column Grid Array 
CERPACK - Ceramic Package
CFP - Ceramic Flat Pack
CGA - Column Grid Array
CLCC - Ceramic Leadless Chip Carrier Packages 
CLGA - Ceramic Land Grid Array 
CQFP - Ceramic Quad Flat Pack, 
CQGP - Ceramic Quad 
CSBGA - Cavity Down BGA
CSOP - Ceramic Small Outline Package
CSP BGA - Chip Scale Package BGA 
TBD - Ceramic Lead-Less Chip Carrier
DBS - DIL Bent SIL 
DFN - Dual Flat Pack, No Lead
DLCC - Dual Lead-Less Chip Carrier (Ceramic) DLCC Graphic
DMP - Dual In-line Mini Molded Package
DQFN - Depopulated Quad Flat-pack; No-leads
EPTSSOP - Thin Shrink Small Outline Exposed Pad Plastic Packages
ETQFP - Extra Thin Quad Flat Package
FBGA - Fine-pitch Ball Grid Array
FCBGA - Flipchip BGA
FCPBGA - Flip Chip Plastic BGA
FFP - Flip-chip Fine Package
FleXBGA - Flexible Ball Grid Array
FLP - Flat Lead Package
fpBGA - Fine Pitch Ball Grid Array
HBCC - Heatsink Bottom Chip Carrier
HBGA - High Performance Ball Grid Array 
HDIP - Heat-dissipating Dual In-line Package 
HSBGA - Heat Slug Ball Grid Array
HSOP - Heatsink Small Outline Package
HTSSOP - Heatsink Thin Shrink Small Outline Package
HUQFN - Heatsink Ultra-thin Quad Flat-pack; No-leads
HVQFN - Heatsink Very-thin Quad Flat-pack; No-leads
HVSON - Heatsink Very-thin Small Outline; No-leads
HWQFN - Heatsink Very-Very-thin Quad Flat-pack; No-leads
HWSON - Heatsink Very-Very-thin Small Outline package; No leads
HXQFN - Heatsink eXtremely-thin Quad Flat-pack; No-leads
HXSON - Heatsink eXtremely Small Outline Package; No leads
JDIP - J-Leaded Dual In-Line J-Lead DIP Picture
JLCC - J-Leaded Chip Carrier (Ceramic) J-Lead Picture
LBGA - Low-Profile Ball Grid Array
LCC - Leaded Chip Carrier LCC Graphic
LCC - Leaded Chip Carrier Un-formed LCC Graphic
LCCC - Leaded Ceramic Chip Carrier
LCGA - Low-Profile Ball Grid Array
LFBGA - Low-Profile, Fine-Pitch Ball Grid Array
The Low-Profile Fine Pitch Ball Grid Array, or LFPBGA, is a smaller version of the ball grid array (BGA) package. It is basically an FBGA package that has a package height ranging from 1.2 mm and 1.7 mm.  It is therefore thicker than the TFBGA and the VFBGA.
Typical LFBGA's have ball counts that range from 48 to 865 solder balls. The typical LFBGA ball pitch is 0.50 mm to 0.8 mm. A typical LFBGA is about 1.3 mm to 1.7 mm thick.
LGA - Land Grid Array LGA Graphic 
LLCC - Leadless Chip Carrier 
A leadless chip carrier (LCC or LLCC) is an integrated circuit package that has no pins/leads for contact. This surface-mount device makes use of metal pads at the outer edges to establish connection with the circuit board. Leadless chip carriers are popular, as they are light in weight, adaptable to a wide range of applications and are considered ideal for surface-mount applications.
A leadless chip carrier is usually square or rectangular in shape. Unlike other integrated circuit packaging, leadless chip carriers do not establish connection to devices by means of pins, but by means studs or metal pads provided around the periphery of the package. Due to reduction in weight, area and volume, leadless chip carriers are more durable and could withstand more vibration and shock compared to dual-in-line packages.
One of the salient features of a leadless chip carrier is its easy and convenient direct insertion to its socket mounted on the circuit board. It can also easily mount directly on the board. It is a low-cost solution for surface mounting, as it is lightweight and has no metallic external legs or leads. Unlike dual-inline packages, no holes are required for leadless chip carriers.
There are a few drawbacks associated with leadless chip carriers. The system is not considered homogeneous when leadless chip carriers are mounted to printed circuit boards. Failures of these systems have been common after limited stressing or thermal expansion. Most of these issues can be resolved by selecting the proper printed circuit board material.
LQFP - Low-profile Quad Flat pack
The Low Profile Quad Flat Pack, or LQFP, is a surface-mount IC package with leads extending from all four sides of the package body.
MCMBGA - Multi Chip Module Ball Grid Array
MCMCABGA - Multi Chip Module-Chip Array Ball Grid Array
MLCC - Micro Leadframe Chip Carrier
MLP - Micro Lead-frame Package MLP graphic
MQFP - Metric Quad Flat Pack (high pin count QFP)
MSOP - Mini Small Outline Plastic Packages
OBGA - Organic Ball Grid Array
ODFN - Optical Dual Flat No-Lead Plastic Package
PBGA - Plastic Ball Grid Array, PBGA graphic
PLCC - Plastic Leaded Chip Carrier
A plastic-leaded chip carrier (PLCC) has a rectangular plastic housing. It is a reduced cost evolution of the ceramic leadless chip carrier (CLCC).
A premolded PLCC was originally released in 1976, but did not see much market adoption. Texas Instruments later released a postmolded variant that was soon adopted by most major semiconductor companies. The JEDEC trade group started a task force in 1981 to categorize PLCCs, with the MO-047 standard released in 1984 for square packages and the MO-052 standard released in 1985 for rectangular packages. The PLCC utilizes a "J"-lead with pin spacings of 0.05" (1.27 mm). The metal strip forming the lead is wrapped around and under the edge of the package, resembling the letter J in cross-section. Lead counts range from 20 to 84. PLCC packages can be square or rectangular. Body widths range from 0.35" to 1.15". The PLCC “J” Lead configuration requires less board space versus equivalent gull leaded components, which have flat leads that extend out perpendicularly to the narrow edge of the package. The PLCC is preferred over DIP style chip carriers when lead counts exceed 40 pins due to the PLCC's more efficient use of board surface area.
POS Package on Substrate
PQFD Plastic Quad Flat --
PQFP Plastic Quad Flat Pack
PSOP Plastic Small-Outline Package PSOP graphic
QFN Quad Flat No-Lead
QFP Quad Flat pack QFP Graphics
QSOP Quarter Size Outline Package
SBGA Super BGA - above 500 Pin count 
SDMP Shrink Dual In-line Mini Molded Package
SO Flat Pack - Small Outline Flat Pack IC
SOIC - Small Outline IC
SOJ - Small-Outline Package (J-Lead), SOJ
SOLIC - Small Outline Large Integrated Circuit (Gull-Wing Lead Wide Body)
SON - Small-Outline No-leads (leadless package)
SOP - Small Out-line Package
SSOP - Shrink Small-Outline Package
SOT - Small Outline Transistor Plastic Package 
TBGA - Tape Ball Grid Array 
TBGA - Thin Ball Grid Array
TDFN - Thin Dual Flat No-Lead Plastic Package
TEPBGA - Thermally Enhanced Plastic Ball Grid Array
TFBGA - Thin profile Fine-pitch Ball Grid Array
TQFN - Thin Quad Flat No-Lead Plastic Package
TQFP - Thin Quad Flat Pack TQFP Graphic
TSOP - Thin Small-Outline Package
TSSOP - Thin Shrink Small-Outline Package
TSOT - Thin Small Outline Transistor Plastic Package
TVSOP - Thin Very Small-Outline Package
TVSP - Thin Very Small Package
UFBGA - Ultra Fine-Line BGA
UTDFN - Ultra Thin Dual Flat No-Lead Plastic Package
VFBGA - Very thin Fine-pitch Ball Grid Array
VQFB - Very-thin Quad Flat Pack
VSO - Very Small Outline
VSSOP - Very thin Shrink Small Outline Package
VSP - Very Small Package
XQFN - eXtremely thin Quad Flat package; No leads
XSON - eXtremely thin Small Outline package; No leads


23.4. [bookmark: Through_Hole_Mounting__THM_E690516D]Through-Hole Mounting (THM)
Through-hole mounting is the process by which component leads are placed into drilled holes on a bare PCB. The process was standard practice until the rise of surface mount technology (SMT) in the 1980s, at which time it was expected to completely phase out through-hole. Yet, despite a severe drop in popularity over the years, through-hole technology has proven resilient in the age of SMT, offering a number of advantages and niche applications: namely, reliability.  
Through-hole components are best used for high-reliability products that require stronger connections between layers. Whereas SMT components are secured only by solder on the surface of the board, through-hole component leads run through the board, allowing the components to withstand more environmental stress. This is why through-hole technology is commonly used in military and aerospace products that may experience extreme accelerations, collisions, or high temperatures. Through-hole technology is also useful in test and prototyping applications that sometimes require manual adjustments and replacements.
Overall, through-hole’s complete disappearance from PCB assembly is a wide misconception. Barring the above uses for through-hole technology, one should always keep in mind the factors of availability and cost. Not all components are available as SMD packages, and some through-hole components are less expensive.
However, that doesn’t negate that fact that, in a modern assembly facility, through-hole is considered a secondary operation.
Through-hole technology (also spelled "thru-hole"), refers to the mounting scheme used for electronic components that involves the use of leads on the components that are inserted into holes drilled in printed circuit boards (PCB) and soldered to pads on the opposite side either by manual assembly (hand placement) or by the use of automated insertion mount machines.
History
Through-hole technology almost completely replaced earlier electronics assembly techniques such as point-to-point construction. From the second generation of computers in the 1950s until surface-mount technology (SMT) became popular in the late 1980s, every component on a typical PCB was a through-hole component. PCBs initially had tracks printed on one side only, later both sides, then multi-layer boards were in use. Through holes became plated-through holes (PTH) in order for the components to make contact with the required conductive layers. Plated-through holes are no longer required with SMT boards for making the component connections, but are still used for making interconnections between the layers and in this role are more usually called vias.
Axial and radial leads
Components with wire leads are generally used on through-hole boards. Axial leads protrude from each end of a typically cylindrical or elongated box-shaped component, on the geometrical axis of symmetry. Axial-leaded components resemble wire jumpers in shape, and can be used to span short distances on a board, or even otherwise unsupported through an open space in point-to-point wiring. Axial components do not protrude much above the surface of a board, producing a low-profile or flat configuration when placed "lying down" or parallel to the board.
Radial leads project more or less in parallel from the same surface or aspect of a component package, rather than from opposite ends of the package. Originally, radial leads were defined as more-or-less following a radius of a cylindrical component (such as a ceramic disk capacitor). Over time, this definition was generalized in contrast to axial leads, and took on its current form. When placed on a board, radial components "stand up" perpendicular, occupying a smaller footprint on sometimes-scarce "board real estate", making them useful in many high-density designs. The parallel leads projecting from a single mounting surface gives radial components an overall "plugin nature", facilitating their use in high-speed automated component insertion ("board-stuffing") machines.
When needed, an axial component can be effectively converted into a radial component, by bending one of its leads into a "U" shape so that it ends up close to and parallel with the other lead. Extra insulation with heat-shrink tubing may be used to prevent shorting out on nearby components. Conversely, a radial component can be pressed into service as an axial component by separating its leads as far as possible, and extending them into an overall length-spanning shape. These improvisations are often seen in breadboard or prototype construction, but are deprecated for mass production designs. This is because of difficulties in use with automated component placement machinery, and poorer reliability because of reduced vibration and mechanical shock resistance in the completed assembly.
Multiple lead devices
For electronic components with two or more leads, for example diodes, transistors, ICs or resistor packs, a range of standard-sized semiconductor packages are used, either directly onto the PCB or via a socket.
Characteristics
While through-hole mounting provides strong mechanical bonds when compared to SMT techniques, the additional drilling required makes the boards more expensive to produce. They also limit the available routing area for signal traces on layers immediately below the top layer on multilayer boards since the holes must pass through all layers to the opposite side. To that end, through-hole mounting techniques are now usually reserved for bulkier or heavier components such as electrolytic capacitors or semiconductors in larger packages such as the TO-220 that require the additional mounting strength, or for components such as plug connectors or electromechanical relays that require great strength in support.
Design engineers often prefer the larger through-hole rather than surface mount parts when prototyping, because they can be easily used with breadboard sockets. However, high-speed or high-frequency designs may require SMT technology to minimize stray inductance and capacitance in wire leads, which would impair circuit function. Ultra-compact designs may also dictate SMT construction, even in the prototype phase of design.

23.5. [bookmark: Surface_Mount_Technology__SMT_BA6414BE]Surface Mount Technology (SMT)
SMT the process by which components are mounted directly onto the surface of the PCB. Known originally as “planar mounting,” the method was developed in the 1960s and has grown increasingly popular since the 1980s. Nowadays, virtually all electronic hardware is manufactured using SMT. It has become essential to PCB design and manufacturing, having improved the quality and performance of PCBs overall, and has reduced the costs of processing and handling greatly.  
The key differences between SMT and through-hole mounting are (a) SMT does not require holes to be drilled through a PCB, (b) SMT components are much smaller, and (c) SMT components can be mounted on both side of the board. The ability to fit a high number of small components on a PCB has allowed for much denser, higher performing, and smaller PCBs.
Through-hole component leads, which run through the board and connect a board’s layers, have been replaced by "vias" -- small components which allow a conductive connection between the different layers of a PCB, and which essentially act as through-hole leads. Some surface mount components like BGAs are higher performing components with shorter leads and more interconnection pins that allow for higher speeds. 

Surface-mount technology (SMT) is a method for producing electronic circuits in which the components are mounted or placed directly onto the surface of printed circuit boards (PCBs). An electronic device so made is called a surface-mount device (SMD). In industry, it has largely replaced the through-hole technology construction method of fitting components with wire leads into holes in the circuit board. Both technologies can be used on the same board, with the through-hole technology used for components not suitable for surface mounting such as large transformers and heat-sinked power semiconductors.
By employing SMT, the production process speeds up, but the risk of defects also increases due to component miniaturization and to the denser packing of boards. In those conditions, detection of failures has become critical for any SMT manufacturing process.
An SMT component is usually smaller than its through-hole counterpart because it has either smaller leads or no leads at all. It may have short pins or leads of various styles, flat contacts, a matrix of solder balls (BGAs), or terminations on the body of the component.
Surface mounting was originally called "planar mounting".
Surface-mount technology was developed in the 1960s and became widely used in the mid 1980s. By the late 1990s, the great majority of high-tech electronic printed circuit assemblies were dominated by surface mount devices. Much of the pioneering work in this technology was done by IBM. The design approach first demonstrated by IBM in 1960 in a small-scale computer was later applied in the Launch Vehicle Digital Computer used in the Instrument Unit that guided all Saturn IB and Saturn V vehicles. Components were mechanically redesigned to have small metal tabs or end caps that could be directly soldered to the surface of the PCB. Components became much smaller and component placement on both sides of a board became far more common with surface mounting than through-hole mounting, allowing much higher circuit densities and smaller circuit boards and, in turn, machines or subassemblies containing the boards.
History
Often only the solder joints hold the parts to the board; in rare cases parts on the bottom or "second" side of the board may be secured with a dot of adhesive to keep components from dropping off inside reflow ovens if the part has a large size or weight. Adhesive is sometimes used to hold SMT components on the bottom side of a board if a wave soldering process is used to solder both SMT and through-hole components simultaneously. Alternatively, SMT and through-hole components can be soldered on the same side of a board without adhesive if the SMT parts are first reflow-soldered, then a selective solder mask is used to prevent the solder holding those parts in place from reflowing and the parts floating away during wave soldering. Surface mounting lends itself well to a high degree of automation, reducing labor cost and greatly increasing production rates.
Conversely, SMT does not lend itself well to manual or low-automation fabrication, which is more economical and faster for one-off prototyping and small-scale production, and this is one reason why many through-hole components are still manufactured. Some SMDs can be soldered with a temperature-controlled manual soldering iron, but unfortunately, those that are very small or have too fine a lead pitch are impossible to manually solder without expensive hot-air solder reflow equipment. SMDs can be one-quarter to one-tenth the size and weight, and one-half to one-quarter the cost of equivalent through-hole parts, but on the other hand, the costs of a certain SMT part and of an equivalent through-hole part may be quite similar, though rarely is the SMT part more expensive.
Assembly techniques
Where components are to be placed, the printed circuit board normally has flat, usually tin-lead, silver, or gold plated copper pads without holes, called solder pads. Solder paste, a sticky mixture of flux and tiny solder particles, is first applied to all the solder pads with a stainless steel or nickel stencil using a screen printing process. It can also be applied by a jet-printing mechanism, similar to an inkjet printer. After pasting, the boards then proceed to the pick-and-place machines, where they are placed on a conveyor belt. The components to be placed on the boards are usually delivered to the production line in either paper/plastic tapes wound on reels or plastic tubes. Some large integrated circuits are delivered in static-free trays. Numerical control pick-and-place machines remove the parts from the tapes, tubes or trays and place them on the PCB.
The boards are then conveyed into the reflow soldering oven. They first enter a pre-heat zone, where the temperature of the board and all the components is gradually, uniformly raised. The boards then enter a zone where the temperature is high enough to melt the solder particles in the solder paste, bonding the component leads to the pads on the circuit board. The surface tension of the molten solder helps keep the components in place, and if the solder pad geometries are correctly designed, surface tension automatically aligns the components on their pads.
There are a number of techniques for reflowing solder. One is to use infrared lamps; this is called infrared reflow. Another is to use a hot gas convection. Another technology which is becoming popular again is special fluorocarbon liquids with high boiling points which use a method called vapor phase reflow. Due to environmental concerns, this method was falling out of favor until lead-free legislation was introduced which requires tighter controls on soldering. At the end of 2008, convection soldering was the most popular reflow technology using either standard air or nitrogen gas. Each method has its advantages and disadvantages. With infrared reflow, the board designer must lay the board out so that short components don't fall into the shadows of tall components. Component location is less restricted if the designer knows that vapor phase reflow or convection soldering will be used in production. Following reflow soldering, certain irregular or heat-sensitive components may be installed and soldered by hand, or in large-scale automation, by focused infrared beam (FIB) or localized convection equipment.
If the circuit board is double-sided then this printing, placement, reflow process may be repeated using either solder paste or glue to hold the components in place. If a wave soldering process is used, then the parts must be glued to the board prior to processing to prevent them from floating off when the solder paste holding them in place is melted.
After soldering, the boards may be washed to remove flux residues and any stray solder balls that could short out closely spaced component leads. Rosin flux is removed with fluorocarbon solvents, high flash point hydrocarbon solvents, or low flash solvents e.g. limonene (derived from orange peels) which require extra rinsing or drying cycles. Water-soluble fluxes are removed with deionized water and detergent, followed by an air blast to quickly remove residual water. However, most electronic assemblies are made using a "No-Clean" process where the flux residues are designed to be left on the circuit board, since they are considered harmless. This saves the cost of cleaning, speeds up the manufacturing process, and reduces waste. However, it is generally suggested to wash the assembly, even when a "No-Clean" process is used, when the application uses very high frequency clock signals (in excess of 1 GHz). Another reason to remove no-clean residues is to improve adhesion of conformal coatings and underfill materials. Regardless of cleaning or not those PCBs, current industry trend suggests to carefully review a PCB assembly process where "No-Clean" is applied, since flux residues trapped under components and RF shields may affect surface insulation resistance (SIR), especially on high component density boards.
Certain manufacturing standards, such as those written by the IPC - Association Connecting Electronics Industries require cleaning regardless of the solder flux type used to ensure a thoroughly clean board. Proper cleaning removes all traces of solder flux, as well as dirt and other contaminants that may be invisible to the naked eye. No-Clean or other soldering processes may leave "white residues" that, according to IPC, are acceptable "provided that these residues have been qualified and documented as benign". However, while shops conforming to IPC standard are expected to adhere to the Association's rules on board condition, not all manufacturing facilities apply IPC standard, nor are they required to do so. Additionally, in some applications, such as low-end electronics, such stringent manufacturing methods are excessive both in expense and time required.
Finally, the boards are visually inspected for missing or misaligned components and solder bridging. If needed, they are sent to a rework station where a human operator repairs any errors. They are then usually sent to the testing stations (in-circuit testing and/or functional testing) to verify that they operate correctly. Automated Optical Inspection (AOI) systems are commonly used in PCB manufacturing. This technology has proven highly efficient for process improvements and quality achievements.
Common abbreviations
Different terms describe the components, technique, and machines used in manufacturing. These terms are listed in the following table:
SMD	Surface-mount devices (active, passive and electromechanical components)
SMT	Surface-mount technology (assembling and mounting technology)
SMA	Surface-mount assembly (module assembled with SMT)
SMC	Surface-mount components (components for SMT)
SMP	Surface-mount packages (SMD case forms)
SME	Surface-mount equipment (SMT assembling machines)
Advantages
The main advantages of SMT over the older through-hole technique are:
· Smaller components.
· Much higher component density (components per unit area) and many more connections per component.
· Components can be placed on both sides of the circuit board.
· Higher density of connections because holes do not block routing space on inner layers, nor on back-side layers if components are mounted on only one side of the PCB.
· Small errors in component placement are corrected automatically as the surface tension of molten solder pulls components into alignment with solder pads. (On the other hand, through-hole components cannot be slightly misaligned, because once the leads are through the holes, the components are fully aligned and cannot move laterally out of alignment.)
· Better mechanical performance under shock and vibration conditions (partly due to lower mass, and partly due to less cantilevering)
· Lower resistance and inductance at the connection; consequently, fewer unwanted RF signal effects and better and more predictable high-frequency performance.
· Better EMC performance (lower radiated emissions) due to the smaller radiation loop area (because of the smaller package) and the lesser lead inductance.
· Fewer holes need to be drilled. (Drilling PCBs is time-consuming and expensive.)
· Lower initial cost and time of setting up for mass production, using automated equipment.
· Simpler and faster automated assembly. Some placement machines are capable of placing more than 136,000 components per hour.
· Many SMT parts cost less than equivalent through-hole parts.
· A surface mount package is favored where a low profile package is required or the space available to mount the package is limited. As electronic devices become more complex and available space is reduced, the desirability of a surface mount package increases. Concurrently, as the device complexity increases, the heat generated by operation increases. If the heat is not removed, the temperature of the device rises shortening the operational life. It is therefore highly desirable to develop surface mount packages having high thermal conductivity.
Disadvantages
· SMT is unsuitable for large, high-power, or high-voltage parts, for example in power circuitry. It is common to combine SMT and through-hole construction, with transformers, heat-sinked power semiconductors, physically large capacitors, fuses, connectors, and so on mounted on one side of the PCB through holes.
· SMT is unsuitable as the sole attachment method for components that are subject to frequent mechanical stress, such as connectors that are used to interface with external devices that are frequently attached and detached.
· SMDs' solder connections may be damaged by potting compounds going through thermal cycling.
· Manual prototype assembly or component-level repair is more difficult and requires skilled operators and more expensive tools, due to the small sizes and lead spacings of many SMDs. Handling of small SMT components can be difficult, requiring tweezers, unlike nearly all through-hole components. Whereas through-hole components will stay in place (under gravitational force) once inserted and can be mechanically secured prior to soldering by bending out two leads on the solder side of the board, SMDs are easily moved out of place by a touch of a soldering iron. Without expert skill, when manually soldering or desoldering a component, it is easy to accidentally reflow the solder of an adjacent SMT component and unintentionally displace it, something that is almost impossible to do with through-hole components.
· Many types of SMT component packages cannot be installed in sockets, which provide for easy installation or exchange of components to modify a circuit and easy replacement of failed components. (Virtually all through-hole components can be socketed.)
· SMDs cannot be used directly with plug-in breadboards (a quick snap-and-play prototyping tool), requiring either a custom PCB for every prototype or the mounting of the SMD upon a pin-leaded carrier. For prototyping around a specific SMD component, a less-expensive breakout board may be used. Additionally, stripboard style protoboards can be used, some of which include pads for standard sized SMD components. For prototyping, "dead bug" breadboarding can be used.
· Solder joint dimensions in SMT quickly become much smaller as advances are made toward ultra-fine pitch technology. The reliability of solder joints becomes more of a concern, as less and less solder is allowed for each joint. Voiding is a fault commonly associated with solder joints, especially when reflowing a solder paste in the SMT application. The presence of voids can deteriorate the joint strength and eventually lead to joint failure.
· SMDs, usually being smaller than equivalent through-hole components, have less surface area for marking, requiring marked part ID codes or component values to be more cryptic and smaller, often requiring magnification to be read, whereas a larger through-hole component could be read and identified by the unaided eye. This is a disadvantage for prototyping, repair, or rework, and possibly for production set-up.
Packages
Surface-mount components are usually smaller than their counterparts with leads, and are designed to be handled by machines rather than by humans. The electronics industry has standardized package shapes and sizes (the leading standardisation body is JEDEC).
Small outline diode (SOD)
SOD-923	0.8 × 0.6 × 0.4 mm 
SOD-723	1.4 × 0.6 × 0.59 mm 
SOD-523 (SC-79)	1.25 × 0.85 × 0.65 mm 
SOD-323 (SC-90)	1.7 × 1.25 × 0.95 mm 
SOD-128	5 × 2.7 × 1.1 mm 
SOD-123	3.68 × 1.17 × 1.60 mm 
SOD-80C	3.50 × ⌀ 1.50 mm 
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Through-Hole Mounting (THM)
Through-hole mounting is the process by which component leads are placed into drilled holes on a bare PCB. The process was standard practice until the rise of surface mount technology (SMT) in the 1980s, at which time it was expected to completely phase out through-hole. Yet, despite a severe drop in popularity over the years, through-hole technology has proven resilient in the age of SMT, offering a number of advantages and niche applications: namely, reliability.  
Through-hole components are best used for high-reliability products that require stronger connections between layers. Whereas SMT components are secured only by solder on the surface of the board, through-hole component leads run through the board, allowing the components to withstand more environmental stress. This is why through-hole technology is commonly used in military and aerospace products that may experience extreme accelerations, collisions, or high temperatures. Through-hole technology is also useful in test and prototyping applications that sometimes require manual adjustments and replacements.
Overall, through-hole’s complete disappearance from PCB assembly is a wide misconception. Barring the above uses for through-hole technology, one should always keep in mind the factors of availability and cost. Not all components are available as SMD packages, and some through-hole components are less expensive.
However, that doesn’t negate that fact that, in a modern assembly facility, through-hole is considered a secondary operation.
Axial vs. Radial Lead Components
There are two types of through-hole components: axial and radial lead components. Axial leads run through a component in a straight line ("axially"), with each end of the lead wire exiting the component on either end. Both ends are then placed through two separate holes in the board, allowing the component to fit closer, flatter fit. Radial lead components, on the other hand, protrude from the board, as its leads are located on one side of the component.
Both through-hole component types are "twin" lead components, and both have their distinct advantages. While axial lead components are used for their snugness to the board, radial leads occupy less surface area, making them better for high density boards. Generally, axial lead configuration may come in the form of carbon resistors, electrolytic capacitors, fuses, and light-emitting diodes (LEDs). Radial lead components are available as ceramic disk capacitors.  
Advantages: THM provides stronger mechanical bonds than SMT, making through-hole ideal for components that might undergo mechanical stress, such as connectors or transformers. Good for test and prototyping. 
Disadvantages: On the bare PCB side, THM requires the drilling holes, which is expensive and time consuming. THM also limits the available routing area on any multilayer boards, because the drilled holes must pass through all the PCB’s layers. On the assembly side, component placement rates for THM are a fraction of surface mount placement rates, making THM prohibitively expensive. Further, THM requires the use of wave, selective, or hand-soldering techniques, which are much less reliable and repeatable than reflow ovens used for surface mount. Most of all, through-hole technology requires soldering on both sides of the board, as opposed to surface-mounts, which only -- for the most part -- require attention to one side of the board. 
Surface Mount Technology (SMT)
SMT the process by which components are mounted directly onto the surface of the PCB. Known originally as “planar mounting,” the method was developed in the 1960s and has grown increasingly popular since the 1980s. Nowadays, virtually all electronic hardware is manufactured using SMT. It has become essential to PCB design and manufacturing, having improved the quality and performance of PCBs overall, and has reduced the costs of processing and handling greatly.  
The key differences between SMT and through-hole mounting are (a) SMT does not require holes to be drilled through a PCB, (b) SMT components are much smaller, and (c) SMT components can be mounted on both side of the board. The ability to fit a high number of small components on a PCB has allowed for much denser, higher performing, and smaller PCBs.
Through-hole component leads, which run through the board and connect a board’s layers, have been replaced by "vias" -- small components which allow a conductive connection between the different layers of a PCB, and which essentially act as through-hole leads. Some surface mount components like BGAs are higher performing components with shorter leads and more interconnection pins that allow for higher speeds. 
Nomenclature
There are perhaps too many terms that describe different aspects of surface mount technology. Here’s what they mean:
SMA (surface-mount assembly) – a build or module assembled using SMT.
SMC (surface-mount components) – components for SMT.
SMD (surface-mount devices) – active, passive, and electromechanical components.
SME (surface-mount equipment) – machines used for SMT.
SMP (surface mount packages) – SMD case forms.
SMT (surface-technology) – the act and method of assembling and mounting electronic technology.

23.7. [bookmark: Solder]Solder
Solder is a fusible metal alloy used to create a permanent bond between metal workpieces. The word solder comes from the Middle English word soudur, via Old French solduree and soulder, from the Latin solidare, meaning "to make solid". In fact, solder must first be melted in order to adhere to and connect the pieces together after cooling, which requires that an alloy suitable for use as solder have a lower melting point than the pieces being joined. The solder should also be resistant to oxidative and corrosive effects that would degrade the joint over time. Solder used in making electrical connections also needs to have favorable electrical characteristics.
Soft solder typically has a melting point range of 90 to 450 °C , and is commonly used in electronics. Alloys that melt between 180 and 190 °C are the most commonly used. Soldering performed using alloys with a melting point above 450 °C is called "hard soldering", "silver soldering", or brazing.
In specific proportions, some alloys can become eutectic — that is, the alloy's melting point is lower than that of either component. Non-eutectic alloys have markedly different solidus and liquidus temperatures, and within that range they exist as a paste of solid particles in a melt of the lower-melting phase. In electrical work, if the joint is disturbed in the pasty state before it has solidified totally, a poor electrical connection may result; use of eutectic solder reduces this problem. The pasty state of a non-eutectic solder can be exploited in plumbing, as it allows molding of the solder during cooling, e.g. for ensuring watertight joint of pipes, resulting in a so-called "wiped joint".
For electrical and electronics work, solder wire is available in a range of thicknesses for hand-soldering (manual soldering is performed using a soldering iron or soldering gun), and with cores containing flux. It is also available as a paste, as a preformed foil shaped to match the workpiece, more suitable for mechanized mass-production, or in small "tabs" that can be wrapped around the joint and melted with a flame, for field repairs where an iron isn't usable or available. Alloys of lead and tin were commonly used in the past and are still available; they are particularly convenient for hand-soldering. Lead-free solders have been increasing in use due to regulatory requirements plus the health and environmental benefits of avoiding lead-based electronic components. They are almost exclusively used today in consumer electronics.
Lead-free solder
On July 1, 2006 the European Union Waste Electrical and Electronic Equipment Directive (WEEE) and Restriction of Hazardous Substances Directive (RoHS) came into effect, restricting the inclusion of lead in most consumer electronics sold in the EU, and having a broad effect on consumer electronics sold worldwide. In the US, manufacturers may receive tax benefits by reducing the use of lead-based solder. Lead-free solders in commercial use may contain tin, copper, silver, bismuth, indium, zinc, antimony, and traces of other metals. Most lead-free replacements for conventional 60/40 and 63/37 Sn-Pb solder have melting points from 50 to 200 °C higher, though there are also solders with much lower melting points.
It may be desirable to use minor modification of the solder pots (e.g., titanium liners or impellers) used in wave-soldering, to reduce maintenance cost due to increased tin-scavenging of high-tin solder.
Lead-free solder may be less desirable for critical applications, such as aerospace and medical projects, because its properties are less thoroughly known.
Tin-silver-copper (Sn-Ag-Cu, or "SAC") solders are used by two-thirds of Japanese manufacturers for reflow and wave soldering, and by about 75% of companies for hand soldering. The widespread use of this popular lead-free solder alloy family is based on the reduced melting point of the Sn-Ag-Cu ternary eutectic behavior (217 °C), which is below the 22/78 Sn-Ag (wt.%) eutectic of 221 °C and the 59/41 Sn-Cu eutectic of 227 °C. The ternary eutectic behavior of Sn-Ag-Cu and its application for electronics assembly was discovered (and patented) by a team of researchers from Ames Laboratory, Iowa State University, and from Sandia National Laboratories-Albuquerque.
Much recent research has focused on selection of 4th element additions to Sn-Ag-Cu to provide compatibility for the reduced cooling rate of solder sphere reflow for assembly of ball grid arrays, e.g., 18/64/14/4 tin-silver-copper-zinc (Sn-Ag-Cu-Zn) (melting range 217–220 °C) and 18/64/16/2 tin-silver-copper-manganese (Sn-Ag-Cu-Mn) (melting range of 211–215 °C).
Tin-based solders readily dissolve gold, forming brittle intermetallics; for Sn-Pb alloys the critical concentration of gold to embrittle the joint is about 4%. Indium-rich solders (usually indium-lead) are more suitable for soldering thicker gold layer as the dissolution rate of gold in indium is much slower. Tin-rich solders also readily dissolve silver; for soldering silver metallization or surfaces, alloys with addition of silvers are suitable; tin-free alloys are also a choice, though their wettability is poorer. If the soldering time is long enough to form the intermetallics, the tin surface of a joint soldered to gold is very dull.
Flux
Flux is a reducing agent designed to help reduce (return oxidized metals to their metallic state) metal oxides at the points of contact to improve the electrical connection and mechanical strength. The two principal types of flux are acid flux (sometimes called "active flux"), containing strong acids, used for metal mending and plumbing, and rosin flux (sometimes called "passive flux"), used in electronics. Rosin flux comes in a variety of "activities", corresponding roughly to the speed and effectiveness of the organic acid components of the rosin in dissolving metallic surface oxides, and consequently the corrosiveness of the flux residue.
Due to concerns over atmospheric pollution and hazardous waste disposal, the electronics industry has been gradually shifting from rosin flux to water-soluble flux, which can be removed with deionized water and detergent, instead of hydrocarbon solvents.
In contrast to using traditional bars or coiled wires of all-metal solder and manually applying flux to the parts being joined, much hand soldering since the mid-20th century has used flux-core solder. This is manufactured as a coiled wire of solder, with one or more continuous bodies of inorganic acid or rosin flux embedded lengthwise inside it. As the solder melts onto the joint, it frees the flux and releases that on it as well.
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you expect and need to rapidly and easily take your design from conception through to production. Its in-built
hierarchical project manager lets you perform both top-down and bottom-up design and reuse design
‘components and sub-systems. Schematic capture and PCB layout has never been easier.

DEX-PCB is the industry’s only unified electronic design software which gives you an unmatched ability to
design and build current and future generation of electronic products.
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No Limits
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paying more. Read more.
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ing environment so it best suits you.
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